Comment 14 for bug 207796

Your symptom is resolved as of 9.04

On Dec 2, 2009 7:41 AM, "bloody" <email address hidden> wrote:

Dec 2 13:25:39 XXXX kernel: [ 5936.938713] pulseaudio[1943]: segfault
at 7 ip 004ec583 sp bfca4f6c error 6 in[47f000+13e000]

Dec 2 13:25:42 XXXX pulseaudio[4925]: pid.c: Stale PID file,

Dec 2 13:26:59 XXXX kernel: [ 6017.015104] pulseaudio[4925]: segfault
at 7 ip 009c2583 sp bf976b5c error 6 in[955000+13e000]

Dec 2 13:27:03 XXXX pulseaudio[5028]: pid.c: Stale PID file,

by rhythmbox shows sometimes this error. the same error appears while
i'm playing game on my ubuntu 9.10 distro.

does exist a fix to this bug?

** Also affects: pulseaudio
  Importance: Undecided
      Status: New

-- pulseaudio segfaults when switching streams You received...
Status in PulseAudio sound server: New
Status in “pulseaudio” package in Ubuntu: Confirmed

Bug description:
Binary package hint: pulseaudio

pulseaudio reliably segfaults on my machine (hardy)

procedure to recreate
start a pulseaudio server with the default configuration

define a bluetooth device in .asoundrc
pcm.headset_hw {
  type bluetooth
  device 00:00:00:00:00:00
  profile "hifi"

ctl.headset {
   type bluetooth
   device 00:00:00:00:00:00

pcm.headset {
   type plug
   slave.pcm "headset_hw"

pactl load-module module-alsa-sink device=headset
start pavucontrol to set the headset as the default output
start mplayer -ao pulse
go back to pavucontrol and swap the stream to the default hw,0 soundcard
it will give an error because it looses connection and dmesg will show a

history of dmesg, i tried multiple times

[ 1695.056366] pulseaudio[14219]: segfault at b6fb536a eip b6fb536a esp
b67b1320 error 4
[ 2087.979040] pulseaudio[15098]: segfault at b6f9336a eip b6f9336a esp
b678f320 error 4
[ 2089.971514] pulseaudio[15111]: segfault at b6fc836a eip b6fc836a esp
b67c4320 error 4
[ 2441.726862] pulseaudio[16020]: segfault at b7ae536a eip b7ae536a esp
b4ffd320 error 4
[ 2545.608121] pulseaudio[16360]: segfault at b7a1e36a eip b7a1e36a esp
b553e320 error 4

package Installed: 0.9.9-1ubuntu2
up to date hardy install.

ProblemType: Bug
Architecture: i386
Date: Thu Mar 27 16:38:13 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: pulseaudio 0.9.9-1ubuntu2
PackageArchitecture: i386
SourcePackage: pulseaudio
Uname: Linux 2.6.24-8-generic i686