When trying to type text nothing happens

Bug #1425749 reported by Connor Carto on 2015-02-25
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

When I select the text tool, click on the area I want to type in, then type, nothing happens.

Alan Horkan (horkana) wrote :

What version of Pinta are you using?
Please try to check against version 1.5

Older versions of Pinta had problems with accented characters, so it would be helpful to know what language you are using while trying to add text.

Connor Carto (connorcipod) wrote :

Version 1.5.

Alan Horkan (horkana) wrote :

I'm another Pinta user and text works for me.

I'm pretty sure the developers will say they can't do anything here without more information.

grofaty (grofaty) wrote :

Maybe you have used Rectangle Select and now you are trying to add new text outside of the selected area. Is it?

If not then please download latest development from http://forge.pinta-project.com/ - download zip file if using Linux or OSx or download "Windows" if using Windows.

Please write what is you operating system name and version. Is this problem reproducible every time. If yes, then I suggest to close down Pinta, reopen it and then write step by step instructions, how to reproduce the problem. In order to recognize the problem we have to be able to reproduce it.

Changed in pinta:
status: New → Incomplete
grofaty (grofaty) wrote :

This may be a duplicate of bug 1426037. But we need more info to confirm. Connor can you please confirm this is the same problem?

Connor Carto (connorcipod) wrote :

No, it is not. What other information do you need?

grofaty (grofaty) wrote :

Infomations:
1. What is your Pinta version? See menu Help | About. Few hours ago there was a new Pinta 1.6 officiall stable release. See download page: http://pinta-project.com/releases Please install latest version and retry to see if problem is reappearing.
2. What is your oprating system? Windows, Linux, OSx - what version of this system (if Linux what distribution)?
3. How did you install Pinta? If Ubuntu using official repository, PPA, http://forge.pinta-project.com/
4. Is problem reproducable? Does it always appears when the same step-by-step instructions are involved. If yes, please type in exact step-by-step instructions how to reproduce a problem. Whithout reproducing a problem it is impossible to fix it.
5. Also see my answer in #4 above. Is this the same problem?

Rob (rob-west) wrote :

I'm having the same issue. I'm on a OSx with Pinta V 1.6. I am using the small Apple wireless keyboard.

What is happening is when I attempt to type, it is selecting tools. For example, I us the mouse to select the 'Text' tool and attempt to type a 'b' into the image, what happens is the toolbar changes to 'Brush'.

I can't seem to find how to turn off the shortcut keys.

grofaty (grofaty) wrote :

Rob, can you please answer to the questions on #7.
Please write step-by-step instructions how to really did it. After selecting the Text tool did you click on canvas to activate text tool or not?

Rob (rob-west) wrote :

Yes, after clicking the text tool, I then clicked in the image area and the text prompt appeared as expected, ready to type. But nothing types and i noticed when I typed certain letters, the tool changes. 'B' changed the tool to the brush etc. I would then manually select the text toll again but still no text appears and if I try to type a 'g', the Gradient tool becomes selected.

Cameron White (cameronwhite91) wrote :

It sounds like something might be going wrong around https://github.com/PintaProject/Pinta/blob/master/Pinta/MainWindow.cs#L237

Which version of Mono did you install? We recently changed the recommended version of Mono for OSX on the download page.

Jeff (gary-wright1979) wrote :

I too am having this problem on a MacBook Pro running Yosemite.

Jeff (gary-wright1979) wrote :

Just found that this is not an issue on my MacBook Pro i7 OSX10 with Pinta V.1.3, but it is with V.1.4 & V1.5.

Same problem, tried several fonts, colors, etc. Properly trying to type text on image, layer, etc.
Version 1.6 running on Ubuntu 15.10 (updated) with 32 GB memory on a 2TB drive with plenty of free space.
This makes Pinta totally unuseable, IMHO. Let us know if it ever gets fixed.

Rob (rob-west) wrote :

Downloaded and installed latest MONO version but still no joy. Can not type text into an image. I have discovered a work around, if I type the text I need into a text editor and then cut-and-paste it into Pinta, I can get the text into the image. This leads me to believe it is definitely a problem with the integration with the keyboard driver.

Right clicking on a tool presents what the shortcut key is. For my installation the shortcut key are just letters without and 'Alt' keys. For example, the shortcut key for Fill is 'F'.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
importance: Undecided → High
milestone: none → 1.7
status: Incomplete → Fix Committed
Tzach Shabtay (tzachshabtay) wrote :

Hi, when is 1.7 going to be released?
If there's still a way to go, is it possible to release this fix as a hotfix to 1.6 (as it's a critical issue)?

Thanks.

grofaty (grofaty) wrote :

In my humble opinion official Pinta 1.7 version is not going to be released any time soon, because there are plenty of bugs marked to be solved before 1.7 milestone is reached.

I suggest to download development version from: https://pinta-project.com/pintaproject/pinta/builds
Currently Pinta version 1.7 development version is very stable, even more then 1.6 official version, because several bugs where fixed.

If using Windows, then just download "Windows" file from above link. If using Linux or OSX then download "Zip" file, extract archive and from terminal run:
mono Pinta.exe
You can create a keyboard or desktop shortcut with above command.
If using Ubuntu, you can also use a daily PPA from: https://launchpad.net/~pinta-maintainers/+archive/ubuntu/pinta-daily

For any further question please use:
a) Questions: https://pinta-project.com/pintaproject/pinta/questions or
b) Mailing list: http://groups.google.com/group/pinta?hl=en

Brent Lehman (mailbjl) wrote :

Workaround (works for me anyway): Type text in a text editor and copy-paste into Pinta.

I have the same issue, running Pinta 1.6 on a Mac Mini (made in late 2014). My operating system is OS X El Capitan (10.11.6), with 8 GB memory and a 2.6 GHz Core i5 processor. Brent's copy/paste workaround also works for me.

It looks like the development version is Windows-only, or I'd try that. I'd love to see this fixed soon--either in a Mac 1.7 release or a 1.6 hotfix, as Tzach suggested last year--as this sort of program is perfect for a skilled amateur like myself. :)

Ramesh (rameshincts) wrote :

My problem got fixed.I guess its about the setting.

I was facing the same issue.After changing some setting now I able to type directly in Pinta.
1)In the bottom left you see pane for Palette. Make sure your primary colour is black and secondary colour is white.
2)When you create new image also make sure your background is white.
3)Choose font "Abyssinica SIL" for English and set the Text style as "normal"
4)Now click on "text" icon and then click on canvas and start typing.

It should work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions