gnome-session keeps respawning nautilus when no desktop is drawed

Reported by JJ on 2009-02-05
416
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Fedora)
Fix Released
Unknown
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Medium
Ubuntu Desktop Bugs
Karmic
Medium
Ubuntu Desktop Bugs

Bug Description

When "show_desktop" is disabled from gconf-editor (apps -> nautilus -> preferences, uncheck "show_desktop"), windows saying "Starting File Manager" replicate until the computer fails to respond. In the System Monitor, the nautilus process keeps opening and closing (presumably crashes and restarts).

If show_desktop is unchecked, running nautilus in terminal yields the following error message. If show_desktop is checked, nautilus opens and no error messages are displayed.

$ nautilus

(nautilus:1307): Unique-DBus-WARNING **: Error while sending message: Message did not receive a reply (timeout by message bus)
$

I think is it worthwhile to note that when I open my flashdrive, this problem does not happen.

This problem occurs with the latest Jaunty updates, specifically nautilus(-data) version 1:2.25.91-0ubuntu1, and originated with nautilus(-data) version 1:2.25.4-0ubuntu1. This problem does not occur with nautilus(-data) version 1:2.25.3-0ubuntu2.

Diff from 1:2.25.3-0ubuntu2 to 1:2.25.4-0ubuntu1: http://launchpadlibrarian.net/21900685/nautilus_1%3A2.25.3-0ubuntu2_1%3A2.25.4-0ubuntu1.diff.gz

Screencast: http://launchpadlibrarian.net/22762464/screencast.ogv

JJ (jjthemagicman) wrote :
Richard Seguin (sectech) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, you are not using the most recent version of this package for your Ubuntu release. Please upgrade to the most recent version and let us know if you are still having this issue. Thanks in advance.

Please re-test with Alpha 4 as it is now the current version. I won't close out the issue for now until we find it has been fixed in Alpha 4 or if it is still an issue.

Thanks,

Richard Seguin

JJ (jjthemagicman) wrote :

Thanks for your fast reply. I updated to the latest Alpha release and the problem still exits.

1 comments hidden view all 111 comments
max (max-illis) wrote :

I have the same problem. Alpha 4 and today's updates

Tim Price (timprice) wrote :

Just another "me too" confirmation - Alpha 4 fully updated.

Thanks to the original poster, whose thorough report pointed me to the workaround of re-enabling "Show Desktop", making my Gnome session usable again.

Tim Price

Darren (darren-insanities) wrote :

I was also going to disable nautiluses drawing of the desktop to have compiz do it, and also experienced this problem. I have a fully updated alpha 4.

Dara Adib (daradib) wrote :

Marking as confirmed and setting importance as high. This bug is reproducible on my system with latest Jaunty updates.

Dara Adib (daradib) wrote :

I'm marking this as affecting the source package nautilus. After manually downgrading nautilus, nautilus-data, and libnautilus-extension to version 1:2.25.3-0ubuntu2 (available in the Jaunty archives from January 23 to February 2) and restarting X (logout and log back in), the problem disappeared.

Therefore, this bug must have originated from version 1:2.25.4-0ubuntu1, diff: http://launchpadlibrarian.net/21900685/nautilus_1%3A2.25.3-0ubuntu2_1%3A2.25.4-0ubuntu1.diff.gz

nautilus (1:2.25.4-0ubuntu1) jaunty; urgency=low

  * New upstream version:
    - Don't show desktop files from other desktops than Gnome on the desktop
    - Support crossfades of desktop backgrounds
    - Don't snap desktop icons outside right margin
    - Fix crashes and leaks (lp: #321359)

Dara Adib (daradib) on 2009-02-17
description: updated
Dara Adib (daradib) wrote :

Here is a screencast of the bug in action. Presumably nautilus is crashing and then tries to restart, repeating the cycle.

description: updated
Dara Adib (daradib) wrote :

Assigned to Ubuntu Desktop Bugs.

Changed in nautilus:
assignee: nobody → desktop-bugs
Dara Adib (daradib) wrote :

This is the error message that appears in terminal if show_desktop is unchecked. It does not occur if show_desktop is checked.

$ nautilus

(nautilus:1307): Unique-DBus-WARNING **: Error while sending message: Message did not receive a reply (timeout by message bus)
$

description: updated
Dara Adib (daradib) wrote :

Since I am not sure when this bug will be fixed, I am providing (as is, with ABSOLUTELY NO WARRANTY) a simple shell script that will downgrade nautilus, nautilus-data, and libnautilus-extension to version 1:2.25.3-0ubuntu2. It downloads the old binary versions of those packages from Launchpad (this will not work when Launchpad removes those files from disk), forces their downgrade, and attempts to fix any unmet dependencies. Extract the script.tar.gz file, and run (in terminal) script32.sh or script64.sh, for Ubuntu 32-bit or 64-bit, respectively. Remember not to upgrade nautilus in the future until this bug is fixed.

Sebastien Bacher (seb128) wrote :

could you stop commenting on this bug? the issue is well understood, it's due to the autorestart in the desktop file which trigger autorestarting from gnome-session when nautilus exit which it does immediatly when there is no background to draw and no dialog open which leads to the loop described there

Ferenc Magyar (garferi) wrote :

Problem also exits in 2009-02-17 jaunty-desktop-i386 daily release!

nyarnon (cabal) wrote :

Todays update reset the nautilus.desktop file rendering marmuta's solution useless I had to reset it manualy to false again as gnome started spawning happely again :-)

As Marmuta's solution isn't shown here and the original thread featuring it was closed I quote it here:

Marmuta says:
Fwiw, the one workaround I found was that I can stop gnome-session from respawning nautilus by setting X-GNOME-AutoRestart=false in /usr/share/applications/nautilus.desktop.

Chris Coulson (chrisccoulson) wrote :

Nautilus should have an AutostartCondition on /apps/nautilus/preferences/show_desktop in the desktop file. There should be no reason to autostart it if this key is false.

Changed in nautilus:
assignee: desktop-bugs → chrisccoulson
status: Triaged → In Progress
Changed in nautilus:
assignee: chrisccoulson → ubuntu-desktop
status: In Progress → Triaged
assignee: ubuntu-desktop → desktop-bugs
Chris Coulson (chrisccoulson) wrote :

That doesn't actually work as intended.

Changed in nautilus:
milestone: none → ubuntu-9.04-beta
bingalls (bruce-ingalls) wrote :

This bug affected my Dell Dimension 4700, but did not manifest itself on a 3 year old HP Compaq.
I used the same Jaunty 9.04 Alpha 5 LIVE CD on both boxes. It may help to report your hardware, with respect to this bug.
Perhaps CMOS settings are relevant, such as PXE boot?

Chris Coulson (chrisccoulson) wrote :

bingalls - there is no need to report hardware. The cause of the bug is well understood and is not hardware dependant in any way.

Changed in nautilus:
status: Unknown → New
nyarnon (cabal) wrote :

And today again the nautilus.desktop file was updated, the problem still exist. Aplied marmuta's test again.

Rebug (j-de-cuba) wrote :

Ubuntu Jaunty Jackalope 9.04 alpha-6
Same problem here today after update, no desktop-background (blackscreen) and continuous loading of Nautilus File Browser. What to do next?!

nyarnon (cabal) wrote :

Confirmed update of Nautilus but problem persists stop gnome-session from respawning nautilus by setting X-GNOME-AutoRestart=false in /usr/share/applications/nautilus.desktop.

Elfy (elfy) wrote :

I have the same issue if I try to show trash on the desktop.

Phan Trọng Khanh (khanhpt) wrote :

I'm using Jaunty alpha-6. After upgrade I get same problem. If disable show_desktop, i can not start nautilus and get allway get high cpu usage.

Changed in nautilus:
status: Unknown → Fix Released
Martin Pitt (pitti) wrote :

Applying the AUTOSTART_CONDITION bandaid can certainly not hurt, but I understand that the real bug is much harder to fix. However, the remaining problem has a low exposure (requiring gconf-editor).

In either case I don't consider this a blocker for the beta.

Changed in nautilus (Ubuntu Jaunty):
importance: High → Medium
milestone: ubuntu-9.04-beta → none
antistress (antistress) wrote :

What about netbooks which come with that conf ?

Chris Coulson (chrisccoulson) wrote :

Hi Martin

The autostart condition wasn't really successful because gnome-session still restarts it even when the condition isn't met. The real bug is that EggSMClient can't set the restartstyle hint after connecting to the session manager, which is how Nautilus used to work with GnomeClient in Intrepid.

I discussed this briefly with Sebastien on IRC yesterday, and the suggestion was that we should probably just completely disable Autorestart for Nautilus in Jaunty (which is what people have already been doing in this bug report to work around the issue).

appel (appel) wrote :

I had this bug out of the box with alpha 6, clean install in vmware, hadn't changed anything in gconf.

Sheldon (sgodinho) wrote :

Any hope for a quick solution here?
I (perhaps stupidly) upgraded to Jaunty on my main machine and this nautilus issue has me buggered.

Alan Ferrier (alan-ferrier) wrote :

Add the line:

AutostartCondition=GNOME /apps/nautilus/preferences/show_desktop

to /usr/share/applications/nautilus.desktop.

Then logout and login again.

Alan Ferrier (alan-ferrier) wrote :

Voila. Unbuggered.

duendetuc (elduendemirande) wrote :

thanks!

Chris Coulson (chrisccoulson) wrote :

The workaround is already discussed in this bug report.

And the AutostartCondition doesn't work, because gnome-session will still restart Nautilus even when the condition isn't true. It just stops it from being started initially.

Sheldon (sgodinho) wrote :

Nope, still buggered.
Is the fact that I get no response to right-clicking the desktop related to this?
I suppose it must be...

Chris Cheney (ccheney) wrote :

I see this problem as soon as I boot on the amd64 daily-live from today. I'm not sure if this isn't supposed to be happening by default on the daily-live cd or if this just hasn't been noticed yet?

Chris Cheney (ccheney) wrote :

On my amd64 daily-live cd I have to actually uncheck 'show desktop' in gconf for the spawning/crashing(?) to stop, which appears to be the opposite of what this bug report mentions...

Sheldon (sgodinho) wrote :

Only functional solution is to uninstall Nautilus, replace temporarily with Dolphin, and hopefully reverse these when the clever boys have identified and solved the problem.

Sheldon (sgodinho) wrote :

One more thing, since this problem started yesterday, every reboot is immediately followed by an Update Information pop-up saying

"The language support files for your selected language seem to be incomplete. You can install the missing components by clicking on "Run this action now" and follow the instructions. An active internet connection is required. If you would like to do this at a later time, please use "System Settings -> Regional & Language" instead."

Choosing to run the action has no effect, choosing Next or Close kills the window. Any advice to kill it permanently? Is it a related problem or a new bug?

summary: - "Starting File Manager" windows open uncontrollably
+ gnome-session keeps respawning nautilus when no desktop is drawed
Changed in nautilus:
status: Triaged → Fix Released
Changed in nautilus:
status: New → Confirmed
Hew McLachlan (hew) on 2009-07-04
Changed in nautilus (Ubuntu):
status: Fix Released → New
Changed in nautilus (Ubuntu):
status: New → Triaged
31 comments hidden view all 111 comments
antistress (antistress) wrote :

same for me with a clean install of karmic alpha 5

Randakar (randakar) wrote :

karmic. Me too ;-)

maehZe (maehze) wrote :

Linux version 2.6.31-10-generic (buildd@yellow) (gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu1) ) #35-Ubuntu SMP
x64

same problem, karmic.

camper365 (camper365) wrote :

I still have this problem in version 1:2.28.0-0ubuntu2 of Nautilus, Linux version 2.6.31.11.22.
I saw a fix a few weeks ago, but the bug became active again. I don't know if it is still open or if it got closed

nyarnon (cabal) wrote :

This is already so old and will occur everytime /usr/share/applications/nautilus,desktop is replaced. You have to edit it again and set autorestart=false. One of these days I will set it ro and see what happens during install :-D evil grin

drs305 (drs305) wrote :

I will confirm camper365's observation in #75; running the same versions.

As soon as I untick "/apps/nautilus/preferences/show desktop" in gconf-editor nautilus starts autospawning. I got tired of turning off the option in /usr/share/applications/nautilus.desktop and now just keep the Desktop view enabled.

Yeah, still happening in Ubuntu 9.10.

Chris Wyatt (wyattmeister) wrote :

Thank you so much. I had it disabled and when I updated to Karmic Koala beta it was continually respawning. Wouldn't have thought to re-enable this option.

nyarnon (cabal) wrote :

@drs305

And loose my cube? No way man. The faces of all those win loosere, gently switching from 1 face to the other and suddenly keeping ctrl-alt-arrow pressed and the cube spinning out of control on my little eee-pc netbook. On an intel card FGS. No way gnome is taking that fun from me.

Simon Gerber (gesimu) wrote :

Still happening for me on an up-to-date Karmic Koala Beta (Although setting AutostartCondition=GNOME /apps/nautilus/preferences/show_desktop in /usr/share/applications/nautilus.desktop seems to do the trick...)

camper365 (camper365) wrote :

I have found that the fix doesn't work the next time you start up (/usr/share/applications/nautilus.desktop) unless you make it read-only (444 permissions)

I have a few questions:
- this was patched in Ubuntu 9.04, any reason (other than time/manpower) why this isn't the case for 9.10 anymore?
- is it harmful in any way to chmod 444 /usr/share/applications/nautilus.desktop?

This is pretty much the only issue I've had with Ubuntu 9.10 so far that is "severe", if I did not have a core2quad, I would probably not have survived to ask about this :)

camper365 (camper365) wrote :

I have found no problems with setting nautilus.desktop as read-only. but I have found that after an update, the problem exists again (because it's run as root, the file can be edited whether it's read-only or not).
I have found that if I open a gnome-terminal (if you can get to it before nautilus takes all of your cpu) or go to a tty and type "killall nautilus" it will work. however, sometimes I have to continually press Up and Enter to get it to work (running the command just once doesn't always work).

Sebastien Bacher (seb128) wrote :

the workaround has been dropped in karmic because if you keep workarounds it doesn't encourage people to work on the issue, the bug didn't worked though so we might want to apply it again now in karmic

nyarnon (cabal) wrote :

Well this has taken to long already I'm seriously thinking of replacing nautilus by Thunar. It's really ridiculous that a bug like this just persists. Unless gnome is protecting it's desktop.

Aron Griffis (agriffis) wrote :

Better to use dpkg-divert to protect your modified nautilus.desktop than trying to use permissions. Here's the formula:

$ sudo dpkg-divert --add --rename --divert \
    /usr/share/applications/nautilus.desktop.real \
    /usr/share/applications/nautilus.desktop
$ cp /usr/share/applications/nautilus.desktop.real \
    /usr/share/applications/nautilus.desktop
$ echo "AutostartCondition=GNOME /apps/nautilus/preferences/show_desktop" \
    >> /usr/share/applications/nautilus.desktop

This will cause upgrades of nautilus to write to nautilus.desktop.real rather than overwriting your modified version. See http://www.debian-administration.org/articles/118

2009/10/12 nyarnon <email address hidden>

> Well this has taken to long already I'm seriously thinking of replacing
> nautilus by Thunar. It's really ridiculous that a bug like this just
> persists. Unless gnome is protecting it's desktop.
>
> --
>

The issue is not trivial to fix and comments like that aren't particularly
helpful. Nautilus is currently a required component of the GNOME session
because it is needed for auto-mounting removable media. However, Nautilus is
currently designed to exit when it has nothing left to do (such as when it
is set to not draw the desktop), which contradicts the need for it to be a
required desktop component and doesn't make much sense.

So far, it doesn't seem like anyone here has come up with any proper
solutions. Either Nautilus should be designed to never exit, even when it
has nothing to do (such as drawing the desktop), or the media handling part
of Nautilus should move to some other desktop component and Nautilus should
not be a required component. Both ideas are non-trivial though, and require
someone with the time and interest in working on it.

You're more than welcome to make a contribution.

In the meantime, if you don't want to keep modifying nautilus.desktop after
every update, just remove nautilus from the list of required components in
your session

camper365 (camper365) wrote :

I'm not meaning to sound rude, but I have seen this bug fixed in previous versions, so I don't see why it has come back.
However, I do not know much about nautilus under the hood, so there could have been another bug fix that occurred in the newer versions that brought this bug back.
I am unable to see why the older versions can't be put into Karmic until this bug gets fixed.

I agree with Sebastien regarding the workaround because, unless you subscribed to this bug via e-mail, most people are going to forget about the bug in a week's time after the workaround is applied.

Chris Coulson (chrisccoulson) wrote :

It's never been fixed properly. Instead, a workaround was applied in Jaunty to stop it respawning. That means that Nautilus just exits instead and means that you lose all media handling capabilities if you don't have Nautilus drawing the desktop.

nyarnon (cabal) wrote :

@ Chris
Thats just the remark I would have expected from you. First of all I contributed by creating a bug report many moons ago. Then I kept adding info and educating people about a work around. All the time waiting patiently for a solution. Do you really think that I as a user give a you know what why it is hard to solve. We users are very simple people if it works we use it if it doesn't out of the window it goes. Wasn't that the point of that 'developer shut up strategy' to make that clear. I will have a look at the stand alone setup of compiz because I'm really fed up with this. Might help me cut some bloat added by Gnome over the last few months also.

Brett Johnson (linuxturtle) wrote :

I agree with Chris that a proper fix ought to be committed, rather than just another workaround. If nobody cares about the "show_desktop" option enough to fix it, maybe it should just be disabled (i.e. remove the gconf key, and just always show the desktop). Personally, losing this option would annoy me enough to make me finally dump the GNOME desktop altogether, but it's at least a solution, and it's better than just continuing to ship a broken Nautilus. The option is certainly useless in its currently broken state, so just disabling it shouldn't be much of a leap.

Simon Gerber (gesimu) wrote :

I certainly don't agree with you Brett, because the amount of posts in this bugreport clearly shows that there are quite a few people who use the feature... I agree though that the issue should be fixed properly.

Sebastien Bacher (seb128) wrote :

could the users who get the issue give details on the reason why they turn off the background display? the new nautilus version used in karmic has a gconf key to not exit in such case, it would make sense to use that if users are trying to get a clean background or get something else to render it but not so much if the goal is to have nautilus not running

Brett Johnson (linuxturtle) wrote :

@Sebastien: Ooh, excellent idea. Here's my story ;)

I don't want nautilus to draw the desktop because it doesn't give me a useful desktop context menu, or even any way to create a useful desktop context menu. And if it's drawing the desktop, it won't allow any other software to give me a desktop menu. So I just turn show_desktop off, and run xfdesktop instead (which gives me a context menu I can customize any way I want). I don't particularly care if Nautilus is running or not, as long as it's not sucking up too many resources. I just want a desktop menu I can control/customize.

camper365 (camper365) wrote :

The reason I turn off the nautilus desktop is to allow compiz to draw it, giving me a different background per workspace. However, if nautilus allowed a transparent desktop background (I have seen the ability to do this, but it requires a recompile, and I haven't taken the time to do it), then I would turn nautilus on.

antistress (antistress) wrote :

The only reason why I turn off the nautilus desktop is that i don't like the desktop metaphor (whereas I like the Netbook Remix way for instance).
All my files are managed through a proper Nautilus window with a navigation toolbar and sort & display options.
Therefore i turn off the nautilus desktop to not have useless options like a contextual menu for creating folders on the desktop etc. Because i like consistency. I don't like having useless things. As you can see my reasons are essentially intellectual and for me i must admit that the bug is minor

Simon Gerber (gesimu) wrote :

I turn the desktop off for several reasons: 1) I don't need desktop icons. 2) As others already mentioned the context-menu which nautilus offers is completely useless (I remember that there used to be an entry to start a terminal at least, that was in GNOME 2.18 or something). 3) There is no way to get to the openbox context menu when the desktop is enabled. 4) I don't really care about nautilus at all, I just like the gnome-panel and other GNOME related stuff and therefore still use the gnome-session, but with openbox as window manager.

Aron Griffis (agriffis) wrote :

I turn off the desktop because ion3, which doesn't support EWMH, insists on managing the window. ion3 is a tiled window manager so (if you're using tiled desktops) there is no desktop for nautilus to draw.

I turn off desktop because...

 * I practically only use nautilus to copy music files to my mp3 player.
 * I'd like to have my home directory (not Desktop) as Desktop directory in nautilus, and I have to many files to fit on the screen.
 * I don't do file handling in my home directory all that much, so why should I have a constantly open file manager that's not even full featured?
 * It's easy to accidentally do bad stuff with your files.
 * I prefer to use the places menu with bookmarks
 * The applications I use have smarter ways to navigate to files relevant to the task. For example, Ryhtmbox lets you search thousands of music files. Eclipse lets you find any file in the current project by pressing a shortcut and type part of the filename.
 * Icons on my pretty background image looks ugly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.28.0-0ubuntu6

---------------
nautilus (1:2.28.0-0ubuntu6) karmic; urgency=low

  * debian/patches/16_workaround_autorestart_issue.patch:
    - set the autorestart key to false to workaround gnome-session respawning
      nautilus again and again when not displaying the background (lp: #325973)

 -- Sebastien Bacher <email address hidden> Tue, 13 Oct 2009 00:03:42 +0200

Changed in nautilus (Ubuntu Karmic):
status: Triaged → Fix Released

Perhaps it is too late to matter since it looks like disabling autorestart just got merged in but...

It seems to me that I was just now able to fix the problem by unchecking *both* show_desktop and exit_with_last_window in configuration editor (apps>nautilus>preferences).

I have my 3D cube working, no spinner, and no nautilus windows open. Looking at my processes I see that I have a nicely cooperating nautilus process with an insignificant amount of CPU usage. The autorestart patch has not yet made it to my computer and I can still switch back and forth between proper behaviour and having the spinner and CPU hogging auto-restarts.

So an alternative fix would be to alter configuration editor to either suggest or automatically uncheck exit_with_last_window if show_desktop is unchecked. Another approach would be to check and correct the settings in a startup script.

> could the users who get the issue give details on the reason why they
> turn off the background display?

To have a clean background (more detailed justification on
http://open-source.ecchi.ca/?voir=articles/killing_the_desktop )

> the new nautilus version used in karmic
> has a gconf key to not exit in such case, it would make sense to use
> that if users are trying to get a clean background

Would work in my personal case, according to your description... I that,
according to replies from other users in this thread, I'm not alone in
this use case, but there are some more "fancy" approaches.

But then it seems this has already been patched by the time I'm writing
this, so I'll just wait for the package updates.

Henrik Nyberg (henrik-mysko) wrote :

I just upgraded to 2.28.0-0ubuntu6, and the issue persists.

I am not sure what autorestart you are talking about, but X-GNOME-AutoRestart remains set to true in nautilus.desktop. This is also the case in the file distributed within the package itself.

Changed in nautilus (Ubuntu Karmic):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:2.28.0-0ubuntu7

---------------
nautilus (1:2.28.0-0ubuntu7) karmic; urgency=low

  * Update the series to list the previous change (lp: #325973)

 -- Sebastien Bacher <email address hidden> Thu, 15 Oct 2009 17:02:44 +0200

Changed in nautilus (Ubuntu Karmic):
status: Confirmed → Fix Released

As noted on the GNOME bugzilla report:

https://bugzilla.gnome.org/show_bug.cgi?id=571417#c31

If you want show_desktop off then set exit_with_last_window to false. Disabling the auto-restart will mean you lose volume automounting and anything else handled by nautilus, by turning off show_desktop.

I would suggest that a better fix for this bug would be to make exit_with_last_window default to false.

Sebastien Bacher (seb128) wrote :

the use of those key has been discussed before but it would be an issue for people who turn the key because they don't want nautilus running

Sebastien,

Who is using this key because they don't want a nautilus process running? Since you asked in comment #94 for people's reasons, none of the responses seem to indicate this.

Roel (roel-muylaert) wrote :

hey I have the same problem in lucid how can I fix it my curen't nautilus version is 1:2.31.1-0ubuntu1~ppa89

Sebastien Bacher (seb128) wrote :

the version you are using is not an ubuntu one but a ppa build

Changed in lucid:
status: New → Invalid
Changed in nautilus:
importance: Unknown → Medium
status: Confirmed → Fix Released
Aiman Baharna (aiman) on 2010-11-05
affects: lucid → launchpad
Curtis Hovey (sinzui) on 2010-11-05
affects: launchpad → null

Fallen victim to his bug on Natty. Interestingly, I only get it when I try to run a dual-monitor. This happens on both Unity and "Classic." Unplugged monitor, reset X, turned show_desktop back on, and every thing worked fine.

Displaying first 40 and last 40 comments. View all 111 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.