Do not switch to fallback menu on mouse-over

Bug #703555 reported by Vish
76
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Application Menu Indicator
Fix Released
Medium
Ted Gould
Ayatana Design
Undecided
Unassigned
Indicator Applet
Fix Released
Undecided
Unassigned
Unity
Fix Released
Wishlist
Neil J. Patel
libindicator
Fix Released
Undecided
Unassigned
indicator-appmenu (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: unity

Previously in Unity, we had a fallback menu(File> Close) when a window had no menu bar.
This made sense since we dint want to leave the top panel empty or blank when there is no menu.

However, for maximixed windows we have now merged the menubar and titlebar, and for normal window we now display the window title. So we do have something being displayed in the top panel always.

Why do we need to switch to a fallback menu?
For example, synaptic displaying a fallback seems odd. We know the fallback menu on top is not the main menubar.
Or apport window which has no menu. We already know a menubar does not exist.

Why do we actively display this false menu?

If it is to keep a consistent regular behavior, (being consistent to change to something when user is hovering over the panel), why not just show something which is not a false menu. [something like "---" ]
Or just brighten/dim the titlebar on mouse-over, just indicating no menu is there to display.

It seems very odd that we are actively trying to display a false menu, when instead we should be looking at ways to show that a menu does not exist for the particular window.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Sun Jan 16 18:46:36 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101224)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101224)
Lsusb:
 Bus 002 Device 002: ID 80ee:0021
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: innotek GmbH VirtualBox
PciDisplay: 00:02.0 VGA compatible controller [0300]: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-11-generic root=UUID=d10db803-076f-48bb-822a-a7ff661fe8ec ro vt.handoff=7 quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu6
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-11-generic

Related branches

Revision history for this message
Vish (vish) wrote :
Revision history for this message
Vish (vish) wrote :
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Omer Akram (om26er) wrote : Re: [Bug 703555] Re: Do not switch to fallback menu on mouse-over
Download full text (3.8 KiB)

in the 2d version of unity hovering over a window with no menus (like
chromium) does not show the stubs and that feel right.

On Sun, Jan 16, 2011 at 6:48 PM, Vish <email address hidden> wrote:

>
> ** Attachment added: "misleading menu.png"
>
> https://bugs.launchpad.net/ubuntu/+source/unity/+bug/703555/+attachment/1795733/+files/misleading%20menu.png
>
> ** Changed in: unity (Ubuntu)
> Importance: Undecided => Wishlist
>
> --
> You received this bug notification because you are subscribed to unity
> in ubuntu.
> https://bugs.launchpad.net/bugs/703555
>
> Title:
> Do not switch to fallback menu on mouse-over
>
> Status in “unity” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: unity
>
> Previously in Unity, we had a fallback menu(File> Close) when a window had
> no menu bar.
> This made sense since we dint want to leave the top panel empty or blank
> when there is no menu.
>
> However, for maximixed windows we have now merged the menubar and
> titlebar, and for normal window we now display the window title. So we
> do have something being displayed in the top panel always.
>
> Why do we need to switch to a fallback menu?
> For example, synaptic displaying a fallback seems odd. We know the
> fallback menu on top is not the main menubar.
> Or apport window which has no menu. We already know a menubar does not
> exist.
>
> Why do we actively display this false menu?
>
> If it is to keep a consistent regular behavior, (being consistent to
> change to something when user is hovering over the panel), why not just show
> something which is not a false menu. [something like "---" ]
> Or just brighten/dim the titlebar on mouse-over, just indicating no menu
> is there to display.
>
> It seems very odd that we are actively trying to display a false menu,
> when instead we should be looking at ways to show that a menu does not
> exist for the particular window.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.2.8-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> Uname: Linux 2.6.37-11-generic i686
> Architecture: i386
> CompizPlugins: No value set for
> `/apps/compiz-1/general/allscreens/options/active_plugins'
> Date: Sun Jan 16 18:46:36 2011
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101224)
> InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101224)
> Lsusb:
> Bus 002 Device 002: ID 80ee:0021
> Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> MachineType: innotek GmbH VirtualBox
> PciDisplay: 00:02.0 VGA compatible controller [0300]: InnoTek
> Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA
> controller])
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> LC_MESSAGES=en_US.utf8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-11-generic
> root=UUID=d10db803-076f-48bb-822a-a7ff661fe8ec ro vt.handoff=7 quiet splash
> ProcVersionSignature_: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
> RelatedPackageVersions:
> xserver-xorg 1:7.5+6ubuntu6
> libgl1-mesa-glx 7.9+rep...

Read more...

Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

I think I'm agreed with this, but want MPT's sign-off as he knows the
state and intent of the fallback menu better than anybody else.

Mark

Revision history for this message
David Barth (dbarth) wrote :

Makes sense: let's see when it's back from the design loop.

Changed in unity:
importance: Undecided → Wishlist
Revision history for this message
Neil J. Patel (njpatel) wrote :

Waiting for design, fwiw I agree with this too.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.6
status: New → Incomplete
Revision history for this message
Mark Shuttleworth (sabdfl) wrote :

Consider this approved from design, we've not heard from MPT since I conditionally ack'd it six weeks ago.

Changed in ayatana-design:
status: New → Fix Released
Vish (vish)
Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
importance: Wishlist → Low
status: New → Triaged
Neil J. Patel (njpatel)
Changed in unity:
milestone: 3.6 → 3.4.4
Revision history for this message
Neil J. Patel (njpatel) wrote :

I've added the code that will stop the hover effect from happening if we have no entries. Now it's over to appmenu to stop making the fallback menu. Adding as task and assigning it to Ted.

Changed in unity:
status: Confirmed → Fix Committed
Changed in indicator-appmenu:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.4.4-0ubuntu1

---------------
unity (3.4.4-0ubuntu1) natty; urgency=low

  * New upstream release:
    - add systray support (LP: #655140, #596879)
    - Dragging and holding a selection over an entry in the Launcher should
      spread out windows belonging to that application (LP: #607796)
    - Unity shouldn't allow to Quit itself (LP: #705536)
    - Launcher should not be locked in place until the pointer is actually in
      the corner (LP: #706146)
    - Top Panel does not respect GTK theme (LP: #663524)
    - Update Unity-Panel Style implementation (LP: #685830)
    - Add keyboard shortcut for the panel (LP: #701663)
    - clicking on the ubuntu logo doesn't close the dash dialog (LP: #708762)
    - "Escape" doesn't close the dash screen (LP: #711195)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
       directory name: "/desktop/unity/launcher/favorites//type": Can't have
       two slashes '/' in a row (LP: #716382)
    - Icon state does not revert when remote libunity user closes (LP: #716863)
    - transparency in places window a bit too high (LP: #718357)
    - Navigating between menus briefly gives focus back to applications
      (LP: #690714)
    - pace on cursor navigation mode should act like middle click (LP: #717213)
    - Do not switch to fallback menu on mouse-over (LP: #703555)
    - Fix the panel service and menus atk object hierarchy (LP: #704350)
    - Expose home panel button via ATK (LP: #715295)
  * debian/source_unity.py: enhanced apport hook for incoming compiz hook
  * debian/control:
    - bump nux and libunity-misc dep
 -- Didier Roche <email address hidden> Thu, 17 Feb 2011 20:37:42 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Vish (vish)
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Omer Akram (om26er) wrote :

I think Unity should do the same as unity-2d i.e. if an app is creating stubs or is blacklisted in indicator-appmenu or appmenu-gtk hovering over its title should not show stubs, this should be done in Unity itself since indicator-appmenu is used in Classic Desktop Session and not having these fallback menus there would make the panel look weirdly empty.

Ted Gould (ted)
Changed in libindicator:
status: New → Fix Released
milestone: none → 0.3.22
Ted Gould (ted)
Changed in indicator-applet:
milestone: none → 0.4.10
Ted Gould (ted)
Changed in indicator-applet:
status: New → Fix Released
Ted Gould (ted)
Changed in indicator-appmenu:
status: Triaged → Fix Committed
milestone: none → 0.2.0
Ted Gould (ted)
Changed in indicator-appmenu:
status: Fix Committed → Fix Released
Changed in indicator-appmenu (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-appmenu - 0.2.0-0ubuntu1

---------------
indicator-appmenu (0.2.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Adding a check of the indicator environment to hide the menu stubs
      under Unity (LP: #703555)
    ∘ Send about-to-show on menus that don't have any children currently
      (LP: #619811)
    ∘ Work around bugs in signaling by delaying the destruction of menu
      caches for five seconds (LP: #718926)
    ∘ Disconnecting client signal handlers on displose (LP: #738561)
    ∘ Remove menuitem signals on root changes (LP: #743404)
 -- Ted Gould <email address hidden> Thu, 07 Apr 2011 11:01:06 -0500

Changed in indicator-appmenu (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Kazade (kazade) wrote :

I don't think this is completely fixed, I'm still experiencing this (duplicate): https://bugs.launchpad.net/ubuntu/+source/unity/+bug/734900

I've removed indicator-appmenu and the title on maximized windows still vanishes on mouse over. I'm running Unity 3.8.4-0ubuntu1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers