attachment added within a comment is sometimes hidden

Bug #1105543 reported by rpr nospam
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Fix Released
Low
William Grant

Bug Description

In the current Launchpad (r16451) if you open a bug report with many comments, some of them are hidden and the info box at the end of the page reads something like the following:
"Displaying first 40 and last 40 comments. View all 155 comments or add a comment."

In this case an attachment added within a comment near the end of the page is not visible.

On the other hand, if you enable viewing all comments, the hidden attachment shows up.

You can reproduce the issue if you open the following two pages and look at the comment #154:
https://bugs.launchpad.net/bamf/+bug/842566
https://bugs.launchpad.net/bamf/+bug/842566?comments=all
(See the attached picture.)

I'd say that an attachment added within a comment should be always shown if the comment is not hidden.

Related branches

Revision history for this message
rpr nospam (rpr-nospam) wrote :
Changed in launchpad:
status: New → Triaged
importance: Undecided → Low
tags: added: bugs comments
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

One way of fixing this would be to have view filters for the comments, including "All Comments" and "Attachments Only". Choosing "Attachments Only" would usually reveal any hidden attachments, since >40 attachments is much less likely than >40 comments.

William Grant (wgrant)
Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Revision history for this message
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
Colin Watson (cjwatson)
tags: added: qa-ok
removed: qa-needstesting
William Grant (wgrant)
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments