knetworkmanager stops kde applications from accessing the network

Bug #86680 reported by fmo on 2007-02-21
150
This bug affects 2 people
Affects Status Importance Assigned to Milestone
KDE Network
Unknown
Medium
knetworkmanager (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: knetworkmanager

My machine is an Acer Aspire 5685WLMI, it's running KUbuntu Herd4 dist-upgraded to 21/02.
I connect to the network through the LAN adapter, the wifi adapter is not in use but is detected and working.

When I start KDE and try to use any application that makes use of the network and that Knetworkmanager is started, I can't access the Internet, typically I can't connect to Msn with Kopete, Akregator and Konqueror can't browse the Internet either.

As soon as I quit KNetworkManager, everything works fine.

The problem doesn't seem to affect Firefox but I suppose it's because it doesn't use the same network libraries.

There is just one exception for Kde applications, the Jabber plugin of Kopete seems to work even when Knetworkmanager is running.

ProblemType: Bug
Date: Wed Feb 21 11:18:04 2007
DistroRelease: Ubuntu 7.04
Uname: Linux avalon 2.6.20-8-generic #2 SMP Tue Feb 13 05:18:42 UTC 2007 i686 GNU/Linux

Luka Renko (lure) wrote :

Is your network connection managed by knetworkmanager (lan or wifi)? Or is knetworkmanager not really managing the active interface?

Can you execute:
dcop kded networkstatus status hostname

(replace hostname with hostname of your mail server, msn server, whatever that you lack access to)

You should execute the above command with knetworkmanager running and when not running.

Changed in knetworkmanager:
status: Unconfirmed → Needs Info
fmo (fmo) wrote :

the Wifi connection is definitely managed by Knetworkmanager, the Lan connection I'm not sure, if I select Static Connection it shows both eth0 (Lan) and eth1 (wifi).

I ran the dcop command and got the following results:
 - if Knetworkmanager is running
"dcop kded networkstatus status messenger.hotmail.com" returns 6
"dcop kded networkstatus status planetkde.org" returns 6

 - if Knetworkmanager is not running
"dcop kded networkstatus status messenger.hotmail.com" returns 1
"dcop kded networkstatus status planetkde.org" returns 1

messenger.hotmail.com is the example for the Msn connection through Kopete.

planetkde.org is for the RSS feed through Akregator.

and I can't access ANY website with Konqueror when Knetworkmanager is running.

Thank you for your help.

Veysel Harun Sahin (harunsahin) wrote :

I live the same problem. When my knetworkmanager is opened i can not access to internet with kde applications. My dcop commands returns the same results. By the way i have disabled wireless networks and i use static connection to access the internet.

Veysel Harun Sahin (harunsahin) wrote :

Sorry i have forgotten to write about my system. I use kubuntu feisty fawn herd 4, knetworkamanager 0.1, kernel 2.6.20-8-generic.

fmo (fmo) wrote :

Dist-upgrade 23/02, problem is still outstanding

Luka Renko (lure) on 2007-02-23
Changed in knetworkmanager:
assignee: nobody → lure
importance: Undecided → High
status: Needs Info → In Progress
Luka Renko (lure) wrote :

Seems that gnome users have same/similar problems: bug 82335

Veysel Harun Sahin (harunsahin) wrote :

Yes, the problems are very similar. Also your comment "Side-effect it that n-m will reissue dhcp call and potentially override static address. :-(" on bug 82335 explains some of the other problems which i live.

fmo (fmo) wrote :

As far as I am concerned, this bug has been addressed and can now be closed

Luis F. Lopez (luis.lopez) wrote :

Bug is still present on my system.

When I connect to Internet using kppp (Cellular connection with Sierra Wireless Card 580) knetworkmanager reports status as Disconnected (as the ppp0 device seems not to be managed by nm) and kopete is not able to connect to MSN.

If kdenetwork manager is stopped, then "dcop kded networkstatus status messenger.hotmail.com" returns 1 and kopete will connect to MSN.

What is strange though, it's the fact that if I reconnect my LAN cable while connected via ppp and then hang up on my ppp connection the default gateway is deleted and I have to set it up manually (or disconnect/connect the LAN cable again)

Scott Kitterman (kitterman) wrote :

knetworkmanager 0.1-0ubuntu12 should resolve this.

Luis F. Lopez (luis.lopez) wrote :

Bug still there after upgrading to knetworkmanager 0.1-0ubuntu12

Colin Pinkney (colin-pinkney) wrote :

This bug is still present for me in the final Kubuntu Feisty Desktop CD (KNetworkManager 0.1-0ubuntu12). This is with a wireless connection setup through System Settings as KNetworkManager does not complete the connection for me as described here: https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/96097

As soon as I quit KNetworkManager KDE apps can access the internet.

I'm still impressed that my Wireless PCI card works 'out of the box' though and I can configure it with the System Settings :)

Robert Penz (robert-penz-name) wrote :

Hi!

I've no problem with lan/wlan, but if i use my UMTS card with kppp I've this problem. Firefox and the shell programs work without a problem, but every KDE application doesn't work until I close knetworkmanager.

I get following with knetworkmanager

$ dcop kded networkstatus status www.heise.de
6

and without I get

$ dcop kded networkstatus status www.heise.de
1

This is a major bug as it makes the usage of UMTS modems for most users impossible.

karel (karel-novotny) wrote :

Hi Luka,

Just to report that I am experiencing the same problem. I am using Acer TravelMate 2000 and I installed the final Feisty release (and have last knetworkmanager package installed).

Thanks for attention to this!

karel

merlot (merlot) wrote :

Hello,

just commenting that the problem occurs here too:

-Wireless network handled by knetworkmanager (works normally)
-When away from work, using kppp + bluetooth + dialup:
Firefox(, ping, wget) works normally, KDE-apps do not.

If I quit knetrworkmanager from system tray, KDE apps can make network connections.

That's all, thanks
Sami

thedanyes (thedanyes) wrote :

I have literally spent probably 20 hours trying to figure this problem out. Chatting on the IRC, chatting on the qunu, reinstalling packages, etc. I never thought to disable knetwork manager.

I'm running ubuntu 7.04, and certain parts of networking for KDE apps fail when knetworkmanager is running. For instance: Konqueror usually works regardless. Amarok will not upload track play information to last.fm, kopete will not log on to MSN (but will log on to other networks), and Kmail will not connect to my IMAP server. When I stop knetwork manager, all these apps work fine. Here is some information that might be helpful:

root@machinename:/home/username# uname -a
Linux machinename 2.6.20-15-generic #2 SMP Sat Apr 14 00:54:01 UTC 2007 i686 GNU/Linux

root@machinename:/home/username# apt-cache showpkg knetworkmanager
Package: knetworkmanager
Versions:
0.1-0ubuntu12 (/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_feisty_main_binary-i386_Packages) (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_feisty_main_binary-i386_Packages
                  MD5: 8e7acde44930387aad6546096099ba84

Reverse Depends:
  kubuntu-desktop,knetworkmanager
Dependencies:
0.1-0ubuntu12 - kdelibs4c2a (2 4:3.5.5-1) libacl1 (2 2.2.11-1) libart-2.0-2 (2 2.3.16) libattr1 (2 2.4.4-1) libaudio2 (0 (null)) libc6 (2 2.5-0ubuntu1) libdbus-1-3 (2 0.94) libdbus-qt-1-1c2 (2 0.62.git.20060814) libfontconfig1 (2 2.4.0) libfreetype6 (2 2.2) libgcc1 (2 1:4.1.2) libglib2.0-0 (2 2.12.9) libhal1 (2 0.5) libice6 (2 1:1.0.0) libidn11 (2 0.5.18) libjpeg62 (0 (null)) libnm-util0 (0 (null)) libpng12-0 (2 1.2.13-4) libqt3-mt (2 3:3.3.8really3.3.7) libsm6 (0 (null)) libstdc++6 (2 4.1.2) libx11-6 (0 (null)) libxcursor1 (4 1.1.2) libxext6 (0 (null)) libxft2 (4 2.1.1) libxi6 (0 (null)) libxinerama1 (0 (null)) libxrandr2 (2 2:1.2.0) libxrender1 (0 (null)) libxt6 (0 (null)) networkstatus (2 4:3.5.6) zlib1g (2 1:1.2.1) network-manager (2 0.6.2) kwalletmanager (0 (null))
Provides:
0.1-0ubuntu12 - network-manager-kde
Reverse Provides:

merlot (merlot) wrote :

Hi again,

I just wanted to add that I'm naturally ready to provide any information that helps to solve the problem. Just let me know.
My system is Feisty, fully updated - and the problem is easy to reproduce.

Sami

Stacey Lane (nonsense28) wrote :

I would also like to confirm this bug. I recently did a fresh install of Feisty Kubuntu. I noted then that Akregator would not download any of the feeds it comes subscribed to by default. Yesterday I installed KDE 3.5.7 and there is no change in the behavior of Akregator. Konqueror also cannot access the Internet, but Firefox and Opera have no problems doing so. I tried turning off Knetwork Manager, but this did not seem to make any difference on my machine. Even after turning of Knetwork Manager, Akregator still cannot access any RSS feeds.

The problem also goes away when the "Network Status Daemon" is disabled in the System Settings Service Manager.

txshtkckr (crf) wrote :

I'm also having this problem. When knetworkmanager first tries to connect to my wireless network, it asks me for the WEP password for my network. After I enter it, it just sits there with the gear spinning (apparently at 0%). When I check the wallet, there is no entry for knetworkmanager, so it did not successfully create the keystore. If I run knetworkmanager --nofork, I get this on the console:

** (process:20494): CRITICAL **: nmu_security_serialize_wep_with_cipher: assertion `(key_format == IW_AUTH_KEYFORMAT_HEX) || (key_format == IW_AUTH_KEYFORMAT_ASC || key_format == IW_AUTH_KEYFORMAT_PASS)' failed

** (process:20494): CRITICAL **: nmu_security_serialize_wep_with_cipher: assertion `(key_format == IW_AUTH_KEYFORMAT_HEX) || (key_format == IW_AUTH_KEYFORMAT_ASC || key_format == IW_AUTH_KEYFORMAT_PASS)' failed
Serialization of encryption payload failed (key reply).

I haven't started digging into the source to figure out why this would be, but all of this suggests to me that knetworkmanager is probably failing to connect to the wallet. It is not, however, giving me any direct indication that this is what happened, much less how to fix it. I can use iwconfig to set the essid and key manually, then run dhclient ath0, and a connectivity is restored. However, since knetworkmanager still thinks the connection is down, KDE apps like Konqueror and Kopete misbehave.

Please feel free to contact me if you need additional information.

RaRue (pasacki) wrote :

I'm using Kubuntu 7.04 and have had difficulties with establishing a network connection.

I have an old Duron machine with an Ethernet device but this is not hooked up to anything. Meanwhile, my serial line is connected to a dial-up modem.

After reducing the connection speed to 38400 I was able to get kppp to dial in and connect to my ISP. Unfortunately, konqueror cannot get to the internet.

So, my Knetworkmanager only shows my "eth0" connection, enabled by default, but my carefully established ppp0 connection is never mentioned.

My instinct tells me that successful establishment of a default route over my PPP link probably depends upon Knetworkmanager at least recognizing that I might want to use a network connection apart from eth0 etc.

Any suggestions? TIA.

RaRue (pasacki) wrote :

Well, I can achieve network connectivity through PPP by knetworkmanager disabling the eth0 interface, then running kppp whose pppd will then be able to succeed in establishing a default route. I think.

Luis F. Lopez (luis.lopez) wrote :

I was able to get knetworkmanager to handle my ppp connection by following the instructions posted here:

http://www.marotori.com/blog/?p=23

However, the bug persists. When the connection is made, kde applications are not able to connect to the network.

Luis F. Lopez (luis.lopez) wrote :

I found a workaround from the KDE bug tracking system:

http://bugs.kde.org/show_bug.cgi?id=130472

After establishing the connection, I manually run this command from konsole:

$ dcop kded networkstatus setNetworkStatus NMNetwork 1

And after that, KDE applications are able to connect!

BTW, I use knetworkmanager 1:0.2~r686534-0ubuntu1 on Kubuntu 7.10 (Gutsy). Can someone else confirm if this works for other versions?

Changed in kdenetwork:
status: Unknown → In Progress

The same problem (kde apps not accessing the net when using ppp and having knetworkmanager running), which also gets fixed with Luis López workaround.
gutsy tribes 4, network-manager-kde 1:0.2ubuntu1-0ubuntu1

Fred van Zwieten (fvzwieten) wrote :

Strange, the dcop workaround works for me on Feisty, but not on a up-to-date gutsy tribe 5

It's still working on gutsy, with todays update. I also followed http://www.marotori.com/blog/?p=23 to add my dial up entry to knetworkmanager.

I've found that I have to do "dcop kded networkstatus setNetworkStatus NMNetwork 1" frequently if there are any encripted wifi networks nearby. The only solution is to disable wireless connections in knetworkmanager.

Juan Villarejo (juaniv-a) wrote :

I have the same problem on feisty fawn, using an usb modem huawei smartAX mt810 using eagle usb drivers. When I disable knetworkmanager, everything is fine

kervel (frank-dekervel) wrote :

i think this functionality (preventing applications from accessing the internet when
 knetworkmanager thinks there is no internet) should be disabled completely.

i'm also affected by this bug, and even when knetworkmanagers manages to detect a ppp connection somehow,
there will be other methods of connecting to the internet (or a LAN which konqueror can browse) that knetworkmanager doesn't see.

btw, on other areas i really like knetworkmanager

kervel wrote:
> i think this functionality (preventing applications from accessing the internet when
> knetworkmanager thinks there is no internet) should be disabled completely.
>
> i'm also affected by this bug, and even when knetworkmanagers manages to detect a ppp connection somehow,
> there will be other methods of connecting to the internet (or a LAN which konqueror can browse) that knetworkmanager doesn't see.
>
> btw, on other areas i really like knetworkmanager
>
>
I agree, knetworkmanager is much nicer than messing with system settings
in KDE..(an admin password is needed to enable/disable eth0 all the time
in both cases...) I think knetworkmanager must be taking exclusion of
other resources.. As oppose to just being a front end for controlling
them...(isn't that what it's supposed to be?) *yawns tiredly* Why must
networking be this way...
 Maybe it's secure to not let grandma have physical access to the
internet on my computer.. lol, anyways, I digress!

Rob Landley (rob-landley) wrote :

I'm encountering this bug too, on a fresh install of 7.10 for x86_64 on a Dell Inspiron 1505 that came preinstalled with Ubuntu 7.04. After the install, /etc/network/interfaces only had lo in it (despite my system having a "b44" eth0 and an "ipw3945" eth1). This meant that knetworkmanager said I had no interfaces, but I could iwconfig, ifconfig, and dhcp from the command line.

This left me in the weird position of having networking work just fine, but nothing in KDE would acknowledge it. I've been fighting this for over a day now. I installed firefox to post this bug report (which works fine, but Konqueror insists I have no net, regardless of reality). I went into the network settings gui and disabled/enabled both interfaces (_that_ could find them just fine), but that made no difference to knetworkmanager.

I just exited knetworkmanager but the dcop thing mentioned above still says:
dcop kded networkstatus status landley.net
6

I can ssh to that server from the command line just fine, but Konqueror still says it can't connect to any host I've tried. Yet I'm typing this on firefox just fine. (I already had kmail set up to shell out to a program that does an ssh tunnel, and Konversation is ignoring Knetworkmanager's delusions.)

I guess after all these years, I'm finally a firefox user. The switch has been forced upon me. I haven't changed the file associations so that clicking on links in Kmail bring up firefox yet, but if I can't fix this soonish...

Rob Landley (rob-landley) wrote :

Ah, closing knetworkmanager _does_ make Konqueror start working again. I just have to tell it "don't start automatically next boot" or it instantly _restarts_ itself when I tell it to quit.

That's a separate bug.

Matthew (gromituk) wrote :

Hello - can I just add my name to the list please? I wasted hours fiddling about until I discovered from this thread that the problem was knetworkmanager and not routing or IPV6. In my case I'm using a Sagem F@st 800 modem (ueagle-atm) which I installed and got hotpluggable with udev without much problem. But then I couldn't get any web pages with Konqueror!

I've worked out a partial fix for KNetworkManager managed PPP connections as a drop in replacement for the current kubuntu_05_networkstatus.patch.

The problem was simply that the original patch didn't account for PPP connections.

Neil Musgrove (neilmusgrove) wrote :

I have created a network bridge for Virtual Box (br0) which knetworkmanager does not detect, it also blocks internet access in this situation when it is running.

Emiel Kollof (emiel-kollof) wrote :

This bug is still present in Gutsy, upgraded just a few hours ago. I also tried Fedora Cora which has the all new singing and dancing 0.7 version, but the ppp support in there I need to connect through rfcomm and bluetooth still is lacking.

Nice that I now can set up a PPP dialup in network-manager, but it still does not "see" the connection.

Just confirmation: Fresh installation of Gutsy (20071016.1) on VBI custom notebook (Asmobile S96S chassis). After configuring network wia K->System settings->Network settings Konqueror did not open standard web pages etc. (see above). After reading all this stuff, I simply found KNetworkManager's process ID "ps -A | grep knetw" and then killed it "kill -9 ...".

Since that I am able to konect with Konquerror normally.

Changed in kdenetwork:
status: In Progress → Invalid
Rob Landley (rob-landley) wrote :

Why was this marked invalid with no explanation? If you're going to say "this is a duplicate" then tell us which bug we should be monitoring. Don't take a bug that's hitting so many people that it's been entered into the system five times yet _this_ one has dozens of comments and say "your concerns are invalid".

Pavel Mendl (pavel-mendl) wrote :

Rob, in my opinion developers just decided that this bug will be assigned to knetworkmanager branch (where Luka Renko is assigned with high importance) and thus KDE network branch is marked invalid to prevent any duplicity.

Please developers, correct me if I am wrong...

Luis F. Lopez (luis.lopez) wrote :

Any news about this bug?

On Thursday 31 January 2008 11:42:33 Luis F. López M. wrote:
> Any news about this bug?

Dunno. I just ripped it out and use the attached script instead. I did
an "add applet to panel" to make a button to run it via sudo. It's annoying
that it prompts me for a password, but not enough to put more effort into it.

I'll try again next release, I suppose. (I really should try the betas this
time...)

The fact that there's code in konqueror and such to LET this thing shut down
the entire network is _stupid_. It shouldn't have the OPPORTUNITY to
malfunction in such a way that unrelated programs stop listening to the
network. That's brain-damaged at the design level. What were they smoking?
Attempts to access the network return "no route to host" immediately when
there are no active interfaces. You don't need any sort of "yes dbus, there
is a network interface" flag. It's just something extra to break!

Rob
--
"One of my most productive days was throwing away 1000 lines of code."
  - Ken Thompson.

I also have a bit to say on this matter. After hours of having to surf with Firefox, I found out Konqueror will work in 2 ways, if knetwork manager is enables: the FIRST option is disabling the cache, the SECOND is running Konqueror as root, which I suppose will work for other apps as well. Because of Konqueror working fine as root, and before reading this thread, I thought the problem might have been in the read/write permissions of the cache folder (home/user/.kde/cache-'hostname', which really points to /var/tmp/kdecache-'username'). The only one to have ANY kind of permission is, indeed, root. What I thought logical was to then chmod the above folder, in order to give read/write permissions to the group which Konqueror belongs to. DO NOT DO THAT. I was updating the system when I did it, and everything crashed, but I thought it was because of the update. I spent hours with only konsole access, because KDE would not load (Yes, that one simple seemingly insignificant folder will do that to you), and I thought I had a broken system because of update issues. I finally thought the problem might have been related to that folder, but not remembering the exact original permissions, I just deleted it hoping it would automatically be recreated exactly as the original. Everything now seems to be working. So...

Option 1) Shut down knetworkmanager
Option 2) Disable cache
Option 3) Run the program as root

Just workarounds. though, any news on actually solving the bug?

PS: DO NOT chmod /var/tmp/kdecache-'username'

And oh, I was thinking... What the hell is an "enterprise version" of free software, anyways :-P ...?

toscano (daniele-toscano) wrote :

I confirm this bug also in kubuntu 8.04

julian.tejada (julian-tejada) wrote :

Well, I find a similar bug in my Kubuntu 8.04, the Knetwork manager blocking the internet access for all kde applications after it return of hibernation. In another situation the Knetwork manager works fine.

I also confirm that the bug is still present in Kubuntu 8.04. I'm using a PPP connection for an Eagle USB ADSL modem. The connection works fine from the command line (ping, wget, ssh, etc.), but not from KDE applications such as Konqueror. If I stop networkstatus (by running kcmshell kcmkded and stopping it), or if I quit Network Manager, then it starts to work correctly.

It's very annoying.

David McNeill (davemc) wrote :

I've also just discovered this bug. Clean install of Hardy 8.04 on a brand new Compaq notebook (wiping Wista off).

It was a new user's first introduction to open source. Email for his small business for weeks had been at cafe's & friends places. He lives miles out in the country, so dial up is all he can get. He's real keen to be up and running, but is not a power user. I chose KMail because Thunderbird is a 12Mb download, and over dialup that's all night or more. I thought kmail would be all nicely integrated, so I'd get less problems. Not!!!

So I spend 1/2 an hour on dialup stooging around till I find this and related threads. I read the above and know for sure it's the same issue. I can also see there's been little concrete progress on solving it. Quite likely because no one who can solve this one uses PPP all the time, and not many who use PPP have the skills to solve it.

To wrap up, it is still current, it does have a lot of real world consequences. I'd like to help but not sure how, since it obviously involves KDE internals and a bit of wizardry. So for now all I can do is add this user's story.

The only workaround for now for this bug is the one on comment 24 (https://bugs.launchpad.net/ubuntu/+source/knetworkmanager/+bug/86680/comments/24), you can always add that line to a script.

Luis F. Lopez (luis.lopez) wrote :

I guess the only definitive solution to this issue is to use the wstephens branch for kppp (http://websvn.kde.org/branches/work/~wstephens/kppp/) and create a package for kubuntu. Volunteers?

BTW, Has anyone tried to reproduce this error in kde 4?

Luis

Yuriy Kozlov (yuriy-kozlov) wrote :

See also:
A report requesting to have kppp set the network status correctly for knetworkmanager is bug 193907

The bug in Ubuntu is bug 191889.

KPPP shouldn't do this, as there are other sources of PPP startup; perhaps putting it in the /etc/ppp/ip-up and /etc/ppp/ip-down scripts; umtsmon also starts up ppp, for example.

I did a fresh hardy heron (8.04) install of ubuntu. then added the kubuntu-desktop package. logged in to kde. network was working fine across suspend/resume and network change. then like a fool I ran knetworkmanager to take a look at it. very next time I resumed from sleep, konqueror couldn't connect to any hosts but firefox still worked. so I killed knetworkmanager and konqueror worked again. thanks for letting me know the workaround. I'll use the gnome network manager when I need it and will viciously kill knetworkmanager if I ever lose network in konqueror again.

Changed in kdenetwork:
status: Invalid → In Progress
Luis F. Lopez (luis.lopez) wrote :

There's hope this error gets fixed for KDE 3:

http://bugs.kde.org/show_bug.cgi?id=130472#c15

Caterpillar (caterpillar) wrote :

I have this problem on Kubuntu 8.10

Luka Renko (lure) on 2009-05-01
Changed in knetworkmanager (Ubuntu):
assignee: Luka Renko (lure) → nobody
Jonathan Thomas (echidnaman) wrote :

Thank you for taking the time to report this bug and helping to make Kubuntu better. The KDE3 version of KNetworkManager has been discontinued by its original authors. This unfortunately means that there will be no more bugfix releases, and updates in general will be limited to those fixing security flaws.

While we cannot fix your bug, the good news is that the applet has been totally rewritten for KDE4 in the upcoming Kubuntu 9.10 release. There is a good chance that this bug is no longer an issue with the new applet. If you find any similar or new issues with the applet included in Kubuntu 9.10, we would politely ask you to file them as new bugs against the "plasma-widget-networkmanagement" package.

Thanks in advance for your cooperation and understanding.

Changed in knetworkmanager (Ubuntu):
status: In Progress → Won't Fix
Changed in kdenetwork:
importance: Unknown → Medium
Changed in kdenetwork:
status: In Progress → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.