Program won't save files without given extension on Win32

Bug #408566 reported by TDolce on 2009-08-03
130
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
David Xiong

Bug Description

Regardless of which file format I choose to save the file as,..it becomes a blank file that cannot be opened by any app. I tried pdf, wmf, png, and svg all with no success..I'm running WIN XP (plenty of speed and available space)

TDolce (todd-dolce) wrote :

Further testing has proven this:

During the Save and Save As Dialogue process,..you MUST add the suffix (file extension) after the name in order for it to save it. This is VERY WEIRD. In other words,..even though I have chosen to save the file as a .png file,...Inkscape is forgetting to add the file extension to the name when saving it. I had to name the file "dogsketch.png" instead of "dogsketch."

Please tell me that this is not by design.

See image attached

theAdib (theadib) on 2009-08-03
Changed in inkscape:
status: New → Confirmed
tags: added: ui win32
summary: - Program won't save files
+ Program won't save files without given extension on Win32
Changed in inkscape:
status: Confirmed → New
theAdib (theadib) wrote :

hm I tried on WinXP
-start inkscape
-draw something
-save as
-enter filename: foo
-and it saves as foo.svg

So I can not confirm you issue. Have you tried a recent 0.47pre1 from sourceforge ? http://sourceforge.net/projects/inkscape/files/

Thx, Adib.

Just downloaded it today.

Td

Todd P. Dolce'
FedEx Solutions
901.224.2889 W
901.201.8840 C

----- Original Message -----
From: <email address hidden> <email address hidden>
To: Todd Dolce
Sent: Mon Aug 03 16:25:41 2009
Subject: [Bug 408566] Re: Program won't save files

hm I tried on WinXP
-start inkscape
-draw something
-save as
-enter filename: foo
-and it saves as foo.svg

So I can not confirm you issue. Have you tried a recent 0.47pre1 from
sourceforge ? http://sourceforge.net/projects/inkscape/files/

Thx, Adib.

** Changed in: inkscape
       Status: New => Confirmed

** Summary changed:

- Program won't save files
+ Program won't save files without given extension on Win32

** Tags added: ui win32

** Changed in: inkscape
       Status: Confirmed => New

--
Program won't save files without given extension on Win32
https://bugs.launchpad.net/bugs/408566
You received this bug notification because you are a direct subscriber
of the bug.

Status in Inkscape: A Vector Drawing Tool: New

Bug description:
Regardless of which file format I choose to save the file as,..it becomes a blank file that cannot be opened by any app. I tried pdf, wmf, png, and svg all with no success..I'm running WIN XP (plenty of speed and available space)

Pablo Trabajos (pajarico) wrote :

> Just downloaded it today.
So?

So....I was asked if it was the latest version.

Yes!

Todd P. Dolce'
FedEx Solutions
901.224.2889 W
901.201.8840 C

----- Original Message -----
From: <email address hidden> <email address hidden>
To: Todd Dolce
Sent: Tue Aug 04 22:36:52 2009
Subject: [Bug 408566] Re: Program won't save files without given extension onWin32

> Just downloaded it today.
So?

--
Program won't save files without given extension on Win32
https://bugs.launchpad.net/bugs/408566
You received this bug notification because you are a direct subscriber
of the bug.

Status in Inkscape: A Vector Drawing Tool: New

Bug description:
Regardless of which file format I choose to save the file as,..it becomes a blank file that cannot be opened by any app. I tried pdf, wmf, png, and svg all with no success..I'm running WIN XP (plenty of speed and available space)

Pablo Trabajos (pajarico) wrote :

Ok, I see now you tried with a recent release. I took your "just downloaded it today" like you downloaded a newer version but didn't try it yet.

TDolce (todd-dolce) wrote :

No problem,...I see your point. I should have been more clear!
Sometimes I rush and that is a bad thing.

I will try and download a later version in a few weeks and see if I get
the same problem. It very well could be something I did...who knows.

I deleted the app for now and will download again later.
I can't wait to use it extensively!

td

Todd P. Dolce'
FedEx Solutions
901.224.2889 W
901.201.8840 C

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of
Pablo Trabajos
Sent: Thursday, August 06, 2009 11:55 AM
To: Todd Dolce
Subject: [Bug 408566] Re: Program won't save files without given
extension onWin32

Ok, I see now you tried with a recent release. I took your "just
downloaded it today" like you downloaded a newer version but didn't try
it yet.

--
Program won't save files without given extension on Win32
https://bugs.launchpad.net/bugs/408566
You received this bug notification because you are a direct subscriber
of the bug.

Status in Inkscape: A Vector Drawing Tool: New

Bug description:
Regardless of which file format I choose to save the file as,..it
becomes a blank file that cannot be opened by any app. I tried pdf, wmf,
png, and svg all with no success..I'm running WIN XP (plenty of speed
and available space)

Alvin Penner (apenner) wrote :

- cannot reproduce this behaviour on Windows XP, using 0.47pre1.
- could you provide more detailed steps to reproduce?

Changed in inkscape:
status: New → Incomplete
jazzynico (jazzynico) on 2009-11-18
tags: added: saving
David Bolton (davidkbolton) wrote :

I encountered this bug today. It happened several times with one file but I eventually resaved with the file extension appended and now I can't reproduce the problem with any file.

(Version 0.47, Windows XP)

David Bolton (davidkbolton) wrote :

I worked it out. Here's the steps to reproduce:

1. Create a folder with a dot in it (e.g. "1. Drawing")
2. Start Inkscape
3. Save the new file into the folder you created in step 1. Do not manually write an extension at the end of the file name.

Expeceted behavior: The file name chosen in step 3 should have a file extension appended automatically

Actual behavior: The file name is saved without any file extension

su_v (suv-lp) wrote :

Changing status to 'Confirmed': the (or one of the) underlying cause(s) as described in comment #10 was reproduced with Inkscape 0.48 and confirmed in #inkscape (irc channel).

Changed in inkscape:
importance: Undecided → Medium
status: Incomplete → Confirmed
Shane Goodwin (ithacanz) wrote :

Confirmed in 0.48.1 on Win7 as well. Very, very annoying "feature".

David Xiong (yunwxiong) on 2011-04-21
Changed in inkscape:
assignee: nobody → David Xiong (yunwxiong)
David Xiong (yunwxiong) wrote :

I just did a quick fix on the two bugs. (quick fixes are not ideal, but solve the problem. Also, it helps to get familiar with the methods and types.)

I have fixed the error and tested the program. It should not cause issue in Ubuntu or other platforms. I don't know for sure without testing.

For bug:
https://bugs.launchpad.net/inkscape/+bug/769725

I added a check on the filename. If it does not end with the extension string, e.g. ".svg" or "eps", add it based on what file format is chosen in the dialog. Then, the missing-extension error no longer happens.

For bug (new):
https://bugs.launchpad.net/inkscape/+bug/769725

It is fixed with the first bug being fixed. If the file does not miss the extension, the problem does not occur any more.

The attached patch file is the change. I generated using bzr diff. I am not sure how to send a patch, or push changes, although I tried making a branch (https://code.launchpad.net/~yunwxiong/+junk/test_debug1).

Finally, I agree with Jon that a better way to deal with cross-platform file directories and names would be useful.

The bugs you link to in your last post are both the same; can you
clarify which ones you meant exactly?

Perhaps you can have a look at my fix of bug 530957 and verify that I
did it correctly, or change it to work better :-)

Thanks for your work on this! Much appreciated :-)

Johan Engelen (johanengelen) wrote :

Sad it took so long for the patch to be applied. Thanks a bunch for the fix!

Changed in inkscape:
milestone: none → 0.48.3
status: Confirmed → Fix Committed
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments