Non-Unicode symbol fonts do not work on Windows

Bug #165665 reported by Ckkart-users on 2004-04-18
132
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Unassigned

Bug Description

I tried both version 0.37 and 0.38.1 and neither of
them seems to be able to display any symbol font (e.g.
Microsoft Symbol, Standard Symbol, Open Symbol). It
would be very nice to have some greek letters...

Kees Cook (kees) wrote :

This seems to be some limitation in the underlying font
subsystem. I can't see them either. (And I don't seem to
render ru_RU chars correctly either...)

Mrdocs-users (mrdocs-users) wrote :

We have battled this with Scribus.

Franz thinks its an issue with freetype2. Open Office
sometimes has difficulties with these fonts as well.

Bryce Harrington (bryce) wrote :

Please check this again with the 0.39 release with the
Pango font rendering option. That change may fix this issue.

Bryce Harrington (bryce) wrote :

Confirmed; Inkscape does not seem to detect the availability of the
symbol font.

Matiphas-users (matiphas-users) wrote :

Behaves OK for me (win2k)
Simply downloaded July 7th 2004 build, unzipped and launched :
symbol fonts directly usable from Inkscape.

see screen capture :
http://www.chez.com/matiphas/symbol_font.png

Matiphas-users (matiphas-users) wrote :

Just a small problem with the refresh of the preview pannel
(as seen on the screenshot).
I'm currently testing it as much as possible and will sum up
issues on devel ML before issuing bugs/rfes

Ckkart-users (ckkart-users) wrote :

I have just built 0.39pre3 on SUSE 9.1 but the problem still
exists. If I remember right, in the versions I tried before
just nothing was displayed. Now the symbol font is
subtituted by some other font.
Christian

Ckkart-users (ckkart-users) wrote :

Just tried the new 0.39 autpackage on SuSE9.1. Now the fonts
are again substituted by some other fonts.

Works in CVS as of today. Tested Symbol font from Windows on
both Windows and Linux. It says "failed to load unicode
charmap" but displays the symbols correctly. Please test and
reopen if you find any problems.

Marcin W. Dąbrowski (rehael) wrote :

In version 0.44+devel from 18 Jun (from
http://mrchapp2.homelinux.net/~inkscape/inkscape-0606180200.7z)
symbol fonts are NOT working.
The font I'm "fighting for" is
http://dvie.dreamsigns.net/fonts/wod/wod.zip

I tried with:
- rebuilding fntcache.dat,
- removing all .fonts.cache-1 files from my filesystem,
- rebooting, restarting, etc...

PS: ...not realted to this, but doeas Inkscape use ~/.fonts
directory? In <installdir>/etc/fonts/fonts.conf it is said
it uses, but in fact it doesn't. (GIMP uses it ok, index in
.fonts-cache-1 is crated, etc...)

Bryce Harrington (bryce) wrote :

Re-opening for user.

Bryce Harrington (bryce) wrote :

Originator: NO

Postponing until post-0.45

Evi1-dad (evi1-dad) wrote :

Originator: NO

Symbol font is required for many jobs. It needs to be fully supported.

Version: .45
System: Windows XP Professional

Changed in inkscape:
status: New → Confirmed
Rygle (rygle) wrote :

Has anyone confirmed this with 0.46? I know there have been some big library changes that may have fixed this.

Rygle (rygle) wrote :

This still seems to be a problem on Win32 with trunk 18352 and the latest devlibs from Ishmal and patched pango libs found here;
http://ftp.gnome.org/pub/gnome/binaries/win32/pango/1.20/pango-1.20.0.zip

The pango guys don't seem too worried about non-unicode fonts.

Inkscape 0.46 breaks fonts handling on my Windows x64. 0.45.1 works as one would expect.

Roy Dennington (roy-semichem) wrote :

I am using Inkscape 0.46 with Windows XP SP2. In addition to the Standard Symbol font, most of the "mathtype" fonts are also missing. You can download the fonts (for display purposes only) from http://www.dessci.com/en/dl/fonts/getfont.asp. It is also not picking up other variants such as "Euclid-Italic"

Hatta (hatta00) wrote :

I am also using 0.46 on XP SP2. Symbol fonts do not show up in the font list. Opensymbol appears, but all characters are empty squares.

I would like to use Inkscape to draw diagrams for publication in a scientific journal. Without greek fonts, this application is not useful at all to me. I can't believe this bug has been open for 4 years, is anyone working on this?

sas (sas-sas) wrote :

There's no problem using Greek fonts, or fonts like Times New Roman that contain the Greek alphabet. Also, you can use the LaTeX effect to do mathematical formulae (though you probably need to download a newer version of eqtexsvg.py - see https://bugs.launchpad.net/inkscape/+bug/55273/comments/36 ).

pbhj (pbhj) wrote :

Kubuntu 8.10 with "Inkscape 0.46+devel, built Apr 6 2008"

No problems with Symbol, Symbolix, Webdings, Wingdings, etc.. FWIW. (Posted due to query on Answers).

WIndows Vista with Inkscape 0.46:

Symbol, Wingdings, Webdings are not showing up in the fonts list. This is rather annoying...

Alex Dent (apd4) wrote :

I am using 0.47 Inkscape for Windows XP. I am trying to use the Clearview font for roadsigns, but it goes straight to the Sans font. Is there anything to fix this?

Domus (dominique-domussoft) wrote :

Using 0.47. Still no Wingdings available. Is this still being worked on?

Dieter Kleinrath (d-kleinrath) wrote :

I have posted a workaround here: https://bugs.launchpad.net/inkscape/+bug/239631.

Alvin Penner (apenner) wrote :

running Gimp 2.6 on Windows XP, these fonts appear to be supported properly. I tested symbol.ttf and Wingdings.ttf and ExtraS R from Bug 887327 to confirm that they work.

It appears that this problem was solved in Gimp by switching from Pango 1.2 to Pango 1.4, according to :
http://docs.gimp.org/en/font-problems.html

perhaps the same upgrade would work on Inkscape as well

su_v (suv-lp) wrote :

> (…) solved in Gimp by switching from Pango 1.2 to Pango 1.
> (…)
> perhaps the same upgrade would work on Inkscape as well

Inkscape on Windows already uses a much newer version - currently pango 1.28.3
(pango 1.4 was released on 16-Mar-2004, pango 1.28.3 on 29-Sep-2010)

References:
<http://bazaar.launchpad.net/~inkscape.dev/inkscape-devlibs/trunk/view/head:/readme.txt>
<http://ftp.gnome.org/pub/GNOME/sources/pango/>

Alvin Penner (apenner) wrote :

committed to rev 10742. This will affect only Windows users. As mentioned in the thread:
http://old.nabble.com/non-Unicode-symbol-fonts-do-not-work-on-Windows.-Bug-165665.-Do-we-need-the-flag-USE_PANGO_WIN32---td32832894.html

there is a possibility that this may adversely affect startup time. If so, please report it here or on the developer list.

Changed in inkscape:
status: Confirmed → Fix Committed
su_v (suv-lp) on 2011-11-17
Changed in inkscape:
milestone: none → 0.49
jazzynico (jazzynico) wrote :

Not sure it's completely fixed. The font name is listed in the font list, and the glyphs correctly rendered on the canvas, but the glyphs are not shown correctly in the font list and in the Text and Fonts dialog preview.

su_v (suv-lp) wrote :

The fix in r10742 possibly triggers this regression in inkscape trunk on Windows:

  Bug #1019522 “trunk (win32): Adobe Type-1 fonts not found”
  <https://bugs.launchpad.net/inkscape/+bug/1019522>
  (see comment #9)

wilfriedh (w-hennings) wrote :

I just tested this with a document imported from pdf with Inkscape on Windows 7 pro 32bit.
The pdf contains text in e.g. "Wingdings 3".

Inkscape 0.48.3.1 r9886 (stable release) does not display the glyphs in Wingdings 3 but uses "Sans" for displaying. The font selection dialogue shows "Sans" selected for all texts. The Wingding fonts are not listed in the font selection dialogue.
Fortunately after saving to svg the svg file contains the correct font names.

Nightly build r11604 (2012-08-13, latest available on skydrive.live.com) displays the glyphs correctly, and the Wingding fonts are listed in the font selection dialogue, BUT in the font selection dialogue NO font, NO font style and NO font size is selected for the selected text.

If needed, I can supply the svg file for testing.

Alvin Penner (apenner) wrote :

>> If needed, I can supply the svg file for testing.

thanks, could you attach the .pdf file?
this would make it possible for others to test this file on non-Windows platforms to see if this problem is unique to Windows or not.

wilfriedh (w-hennings) wrote :

Sorry, I cannot upload the pdf because it contains corporate logos. I deleted the corporate things from the drawing and upload the resulting svg file. The svg file exhibits the problems quite well:
Inkscape 0.48.3.1 r9886 (stable release) does not display the glyphs in Wingdings 3 but uses "Sans" for displaying. The font selection dialogue shows "Sans" selected for all texts, even for texts in font arial (Unicode font!). When a text is selected, the status line sais "Text (Sans, ..."
The Wingding fonts are not listed in the font selection dialogue.

Nightly build r11604 (2012-08-13, latest available on skydrive.live.com) displays the glyphs correctly, and the Wingding fonts are listed in the font selection dialogue, BUT in the font selection dialogue NO font, NO font style and NO font size is selected for the selected text, even for texts in font arial (Unicode font!). When a text is selected, the status line sais "Text (<no name found>, ...", even for texts in font arial (Unicode font!)

Alvin Penner (apenner) wrote :

>> BUT in the font selection dialogue NO font, NO font style and NO font size is selected for the selected text, even for texts in font arial

the missing font style is confirmed on Windows XP, Inkscape 11643. For both Arial text and also for Windings text, there is no font family reported in the status bar at the bottom. This appears to be related to the structure of the <text> tag. Normally, if you create text using the gui, you will have a <text> tag with a style attribute in it, and the style attribute will contain the font-family. The <text> tag will then have a <tspan> inside it, with no font information in the <tspan>. In the file FontTest.svg the font family info is in the <tspan> tag, not the <text> tag, which is probably why it is not found.
      This is a valid bug, but it should be reported separately, since it is not related to the use of non-unicode fonts, and since it may not be Windows-specific, where the original bug report was Windows-specific.

wilfriedh (w-hennings) wrote :

OK, I reported this issue (font family not shown) separately as bug 1046170.

Aimee Reynolds (frame313) wrote :

Hi. I'm totally new so please forgive me if this is of no help or you already knew but here is my workaround for Inkscape not showing these characters:

If I type up a wingding (or webding) in Word and paste it into Inkscape it still doesn't work and I get the 'empty clipboard' message. However, if I type one of those characters up in Word, and then go to the font properties and add an outline, I can then paste it into Inkscape and it does work.

So what I do is add the smallest outline possible in Word (.01) at the same color as the character and it looks great. Not sure why that works but it does.

Hope that is of some help to somebody.

Alvin Penner (apenner) wrote :

@Aimee, thanks for the tip. that's quite innovative! I should mention that the fix for this bug has already been committed to the trunk code. It is available for use if you download a development version of Inkscape. For Windows this is available at:
http://www.oss-marketplace.com/index.php/downloads-mainmenu-63/Inkscape/Entwicklerversionen/

summary: - non-Unicode symbol fonts do not work on Windows
+ Non-Unicode symbol fonts do not work on Windows
Jason Spencer (spencer8) wrote :

I don't believe the committed fix fully addresses the problem. I'm using Inkscape 0.48.4 r9939. The re-create case is pretty simple: Go to http://support.wolfram.com/kb/10427 and download either font pack on windows 7. Install the fonts. Open an new IS document, and choose the text tool. Select Mathmatica6 as the font--it's not listed in the font dialog. IS won't recognize the font at all. Other MS programs will. IS won't read the font if it's referenced in an imported file, or otherwise.

What I notice is that the font does not provide many glyphs. This may be about more than just unicode, and since so many of these bugs trace to this one, I decided to post this case here.

su_v (suv-lp) wrote :

On 2014-05-19 02:51 +0100, Jason Spencer wrote:
> I don't believe the committed fix fully addresses the problem. I'm
> using Inkscape 0.48.4 r9939.

Inkscape 0.48.4 does _not_ contain the fix (See bug status and milestone - the fix will be in the next major release (0.91). The bug status 'Fix Committed' does not mean 'Fix Released').

Bryce Harrington (bryce) on 2015-02-21
Changed in inkscape:
status: Fix Committed → Fix Released
Paul Ortyl (ortylp) wrote :

The issue still pesists (on Ubuntu) with 0.91

Example: see the following PDF: https://www.bundesnetzagentur.de/SharedDocs/Downloads/DE/Sachgebiete/Telekommunikation/Unternehmen_Institutionen/Frequenzen/Amateurfunk/AntraegeundFormulare/AntragZulassungAmateurfkPruefg130429.pdf

All rectangles are replaces with some other characters.

Alvin Penner (apenner) wrote :

@Paul - I think it would be best to open a new bug report for this issue, since the original report referred specifically to Windows, and since the import of pdf is a separate issue from the use of existing installed fonts.

Roma44 (onirix) wrote :

I can't use characters from Wingdings fonts with Inkscape 0.91.

I could with the same version of Inkscape on Windows XP.
In Windows XP in the Glyph panel I could insert good characters without having any preview in the panel but knowing the Unicode code of choose character. At the insertion symbol was well displayed.

Now on Windows 7, nothing happen.

David Bolton (davidkbolton) wrote :

Wingdings does not work for me in Inkscape 0.91 on Windows 7. It just shows a san-serif style font (even though it is listed as Wingdings in the font selection).

Maestro (a musical font that is used by Finale notation software) has a mix characters that work in Inkscape 0.91 and characters that appear as standard san-serif characters instead (see attached). The font is available with the free trial of Finale: http://www.finalemusic.com/ (I don't believe you can download the font separately).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions