Crashes on shift/ctrl+click on control handles of shapes (e.g. rectangle rounding, ellipse to circle, make circle whole, ...)

Bug #1594877 reported by PittMonkeyAT on 2016-06-21
194
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Patrick Storz
inkscape (Debian)
Fix Released
Unknown

Bug Description

Inkscape: ver. 0.91
OS: Windows 10 Home, x64, ver. 1511, Build 10586.420

Open new document. Draw rectangle. Drag to adjust vertical rounding radius. Shift+click to remove vertical rounding radius. App shuts down. Sometimes it takes two or three clicks but it always happens.

Attached a video. App crashes at the moment the video ends b/c Windows native video recorder stops when the current app stops.

PittMonkeyAT (ncerniglia) wrote :

Also affects making ellipse whole (closing ellipse after creating segment).

jazzynico (jazzynico) on 2016-06-22
tags: added: crash shape-editing
jazzynico (jazzynico) wrote :

Thanks for taking the time to file a report!

Not reproduced on Windows XP (32-bit), Inkscape 0.91, trunk rev. 14998 (official devlibs) and trunk rev. 14640 (experimental gcc5.1 devlibs).

The following reports seem to be at least related:
Bug #1522085 "Crash when shift+clicking on arc/segment node (ellipse tool)"
Bug #1530272 "shift click on rounded star crashes"
Bug #1594877 "crashes on shift+click rectangle rounding"

@64-bit Windows users, could you please test an experimental version (based on updated dependencies) available at ftp://download.tuxfamily.org/inkscape/win64/ and report back if it's fixed or not? Thanks!

Changed in inkscape:
importance: Undecided → High
tags: added: win64
Lars Johansen (larsmjo) wrote :

Same problem/crash here with Shift+click to remove rectangle rounding:
Was just following the tutorial-shapes.svg

Inkscape 0.91 r13725

OS: Windows 10 Pro, x64, ver. 1511, Build 10586.420

jazzynico (jazzynico) on 2016-07-05
Changed in inkscape:
status: New → Confirmed
Lars Johansen (larsmjo) wrote :

Rectangle:
Shift+click to remove rounding - crash 6 out of 10
Ctrl+click to equal rounding - crash 8 out of 10

Circle/Ellipse:
Shift+click to close circle/ellipse - crash 9 out of 10
Ctrl+click to make a circle from an eclipse - crash 8 out of 10

Star/Polygon:
Shift+click to remove rounding - crash 4 out of 10
Ctrl+click to remove skew - crash 7 out of 10
Alt+click to remove randomization - crash 8 out of 10

Spiral:
Shift+click to move inner handle to center - crash 9 out 10
Alt+click to reset divergence - crash 9 out of 10

-----------------------
Inkscape 0.91+devel 64bit r14950 (Inkscape 0.92pre1_64bit r14950)
OS: Windows 10 Pro, x64, ver. 1511, Build 10586.420
(this version have slow startup around 15 sec. on a QuadCore2.4GHz)

jazzynico (jazzynico) wrote :

Attaching backtrace from duplicate bug #1672543.

Changed in inkscape:
status: Confirmed → Triaged
Mc (mc...) wrote :

reproduced on 0.92.x but can't reproduce on master (please feel free to reopen with repro steps on master if needed)

Changed in inkscape:
status: Triaged → Fix Committed
milestone: none → 1.0
Patrick Storz (ede123) wrote :

This is actually a pretty annoying class of bugs in 0.92.x - even if it's fixed in master we'd want to backport the fix for 0.92.4, but I couldn't find the commit that fixed it, yet (so maybe it is not fixed at all or is gtk2-specific).

Changed in inkscape:
status: Fix Committed → Confirmed
milestone: 1.0 → 0.92.4
Sylvain Beucler (beuc) wrote :

(Apparently another report is #1522085.)

I eventually tracked the bug down to a "knot handler" that triggers various events that eventually delete it while it's still processing the click event.
(KnotHolder::knot_clicked_handler -> ShapeEditor::event_attr_changed -> ~KnotHolder)

AFAICS the related upstream commit is 1d2fa48c9a62c4929264cf5b59907f8d4f0e55b5
It introduces several other changed that are based on a newer code base.

The attached patch is a subset of that commit and fixes the issue, although I only tested in minimally.

I hope this will stabilize Inkscape until the next upstream release :)

Sylvain Beucler (beuc) wrote :

Same patch without the debug trace.

Sylvain Beucler (beuc) wrote :

Sorry, right patch attached again.
I spent too much time on this and need some sleep ;)

Patrick Storz (ede123) on 2018-10-25
summary: - crashes on shift+click rectangle rounding
+ Crashes on shift/ctrl+click on control handles of shapes (e.g. rectangle
+ rounding, ellipse to circle, make circle whole, ...)
Patrick Storz (ede123) on 2018-10-25
Changed in inkscape:
assignee: nobody → Patrick Storz (ede123)
Patrick Storz (ede123) wrote :

Based on discussion in the linked MR I created [1] which was merged into master now. If no regressions are found I'm going to merge [2] into 0.92.x which is a back-port of that change.

[1] https://gitlab.com/inkscape/inkscape/merge_requests/377
[2] https://gitlab.com/inkscape/inkscape/merge_requests/387

Patrick Storz (ede123) wrote :
Changed in inkscape:
status: Confirmed → Fix Committed
Changed in inkscape (Debian):
status: Unknown → Fix Released
Bryce Harrington (bryce) on 2019-01-18
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.