Dash - System commands presence confuse the definition of App

Bug #973181 reported by Christian Giordano on 2012-04-04
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
Christian Giordano
Session Menu
Fix Released
Medium
Ted Gould
Unity
Fix Released
Low
Unassigned
indicator-session (Ubuntu)
Low
Unassigned
unity (Ubuntu)
Low
Unassigned

Bug Description

As reported on unity-design mailing-list (https://lists.launchpad.net/unity-design/msg08912.html), commands which can be found in the Application Lens like "logout", "restart","shut down" can confuse the user about the nature of Applications.

While these commands could have been still useful for keyboard input, now some of them are accessible from the HUD, and the HUD is likely to be the better place to contain all of them.

----------------------------------
Desired solution:

Remove all the system commands from the Application Lens and add to the HUD what is not there yet.

Related branches

Sebastien Bacher (seb128) wrote :

those commands are .desktop from indicator-session, reassigning there

affects: unity-lens-applications → indicator-session
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → Low
Charles Kerr (charlesk) on 2012-04-04
tags: added: hud
manny (estelar57) wrote :

agree should not appear in the apps lens.

but in searches and/or hud is useful.

Ted Gould (ted) wrote :

So, I have mixed feelings on this. The reason we added them to indicator-session was a stop gap on some pretty rare, but possible upgrade scenarios where the indicator-session would either not load or not get installed. So, as a fallback, we put them in the dash so that there would be a way to shutdown the machine if we got into that case. The case is especially rare, and one could argue impossible to get to... but... I do like having the safty net.

The problem with using the HUD for this saftey net is that it isn't exposed in anyway currently so most users won't find it.

Sebastien Bacher (seb128) wrote :

if users need to log out they can press ctrl-alt-del the microsoft way and logout from the dialog displayed...

Ted Gould (ted) wrote :

Good point. Or if they have a soft power switch they get a dialog. That dialog is ugly now, but it works.

Changed in indicator-session:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ted Gould (ted)
Ted Gould (ted) on 2012-04-04
Changed in indicator-session:
status: Confirmed → In Progress
Changed in indicator-session (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.3.96-0ubuntu1

---------------
indicator-session (0.3.96-0ubuntu1) precise; urgency=low

  * New upstream release.
    * Remove desktop files so they don't appear in the dash. (LP: #973181)
    * Add gcov to the build for coverage statistics
 -- Charles Kerr <email address hidden> Thu, 05 Apr 2012 12:50:09 -0500

Changed in indicator-session (Ubuntu):
status: Confirmed → Fix Released
Charles Kerr (charlesk) on 2012-04-05
Changed in indicator-session:
status: In Progress → Fix Committed
Britt Yazel (bwyazel) wrote :

I agree with this 100%! (possibly because I posted the original message to the design list ;-) )

Along with the shutdown/lock scree/restart/logout items being removed, I still believe we should at least hide the system-settings duplicate items by default, or remove them all together. It is just rendundancy for the sake of redundancy to keep them in the applicaiton lens. It was usefull to have the system-settings options in the application menu back in gnome 2 because there was not a system-settings window, but now that we have a system-settings it is just clutter.

Also, having all of the system setting links solely in the system-settings menu intuitively makes a lot of sense, and also is comfortable for people coming from mac/windows with the system preferences/control panel.

I just don't like having it list 90+ applications on what should be a 'freshly' installed system.

Changed in hundredpapercuts:
status: In Progress → Fix Released
John Lea (johnlea) on 2012-04-10
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Christian Giordano (nuthinking)
tags: added: udp
Charles Kerr (charlesk) on 2012-04-12
Changed in indicator-session:
milestone: none → 0.3.96
John Lea (johnlea) on 2012-04-18
no longer affects: hundredpapercuts
summary: - System commands presence confuse the definition of App
+ Dash - System commands presence confuse the definition of App
description: updated
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
milestone: none → backlog
D. Wegener (dpwegener) wrote :

I couldn't disagree more with this bug. The session commands (logout, restart, shutdown, etc) definitively belong in the application lens. The whole point of the lens is to provide a single point of entry to the system. You hit super, start typing, and hit enter when you choice becomes the first one in the list.

The rest of this post is going to be pretty much a rant, but that is because of how frustrating the effects of these decisions are on the useability of the system from an experienced users perspective.

You have broken my system yet again. Please, Please, Please pick with a direction and stick with it. I DON'T WANT TO COMPLETELY RELEARN MY WORKFLOW WITH EACH NEW RELEASE. STOP IT.

I have been running a pre-release version of Precise for some time. This behavior just recently changed. This should not be a last minute addition to a Long Term Release. It basically means that if we don't like it, we have not input to get it changed. Another F-U from the Ubuntu Design gods. These changes need to be made available to the community at large well ahead of feature freezes and release candidates.

The initial write up of this bug indicates that some of these commands are available in the HUD. If so, I can't find them. Even if they are available there it means that you have to learn yet another interface to use them. There should not be 15 different interfaces that the user needs to learn to use in order to accomplish things on the system.

Britt Yazel (bwyazel) wrote :

"The session commands (logout, restart, shutdown, etc) definitively belong in the application lens." Considering the applications lens is used to list applications, there is no possible way that non applications should 'definitively' belong in the applications lens. Now, considering that it seems like your issue is that those items are not listed in the "dash" in general, I suggest you consider filing a bug report or a suggestion on the Design list to get a new category listed for items such as logout, restart, shutdown, etc.

Now, I apologize for perhaps ignorance on my part, but I do not see how not having access to these items via the dash "breaks your system" or your workflow.

"It basically means that if we don't like it, we have not input to get it changed. Another F-U from the Ubuntu Design gods." You do know that you can be a part of the design team and be able to give input into decisions such as this correct? Just because you haven't been voicing your input doesn't mean that the capacity for you to voice your input is not there. Just note when an issue like this arises, such as non applications being listed as applications, arguing for retaining of a flaw in order to not have to adapt to changing software will not get your far.

Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Changed in unity:
status: Confirmed → Fix Released
importance: Undecided → Low
Changed in indicator-session:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers