indicator applet needs keyboard shortcut

Reported by Eitan Isaacson on 2009-02-25
208
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Indicator Applet
Low
Ted Gould
One Hundred Papercuts
Low
Unassigned
indicator-applet (Ubuntu)
Medium
Canonical Desktop Experience Team
Lucid
Medium
Canonical Desktop Experience Team

Bug Description

Because there is no easy way of accessing the indicator applet via keyboard (in compiz, I think it is impossible), there should be a global hotkey that will activate it in a similar way that alt+f1 activates the main application menu.

Ted Gould (ted) on 2009-03-12
Changed in indicator-applet:
importance: Undecided → Low
milestone: none → 0.2
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

Now that the session menu (fusa replacement) is using an indicator, this is rather critical. There will be no other way for a user to shutdown/suspend/logout.

Changed in indicator-session (Ubuntu):
status: New → Confirmed
Changed in indicator-session (Ubuntu):
importance: Undecided → Medium
Changed in indicator-applet:
milestone: 0.2 → ubuntu-9.10-beta-freeze
Changed in indicator-session (Ubuntu):
milestone: none → ubuntu-9.10-beta
Changed in indicator-applet:
milestone: ubuntu-9.10-beta-freeze → none
milestone: none → 0.2
Changed in indicator-session (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Ted Gould (ted) on 2009-09-01
Changed in indicator-applet:
milestone: 0.2 → ubuntu-9.10-feature-freeze
David Barth (dbarth) on 2009-09-09
Changed in indicator-applet:
milestone: ubuntu-9.10-feature-freeze → ubuntu-9.10-beta-freeze
David Barth (dbarth) on 2009-09-18
Changed in indicator-applet:
assignee: nobody → Ted Gould (ted)
importance: Low → Medium
David Barth (dbarth) on 2009-09-25
Changed in indicator-applet:
importance: Medium → Low
milestone: ubuntu-9.10-beta-freeze → ubuntu-9.10
David Barth (dbarth) wrote :

Proposing CTRL-ALT-S for the session menu: it is really about /s/tatus, /s/ession and /s/ystem, so an S sounds like the right choice.

Paul Sladen (sladen) wrote :

Good that a key-combination is being proposed. My initial reaction to C-M-s is that it is locale-specific and likely to be undiscoverable. Wonder if mvo has any thoughts on this issue.

Paul Sladen (sladen) wrote :

...mpt even.

Martin Olsson (mnemo) wrote :

The most important thing is that you can open Applications and then use "right arrow" three times to get to this menu. If I had to pick a key though I would pick the SUPER-key (aka. the Windows key); but maybe the SUPER-key should be saved for a more common use case though. The SUPER-key is nice though because it's conceptually reserved for the shell (i.e. it will pretty much never be bound to something inside an application window).

David Barth (dbarth) on 2009-10-23
Changed in indicator-applet:
milestone: ubuntu-9.10 → none
Michał Małecki (michalus) wrote :

Is "milestone: ubuntu-9.10 → none" means that this idea is abandoned? Indicator applet without key bindings is useless! I think that it's big lack in user experience. Who has time to access to Empathy/Gwibber/Evolution by mouse? When Ubuntu didn't have indicator we click Empathy/Gwibber/Evolution by clicking on its taskbar icons. Now we have additional step - we must click on applet, then click item from the text list. It isn't improvement - it's obstacle.

Roman Yepishev (rye) wrote :

Live example:
mouse stopped working (possibly, Alps touchpad problem or remote VNC connection, cannot reproduce reliably). Decided to log out and log in again.
Alt+F1 - gives menu, System.... Help & Support, About Gnome and About Menu items, no link to log out.
Closing all windows, Alt+F4 on the root window - nothing
Power button/Ctrl+Alt+Del: Shut Down, Restart, Suspend, Hibernate...
Opening gnome-terminal, killing Xorg solved the logout problem.

By default with Compiz effects enabled, Ctrl-Alt-TAB brings Window switcher, not desktop/panel switching, so it is impossible to get to the applet via keyboard. With desktop effects disabled this is possible, but applet does not show any border in default Human theme around itself.

Just foe the record. We are not against fixing this it just hasn't
been fixed. Infinite time/money it would be fixed.

This is the one thing that's keeping the applet off my panel. It seems to me that this should be seen as an absolutely fundamental part of desktop functionality, and any environment with aspirations towards accessibility should treat it seriously. More over, it should ideally have as minimal a key combo as possible. My preference is for Alt-[ESCAPE], which carries the connotation of exiting.

Luca Ferretti (elle.uca) wrote :

IMHO this bug should be fixed in two steps:
  * fix Compiz in order to use Ctrl+Alt+Tab in a sane way (i.e. as metacity)
  * fix libindicator based stuff to act like real menu widget

Comiz has too many a11y related issue: no good keyboard navigation (see bug #228343 for ctrl+alt+tab), no audio feedback for keyboard (see bug #514943), no orca magnifier... IMHO, for the sake of impaired people, we should disable compiz to be automatically enabled if supported by graphic card, and run it on demand.

Libindicate stuff, instead, should implement keyboard navigator ASAP. Note that in Lucid we have now 3 libindicate based applet: the "system" indicator (shutdown, reboot, logout...), te "me" indicator and the messaging notification indicator. We can't add a global shortcut for each one. We should make basic keyboard navigation working (focus the panel, use Tab to focus the applet, use Space to activate it).

PS I've missed this bug previously, so I reported a separate one for libindicate issue: #519195

Luca Ferretti (elle.uca) wrote :

PPS direct link, for your pleasure: bug #519195

affects: indicator-session (Ubuntu Lucid) → indicator-applet (Ubuntu Lucid)
Pablo SEMINARIO (pabluk) wrote :

And maybe could be added the keyboard shortcut to the keyboard shortcuts preferences (System -> Preferences -> Keyboard Shortcuts) in the Desktop section.

David Barth (dbarth) on 2010-03-17
Changed in indicator-applet:
milestone: none → ubuntu-10.04-beta-1
David Barth (dbarth) on 2010-03-24
Changed in indicator-applet:
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
David Barth (dbarth) on 2010-03-24
Changed in indicator-applet (Ubuntu Lucid):
milestone: ubuntu-9.10-beta → ubuntu-10.04-beta-2
Vish (vish) wrote :

Adding task and milestones from dup

Changed in hundredpapercuts:
importance: Undecided → Low
milestone: none → lucid-round-10
status: New → Triaged
Ted Gould (ted) wrote :

Merging in a branch that adds Super+S as the hotkey. Super+Esc was also considered but seems to be blocked by the window manager or X because I can't find another program blocking it.

Changed in indicator-applet:
milestone: ubuntu-10.04-beta-2 → 0.3.5
status: Confirmed → Fix Committed
Vish (vish) on 2010-04-01
Changed in hundredpapercuts:
status: Triaged → Fix Committed

It's great that a keybinding has been assigned, but adding an undocumented, hard to discover keybinding is not a notable usability win for most users. Very very few users will discover and use this shortcut. Vish, your thoughts?

Changed in hundredpapercuts:
status: Fix Committed → Incomplete
Vish (vish) wrote :

We have Ctrl+Q to quit the app,
Ctrl+W to close window and also Alt+F4 which closes windows.
Ctrl+S is Save on the other hand. If we use Super+S , Different accelerator but same letter would be a bit confusing.

We could use Super+Q which would be atleast a bit similar to quiting apps.
But, The menu has it named "Shut down" and in future to "Switch Off" , we might have users filing bugs & complaining that Super+S is better.

The best option would be Super+Q to bring up the drop-down [and in the future , once the menu is open shortcut "S" for the selecting Switch Off , "L" for Logout , "R" for Restart. probably "E" for Sleep or "P" if using E is confusing with expo]

Ted Gould (ted) on 2010-04-01
Changed in indicator-applet:
status: Fix Committed → Fix Released
Dylan McCall (dylanmccall) wrote :

I recommend investigating how to get this into gnome-keybinding-properties, like the panel main menu shortcut key, etc :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-applet - 0.3.6-0ubuntu1

---------------
indicator-applet (0.3.6-0ubuntu1) lucid; urgency=low

  * New upstream release.
    * Adds LGPL for TomboyBinder and EggAccelerators
  * debian/copyright: Updated for LGPL code in files above

indicator-applet (0.3.5-0ubuntu1) lucid; urgency=low

  * New upstream release.
    * Adding hotkey support. Super+S. (LP: #334544)
 -- Ted Gould <email address hidden> Thu, 01 Apr 2010 15:44:06 -0500

Changed in indicator-applet (Ubuntu Lucid):
status: Confirmed → Fix Released
Luca Ferretti (elle.uca) wrote :

This change doesn't fix all other keyboard navigation issues for libindicator based applets reported in bug #519195. That bug was marked as a duplicate of this, bug keyboard is still a mess (while that bug summary couuld needs to be updated).

To test, unplug your mouse[1], press Super+S and try to switch back to focus, for instance, your desktop.

[1] this is a basic test rule for any GNOME application or component, software unusable with keyboard only is a poor quality software for GNOME standards.

Roman Yepishev (rye) wrote :

Please see bug #553918 for the consequence of shortcut usage.
Keyboard shortcut usage blocks keyboard and other menus

Michel (michel-crondor) wrote :

I already use Super-S for something else, and this shortcut is not listed under System > Preferences > Keyboard Shortcuts, how can I disable or change this shortcut?

As there are keyboards lacking the Super key, could some other key combination be used?

For example:
* Alt+Ctrl+L is used to lock the screen
* Alt+Ctrl+D is used to show the desktop

Wouldn't Alt+Ctrl+S be better (from an accesibilty point of view) than Super+S?

Vish (vish) wrote :

Closing papercut task.

Changed in hundredpapercuts:
milestone: lucid-round-10 → none
status: Incomplete → Invalid
FlashBuster (flashbuster) wrote :

I have the same issue as #21, as i am using super+s for new terminals for some years now.
Now, it stopped working and i can't change this :(

( see https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/557917 )

FlashBuster (flashbuster) wrote :

Please ignore the last comment. I see this issue is marked as fixed for the next beta, so i guess it will be a changeable shortcut soon :)
Thanks!

Mark Fernandes (typist) wrote :

Super+M used to toggle the laptop between normal and negative mode (easier on the eyes in different light conditions) in earlier versions of Ubuntu but it does not seem to work anymore, Instead now it highlights the mail message icon. How do I restore it to not go to the mail icon?

johnny (johnnywingnut) wrote :

this is not listed in System > Preferences > Keyboard Shortcuts, and i can't disable it. anyone know how?

David Marín (davefx) wrote :

I have just upgraded to Lucid, using a remote VNC connection.

After reboot, I have discovered that whenever I press the 's' key in a VNC connection (served by vinagre, or Xvnctightserver), the indicator applet gets launched, so now I cannot type "sudo" in a terminal, nor any other word with s.

It seems that VNC servers doesn't support well the "Super" key...

Lachlan F (lachlan-fletcher) wrote :

I am having a similar issue as #29.

I have just installed Lucid Beta 2 (x64).

The system functions normally when used locally, but any kind of remote X access (VNC, X over SSH, NX) causes keyboard problems. Any press of the "s" key in any application highlights the Indicator applet session menu with Shutdown, Restart, Logout etc and the m key highlights the Indicator applet for mail.

If these applets are removed from the panel then the keys work as normal, and if the applets are added again the keys malfunction again.

Jijoe Vurghese (jijoejv) wrote :

https://bugs.launchpad.net/indicator-applet/+bug/557376/comments/2 - unable to find a way to reassign keyboard shortcut for indicator applet even in 10.04 Lucid RC AMD64. Is there another location to change this shortcut?

johnny b (stepore) wrote :
Jan Minář (rdancer) wrote :

Even on a local X session, the press of the "s" key brings up the Indicator Applet *Session* menu. Pressing the "m" key doesn't have any adverse effect.

Restarting the Indicator Applet Session by removing from the panel and re-adding it (as suggested by one of the comments) does not solve the issue.

I have installed the 0.3.7 version from <http://archive.ubuntu.com/ubuntu/pool/main/i/indicator-applet/indicator-applet-session_0.3.7-0ubuntu1_amd64.deb>, and it solves the issue.

yogsototh (yann-esposito-2nd) wrote :

same as #21, #27 and others. I don't know how to disable <Super>s and <Super>m used by 'awesome' wm.

Ddorda (ddorda) wrote :

this shortcut does not work to me using compiz (no effect uses even "s").
Ubuntu 10.04.

Jan Vornberger (javlp) wrote :

I find the choice of Super+S as the keyboard shortcut for the indicator applet very unfortunate and would like to voice my support for changing it.

I agree that a keyboard shortcut for this functionality is good to have, but it will be rarely used throught the day, so please don't "waste" a handy shortcut like Super+S on this. Make it a two modifier thing. Lucian Adrian Grijincu mentioned Ctrl+Alt+S (in line with things like Ctrl+Alt+D to show the desktop) which seems to me like a good choice. From what I can tell it also doesn't conflict with anything on my Lucid Lynx installation. It is also a more universal solution, since there are still a few users with keyboards that don't have a super key.

As the author of Bluetile ( http://www.bluetile.org/ ) I would appreciate this change, since Bluetile's standard keyboard shortcuts already include Super+S. If this will not be changed in Ubuntu, I guess I will have to switch to alternative keys. But again, I find it a waste to use a 'premium' shortcut like Super+S for a task that will be rarely performed.

Dylan McCall (dylanmccall) wrote :

Given that we're going to have a single indicator applet in the near future, instead of two, another option for default is Alt+F3, or maybe Alt+F5. It rhymes nicely with the shortcut for opening the main menu. Alt+F* feels like a nice convention going forwards for keyboard shortcuts that relate to the panel (with the unfortunate exception of Alt+F4).

Still not wonderfully discoverable, but I think it would be a hair more discoverable than Super+S given that we basically never use the super key for shortcuts by default (and that no normal user knows that a particular indicator is the Session indicator).

Ev][L (klikevil) wrote :

FIGURED IT OUT

Ghetto workaround time.... ready? Right click on it, remove from panel go in to compiz choose disabled for the select single window keyboard binding then click close. Re-enable the select single window and VIOLA you can now group and tab windows as you please. Of course you'll be restarting with init 6 and what not or your preferred method, but hey it got the job done and until you find a better solution then my word is the law!

Brett Johnson (bjohnson) wrote :

I highly recommend AGAINST using Super+S as it's already the default shortcut for the window grouping plugin in compiz and has been for sometime. Just went to enable it on my maverick build and Super+S is bringing up the indicator applet instead of window grouping as the indicator applet is taking precedence.

Ev][L's post above details what I believe is a workaround they found for the problem but I couldn't find anyone who voiced the problem in the first place above hence my post (if I missed it please excuse the double post).

Again though - alt + control + s makes more sense over super + s. Alt + F1 brings up the Applications menu. Maybe Super + F1 would work also? Either way the current Super + S is conflicting.

Smeuuh (smeuuh) wrote :

Please change the super+s binding. Or at least provide a way to customize it. I use it to control emacs, and as it stands I'm disabling indicators because of it.

TomasHnyk (sup) wrote :

There is bug 554713 open for those who would wish to change this binding.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers