Ubuntu

Indicator applets open when pressing S or M key via NX, VNC

Reported by Roel van Os on 2010-04-22
108
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Indicator Applet
Undecided
Unassigned
gnome-do (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
indicator-applet (Ubuntu)
Low
Ted Gould
Lucid
Low
Unassigned

Bug Description

Binary package hint: indicator-applet

When logging into a session user NX or VNC, whenever I press the S key (without modifiers), the logout menu is opened. When I press M, the messaging menu is opened.

Other programs in the NX/VNC session don't have this problem. When I remove the indicator applets from the panel, the M and S keys work OK.

Tested using the NX client for Mac OS X and Jolly's Fast VNC. The Windows client of NX doesn't have the problem.

xkeycaps shows the following info:

* Mac OS NX client: pressing M key gives keycode "C 0x36 54 066" and KeySym "m M mu U02DC".
* Windows NX client: pressing M key gives keycode "M 0x3A 58 072" and KeySym "m M mu masculine mu masculine".

indicator-applet:
  Installed: 0.3.6-0ubuntu2
  Candidate: 0.3.6-0ubuntu2
  Version table:
 *** 0.3.6-0ubuntu2 0
        500 http://nl.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Roel van Os (roel-van-os) wrote :

When I open Keyboard Shortcuts, and press S or M when assigning a shortcut to an action, the following message appears:

  The shortcut "S" cannot be used because it will become impossible to type using this key.
  Please try with a key such as Control, Alt or Shift at the same time.

So Gnome at least sees the key presses correctly, without any modifiers. Furthermore, the indicator applet doesn't open when I try to assign the shortcut.

Luke Hoersten (lukehoersten) wrote :

Same problem on 10.04. 'm' opens the indicator applet for messages and 's' opens the status menu. The problem doesn't happen with capital 'S' or 'M' though.

Luke Hoersten (lukehoersten) wrote :

Restarting the indicator-applet (removing it from the panel and re-adding it) seems to fix the issue for the current boot.

Hi, I experience the same bug on Lucid (with neatx-server from the PPA archive and NoMachine NX client for MacOS X). However, in my case restarting the applet does not fix the issue.

buzz (buzz2) wrote :

We can confirm this bug via VNC aswell, disabling the hotkey binding within source code "fixes" this one.

Sebastien Bacher (seb128) wrote :

Ted could you look at this issue, it seems to annoy quite some users and something worth trying to solve in lucid updates

Changed in indicator-applet (Ubuntu):
assignee: nobody → Ted Gould (ted)
johnny b (stepore) wrote :

Using Lucid 10.04 and I get the same behaviour. 's' and 'm' keys only effected. Happens with VNC servers (TightVNC) but not X11vnc.

Roman Vorobets (roman-vorobets) wrote :

This bug affects me too, but when NOT using VNC.
This is quite annoying. I had to remove indicator applet.
Juts upgraded to 10.04.

Same here. This is a regression in 10.04. I am marking the bug as confirmed since many people say they experience it.

I observe the bug with vnc4server, but not with a Vino connection to a real display. This is similar to johnny b's observation that it happens with TightVNC but not X11vnc.

Also, if I start a session with vnc4server and join it from another computer via Vino then the bug occurs in the Vino window too. So the fault must be in some component that is common to both of those code paths (and which is _not_ in the code path of a Vino connection to a real display).

Changed in indicator-applet (Ubuntu):
status: New → Confirmed

I've just found why I'm having this problem with plain local login (not with VNC). I had my Windows key mapped to Hyper, I changed this to default behavior (Super key), this fixed it for me.
I have downloaded the indicator's sources and I can see in indicator-applet-0.3.6/src/applet-main.c that the shortcut passed to tomboy_keybinder_bind() function is either "<Super>S" or "<Super>M"; so the "<Super>" part did not work for my system.

After digging further into the code, I found the problem: the egg_keymap_resolve_virtual_modifiers() function in indicator-applet-0.3.6/src/eggaccelerators.c returns concrete_mods=0 for modifiers that are not bound to any key (which I confirm happens for Super key in remote session).
As a temporary (?) solution, I propose not to grab a key in indicator-applet-0.3.6/src/tomboykeybinder.c:do_grab_key() function if binding->modifiers equals zero.

mevdschee (mevdschee) wrote :

Same here, m opens indicator applet menu on panel using nx. Removing indicator applet from panel works for me (as workaround).

I've built a patched package which solves the issue for me.
Can somebody check this with VNC?

Here goes the patch.

buzz (buzz2) wrote :

The patch works fine for us on all computers.

hai (haihovu) wrote :

I also am experiencing this problem, the lower-case m key causes focus to be captured by the Indicator applet, in XRDP sessions (from Windows PCs). All the same behaviours as most other posters, uninstall the Indicator applet made the problem go away, no issue with native console, ... I have no issue with the s key though, and am not sure what the Super key issue is all about, perhaps that pertains to Apple keyboards?

Roel van Os (roel-van-os) wrote :

I've tested the patch from #14 on amd64: it fixes the problem. Tested using NX and VNC, both from Mac OS X. The Meta+S and Meta+M combinations still work on local sessions, so no regressions there :-)

John Zumkehr (zumkehr) wrote :

Can someone compile the amd64 version of the complete indicator patch?
Thanks

Omer Akram (om26er) on 2010-05-04
tags: added: patch
Edward (ecadman) wrote :

Just FYI, I can't install the patch. Getting "Error: Dependency is not satisfiable: indicator-applet (= 0.3.6-0ubuntu2.1)"

Ted Gould (ted) on 2010-05-04
Changed in indicator-applet:
status: New → Fix Committed
milestone: none → 0.3.7
Ted Gould (ted) on 2010-05-04
Changed in indicator-applet:
status: Fix Committed → Fix Released
johnny b (stepore) wrote :

@Roel van Os

Could you please explain how you applied the patch on your 64bit?

John, I'm sorry but I don't know how to compile for amd64 on 32-bit system and don't have much time now to find out this (just followed some guide to create .deb package from source code).

On 05/04/2010 03:11 PM, Roman Vorobets wrote:
> John, I'm sorry but I don't know how to compile for amd64 on 32-bit
> system and don't have much time now to find out this (just followed some
> guide to create .deb package from source code).
>

No you misunderstood, I've got 64bit system, and you said you got the
patch working on amd64. I'm trying to get the same to work. Do you have
a link I can follow?

Roel van Os (roel-van-os) wrote :

Not sure if this is the right place, but here's how I did it (this is from memory):

* Install required packages

  sudo apt-get install build-essential
  sudo apt-get build-dep indicator-applet

* Get the source for the indicator-applet (don't use sudo here!):

  apt-get source indicator-applet

  This will extract the source in a directory under your working dir

* Download and apply the patch:

  cd indicator-applet-<version>
  patch -p1 < path/to/patch

  /path/to/patch is the path to the patch in comment #14

* build packages:

  dpkg-buildpackage

  This will produce packages in the dir where you ran apt-get source.

johnny b (stepore) wrote :

On 05/04/2010 03:59 PM, Roel van Os wrote:
> Not sure if this is the right place, but here's how I did it (this is
> from memory):

Thank you so much Roel, this was great. Instructions were right on, and
the patch worked.

I owe you.

johnny

Michael Del Tito (mdeltito) wrote :

If I apply this patch, how can I revert to the source package when it is fixed in the repo?

johnny b (stepore) wrote :

On 05/03/2010 05:37 PM, Roman Vorobets wrote:
> I've built a patched package which solves the issue for me.
> Can somebody check this with VNC?

Hi Roman, thanks for the patch. With Roel's help in building for 64bit I
can confirm that your patch works for VNC. I'm using tightvncserver on 3
other PCs and indicator-applets no longer intercept 's' or 'm' keys.

cheers

Roel van Os (roel-van-os) wrote :

> If I apply this patch, how can I revert to the source package when it is fixed in the repo?

When this bug is fixed in the repositories, the package will probably have a higher version number, so it will automatically replace the one you compiled yourself.

Sebastien Bacher (seb128) wrote :
Changed in indicator-applet (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Changed in indicator-applet (Ubuntu Lucid):
importance: Undecided → Low
status: New → Fix Committed

Patch works as intended. 10.04 64bit AMD here and now I don't have to cut-n-paste those keys anymore! :-)

Simon Elmir (nerd65536) wrote :

The default keybinding to activate gnome-do is Meta-Space. Simply running gnome-do in VNC makes typing a space impossible.

Patch for gnome-do (solution is the same).

Accepted indicator-applet into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

On 05/09/2010 06:37 AM, Martin Pitt wrote:
> Accepted indicator-applet into lucid-proposed, the package will build
> now and be available in a few hours. Please test and give feedback here.
> See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how
> to enable and use -proposed. Thank you in advance!
>
> ** Tags added: verification-needed

Just installed and tested the new proposed indicator-applets for Lucid
on 3 PCs and everything works well with VNC.

Thanks everyone.

Martin Pitt (pitti) on 2010-05-10
tags: added: verification-done
removed: verification-needed
tonyw (tony-whyman) wrote :

I came across this problem this morning (10/5/10) on an amd64 installation of lucid accessed remotely using vnc4server. The fixed installed without a problem and seems to work fine. Thanks guys for sorting it out so quickly.

Edward (ecadman) wrote :

Works perfectly in 32-bit over XRDP. Thank you!!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-applet - 0.3.7-0ubuntu1

---------------
indicator-applet (0.3.7-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    * Fix shortcuts over remote connections (LP: #568401)
    * Compiler cleanups
    * Support for vertical panels (LP: #498182)
 -- Ted Gould <email address hidden> Tue, 04 May 2010 19:44:02 +0200

Changed in indicator-applet (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick.

Changed in indicator-applet (Ubuntu):
status: Fix Committed → Fix Released

I switched from pidgin to empathy in 10.04.
I used the shortcut "<super>-m" to view unread empathy messages.
However, since the latest kernel update... that does not work anymore!
Can someone please tell me what shortcut I can now use to view my unread messages?
Thanks a lot.
Greetings from Austria.

I would like to un-bind the <super>-S and <super>-m keys from the indicator. It is grabbing the keys before my application. How do I remove these key mappings?

Alternatively - How do I disable this applet to remove this un-wanted behavior?

   David

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers