Browser hangs intermittently waiting for resources to download

Bug #216699 reported by Rys Sommefeldt on 2008-04-13
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Medium
firefox-3.0 (Ubuntu)
Low
Randall OBrien

Bug Description

Binary package hint: firefox-3.0

Ubuntu Hardy 8.04 x64
3.0~b5+nobinonly-0ubuntu1

While accessing any web pages, Firefox will hang and not respond to immediate user input, sometimes long enough for the Compiz desaturate plugin to activate and show Firefox as hung. The status bar says that Firefox is waiting for the website to respond (usually an element being downloaded from another website, like the Google Analytics .js, or some Flash, or an image or some other resource, but not always), and user input is queued up. Firefox always comes back after a period of time, and the queued user input is performed. Most of the time Firefox will hang again straight away waiting for the next resource it's downloading, until the webpage is done.

Usually, while downloading page elements, you can still scroll the page or switch to a different tab or activate Firefox's menus, and otherwise use the browser normally.

Not all websites display this behaviour, and it's not repeatable by going to particular websites. Any of them may or may not be affected. Firefox 3.0b4 was fine.

The rest of my system remains perfectly responsive while it happens, and other browsers are fine.

I've confirmed with the test link, and seen this issue in other places as well.

*** Bug 407102 has been marked as a duplicate of this bug. ***

Rys Sommefeldt (rys) wrote :

Binary package hint: firefox-3.0

Ubuntu Hardy 8.04 x64
3.0~b5+nobinonly-0ubuntu1

While accessing any web pages, Firefox will hang and not respond to immediate user input, sometimes long enough for the Compiz desaturate plugin to activate and show Firefox as hung. The status bar says that Firefox is waiting for the website to respond (usually an element being downloaded from another website, like the Google Analytics .js, or some Flash, or an image or some other resource, but not always), and user input is queued up. Firefox always comes back after a period of time, and the queued user input is performed. Most of the time Firefox will hang again straight away waiting for the next resource it's downloading, until the webpage is done.

Usually, while downloading page elements, you can still scroll the page or switch to a different tab or activate Firefox's menus, and otherwise use the browser normally.

Not all websites display this behaviour, and it's not repeatable by going to particular websites. Any of them may or may not be affected. Firefox 3.0b4 was fine.

The rest of my system remains perfectly responsive while it happens, and other browsers are fine.

Rys Sommefeldt (rys) wrote :

I should have mentioned that the status bar text is always "Transferring data from wherever.the.resource.is.coming.from...."

Rys Sommefeldt (rys) wrote :

Or "Waiting for wherever.the.resource.is.coming.from...."

Created an attachment (id=315745)
test case

I atached a set of simple test case files.

I also want to note that if I run the test inside FireFox with Flash Tracer active (and of course a Flash Debug Player) then a warning message is issued:
"Warning: Not a known player download type, http://localhost/lab/tests/f4loadvariables/variables.php" which doesn't amke any sense to me, but might give a clue to others.

If the call to the PHP file is replaced with a call to the .txt file (see attachment) then the problem doens't occur (also the warning message shown in FlashTracer is gone). The problem occurs also with other server languages like ASP & Fortran.

All browsers with the Mozilla engine show the problem any other engine base brwser like IE, Opera, Safari don't exhibit this behavior.

pbeeson (pbeeson) wrote :

Occasionally on my laptop, my processor maxes for a few seconds when this happens.

skipnyip (skipnyip) wrote :

I have the same problem. I have also noticed that it sometimes will hand more than once on the same page.

Don Lindsay (don-lindsay) wrote :

I have noticed that this occurs frequently after having made an online purchase, then it hangs waiting for the confirmation screen.

Created an attachment (id=329021)
ethereal network capture showing completed transaction

I've got a problem like this or very similar without the flash, and not always reproducible. I'm loading small pages with a single cached graphic: the connection closes but the browser continues to show "transferring data from spsd-enet"
Attached is a network capture file. Because the transfer never completes, the refresh cycle in the web page never completes, (and stale data is displayed to the customer).

(In reply to comment #4)
> Created an attachment (id=329021) [details]
> ethereal network capture showing completed transaction
> I've got a problem like this or very similar without the flash, and not always
> reproducible. I'm loading small pages with a single cached graphic: the
> connection closes but the browser continues to show "transferring data from
> spsd-enet"
> Attached is a network capture file. Because the transfer never completes, the
> refresh cycle in the web page never completes, (and stale data is displayed to
> the customer).

Note that there is no content-length header in the HTTP conversation in the capture file. There is a connection:close header.

I just came across this as well when troubleshooting some Flash I've written... I came across some fairly old discussions about what appears to be this same bug from as early as 2005 so I think this is a pretty old issue. Does anyone have a work around?

Evan Klitzke (eklitzke2) wrote :

the upstream bug for this appears to be https://bugzilla.mozilla.org/show_bug.cgi?id=383811

Same issue :

Using the Gecko API:

Using NPN_Status or JavaScript to updated the status bar works fine until a call to NPN_PostURLNotify is made.
After the post has completed, and called successfully NPP_URLNotify, the status bar displays "Transferring data from x...".

All calls to update the status bar text now fail (NPN_Status is a void function unfortunately). The only thing that will clear the message is reloading the page.

Notes:

dom.disable_window_status_change is not enabled.
No errors were reported to NPP_URLNotify.

Possibilities:

1.The browser is stuck in STATE_TRANSFERRING and repeatedly updating the status bar.
2. NPP_Status is now failing on one of the checks in nsGlobalWindow::SetStatus.
3. Something else not being destroyed.

XPCOM stuff

I was also wondering if there is a way to get the nsIWebBrowerChrome interface in a plug-in. Seems GetChromeForWindow doesn't work, just returns null when given the Active window. With it I might be able to get around the bug.

Ken Pratt (kenpratt) wrote :

I have several RSS bookmarks. I wonder if the process of updating the RSS streams is part of this?

Changed in firefox:
status: Unknown → Confirmed
locust (marineworks) wrote :

same problem here
Intrepid 64 - 2.6.27-3

It seems related to media (flash, flv, etc) contents loading. Flash support is horrible (intermittent play and sound).
It seems related to intermittenyìt audio problem too (very bad audio!).
David

Alexander Sack (asac) on 2008-10-20
Changed in firefox-3.0:
importance: Undecided → Low
status: New → Triaged
Tom (tom6) wrote :

Still seems to be happening in Intrepid 8.10 with Firefox 3.0.4 Glad i'm not alone. Good luck in sorting :)

Ken Resander (kresander) wrote :

I confirm Don Lindsay's observation.
It has happened to me when ordering from amazon and ebay. In all cases waited for confirm screen at least 10 minutes with no info returned. amazon and ebay confirmed receipt of order by email in all cases.

Ken Resander (kresander) wrote :

AND it happened when I pressed submit for a launchpad comment about 20 minutes ago. No response, but my comment had actually been received and and showed in the comment list.

Same problem here, Intrepid 8.10 x64, Firefox 3.0.4. Seems to be random, but the problem is worse with 8.10 than it was with 8.04 x64 with 3.0b5.
Something I also noticed was that the contents of a tab stays the same after having clicked a link and it seems to have loaded the new data (so it doesn't seem to display the new data).

Andrew Melo (andrew-melo) wrote :

Bug is still present in 9.04 alpha 3.

Stefan Lesicnik (stefanlsd) wrote :

I experience this problem on Intrepid and its always reproducable for me by visting http://www.otrs.org/

Hangs for about 25 seconds. Even if i look at that tab and then another, it does it again...

On Fri, Jan 23, 2009 at 6:28 PM, Stefan Lesicnik <email address hidden> wrote:
> I experience this problem on Intrepid and its always reproducable for me
> by visting http://www.otrs.org/
>
> Hangs for about 25 seconds. Even if i look at that tab and then another,
> it does it again...

I've noticed that on Debian Lenny I'm not seeing this. I tried with
the standard Firefox-3.0.5 included with the distro (named Iceweasel
there..) and with "Minefield" or Firefox-3.2a1pre.

Rys Sommefeldt (rys) wrote :

Still happens for me in Intrepid x64 with Ubuntu's stock firefox-3.0 package, and I can reproduce the bug consistently by visiting http://www.kohanaphp.com/

Haven't tried any other build of Firefox so far.

Stefan Lesicnik (stefanlsd) wrote :

I've been using an up to date jaunty and my issues are fixed. (otrs.org). kohanaphp.com doesnt give me any issues either.

John Vivirito (gnomefreak) wrote :

There is no difference between 3.0.6 on jaunty and 3.0.6 on hardy the code is the same so if you dont see it with 3.0.6 on jaunty than 3.0.6 on intrepid or hardy should no longer see it. please confirm.

Rys Sommefeldt (rys) wrote :

Things appear to be fine with 3.0.7, on my previously problematic AMD64 8.10 upgraded to 9.04.

Changed in firefox-3.0 (Ubuntu):
status: Triaged → Fix Released

It is happening to me too.

I have Kubuntu 8.10 64 bit and Firefox 3.0.8 (but it was occuring also with 3.0.7 and previous versions).

John Vivirito (gnomefreak) wrote :

I am still unable to reproduce this bug. Can you please run the following command and visit those sites in safe-mode.
firefox --safe-mode
The pages open fine there is a slight lag on http://www.kohanaphp.com/ but by no means is it a "hang". Since everyone elses problem went away except yours im thinking its either an extensions or your profile.
If safe-mode still sees this issue try running the following command
firefox -ProfileManager
When running profile manager do not name the new one the same as the old one, also dont remove any profile just add one with a different name or your old one will be removed.

John Vivirito (gnomefreak) wrote :

Sabrewolfy,
Since the upstream bugs are not the same than i am having a hard time to mark them the same unless it is decided to be the same upstream.

SabreWolfy (sabrewolfy) wrote :

Ok. Appears to be fixed for me with 3.0.7 under Ubuntu Hardy 32bit.

I apologize if I did not followed up on my report, but I have been busy in the last few days.

I have found (apparently at least) that my case was due to the "Alexa Sparky" addons. Maybe it was querying its server too often (making FF hanging to wait for the results).

I have been using FF few days without this addons and almost had no problems (still some sporadic halt, but every time I found the source of the over-processing).

I apologize for the not pertinent report. :-/

I am seeing this problem with timer events that fetch images after the initial page load. Below is a reproducible case. Load and wait for 10 seconds. You will see "Transferring data from ping.chartbeat.net..." in the status bar even though the request was completed.

http://thesuperficial.com/

As with the comment above, content-length is missing from the response headers.

I also have the "Transferring data ..." problem and it doesn't go away when clicking on another tab and going back. I confirmed the request were served ok so it has to be a ff bug. All other browsers are not showing this behavior.

David Oxland (doxland) wrote :

Similar for me
-repeated attempts to use Firefox for apport report hung while reading through the first page of suggestions
-One CPU goes to full load and and stays there; when a kill instruction is given via System Monitor the firefox Icon will disappear but it will show as running for a while as a zombie.
Firefox has consistently been giving this problem for two days;
It is unusable now. Will hang on start up
Also makes other processes hang.

Might this be Help?
Error: [Exception... "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFileInputStream.init]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: file:///<email address hidden>/components/foxmarks-service.js :: logMoveFile :: line 331" data: no]
Source File: file:///<email address hidden>/components/foxmarks-service.js
Line: 366

Same problem. I have a wordpress site using the (free) ProPlayer plugin, which uses flash to load another video file. This happens on both 3.5.5 and 3.0.15. My wordpress site is tanks.brightsoo.com, but I don't guarantee the content there won't change :)

Does anyone know if there's a workaround on the server side (i.e. web site)? Something to set the status bar manually?

Michele (denber) wrote :

I'm having the exact same problem as the original poster. Firefox 3.5.6, Win XP Home SP3 on a custom Intel Core 2 Duo E8500, all updates current.

However, the bug does NOT occur on an Acer Aspire One netbook, same OS, same LAN, but Firefox 3.5.5.

I have the same problem in pages containing swfs. As soon as I click on another browser tab and return to page the status bar reports "Done" but if I stay on the page without clicking any other tabs the status bar keeps displaying "Read domain.name" forever. The problem does not occur in Internet Explorer.

I also have the same problem. It appears to also affect iframes both dynamically injected and in the static html. I can't believe this hasn't been fixed in over 3 years! Some of the biggest sites on the web have this problem.

- Watching videos on youtube
- Embedding a Google map

With the proliferation of iframes through Facebook and other widget providers this is only going to become an every expanding problem.

Very very annoying bug!!!!
when it planned to be solved???

3 years old and still with NEW status ...?
Wake up Mozilla!!! WAKE UP!!!!

You know, Mozilla is an open source project. Patches to fix this are very
welcome ;)

But I'll try to look at this soon. Perhaps tomorrow.

It would be *very* useful to have a minimal testcase here.
Since based on the comments this doesn't depend on plugins, the testcase
shouldn't use a plugin either.

Though, if I've misunderstood this, and the problem really shows up only
with Flash, then I should just re-try the testcase attached already.

The problem is not just flash. There is also a problem with dynamically injected iframes. Trying adding an iframe with javascript and the download an image directly after it.

Alex, could you perhaps provide a *minimal* testcase, please.
Attach it to this bug using "Add an attachment"

Olli, I just triggered this bug with youtube. Load any video, do a right click and stop the movie (the flash right click menu that allows you to stop the movie download not the pause button from the flash player). This will leave the status bar on "Transferring data from blahblah.youtube.com" until you go to another tab and then go back to see the status bar changed to "Done".

Hope this helps.

Also with other test cases I made the status bar to never go back to "Done", it was stuck with the "Transferring data" message even when changing tabs. Sorry for the double post but I just remembered that, I don't have access to that test case anymore so I'm not able to help with that but I wanted you to give you all the info I could.

Now, hope that helps even more.

Olli, is this minimal enough? http://tanks.brightsoo.com/mission4/

This is a wordpress site that I own. I'm not sure how to "attach" the site... I know a little bit of shell scripting, so let me know if there's something I can do.

I even have the worse case in my browser.

I see the progress bar in the right side of the status bar after page loads. "Transferring data from ...." never goes away even if there is nothing to download anymore.

I checked with Firebug/Net and Live HTTP Headers, still I see these annoying bugs.

My tests show the problem to be greater than just a failure to update the status bar. The browser is also failing to tell the Flash Player that the file transfer is complete.

We have a Flash Player application that loads a list of files in order, one at a time. When ActionScript recieves a load complete event for one file, it begins loading the next. If we don't receive the load complete event for a file, we cannot know when to load the next. Loading all files simultaneously isn't an option.

We've learned that the problem is intermittent, but haven't seen a pattern of when it occurs. For example, if our list of files was data1.swf, data2.swf, ..., data20.swf, the browser might fail to report that data2.swf complete, when in fact proxies and other monitors show us byte-for-byte that the file did completely deliver to the browser. The browser just fails to tell the player that the load was complete, and the browser's status bar is another visible sign that it failed to recognize when the load completed.

The problem comes and goes with minor versions of Firefox. I don't recall the version when we first saw the problem. Our solution at the time was to have our Flash application retry the load request, but we found that once Firefox began failing on a particular file it would not ever report that file had completely loaded during that session. We could clear the browser's cache and close the browser and the problem would go away, for that file. So, retrying alone was not enough. We resorted to retrying and overriding the browser caching. For example if the request was for data1.swf and Firefox failed to tell us when the transfer was complete, we'd request it again as data1.swf?trycount=1.

Another work-around was to switch users to using https instead of http. When using http, the transferring data status message never hangs and thus the browser ALWAYS tells the player when files have completely loaded. This work-around worked up to Firefox 3.6.10. With Firefox 3.6.10, using https no longer gaurantees that we'll recieve the load complete... and of course the Transferring data status remains on.

Our application runs in a non-tabbed window, but regardless switching tabs only makes the status bar update. It does not cause the browser to tell the player that a load has completed.

I see this as a VERY bad bug, that is costing us and everyone else time and money, and hope that it will be permanently resolved soon.

Changed in firefox:
importance: Unknown → Medium

We had the same issue with an old version of the jquery jsonp plugin
http://code.google.com/p/jquery-jsonp/

they used in earlier versions an iframe to allow catching errors and timeout of requests. The new version works without iframes and also the problem is gone.

i would like to see this fixed, gave as a lot of headache.

Changed in firefox-3.0 (Ubuntu):
assignee: nobody → Randall OBrien (rlobrien2)

Is this still happening? If so, it would be super helpful if someone could provide a testcase that didn't use frames.

It unfortunately still happens, but actually constructing a testcase has been hard :(

I had this problem in the following scenario:
-web page with lots of iframes and references to external resources.
-one of them injects some ad dynamically in the mootools's domeready event like this:

           this.contentWindow.document.write('<html><head></head><body style="margin:0;overflow:hidden;"><script type="text/javascript" src="'+ script +'"></script></body></html>');

-But it should like this and this is what solved the problem:

           this.contentWindow.document.open();
           this.contentWindow.document.write('<html><head></head><body style="margin:0;overflow:hidden;"><script type="text/javascript" src="'+ script +'"></script></body></html>');
           this.contentWindow.document.close();

I've been seeing this for a while. Only (so far) on requests to localhost. No Flash on my pages, but there is Javascript.

Created attachment 579983
Simple test case

I reproduced the issue by creating an iframe element and then writing to its ownerDocument without opening & closing it.

Simple enough?

I find this happening on Bridge Base Online. The "transferring data from..." message blocks the chat window. I am using Firefox 21.0. This only started to happen recently! If I place cursor on message it disappears, most annoying.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.