[MASTER] Firefox freezes often

Bug #226878 reported by Noumaan Yaqoob on 2008-05-05
86
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Expired
Medium
firefox-3.0 (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Alexander Sack

Bug Description

Binary package hint: firefox-3.0

I am using Ubuntu 8.04 and I am having lots of problems with firefox. It freezes often and the screen becomes grayish. I saw some bug reports mentioning a similar problem which particularly occurs when accessing a page containing a flash video. In my case the problem occurs even when i am accessing pages with no flashvideos. I can not understand when and why it happens. Sometimes I am unable to type in the text boxes. Attached is the screen shot of my desktop when firefox freezed i had only synaptic and firefox opened at that time.

Firefox becomes usable after a while but it is really very annoying and i would appreciate if someone could help me find a solution.

ProblemType: Bug
Architecture: amd64
Date: Mon May 5 17:28:22 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0~b5+nobinonly-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-16-generic x86_64

Binary package hint: firefox-3.0

I am using Ubuntu 8.04 and I am having lots of problems with firefox. It freezes often and the screen becomes grayish. I saw some bug reports mentioning a similar problem which particularly occurs when accessing a page containing a flash video. In my case the problem occurs even when i am accessing pages with no flashvideos. I can not understand when and why it happens. Sometimes I am unable to type in the text boxes. Attached is the screen shot of my desktop when firefox freezed i had only synaptic and firefox opened at that time.

Firefox becomes usable after a while but it is really very annoying and i would appreciate if someone could help me find a solution.

ProblemType: Bug
Architecture: amd64
Date: Mon May 5 17:28:22 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0~b5+nobinonly-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-16-generic x86_64

Noumaan Yaqoob (noumaan) wrote :
Sven Boden (svenboden) wrote :

Well... as solution, report it upstream to the firefox team (being very specific on the URLs where you encounter your problem), have a look at e.g. http://developer.mozilla.org/en/docs/Bug_writing_guidelines

What you see will not be fixed anymore in the current beta, possibly in a next one if the firefox team can find your specific problem.

Changed in firefox-3.0:
status: New → Incomplete
Noumaan Yaqoob (noumaan) wrote :

I will try to report this to upstream, meanwhile I would like to add my recent investigation.

I noticed that the problem occurs in these two conditions:

1. When I have synaptic running and I open google webpage to search for something. Sometimes it freezes when I am writing text in search box and sometimes it freezes when I have entered the query.

2. When I am reading pages that contain youtube video clips. I have adobe non-free flash plugin installed.

Steven Harms (sharms) wrote :

I would like to add that I have also observed this behavior. Unfortunately there are not specific URLs and I don't get a crash report from it. Can someone give us additional information for reporting bugs that do not generate a stack trace?

Added two my suggestion related to places performance, Bug 429324 and Bug 438249.
Adjusted some depending on duplicates.

Sorry, I forgot Bug 436199

isnt reawlly a valid bug. look at https://wiki.ubuntu.com/MozillaTeam/NormalizedBugFormat to get the start.

Changed in firefox-3.0:
status: Incomplete → Invalid

@Alexander:
What would you write, if a bug isn't reproducable??

Expected Result: Firefox is usable all the time
Actual Result: Firefox freezes randomly and after a while it becomes usable again.
That IS a bug...
A problem might be the connection to the internet. Firefox freezes mostly when the connection is broken for a short time.

Alexander Sack (asac) wrote :

this bug is covered by the places performance meta bug ... settings up.

Changed in firefox-3.0:
importance: Undecided → Medium
status: Invalid → Triaged
Changed in firefox:
status: Unknown → Confirmed
Gagan Brahmi (gaganb) wrote :

I am also having the same problem since I had upgraded to the latest Firefox release. It is not related to any specific URL or a type of web page. It occurs even if I have just Firefox running and no other application.

I am on a 32 bit architecture with 2.6.24-21-generic kernel and running Ubuntu 8.04.1.

Interesting discovery: I have a dual core. When the freezing occurs, one CPU runs at 100%, the other drops to about 5%. Both cores can run at 100%, it seems random.

Does everyone else having this problem have a dual core? If not, are those that do experiencing the same thing?

Gagan Brahmi (gaganb) wrote :

I have got my issue solved. It had nothing to do with Firefox or Ubuntu updates or anything like that. Neither was it google search bar. It was the add-on that I had for the browser. "Show IP", was the one bugging the browser.

Strangely I have been using this add-on for some time now and it worked perfectly. This is the first time I came across such weird behaviour of this Add-on.

avaflipsalot@aim.com (avav) wrote :

I have the same exact problem.
I have a dual core processor, but that's the only thing I understand.
I removed most my add-ons, and I still have the problem.
It's driving me INSANE!

SabreWolfy (sabrewolfy) wrote :

I can confirm the freezing often / graying out of Firefox. Hardy 8.04 and Firefox 3.0.5 on Quad Core machine with 3GB RAM. Happens only sometimes with some websites -- I can't find a pattern or common feature of the sites. I ran "top" in an always-on-top terminal in an attempt to trace the problem, but did not notice any application pulling more CPU usage during the freeze. Damnit, just happened now actually! The screen does not always grey-out though -- the browser just "stops" for a few seconds -- the mouse cursor cam be moved around but stays the same as when the freeze started (in other words, I had a text caret cursor now which I could move over the title bar, etc., until the freeze ended). Opened up Tools --> Add-Ons now and screen greyed out for a few seconds.

I *think* this issue only started with the latest update to Firefox which came through the normal Ubuntu updates. I certainly have *not* always experienced this issue with Hardy and FF3.

joeyboots (scottdefeo) wrote :

I have a duo core. Same Exact thing is happening to me .
Is their a fix for this bug ? I didnt see it.
Im Knew to Linux.

bob_d (saturne-2001) wrote :

I have a single core AMD 64 running firefox 3 and this bug has been ettin worse. It's almost unusable now. I noticed firefox is allways in futex_wait state when this happens. I can confirm it's Ubuntu only since I can reboot in Suse and it works fine

fig_wright (fig-wright) wrote :

I am also having this problem. There is no pattern I can see to the URLs that cause the greying out of firefox. But it seems to be getting worse with later versions.

I am using Ubuntu 8.04 and Firefox 3.0.6. Using the same version of firefox in Windows XP doesnt have this problem.

Seems to be the same as this bug:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/172419

Covered in this thread:
http://ubuntuforums.org/showthread.php?t=590242&page=27

John Vivirito (gnomefreak) wrote :

Sabrewolfy,
Upstream thinks these bugs are not the same so for now ill leave them this way

summary: - Firefox freezes often
+ [MASTER] Firefox freezes often
SabreWolfy (sabrewolfy) wrote :

Ok. Appears to be fixed for me with 3.0.7 under Ubuntu Hardy 32bit.

You should add Bug 427521 to the list.

fig_wright (fig-wright) wrote :

Not fixed with me for FF 3.0.11 on Ubuntu 8.04.

Mike Trim (miketrim) wrote :

I am experiencing what appears to be this bug with 3.0.11+build2+nobinonly-0ubuntu0.9.04.1 on jaunty. Often (not always) when opening links, switching tabs or scrolling Firefox locks up and uses 100% of one core for several seconds. This may be exacerbated by me having approximately 50 tabs open at the moment.

After these freezes occur, an error is output on the error console, which says "too much recursion", and references line 1909 of nsSessionStore.js:

  saveState: function sss_saveState(aUpdateAll) {
    // if crash recovery is disabled, only save session resuming information
    if (!this._resume_from_crash && this._loadState == STATE_RUNNING)
      return;

    this._dirty = aUpdateAll;
    var oState = this._getCurrentState();
    oState.session = { state: ((this._loadState == STATE_RUNNING) ? STATE_RUNNING_STR : STATE_STOPPED_STR) };
>>> this._writeFile(this._sessionFile, oState.toSource());
    this._lastSaveTime = Date.now();
  },

Sometimes I instead/also get the following message, which references the same line:
Error: [Exception... "Component is not available" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///usr/lib/firefox-3.0.11/components/nsSessionStore.js :: sss_saveState :: line 1909" data: no]
Source File: file:///usr/lib/firefox-3.0.11/components/nsSessionStore.js
Line: 1909

fig_wright (fig-wright) wrote :

Since upgrading from Ubuntu 8.04 to 9.04 this seems to have cleared up for me, still with FF 3.0.11. :-)

Alex Cockell (alcockell) wrote :

I am on Hardy - 8.04.3LTS, with all updates as at 5 aug 2009, Firefox 3.0.12.

Experiencing lockups in Firefox as above.

Please could Mozilla hurry up and fix this incident...

Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body contains places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv

Changed in firefox:
importance: Unknown → Medium

This bug has lost most of the interest, indeed it has not been updated from 2009 and most of the reported issues have been fixed.
It's actually easier to search for Places bugs with "perf" specified in the keywords, that is the suggested way to track these bugs.

Changed in firefox:
status: Confirmed → Expired

This bug report is being closed, as it's about a version of FF that is no longer supported.

Changed in firefox-3.0 (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.