Edit from OPAC View doesnt' close on Save & Exit

Bug #1913219 reported by Mary Llewellyn
88
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Evergreen
Medium
Unassigned
3.5
Medium
Unassigned
3.6
Medium
Unassigned

Bug Description

Version 3.1

What we did:
Clicked on the Edit link from the OPAC view and made changes to an item in the Volume/Copy Editor.
Clicked on Save & Exit when finished.

What we expected:
The tab for the V/C editor would close, as it does when editing items from Holdings View and Item Status.

What happened:
The item was moved to the Completed Copies tab. The V/C editor tab did not close. It had to be closed manually.

Version 3.5
Same steps.

Expected the Editor tab to close after clicking Save & Exit.

Instead, we get a "Leave site?" message as if no changes had been made. Once the screen is left, refreshing the OPAC view shows the item was indeed edited.

Revision history for this message
Mary Llewellyn (mllewell) wrote :
Revision history for this message
Mary Llewellyn (mllewell) wrote :

I just tested again in 3.5.2 and found that edits from OPAC view are going to Completed copies instead of saving the changed item and closing the Editor tab.

Revision history for this message
Mary Llewellyn (mllewell) wrote :
Revision history for this message
Jason Stephenson (jstephenson) wrote :

See the duplicate bug 1914114 for more information and a patch for Evergreen 3.5 and earlier.

This issue appears to be caused by recent security updates in Chrome 88 and Firefox. (It was observed in Firefox 84, but not tested in earlier versions of that browser.)

Changed in evergreen:
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Jason Stephenson (jstephenson) wrote :

We installed the patch from bug 1914114 in production on 3.2.10 this morning with no ill effects reported so far.

I will start a collab branch and link it in another comment here.

Revision history for this message
Jason Stephenson (jstephenson) wrote :

Here's the collab branch, as promised:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/lp1913219-staffcatalog-edit-link-repair

I'm less sure of a patch for the Angular Staff Catalog, but I have observed this behavior there. If anyone wants to push a fix to the collab branch, then feel free. That's why I've made a collab branch.

Revision history for this message
Jane Sandberg (sandbej) wrote :

Thanks so much, Jason.

I signed off on your commit, and threw an Angular commit into this branch: https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/user/sandbergja/lp1913219-staffcatalog-edit-link-repair

Revision history for this message
Mary Llewellyn (mllewell) wrote :

I just tested on our 3.5 test database, and while the item is no longer sent to Completed Copies, I'm getting the message asking if it's OK to leave the screen. We still don't have an automatic exit after closing.

Revision history for this message
Jennifer Bruch (jbruchpails) wrote :

PaILS/SPARK

Just tested this on one of our test servers that has 3.6, still seeing this bug.

Revision history for this message
Jason Stephenson (jstephenson) wrote :

Those of you who report still seeing the bug, did you:

1. Apply the patches and reinstall the webstaff client on the server?
2. Clear cache in your browser before testing?

Changed in evergreen:
assignee: nobody → Jason Stephenson (jstephenson)
milestone: none → 3.7-beta
tags: added: pullrequest
Revision history for this message
Jason Stephenson (jstephenson) wrote :

Jane's fix works for me with the Angular editor. I have signed off and pushed both commits to master and rel_3_6.

I tried backporting to rel_3_5 and there was a conflict in Open-ILS/src/eg2/src/app/staff/catalog/record/copies.component.ts that I was not sure how to resolve.

I'm not sure if the Angular client is affected by this in 3.5, anyway, so I'll attempt to retest it there.

I know that that the AngularJS edit is affected and could benefit from my patch.

Changed in evergreen:
status: Confirmed → Fix Committed
assignee: Jason Stephenson (jstephenson) → nobody
Revision history for this message
Jason Stephenson (jstephenson) wrote :

I have confirmed that the experimental catalog is affected on 3.5.

I will attempt to back port Jane's fix.

Revision history for this message
Jason Stephenson (jstephenson) wrote :

I have pushed a backport branch that works for me:

https://git.evergreen-ils.org/?p=working/Evergreen.git;a=shortlog;h=refs/heads/collab/dyrcona/lp1913219-staffcatalog-edit-link-repair-rel_3_5

More eyes welcome. Otherwise I'll likely push it in a day or two.

tags: added: signedoff
Revision history for this message
Jason Stephenson (jstephenson) wrote :

I pushed the backport to rel_3_5.

Thanks, Jane!

tags: removed: webstaffclient
Changed in evergreen:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers