Debian GNU/Linux

ecb: incompatible with emacs23, breaks installation / upgrade

Reported by Angus77 on 2009-10-31
362
This bug affects 52 people
Affects Status Importance Assigned to Milestone
ecb (Debian)
Fix Released
Unknown
ecb (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

(This SRU info copied from duplicate bug 1051783)

Current version in Quantal: ecb-2.40+cvs20110608-3
Current version in Precise: ecb-2.40+cvs20110608-2

Full upstream Changelog:

   * add temporary conflicts on cedet-common, cogre (Closes: #657765)

... (though the correct upstream bug number is actually #657756!)

[IMPACT]

 * Upgrading to Precise is impossible on systems which have emacs23 and cogre installed.

 * Since a few years back, emacs23 includes its own version of cogre, but the current ecb packaging is from before those days, and does not cope with this scenario.

 * The difference between the current Precise version 2.40+cvs20110608-2 and the proposed version from Quantal ditto ditto-3 is the addition of yet one more Conflicts: field in debian/control.

[TESTCASE]

 * Set up a pre-Precise system. You may have to go so far back as Hardy or Intrepid to find a platform where it was in fact possible to have emacs23 and ecb installed successfully.

 * Install emacs23

 * Install ecb

 * Upgrade to Precise.

[Regression Potential]

 * Because this fix simply prevents the installation of a package which is now superfluous, it should have very limited impact.

[Other Info]

 * I would love to see this fixed in older supported releases, too, but the fix for Precise is extremely minor, and a good start.

[Original Report]

Binary package hint: emacs23

package emacs23 23.1+1-4ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

ProblemType: Package
Architecture: amd64
Date: Sat Oct 31 21:20:52 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: emacs23 23.1+1-4ubuntu3
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: emacs23
Title: package emacs23 23.1+1-4ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-14-generic x86_64

Angus77 (andrewmcintosh-yahoo) wrote :
Reinhard Tartler (siretart) wrote :

according to the terminal log, this seems to be a failure in the ecb package. reassigning.

affects: emacs23 (Ubuntu) → ecb (Ubuntu)
era (era) wrote :

It appears that ecb is incompatible with emacs23. As a workaround, try uninstalling ecb and reinstalling emacs23.

summary: - package emacs23 23.1+1-4ubuntu3 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ ecb: incompatible with emacs23, breaks installation / upgrade
arky (arky) wrote :

Broken Package on 10.04

Changed in ecb (Ubuntu):
status: New → Confirmed
François Isabelle (isabellf) wrote :

I've been using ecb on emacs23 before , I think the problem is that emacs23 no longer need a separate CEDET since it's builtin, marking cedet-common and cedet-contrib as conflicting with emacs23 might be the way to fix this.

Chris Hall (bitmonki-y) wrote :

I would very much like to use JDE on Oneiric. I am not thrilled by the prospect of doing everything necessary to downgrade my primary development tool in order to use just this one component (JDE).

I could, I suppose, use Netbeans for the Java work I do, but why should I need to devote all sorts of hours and effort to that when everything was just fine before the upgrade to Oneiric?

This seems to be primarily a packaging issue?

I sure hope this can be resolved in the near future.

Chris Hall (bitmonki-y) wrote :

And IINM, the ecb issue above is just the last message in a series. ecb depends on some component of CEDET, as is JDE but CEDET and friends (EIEIO, Speedbar, et. al.) are flagged:

jde:
 Depends: cedet-contrib (>=1:1.0pre4-2) but it is not installable
 Depends: cogre (>=1:1.0pre4-2) but it is not installable
 Depends: eieio (>=1:1.0pre4-2) but it is not installable
 Depends: semantic (>=1:1.0pre4-2) but it is not installable
 Depends: speedbar (>=1:1.0pre4-2) but it is not installable
 Recommends: ecb but it is not going to be installed

Changed in ecb (Debian):
status: Unknown → New
era (era) wrote :

As per duplicate bug #1032921, apparently affects emacs-snapshot, too.

Changed in ecb (Debian):
status: New → Fix Released
era (era) wrote :

See also bug #1051783 for a SRU proposal for Ubuntu 12.04.

Michael Terry (mterry) wrote :

I am bringing the separate SRU bug into this one. No reason for separate bugs.

description: updated
Changed in ecb (Ubuntu):
status: Confirmed → Fix Released
Michael Terry (mterry) wrote :

Confirmed that I got an error message when upgrading from lucid to precise with both emacs23 and ecb installed. It did not halt the precise upgrade, but I did see the error popup.

I've uploaded the fix to precise-proposed, pending acceptance by the archive admins.

Changed in ecb (Ubuntu Precise):
status: New → Confirmed
Daniel Holbach (dholbach) wrote :

Still sitting in the review queue: https://launchpad.net/ubuntu/precise/+queue?queue_state=1&queue_text=ecb

As there is nothing to be reviewed and sponsored right now, I'll unsubscribe the ubuntu-sponsors team.

Changed in ecb (Ubuntu Precise):
status: Confirmed → In Progress
era (era) wrote :

I'm sorry, I don't understand (probably an incomplete understanding of the process on my part). Why is there nothing to review and sponsor? Isn't the pending package in the review queue the thing which needs to be reviewed and sponsored? In particular, http://launchpadlibrarian.net/118400222/ecb_2.40%2Bcvs20110608-2_2.40%2Bcvs20110608-2ubuntu1.diff.gz

Daniel Holbach (dholbach) wrote :

Sorry. I could have been more clear.

The initial code review is done by members of the Ubuntu Development team. This was done and the change was uploaded - this was the 'sponsorship' part. In usual circumstances, this is good enough. In cases where we are in Freeze times or if we want changes to go into a stable release, we have the release team, archive team or sru team review the changes again.

From a sponsoring perspective this is done now.

era (era) wrote :

Thanks for the clarification. So do I understand correctly that it passed sponsor review and is waiting for SRU review?

Sebastien Bacher (seb128) wrote :

re comment #15: that's correct

Hello Angus77, or anyone else affected,

Accepted ecb into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ecb/2.40+cvs20110608-2ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ecb (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Clint Byrum (clint-fewbar) wrote :

Note that it looks like the package wasn't actually accepted on 10/23. I've just now accepted it.

Colin Watson (cjwatson) wrote :

Upgrade from lucid emacs23 and ecb to current precise-updates fails; upgrade to the versions in precise-proposed succeeds. Looks good to me.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ecb - 2.40+cvs20110608-2ubuntu1

---------------
ecb (2.40+cvs20110608-2ubuntu1) precise-proposed; urgency=low

  * debian/control:
    - Conflict on cedet-common and cogre, allowing clean upgrades to
      precise from lucid (LP: #466531)
 -- Michael Terry <email address hidden> Thu, 04 Oct 2012 17:17:28 -0400

Changed in ecb (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.