Netbooks- Cheese video recording is laggy at higher video resolutions

Bug #385344 reported by Chris Wayne on 2009-06-09
294
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Cheese
Fix Released
Critical
OEM Priority Project
Undecided
Unassigned
cheese (Ubuntu)
Low
Unassigned

Bug Description

Build Version/Date: unr-jaunty 20090609
Environment used for testing: Dell Inspiron Mini 1011

Summary:
When recording a video with cheese, the resulting video is extremely choppy, to the point where it drops more frames than it captures.

Steps to Reproduce:
1. Install OS from USB
2. Go through config
3. Open cheese, record a video
4. Notice very laggy video

Expected result:
Video is watchable

Actual result:
Video unwatchable

Chris Wayne (cwayne18) on 2009-06-09
affects: netbook-remix-launcher → netbook-remix
Alan Hartless (harty83) wrote :

It is the same for the Toshiba NB205 netbook. I'm sure it has something to do with cheese using 100+ % (top showed 103?) of the CPU when recording.

Thanks,
Alan

Paul Larson (pwlars) wrote :

Moved to Ubuntu distribution since netbook-remix is not a valid target for bugs

Changed in netbook-remix:
status: New → Invalid
Jimmy Cao (jcao219) wrote :

This happens to me, for the netbook remix on my Asus eeepc 1000he (netbook).
Cheese records at a terrible fps.

Joe (ttech5593) wrote :

Happens to me as well on a Aspire One, however it think it may have something to do with constant CPU usage

Richard Pineger (richm4n) wrote :

Yup, during recording, even at 160x120 pixels, processor on Dell Inspiron 9300 with 1.7GHz Centrino goes to 100% and frames are dropped. We also have Acer Aspires that show the same effect. This processor hogging seemed to happen along with the upgrade to Karmic Koala. Thx. Richard

Gillou (gilles-muller) wrote :

I have the same problem on a 1.6GHZ Centrino. Processor goes to 100% at 640x480. I'm still able to use 320x240 with 80% proc use.
I'm using ubuntu 9.10 Karmic Koala.

ubuntuhal (ubuntuhal) wrote :

I'm using Ubuntu 10.04 beta 1 32 bit. The web cam I use is the Logitech quickcam 9000 pro. Good pic but when I record there is a black screen for approx 3 or 4 seconds then the recording is really laggy so much so that its pretty much just a picture with me moving for a second or so. Tried different resolutions, same problem. No problems under Jaunty.

WalterCool (waltercool) wrote :

Reproducible on Ubuntu Lucid.

Acer Aspire D250

Vish (vish) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
If you are running Lucid:
Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 385344

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

When reporting bugs in the future please use apport, either via the appropriate application's "Help -> Report a Problem" menu or using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in cheese (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 10.04
MachineType: Acer, inc. Aspire 1690
Package: cheese 2.30.1-0ubuntu1
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: root=UUID=7486395b-f8da-4ce7-868f-c18084dc81dc ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev pulse-access sambashare video
dmi.bios.date: 01/06/05
dmi.bios.vendor: Acer
dmi.bios.version: 3C11
dmi.board.name: Crane
dmi.board.vendor: Acer, Inc.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag XXX
dmi.chassis.type: 1
dmi.chassis.vendor: , Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAcer:bvr3C11:bd01/06/05:svnAcer,inc.:pnAspire1690:pvrNotApplicable:rvnAcer,Inc.:rnCrane:rvrNotApplicable:cvn,Inc.:ct1:cvrN/A:
dmi.product.name: Aspire 1690
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer, inc.

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in cheese (Ubuntu):
status: Incomplete → New

apport information

apport information

apport information

I added apport information from my laptop. The issue can also be noticed due to 100% cpu usage just to display the video stream from the webcam in cheese's photo mode. I believe that the cause of the problem is the lack of hardware acceleration. Pixels are drawn on the screen using only the cpu instead of going through the regular display interface.
I'm able to play a 720p movies on my hardware (decoding+display), so why can't cheese display a low resolution video stream ?
Thanks for the great work !

Vish (vish) wrote :

Hmm , looks like you selected the option which did not collect the debugging information. [Maybe we need to improve the wording in the dialogue prompt :-) ]

Anyways , could you run the following command in a terminal which will launch cheese in debugging mode[note the command will only work in Lucid ]:

 GST_DEBUG=*cheese*:3 cheese -v 2>&1 | tee cheese-debug.log

After you reproduce the problem , close cheese and attach the file cheese-debug.log [which will be created in your Home folder]

Changed in cheese (Ubuntu):
status: New → Incomplete
WalterCool (waltercool) wrote :
Vish (vish) wrote :

This bug report has been sent upstream , you can follow the bug at : https://bugzilla.gnome.org/show_bug.cgi?id=619409

@WalterCool:
Could you also attach the output of command
 lsusb

@ Gillou :
Would be better if you could run the debugging as well[as mentioned in comment #24 ] , since the upstream bug report has most of your hardware information

affects: netbook-remix → cheese
Changed in cheese:
status: Invalid → New
importance: Undecided → Unknown
status: New → Unknown
Changed in cheese (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
WalterCool (waltercool) wrote :

lsusb

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b175 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Changed in cheese:
status: Unknown → New
Vish (vish) wrote :

Upstream wants to confirm:
"Are we talking about video recording or video displaying? "

Further comments:
" If the reporter sees 100% cpu with just displaying I guess he's either using the wrong video sink, or xvideo doesn't work (gpu driver issue), or the webcam uses some strange format quite difficult to decode.

Cheese uses the video sink configured in gconf through gstreamer-properties.
If it is set to XVideo it uses hardware acceleration, XImage doesn't."

Changed in cheese (Ubuntu):
status: Triaged → Incomplete
WalterCool (waltercool) wrote :

Ok....

lspci:

00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
03:00.0 Ethernet controller: Atheros Communications Atheros AR8132 / L1c Gigabit Ethernet Adapter (rev c0)

Im going to explain this...

I can take good pictures, i can see perfectly when im using video, but when i press record, the image goes black (maybe is normal), 3s after, i can see the webcam for ~1s and freeze for 40s~1.2m and freeze again... show a picture again on 40s~1.2m and freeze... etc etc...

When im going to see the final video... i can hear a good audio, but with freezed images.

Strangly, i can record a good video with a ultra bad resolution (160x120), my webcam is 640x480.

Thanks

Vish (vish) wrote :

Thanks for the reply.

Changed in cheese:
status: New → Unknown
Changed in cheese (Ubuntu):
status: Incomplete → Triaged
summary: - Cheese video recording laggy
+ Netbooks- Cheese video recordingis laggy at higher video resolutions
Changed in cheese:
status: Unknown → Confirmed
Vish (vish) on 2010-06-07
summary: - Netbooks- Cheese video recordingis laggy at higher video resolutions
+ Netbooks- Cheese video recording is laggy at higher video resolutions
Changed in cheese:
importance: Unknown → Critical
saewelo (saewelo1) wrote :

Same result with the last 2 release now. 10.10 has same issue with video in Cheese. I have also tested Camorama with same results. Has any progress been made? I have the same failure on both multiple PCs and laptop/netbooks. This is definitely not all hardware based.

Molnár Gábor (csirkus) wrote :

This works well for video recording on the same machine where cheese is very laggy:

ffmpeg -f alsa -i pulse -f video4linux2 -s 640x480 -i /dev/video0 -r 24 video.mpg

This works okay for me (pause at the beginning and occasional pause in
middle of video) but not great. Probably good enough, though, is there a way
to specify what command to use in cheese?

2010/10/31 Molnár Gábor <email address hidden>

> This works well for video recording on the same machine where cheese is
> very laggy:
>
> ffmpeg -f alsa -i pulse -f video4linux2 -s 640x480 -i /dev/video0 -r 24
> video.mpg
>
> --
> Netbooks- Cheese video recording is laggy at higher video resolutions
> https://bugs.launchpad.net/bugs/385344
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (653426).
>
> Status in Cheese Camera Application: Confirmed
> Status in “cheese” package in Ubuntu: Triaged
>
> Bug description:
> Build Version/Date: unr-jaunty 20090609
> Environment used for testing: Dell Inspiron Mini 1011
>
> Summary:
> When recording a video with cheese, the resulting video is extremely
> choppy, to the point where it drops more frames than it captures.
>
> Steps to Reproduce:
> 1. Install OS from USB
> 2. Go through config
> 3. Open cheese, record a video
> 4. Notice very laggy video
>
> Expected result:
> Video is watchable
>
> Actual result:
> Video unwatchable
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cheese/+bug/385344/+subscribe
>

Marc (mphaan) wrote :

Same problem here with an Asus Eee PC 1000. I treid all bios versions. It used to work, same story.

Rainfly_X (campadrenalin) wrote :

I figured out how to make it work! Use Guvcview instead of Cheese! The
interface isn't as good but it worked perfectly once I got the sound
settings set properly.

On Fri, Dec 10, 2010 at 12:53 PM, Marc <email address hidden> wrote:

> Same problem here with an Asus Eee PC 1000. I treid all bios versions.
> It used to work, same story.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (653426).
> https://bugs.launchpad.net/bugs/385344
>
> Title:
> Netbooks- Cheese video recording is laggy at higher video resolutions
>
> Status in Cheese Camera Application:
> Confirmed
> Status in “cheese” package in Ubuntu:
> Triaged
>
> Bug description:
> Build Version/Date: unr-jaunty 20090609
> Environment used for testing: Dell Inspiron Mini 1011
>
> Summary:
> When recording a video with cheese, the resulting video is extremely
> choppy, to the point where it drops more frames than it captures.
>
> Steps to Reproduce:
> 1. Install OS from USB
> 2. Go through config
> 3. Open cheese, record a video
> 4. Notice very laggy video
>
> Expected result:
> Video is watchable
>
> Actual result:
> Video unwatchable
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/cheese/+bug/385344/+subscribe
>

John Baptist (jepst79) wrote :

I can verify that guvcview works, while cheese doesn't. Still, cheese has an easier user interface and has the effects. It would be nice if we could fix cheese, especially since it is installed by default.

hawthornso23 (hawthorn) wrote :

In my case these symptoms were caused by a sound issue. Specifically I was using a USB webcam with built in microphone. When recording, cheese was fighting the sound system for access to the device. That is why preview was no problem (no sound involved), but the instant I tried to record the framerate dropped to something like one frame every two seconds. The workaround was simply to tell the sound system not to use the microphone built into the USB webcam but to use an external mike. That fixed the problem completely for me.

I reported all this in one of the many other bugs that got marked duplicates of this one. That comment seems to have been ignored. I am not sure that all those duplicates really deserve to be duplicates as others seem to be reporting the problem on laptops and in situations with very different hardware setups to mine. However my experience makes me suspect that while the details probably differ, this is most likely a sound issue in all cases. That would explain why preview is just fine but recording is unusable, since only when recording is sound used.

If you have this problem try playing with your sound recording settings in pulseaudio. For example try plugging in an external microphone and telling pulseaudio to use that as default audio source.

I saw your comment and it seems correct to me.
However, I couldnt find a way to do so easily. I don't know how to make pulseaudio change my sound card.
- "startup - sound & video - pulseaudio device chooser" does not produce anything
- "startup - system - preferences - pulseaudio preferences" does not give me the list of hardware, only network informations.
- gnome-volume-control applet does not allow me to change the hardware informations.

So, I am quite lost about what I can/should do. But I think you may be right about the sound reason for this bug.

John Baptist (jepst79) wrote :

hawthornso23: Your solution does not work for me. I used gstreamer-properties to set audio input to Silence, but the problem persists.

riverfr0zen (riverfr0zen) wrote :

I am having the same issue, on a 4x AMD Phenom(tm) 9550 (5867MB RAM) desktop with a ATI Radeon HD 4550. I think the issue may have sprung up somewhere between the karmic -> maverick, since I'd recorded some pretty sweet vids back on karmic (sorry, only realized the problem now, when I had some new vids to record).

hawthornso23's comment is interesting because I am using a PS3 eye camera, a USB device with an in-built mic, but also have a separate mic that I generally use. However I use ALSA, not Pulse (does bad things to my setup) -- does anyone have any tips on how to disable the PS3 mic?

On a separate note, GTK UVC Viewer works great (except weird interface)

Shang Wu (shangwu) wrote :

This oem-priority bug will be tracked in #610600

Changed in oem-priority:
status: New → Invalid
psypher (psypher246) wrote :

I have the exact same problem but I have logged a new bug for my issues and my laptop:
https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/800219

thanks

Danté (dante-ashton) wrote :

I appear to suffer from the bug, with one added item (if anyone else has noticed this as well)

If you get Cheese to record audio and video; the audio (and video) chops off several seconds before you actually stopped telling it to record. Also, the audio is not choppy. Not sure if this is helpful or not.

Kevin S (ks20xx) wrote :

Confirmed. Kubuntu 11.04 and Testing 11.10.

Video recording lags at high resolution but stabilizes once the resolution is decreased.

Ohad (ohad-basan) wrote :

I experience the issue on an acer aspire timeline 3810t

NT Man (mikhail-v-gavrilov) wrote :

Same problem on Acer Aspire One 521

tags: added: precise running-unity

ApportVersion: 1.26-0ubuntu1
Architecture: i386
CasperVersion: 1.290
DistroRelease: Ubuntu 12.04
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111112)
MachineType: Acer AO521
Package: cheese 3.2.0-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
RelatedPackageVersions:
 cheese 3.2.0-0ubuntu2
 cheese-common 3.2.0-0ubuntu2
Tags: precise running-unity
Uname: Linux 3.1.0-2-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout lpadmin plugdev sambashare sudo
dmi.bios.date: 08/16/2010
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.08
dmi.board.name: JV01-NL
dmi.board.vendor: Acer
dmi.board.version: Not Applicable
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.08:bd08/16/2010:svnAcer:pnAO521:pvrNotApplicable:rvnAcer:rnJV01-NL:rvrNotApplicable:cvnAcer:ct10:cvrN/A:
dmi.product.name: AO521
dmi.product.version: Not Applicable
dmi.sys.vendor: Acer

apport information

apport information

apport information

apport information

apport information

ronny (ronny-standtke) wrote :

I just run into the very same issue on an Intel Classmate PC.

ronny (ronny-standtke) wrote :

Short additional info: guvcview on the same machine works smooth as silk. This shows that the hardware of the Intel Classmate is capable enough, it's just the software stack with and below cheese that's not working correctly...

Changed in cheese:
status: Confirmed → Fix Released

I have a Dell Inspiron n5010
lsb_release -rd
Description: Ubuntu 12.04 LTS
Release: 12.04

apt-cache policy cheese
cheese:
  Installed: 3.4.1-0ubuntu2
  Candidate: 3.4.1-0ubuntu2
  Version table:
 *** 3.4.1-0ubuntu2 0
        500 http://ro.archive.ubuntu.com/ubuntu/ precise/universe amd64 Packages
        100 /var/lib/dpkg/status

Scott O'Nanski (s-onanski) wrote :

Here's my solution posted on bug #981803;

This is how I fixed my poor FPS in cheese, on Ubuntu 12.04;

1) sudo apt-get install guvcview;

2) Under image controls look for the drop-down menu item "Exposure, Auto" and select "Manual Mode";

                     "TAB" select the next option!!!

3) You should "TAB" select to the slider bar beneath "Exposure, Auto" labeled "Exposure (Absolute) - use your right arrow key to bump up the selection. Mine was set to "156" so I knocked it up to "157" then down to "155", and back again to "156". Now my exposure it fine, and I get a solid 30fps at 1280x720.

I'm not sure how or why this works, but it seems the exposure it set way too high or something.

Anyway, just quit out of guvcview and launch cheese. Everything should be working now. Or at least it did for me.

Luis Alvarado (luisalvarado) wrote :

Using 12.10 and 13.04, I tried what Scott O'Nanski just mentioned. Using guvcview (or any other webcam software) other than cheese works perfectly on several types of webcams. Juts tested an HP 1080p camera and a Genius one. Both work perfect. But if I use cheese with them, everything looks lagged. Feels like 5fps instead of 30fps. This only happens with cheese.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.