Launcher - the rendering of the BFB and Lens squircle does not match the design

Bug #838708 reported by John Lea on 2011-09-01
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Jason Smith
unity-2d
High
Tiago Salem Herrmann
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

*update* The latest designs for the BFB and Lens squircles are now attached to this bug. "launcher.png" shows exactly how the BFB should look, and "glow.png" and "base.png" should provide the required assets. Contact Rosie if these assets need any adjustment or if additional assets are required.

--------------------------------

The rendering of the BFB and Lens squircle does not match the design.

Look closely at the attached design and compare to the implementation. The issues are:
- the border of the squircle is incorrect
- there seems to be a strange highlight on the sides of the squircle that is not present in the design.
- the white glow effect seems to be missing.
- the background should be tinted using the wallpaper average background colour

If any changed or additional assets are required to match the implementation with the design contact Rosie.

Related branches

John Lea (johnlea) on 2011-09-01
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Critical
status: New → Fix Committed
tags: added: onew udo
Jono Bacon (jonobacon) wrote :

Out of curiosity was these really considered "Critical"?

Changed in unity-2d:
importance: Undecided → High
status: New → Confirmed
Jason Smith (jassmith) wrote :

the current implementation is a faithful rendering of the provided assets, new assets must be provided if you wish this to be fixed

Jason Smith (jassmith) on 2011-09-14
Changed in unity:
status: New → Incomplete
importance: Undecided → High
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) wrote :

@jassmith; I have updated the attached design, and also attached the required assets (see updated bug description).

Note that the backgrounds also needs to be tinted with the average colour of the current wallpaper. Ping me if you need anything else, thx.

description: updated
description: updated
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
Omer Akram (om26er) wrote :

@John, a totally offtopic question, is the BFB in the panel coming back(in future)? I saw that in another screenshot you attached so was wondering or would it be only visible for when desktop has the focus?

Jason Smith (jassmith) on 2011-09-14
Changed in unity:
status: Incomplete → Fix Committed
milestone: none → 4.16.0
John Lea (johnlea) wrote :

@om26er; no, the BFB won't be coming back to the panel. When Ubuntu first boots and no application is in focus the left of the top bar will say "Ubuntu desktop" by means of showing a Ubuntu roundel and the word 'desktop'. But the roundel will not be functional, and will not really be seen after that point as there is almost always an application in focus.

Didier Roche (didrocks) on 2011-09-15
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package unity - 4.16.0-0ubuntu1

---------------
unity (4.16.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::GpuDevice::GetGpuInfo()
      (LP: #765375)
    - F10 doesn't start keyboard navigation to the panel (LP: #839628)
    - Change on the at-spi accessibility-toolkit can affect also Unity
      (LP: #844927)
    - compiz crashed with SIGSEGV when a lens is shutting down (LP: #848675)
    - [UIFe] Radiance panel icons are unreadable and ugly when panel goes
      transparent with Dash (LP: #828862)
    - window switcher stuck (not only, but can be triggered with Onboard)
      (LP: #832033)
    - Window titlebar is click through after raising a minimized window
      (LP: #840285)
    - Alt+Shift+` does not work in symmetry with Alt+` (LP: #843250)
    - UIFe: Alt-Tab: Update layout behavior to make previews larger and
      outline active preview (LP: #847944)
    - windows clipped on resize (LP: #848962)
    - Alt-tab - Add orange border to selected window in alt-tab window spread
      (LP: #838114)
    - Launcher - the direction the Launcher is scrolled with the mouse wheel
      is inverted (LP: #839703)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - Alt-Tab - In the app window spread, all windows should have the same
      height, only the width should vary (LP: #838110)
    - Launcher - the background of the Launcher should be tinted using the
      average colour of the wallpaper (LP: #850068)
    - Alt-tab - It is currently very difficult to see pips in the left of the
      app icon for the currently selected app (LP: #838134)
    - Launcher - Auto scroll missing from the top of the Launcher
      (LP: #838744)
    - Scope searches blocks the lens (LP: #850816)
    - Shortcuts SUPER+1...9 doesn’t work until opening a window (LP: #768076)
    - Dash closes prematurely when dragging apps into the launcher
      (LP: #773892)
    - Dash - As soon as a user starts dragging a .png file from the Dash, the
      file icon turns into a grey question mark (LP: #764447)
    - Dash shows an empty icon for some applications. (LP: #830887)
    - Windows are click through after restore from minimize (LP: #834034)
    - Dash - No keyboard shortcuts for switching lenses (LP: #842086)
    - Dash search for files states "two more results" but doesn't display them
      (LP: #840005)
    - <meta>+<shift>+<launcher #> to start a new instance of a program doesn't
      work anymore (LP: #842977)
    - Alt-tab - Cross interactions between Alt-tab and Dash are broken
      (LP: #844021)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (Part 2) (LP: #844889)
    - Alt-Tab - make pause to spread default alt-tab behaviour. Upgrade
      existing installs as well. (LP: #838075)
    - Do not install unity-preference (LP: #847599)
    - Update unity --distro to latest plugins installed (LP: #847799)
    - off by one error in count of additional results in a category
      (LP: #848218)
    - UIFe - Launcher - The background of the BFB, Workspace Switcher, Lens,
    ...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
tags: added: delta-with-3d
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-09-30
tags: added: reviewedbydesigno
removed: onew udo
tags: added: reviewedbydesign
removed: reviewedbydesigno
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
status: New → Confirmed
John Lea (johnlea) wrote :

@Dmitry Shachnev (mitya57); Hyia, thanks for your interest in this bug but please don't change existing tags on bugs in the ayatana-design project. Feel free to add new tags if you wish, but please don't modify existing tags.

tags: added: reviewedbydesigno
removed: reviewedbydesign
Changed in unity-2d:
milestone: none → 4.14
Changed in unity-2d:
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Gerry Boland (gerboland) on 2011-11-21
Changed in unity-2d:
milestone: 4.14 → 5.2
assignee: Renato Araujo Oliveira Filho (renatofilho) → nobody
Changed in unity-2d:
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity-2d - 5.2.0-0ubuntu1

---------------
unity-2d (5.2.0-0ubuntu1) precise; urgency=low

  [ Didier Roche ]
  * New upstream release:
    - Select quicklist items with just one right click (LP: #688830)
    - Launcher - Dragging and dropping a running application in to the Trash
      should quit the application and (if the app is pinned to the Launcher)
      un-pin the application from the Launcher (LP: #870143)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - right click on the dash icon should display a list of the lenses
      (LP: #868452)
    - Top Bar - rename the "Desktop" title in the Top Bar (displayed when no
      window has focus) to "Ubuntu Desktop" (LP: #869873)
    - Application title on quicklist should be bold (or more visible)
      (LP: #900400)
    - unity-2d-launcher crashed with SIGSEGV when opening a folder on a CD
      (LP: #831868)
    - unity-2d-places crashed with SIGSEGV in QScriptValue::call()
      (LP: #836498)
    - unity-2d-launcher crashed with SIGSEGV in geis_finish() (LP: #850893)
    - unity-2d-places crashed with SIGABRT in raise() (LP: #857575)
    - unity-2d-launcher crashed with SIGSEGV in exit() (LP: #859596)
    - [spread] layout broken since bzr revision 799 of lp:unity-2d
      (LP: #900895)
    - [workspace switcher] keyboard navigation of workspace switcher broken
      for accessibility (LP: #744978)
    - [spread] workspace switcher performance is poor, especially on low
      powered CPUs (LP: #745764)
    - Launcher - the rendering of the BFB and Lens squircle does not match the
      design (LP: #838708)
    - [dash] Huge performance hit when scrolling search results with
      accessibility enabled (LP: #862956)
    - DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE aren't always unset from
      environment making gedit and possibly others fail to start (LP: #873027)
    - Win Key can not be disabled in Unity-2d (LP: #873580)
    - [dash] Unity-2d dash very slow to open (LP: #881756)
    - [tests] LauncherViewTest hanging (LP: #894380)
    - [tests] Unit tests failing due to lack of Xserver (LP: #894381)
    - [launcher] Alt+F1 broken: does not give the focus to the launcher's
      content (LP: #901505)
    - [tests] Add Automated User Experience testing (LP: #903495)
    - [workspace switcher] Performance can be poor when using the opengl
      backend because of window texture sizes that are not limited
      (LP: #808716)
    - [dash] no way to unmaximize (LP: #860400)
    - [launcher] In non-composite mode, background is black (LP: #879288)
    - [dash] Unity 2D shows 'Search' instead of 'Run Command' on ALT + F2
      (LP: #883392)
    - [launcher] Removing icon from launcher makes it hide immediately
      (LP: #884410)
    - OpenGL disabled regardless of use-opengl setting (LP: #887957)
    - if libdir does not equal lib (LP: #888164)
    - [launcher] Launcher stuck open while mouse moved to left corner of panel
      (LP: #892004)
    - [dash] Long results label are truncated instead of elided and a few
      pixels of the next line is visible (LP: #901491)
    - [launcher] Dash icon missing...

Read more...

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers