Where the average background colour is either very light or dark, adjust this value to darken/lighten in order to preserve readability

Bug #837993 reported by John Lea on 2011-08-31
110
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Fix Released
Medium
Gord Allott
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The background of the Dash, Launcher, NotifyOSD, etc.. is tinted with the average background colour of the wallpaper. In cases where this average colour is either very light or very dark it should be respectively darkened or lightened to improve readability.

Inside the 'too dark/light' thresholds, the level of adjustment needs to be on a sliding scale so that a very very dark background is lightened more than a background that is just a bit too dark. Average background colours that do not fall inside the 'too dark/light' thresholds should not be modified.

There is an additional issue in that the implementation does not match the design in terms of both the saturation of the tint and the radius of the blur. Both of these issues also significantly impact readability.

---------------------------------------------------

Desired resolution:

There are two parts to this fix:

1. adjust the tint colour inside the 'too dark/light' thresholds.

2. bring implementation in to line with the designs
- Compare "dash_design.png" with "dash_implementation.png" (files attached to this bug)
- Note that both of these screenshots use the same wallpaper, and therefor the dash tint should be the same in both.
- Note that in "dash_design.png" the text in the dash on top of the white area in the window behind the dash is legible, while in "dash_implementation.png" it is not.
- Increase the tint saturation in the implementation to match the design.
- Increase the radius of the dash blur to match the design.

It would be much appreciated if screenshots of the proposed fixes could be sent to Otto for review and iteration *before* they are committed.

John Lea (johnlea) on 2011-08-31
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
status: New → Fix Committed
tags: added: onew udo
Gord Allott (gordallott) on 2011-08-31
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
status: New → Confirmed
importance: Undecided → Medium
John Lea (johnlea) on 2011-08-31
Changed in ayatana-design:
status: Fix Committed → Fix Released
Neil J. Patel (njpatel) on 2011-09-01
Changed in unity:
milestone: none → 4.14.0
Gord Allott (gordallott) on 2011-09-01
Changed in unity:
status: Confirmed → Fix Committed
Andrea Azzarone (azzar1) on 2011-09-07
Changed in unity (Ubuntu):
status: New → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.14.2-0ubuntu1

---------------
unity (4.14.2-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - unity crashed with AttributeError in reset_unity_compiz_profile(): 'str'
      object has no attribute 'get_string' (LP: #809378)
    - Trying to minimize Unity Dash to make it fit on a 1024x768 screen makes
      Unity freeze and then, after I log out by killing X, never start again
      (LP: #839200)
    - unity-panel-service crashed with SIGSEGV in main_arena() (LP: #817477)
    - UIFe: Panel - Indicators should be orderable regardless of their parent
      IndicatorObject (LP: #823061)
    - 'Show Desktop' fails to hand focus to desktop (LP: #836315)
    - Dash - Functionality of top left close, minimise and maximise/restore
      window decorations is confused (LP: #838875)
    - unity-panel-service Leaks Memory (LP: #779185)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - Unity window switcher takes over <alt> key (LP: #835699)
    - update assets for window buttons (topleft) with dash opened
      (LP: #836655)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Applications don't have priority over other results (LP: #839518)
    - task tray icons are misaligned and badly sized (LP: #839354)
    - UIFe: Dash - Shape and positioning of most of the elements in the Dash
      need adjustment (LP: #841945)
    - Cannot drag applications from dash to desktop (LP: #756614)
    - systray icons still visible on each desktop in expo mode (LP: #759129)
    - transparency on unity panel broken (LP: #827012)
    - Window buttons and application menu don't autohide if left edge is
      touched (LP: #835637)
    - 'Filter results' should be right indented as in the mockups(and unity-
      2d) (LP: #838118)
    - window title should not appear until cursor leaves the menubar
      (LP: #838759)
    - Window title is not redrawn on leaving global-menu from buttons
      (LP: #839488)
    - In the dash, main text field can not be edited, except at the end
      (LP: #840862)
    - Quicklist can't be correctly hidden (LP: #843425)
    - After double clicking on the panel to restore a window, the menus won't
      be hidden on mouse-out (LP: #838021)
    - After restoring a window the application title doesn't fade-out and it
      goes below the menus (LP: #838479)
  * debian/control:
    - build-dep on latest libunity-dev for ABI/API break, nux
  * debian/rules:
    - bump shlibs, remove tweak for garantuing the version as the ABI
      is considered stable until finale now.
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:07:50 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Doug McMahon (mc3man) wrote :

Well - taking a look on 4.14.2, you've made it a little better on some backgrounds and I'm sure many will like/love the blurs.
I'm just as sure a significant number will not and will find the blur lens' distracting at best.
For those significant others it would be nice if the 'no blur' option, which currently is almost worthless, be turned into static, smoked glass or similar .
At least then there would be options that would suit just about everyone . (As antithetic as that may be to the current philosophy

bug 837401

Hernando Torque (htorque) wrote :

Take a look at the attached screenshot: people that like to collect icons on the desktop are screwed, no matter how fixed this bug gets marked. The dash becomes basically unusable and that's not even the no-blur case which might be preferred by some due to better performance.

When a very bright window is open (firefox - google), the text on the dash is quite unreadable.
see attached screenshot.

David Raid (davidraid) wrote :

Could an option just be added to CCSM to turn off the chameleonic feature of Dash? As cool as it changing colour to match the background image is, not everyone wants their, say, green background to force them to have a green launcher and Dash.

The best way to please everyone is to offer the choice, so that there is an option in CCSM to make the Dash and Launcher one colour again, black like it was in Natty. This would solve all usability issues in this bug.

It could even go one step further, allow the user to choose the colour manually in CCSM! Imagine, a mostly black wallpaper with a bit of green in it and the user could make the Dash and Launcher green as well, despite it not being the majority colour of the wallpaper.

I know when using the monochrome photo of buildings thats in the default wallpaper selection the Dash becomes annoyingly white. I'd love to have that back to black as it was in Natty when using such backgrounds.

Jono Bacon (jonobacon) wrote :

This bug is still a problem. See my attached screenshot - opening the dash in front of a white window (such as a webpage in Firefox) makes the text unreadable.

Can we please just ask Mirco to add a shadow outline to the text in the same way he did in notify-osd? This would resolve the issue.

Neil J. Patel (njpatel) on 2011-09-27
Changed in unity:
milestone: 4.14.0 → 4.20.0
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
John Lea (johnlea) wrote :
description: updated
John Lea (johnlea) wrote :
Gord Allott (gordallott) on 2011-09-28
Changed in unity:
status: Confirmed → Triaged
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
arm-c (arickmcniel) wrote :

The concept is great. The implementation is not.

Give me a smoked glass option where white text / icons are very visible. Put only a slight transparency and blur to the dash window.

tankdriver (stoneraider) wrote on 2011-09-16: (#4 above) is right on the money.

When I open DASH, I want to be able to dash through and find what I want and move on. Presently, I STUMBLE instead and have to look very hard and the background icons/colors are always distracting and making the foreground difficult to read.

I vote for options that include the following:

a. Smoked Glass Option.

b. Option for blurred wallpaper (without showing windows above or icons on desktop.).

c. Pannel, launcher, and dash background based on theme color... not wallpaper.

I'm only after one thing in reality - a readable dash with no distractions to reading it.

Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-10-03
tags: added: reviewedbydesigno
removed: onew udo
thom (tsk) wrote :

Regression of this bug:

Again, launcher behaves like a chameleon.....manual override is broken.
Come on guys, this is bad engineering: Designrule #1: Manual ALWAYS overrides automation

thom (tsk) wrote :

additional info:
Ubuntu 12.04
unity:
  Geïnstalleerd: 5.10.0-0ubuntu3
  Kandidaat: 5.10.0-0ubuntu3
  Versietabel:
 *** 5.10.0-0ubuntu3 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

unity-2d:
  Geïnstalleerd: 5.10.0-0ubuntu1
  Kandidaat: 5.10.0-0ubuntu1
  Versietabel:
 *** 5.10.0-0ubuntu1 0
        500 http://nl.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Edmond Dantes (edantes) wrote :

 I find Dash impossible to read in many situations (Ubuntu 12.04), especially with the Applications lens. Also, I would love to have control over the size of the Dash screen and icons.

Robin Pecha (robinpecha) wrote :

Problem persist.
unity 7.2.5+14.04.20150603-0ubuntu1
Ubuntu 14.04.3 LTS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers