Enable Gnome-Control-Center in Unity, and add "System Settings" link to the session indicator menu

Bug #727823 reported by John Lea on 2011-03-02
106
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Session Menu
Fix Released
Undecided
Martin Pitt
Unity
Invalid
Undecided
Unassigned
Unity Foundations
Medium
Martin Pitt
gnome-control-center (Ubuntu)
Medium
Martin Pitt
Natty
Medium
Martin Pitt
gnome-menus (Ubuntu)
Medium
Martin Pitt
Natty
Medium
Martin Pitt
indicator-session (Ubuntu)
Wishlist
Martin Pitt
Natty
Wishlist
Martin Pitt

Bug Description

1) Enable Gnome-Control-Center in Unity

2) Add a "System Settings" option to the end of the session indicator menu. e.g.

...
Shutdown
-----------------------------
'System Settings'

Clicking on the "System Settings" link will open the Gnome Control Center.

A separate bug about fixing the exact menu item name is bug #733234 ("Link to gnome-control-center is session menu should be titled "System Settings"").

Related branches

John Lea (johnlea) on 2011-03-02
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → John Lea (johnlea)
tags: added: udt
Martin Pitt (pitti) wrote :

What does 1) mean? Show the shell in the dash, as "Configure your Desktop"? Also/or show it in installed apps?

David Barth (dbarth) wrote :

Pitti: can i assign to you for the moment?

Changed in ayatana-ubuntu:
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-11.04-beta
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Pitti, if you search for "Gnome Control Center" in the dash home or App Lens, yes, the Gnome Control Center icon should appear.

Martin Pitt (pitti) wrote :

OK, I have a first idea how to make it show up only in Ubuntu, will discuss with Didier.

Changed in unity (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
milestone: none → ubuntu-11.04-beta-1
status: New → In Progress
Martin Pitt (pitti) wrote :

Note to self: While I'm at it, also show baobab.

affects: unity (Ubuntu Natty) → unity-place-applications (Ubuntu Natty)
Martin Pitt (pitti) wrote :

@John: Just to be sure, you actually want the session menu? Not the me-menu?

Martin Pitt (pitti) wrote :

seb128 | pitti, btw the decision to hide the g-c-c entry was before the interface has issues, it's slow to load and has some bugs
seb128 | pitti, it would make sense to let the place find it but we shouldn't expose it in the indicator

John, would that be an acceptable compromise?

Didier Roche (didrocks) on 2011-03-04
Changed in unity:
status: New → In Progress
Changed in unity-place-applications:
status: New → In Progress
Omer Akram (om26er) wrote :

Control Center maybe slow but it provides a much quick interface for playing with settings and I think the ease here is greater than little slowness, btw control center doesn't look slow even on my netbook.
Also having it at quick access it really nice as I am using it.

Martin Pitt (pitti) on 2011-03-07
Changed in unity:
status: In Progress → Invalid
Changed in unity-place-applications:
status: In Progress → Invalid
affects: unity-place-applications (Ubuntu Natty) → gnome-menus (Ubuntu Natty)
Martin Pitt (pitti) on 2011-03-07
Changed in gnome-control-center (Ubuntu Natty):
status: New → In Progress
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Medium
John Lea (johnlea) wrote :

Pitti: yes. in the session menu, not the me menu

Martin Pitt (pitti) on 2011-03-07
Changed in gnome-menus (Ubuntu Natty):
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
Ted Gould (ted) wrote :

I don't understand how the design task can be "Fix Released" when the spec hasn't been updated:

  https://wiki.ubuntu.com/SessionMenu

Matthew Paul Thomas (mpt) wrote :

System settings has nothing whatsoever to do with the session menu. I think John must have meant something else.

Martin Pitt (pitti) wrote :

The session indicator doesn't currently support adding extra desktop files, this needs to get patched in.

Changed in gnome-control-center (Ubuntu Natty):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Fix Committed
affects: unity-place-applications → indicator-session
Changed in indicator-session:
status: Invalid → Confirmed
Changed in gnome-control-center (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
Changed in indicator-session:
assignee: nobody → Martin Pitt (pitti)
Changed in indicator-session (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Wishlist
status: New → Triaged
Martin Pitt (pitti) wrote :

@mpt: The description makes it quite clear that it's not a terminology problem -- John indeed did mean the session menu. I guess I let you design guys fight it out, and then implement whatever the decision is where to put it? :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.32.1-0ubuntu6

---------------
gnome-control-center (1:2.32.1-0ubuntu6) natty; urgency=low

  * Add 53_ubuntu_show_shell.patch: Show gnomecc.desktop, so that we can find
    it in Unity. For classic GNOME we will disable it in
    /etc/xdg/menus/settings.menu instead. (LP: #727823)
 -- Martin Pitt <email address hidden> Mon, 07 Mar 2011 16:50:00 +0100

Changed in gnome-control-center (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 2.30.5-0ubuntu3

---------------
gnome-menus (2.30.5-0ubuntu3) natty; urgency=low

  * Add 24_ubuntu_hide_control_center.patch: Hide the Control Center shell
    from the Settings menu. We only want to expose it in Unity and the session
    indicator. (LP: #727823)
 -- Martin Pitt <email address hidden> Mon, 07 Mar 2011 16:50:14 +0100

Changed in gnome-menus (Ubuntu Natty):
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Hi Pitti, I've chatted to MPT, this option does need to go in the Session Menu so you are now unblocked.

Martin Pitt (pitti) on 2011-03-07
Changed in indicator-session (Ubuntu Natty):
status: Triaged → In Progress
Changed in indicator-session:
status: Confirmed → In Progress
Timothy Kross (timkross) wrote :

If this were to go in the Session Menu, the Session Menu Rationale would need to be updated https://wiki.ubuntu.com/SessionMenu
It currently states: "The session menu is for when you want to stop using the computer, either temporarily or indefinitely".

Ted Gould (ted) wrote :

Can we get an update of the spec with the rationale then?

David Barth (dbarth) on 2011-03-09
Changed in ayatana-ubuntu:
status: Triaged → Invalid
affects: ayatana-ubuntu → unity-foundations
Changed in unity-foundations:
assignee: nobody → Martin Pitt (pitti)
milestone: ubuntu-11.04-beta → none
status: Invalid → In Progress
milestone: none → ubuntu-11.04-beta-1
John Lea (johnlea) wrote :

Brief updated added to the spec, will be explored more in the indicator project post UDS

Martin Pitt (pitti) wrote :

I confirm that copying /usr/share/applications/gnomecc.desktop to /usr/share/applications/indicator-session-extra.desktop already does the right thing, i. e. adds the control center launcher to the end of the session menu with a separator. It is also properly translated (using the usual X-Ubuntu-Gettext-Domain).

So I'll change the special support for this file into a more general directory, like /usr/share/indicators/session/applications/*.desktop (to stay reasonably consistent with /usr/share/indicators/messages/applications/). Then gnome-control-center only needs to be changed to install a symlink to the existing gnomecc.desktop into that directory. For that part I'm reopening the g-c-c task.

Changed in gnome-control-center (Ubuntu Natty):
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

MP submitted. I tested this with

  sudo mkdir -p /usr/share/indicators/session/applications
  sudo ln -s /usr/share/applications/gnomecc.desktop /usr/share/indicators/session/applications/gnomecc.desktop

and also combinations of that link with /usr/share/applications/indicator-session-extra.desktop, and several desktop files, and no desktop files at all.

Changed in indicator-session:
status: In Progress → Fix Committed
John Lea (johnlea) wrote :

thanks Pitti !

Ted Gould (ted) on 2011-03-10
Changed in indicator-session:
milestone: none → 0.2.15
Ted Gould (ted) on 2011-03-10
Changed in indicator-session:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-session - 0.2.15-0ubuntu1

---------------
indicator-session (0.2.15-0ubuntu1) natty; urgency=low

  * New upstream release.
    ∘ Support adding arbitrary items to the end of the session
      menu. (LP: #727823)
    ∘ Call guest session with --no-lock to ensure there is no
      double locking (LP: #636693)
 -- Ted Gould <email address hidden> Thu, 10 Mar 2011 16:10:19 -0600

Changed in indicator-session (Ubuntu Natty):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2011-03-11
Changed in unity-foundations:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.32.1-0ubuntu7

---------------
gnome-control-center (1:2.32.1-0ubuntu7) natty; urgency=low

  * Add debian/gnome-control-center.links: Add gnomecc.desktop to
    indicator-session extra menu list. (LP: #727823)
 -- Martin Pitt <email address hidden> Fri, 11 Mar 2011 09:22:41 +0100

Changed in gnome-control-center (Ubuntu Natty):
status: In Progress → Fix Released

I think that 3 buttons on the dash screen could do that job better.

see my attach.

Gerson, interesting idea to add those link areas to the dash sections,
but I think we need to find more general use cases for those if we're
going to use them here. And that would be an Oneiric issue.

Mark

Thanks Mark,

I've thinking on buttons that way for tablet users of Unity, so they can change simple details on their systems pretty fast.

Sorry for my english, thanks again. :)

On 7 March 2011 16:03, John Lea <email address hidden> wrote:
> Hi Pitti, I've chatted to MPT, this option does need to go in the
> Session Menu so you are now unblocked.

Could someone explain on the bug report what the response to mpt's
comment was. It seems valid to me - I can't see why this option isn't
in the main menu where users will actually find it rather than in the
session menu which has nothing to do with system settings.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

On 14/03/11 08:28, Matthew East wrote:
> Could someone explain on the bug report what the response to mpt's
> comment was. It seems valid to me - I can't see why this option isn't
> in the main menu where users will actually find it rather than in the
> session menu which has nothing to do with system settings.

What do you mean by the "main menu"?

On 14 March 2011 08:37, Mark Shuttleworth <email address hidden> wrote:
> On 14/03/11 08:28, Matthew East wrote:
>> Could someone explain on the bug report what the response to mpt's
>> comment was. It seems valid to me - I can't see why this option isn't
>> in the main menu where users will actually find it rather than in the
>> session menu which has nothing to do with system settings.
>
> What do you mean by the "main menu"?

I mean the menu that appears down the left hand side of the screen
when using Unity.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Ah. The problem with that is that the contents are unpredictable. We
could put it there, we could also put it in the Shortcuts that appear
when you click on the Ubuntu button (and which are for Natty at least
always accessible that way).

The advantage of putting it in the last indicator menu is that it can be
consistent across all the desktop interfaces. Also, the roadmap for the
indicators introduces a device menu, in the top right corner, which
would have the settings in it, so we're triangulating to that
destination here.

We can however do some tests on discoverability and tweak this before
release if there's a problem.

Mark

On 14 March 2011 10:01, Mark Shuttleworth <email address hidden> wrote:
> Ah. The problem with that is that the contents are unpredictable.

I don't understand what that means. If there is an issue with that
menu, then it would apply to any item put in it, and there has been no
issue adding "Applications" and "Files & Folders" to it, so why not
"Settings" as another entry?

> The advantage of putting it in the last indicator menu is that it can be
> consistent across all the desktop interfaces.

Again, that argument doesn't apply to any other item in the left hand menu?

> Also, the roadmap for the
> indicators introduces a device menu, in the top right corner, which
> would have the settings in it, so we're triangulating to that
> destination here.

Ok, it's just that from some of the above comments, it didn't sound
like there was a roadmap for this which was known among at least some
of the developers. It sounded more like this was introduced as a
stop-gap, pending further discussion at some future UDS with a
retrospective update made to the relevant specification to justify the
change.

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

On 14/03/11 10:26, Matthew East wrote:
> On 14 March 2011 10:01, Mark Shuttleworth <email address hidden> wrote:
>> Ah. The problem with that is that the contents are unpredictable.
> I don't understand what that means. If there is an issue with that
> menu, then it would apply to any item put in it, and there has been no
> issue adding "Applications" and "Files & Folders" to it, so why not
> "Settings" as another entry?

Users can remove items from the launcher, whereas they can't remove them
from the indicator menus. The launcher is "user space" and we seed it
with some useful stuff. The indicators are (mostly) "system space".

>> The advantage of putting it in the last indicator menu is that it can be
>> consistent across all the desktop interfaces.
> Again, that argument doesn't apply to any other item in the left hand
> menu?

All of the things that are going in the launcher are optional. The
system still works without any of 'em.

Mark

On 14 March 2011 11:49, Mark Shuttleworth <email address hidden> wrote:
> On 14/03/11 10:26, Matthew East wrote:
>> On 14 March 2011 10:01, Mark Shuttleworth <email address hidden> wrote:
>>> Ah. The problem with that is that the contents are unpredictable.
>> I don't understand what that means. If there is an issue with that
>> menu, then it would apply to any item put in it, and there has been no
>> issue adding "Applications" and "Files & Folders" to it, so why not
>> "Settings" as another entry?
>
> Users can remove items from the launcher, whereas they can't remove them
> from the indicator menus. The launcher is "user space" and we seed it
> with some useful stuff. The indicators are (mostly) "system space".

I don't think that is a clear distinction at all. Music, mail, chat,
social networking etc are all present in the indicators and these seem
to me to be user space. But putting that aside, it seems to me that
the launcher is intended to be the place where users *start* things
and I still don't see any meaningful reason not to include settings
alongside applications there.

>>> The advantage of putting it in the last indicator menu is that it can be
>>> consistent across all the desktop interfaces.
>> Again, that argument doesn't apply to any other item in the left hand
>> menu?
>
> All of the things that are going in the launcher are optional. The
> system still works without any of 'em.

That's also true of the settings (which are currently present in the
applications launcher already).

--
Matthew East
http://www.mdke.org
gnupg pub 1024D/0E6B06FF

Paul Sladen (sladen) on 2011-03-15
description: updated
Benjamin Drung (bdrung) wrote :

I opened bug #736375 requesting the reverting of this change.

BavarianPH (bavarianph) wrote :

Frankly, I have no idea how unity works, or how it should work,

especially where the settings are to adjust or enhance unity.

Perhaps unity was introduced before its time or maybe I am

just getting too old to keep up with the Linux masters? -

[By the way, Is Mark Shuttleworth left handed?] -

Unity has great possibilities, if windows decoration & functionality

remains a user's choice.

So far, windows loose their headers far too easily when unity fails.

- Naked windows are like chickens without feathers. -

Unity must become 'un-crash-able'.

A right click menu like gnome-panel, with many options, would help.

Still, I prefer a panel on the bottom of the desktop,

it is more comfortable, & easier for me to work with.

So, I simply auto-start gnome-panel, which appears on the bottom,

& gives me many choices, including The familiar Main Menu.

Yes, this main menu needs some tweaking, however, I discovered,

that under natty there is no delay in using the menu, &

scrolling works as well, under maverick these functions

where a problem, natty somehow fixed it.

Sure, if unity had right-click functions, & a Menu

that is easily configured & customized, would make unity

far better than gnome-desktop & gnome-panel.

Just an open source thought.

BavarianPH,

Ubuntu Forever!

I added a comment (#10) about the problems this change may bring in a school environment in bug #735343, unless this addition may be easily removed by the sysadmin.

John Lea (johnlea) on 2011-04-19
tags: added: reviewedbydesign
removed: udt
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers