Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars are too thin to grab on to.

Reported by David Siegel on 2010-07-21
288
This bug affects 60 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Nux
High
Brandon Schaefer
Unity
High
Brandon Schaefer
nux (Ubuntu)
High
Brandon Schaefer
unity (Ubuntu)
High
Brandon Schaefer

Bug Description

Note: prior to fixing this bug, bug #1050959 needs to be fixed first.

----------------

Add overlay scrollbars to the Dash. The scrollbar behaviour should be identical to Cimi's GTK overlay scrollbars. Use vertical white line for the position indicator see https://chinstrap.canonical.com/~sabdfl/12_10/desktop_and_netbook/Dash/Home/dash_home_v1.png for visual design (as opposed to vertical orange line in the GTK version).

Contact Roise for the thumb visual assets.

Note that the overlay scrollbar needs to be positioned on top of the dash background texture.

Related branches

lp:~brandontschaefer/nux/mouse-near-signal
Merged into lp:nux at revision 712
Jay Taoko (community): Approve on 2012-11-19
Marco Trevisan (Treviño): Approve on 2012-11-19
Stephen M. Webb: Needs Fixing on 2012-11-16
Andrea Azzarone: Needs Fixing on 2012-11-08
PS Jenkins bot: Pending (continuous-integration) requested 2012-11-20
lp:~brandontschaefer/unity/lp608124-overlay-scrollbar-dash
Merged into lp:unity at revision 2928
Marco Trevisan (Treviño): Approve on 2012-11-23
John Lea: Approve (design) on 2012-11-20
PS Jenkins bot: Pending (continuous-integration) requested 2012-11-24

Assigning to Otto; Otto, please add visual information to the Dash spec, and deliver assets.

Changed in ayatana-design:
assignee: nobody → Otto Greenslade (otto-chaotic)
description: updated
Otto Greenslade (otto-chaotic) wrote :

Designed scrollbar - a lightweight design without steppers - including (from left to right) off/over/down states.

Changed in ayatana-design:
status: New → In Progress
David Barth (dbarth) on 2010-08-04
Changed in unity:
milestone: none → 2010-08-05
Neil J. Patel (njpatel) on 2010-08-20
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → Low
milestone: 2010-08-05 → 2010-08-26
status: New → Triaged
Mirco Müller (macslow) on 2010-08-26
Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) on 2010-08-26
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2010-09-02
Changed in unity:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: In Progress → Fix Committed
John Lea (johnlea) on 2010-12-16
Changed in ayatana-design:
status: Fix Committed → Fix Released
Mark Shuttleworth (sabdfl) wrote :

 status confirmed

Sorry, not signed off yet.

Changed in ayatana-design:
status: Fix Released → Confirmed
John Lea (johnlea) on 2010-12-16
tags: added: udn-dash udt
Changed in ayatana-design:
status: Confirmed → Triaged
importance: Undecided → High
description: updated

Is this work now dropped for the Natty cycle?

Changed in ayatana-design:
status: Triaged → Incomplete
importance: High → Medium
John Lea (johnlea) wrote :

This work has been confirmed as being in scope for the Natty cycle.

Changed in ayatana-design:
importance: Medium → Critical
status: Incomplete → Triaged
David Barth (dbarth) on 2011-02-21
tags: added: needsdesignreview
John Lea (johnlea) on 2011-02-23
description: updated
Changed in ayatana-design:
status: Triaged → Fix Committed
John Lea (johnlea) on 2011-03-04
Changed in ayatana-design:
status: Fix Committed → Fix Released
John Lea (johnlea) wrote :

Tested today, and the new style scroll bars are not currently implemented in the Dash. Reverted to triaged.

summary: - Deliver and implement design for Dash scrollbar
+ Implement new style scrollbars in Dash

amended title for clarity

Mirco Müller (macslow) wrote :

John, I think opening a new bug for this is better and will show up better on the radar. Since the current unity is a rewrite and this bug refers to the old unity, a new bug will make handling the issue in a better way. You can assign me to the new bug again.

Neil J. Patel (njpatel) on 2011-03-11
Changed in unity:
milestone: 2010-08-26 → 3.6.6
status: Fix Released → Triaged
Didier Roche (didrocks) on 2011-03-11
Changed in unity (Ubuntu):
status: New → Triaged
Mirco Müller (macslow) on 2011-03-11
Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) wrote :

I've linked the two new branches relevant for the re-implementation for this to the bug. Next time opening a new bug, instead of reopening this one, would avoid confusion. Since the last unity-version, we switched to a new foundation, which would justify opening a new bug for it... although the visual might have stayed the same.

Didier Roche (didrocks) on 2011-03-16
Changed in unity (Ubuntu):
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Mirco Müller (macslow) on 2011-03-23
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity - 3.6.8-0ubuntu1

---------------
unity (3.6.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - crash at the second drag and drop from an unity place (LP: #736704)
    - Compiz crashes with SIGSEGV in nux::GraphicsDisplay::GrabPointer when
      opening the Dash (LP: #737287)
    - Visual Tearing/Rendering Issues with Unity Launcher (LP: #737476)
    - unity-window-decorator crash on unity panel dragout (LP: #740480)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #694699)
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - the "no result" and "search the web" items need icons (LP: #711199)
    - Resizing with external padding/grab area prevents reaching edge of
      screen (LP: #710356)
    - drag and drop of launcher icons uses microscopic drag icon (LP: #727647)
    - text in places look squeezed (LP: #727799)
    - at-spi-registry consumes most of the CPU and make the system unusable on
      Natty (LP: #729827)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-
      dc++.desktop/type": `+' is an invalid character in key/directory names
      (LP: #737016)
    - Launcher hide state is confusing (LP: #739850)
    - Polish new launcher hide state (part 2) (LP: #740020)
    - launcher icons should expan on super or when entering keynav
      (LP: #741319)
    - Launcher - Dragging a Launcher icon to the Trash should remove the icon
      (LP: #676466)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Dash - Add Dash group header mouseover effect (LP: #689640)
    - unity aborts when you plug in an external monitor (LP: #700757)
    - Keyboard-navigation: focus on launcher remembered (LP: #713340)
    - Launcher Quicklists should always contain the application title
      (LP: #723877)
    - When a maximized window has window on top of it in 'restored state' (not
      maximised) , it is not possible to un-maximized the window by dragging
      the title bar downwards (LP: #723882)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - UI blocked when expanding a section with more than 2000 items
      (LP: #736059)
    - Change ALT-Tab to bring the target window to the front (LP: #736938)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #737814)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - Implement new style scrollbars in Dash (LP: #608124)
    - Closing launcher menu raises window under mouse (LP: #728787)
    - adding url launcher support from the search (LP: #739038)
    - Launcher - Set Launcher 'Hide Animation' to 'Slide only' by default.
      Also introduce subtle fade in effect. (LP: #739567)
    - "Time & Date" settings appears in launcher with empty tooltip
      (LP: #740907)
    - ZeitgeistLog missing implementation of get_property for "connected"
      (LP: #734080)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - The Unity P...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-04-19
tags: removed: udt
John Lea (johnlea) wrote :

@om26er; could you revert this bug to 'confirmed' in Unity, thx

description: updated
Changed in unity:
status: Fix Released → Confirmed
tags: added: onew udo
removed: needsdesignreview
summary: - Implement new style scrollbars in Dash
+ Dash - Implement new style scrollbars in Dash
Omer Akram (om26er) on 2011-09-14
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
importance: Undecided → Low
assignee: nobody → Mirco Müller (macslow)
Omer Akram (om26er) on 2011-09-24
Changed in unity:
milestone: 3.6.8 → backlog
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Low

Closing this bug (marking as "Won't fix") because there have been newer designs, which got implemented.

Changed in unity:
status: Confirmed → Won't Fix
Changed in unity-2d:
status: Confirmed → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Won't Fix
Vistaus (djmusic121) wrote :

But it's really incosistent to not give the Dash overlay scrollbars.

Changed in unity-2d:
status: Invalid → Confirmed
John Lea (johnlea) wrote :

@macslow; I think this is the bug that tracks the implementation of the new style overlay scrollbars in the Dash, so I hope you won't mind me re-opening.

Changed in unity:
status: Won't Fix → Confirmed
John Lea (johnlea) on 2011-10-01
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2011-10-01
Changed in unity (Ubuntu):
importance: Low → Medium
Changed in unity:
status: Confirmed → Triaged
importance: Low → Medium
Changed in unity (Ubuntu):
status: Won't Fix → Triaged
Didier Roche (didrocks) on 2011-10-03
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
importance: Low → Medium
John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
assignee: Otto Greenslade (otto-chaotic) → John Lea (johnlea)
status: Fix Committed → Triaged
tags: added: udp
John Lea (johnlea) on 2011-10-20
Changed in ayatana-design:
status: Triaged → Fix Committed
Andrea Cimitan (cimi) on 2011-12-13
tags: added: unity3p
turbolad (turbolad995) wrote :

Scrollbars in Unity e.g. Dash are too thin AND don't have any "up" and "down" arrows or triangles. These scrollbars could easily be mistaken for vertical lines that don't actually do anything, except add decoration to the background!

Omer Akram (om26er) on 2012-01-10
Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in unity-2d:
status: Confirmed → Triaged

I've updated the bug's title to reflect the change from the initial bug-description, since the old wasn't closed and a new one created. Like mentioned the initial bug was filed against the clutter/mutter-implementation of unity and in between there have been many visual design-changes to the scrollbars, unity ported to a new foundation (compiz/nux) and the design now demands overlay-scrollbars to be also usedin the dash.

Since the dash uses nux, this needs a nux-implementation of overlay-scrollbars. The initial implementation for the rest of the desktop is gtk+-based and can't be used inside the dash.

summary: - Dash - Implement new style scrollbars in Dash
+ Dash - Implement overlay scrollbars in Dash
John Lea (johnlea) on 2012-01-12
Changed in ayatana-design:
importance: Critical → Medium
Andrea Cimitan (cimi) on 2012-02-14
description: updated
Andrea Cimitan (cimi) on 2012-02-17
tags: added: top5p
Andrea Cimitan (cimi) on 2012-02-18
Changed in unity:
milestone: backlog → 5.6.0
John Lea (johnlea) on 2012-02-20
Changed in ayatana-design:
importance: Medium → Critical
Mirco Müller (macslow) on 2012-02-29
Changed in unity:
status: Triaged → In Progress
Mirco Müller (macslow) wrote :

The bug-title no longer reflects the description, which got updated and is lacking any real information, about what to change/fix.. Am I expected to figure out myself what's actually required?

From looking at the 12.04 mockups, I don't know if the scrollbar on the right (of the filters) is really expected to give the user the clue that it'll scroll the results view, which is much farther to the left. Is this really the desired layout?

What's meant with "padding"? Padding what element againt what? Scrollbar against what other elements? 12px gap against left side to the filters?! Flush against the right edge of the dashs decoration?!

A single mockup doesn't show how the scrollbar is expected to move with the content... especially in the edge-cases (being at the top and being at the bottom of the results view).

How far does it go up/down?

Andrea Cimitan (cimi) wrote :

There should be two scrollbars: one for the content and one for the filters (like the current implementation).

The scrollbar for the content is shown here:
https://chinstrap.canonical.com/~sabdfl/11_10/desktop_and_netbook/dash/file/file_lens_17_08_11_02.png
* It shows (thus what needs tweaking):
- the positioning of the scrollbar at top
- its top padding between the search box
- It doesn't seem to add any sort of padding with the filters (in fact, it's an overlay)
- its horizontal position and the margin with the content on left and filters on right
- [ the top padding of the first category (in the current implementation there is more padding between the search box and the first category/scrollbar) ]
- I would say that the scrollbar should be as tall as its scrollable area (scrolled window)

The scrollbar for the fiters is shown here:
https://chinstrap.canonical.com/~sabdfl/12_04/desktop_and_netbook/dash/tweaks_dash.png
* It shows (thus what needs tweaking):
- the horizontal positioning of the scrollbar (touching right edge of the dash)
- It doesn't seem to add any sort of padding with the filters (in fact, it's an overlay)
- I would say that the scrollbar should be as tall as its scrollable area (scrolled window)

Please contact me in IRC If anything of these is not satisfying or you need any more info.

Xi Zhu (xi.zhu) wrote :

There are 2 files showing the position of scrollbar

1. when filters is off

Xi Zhu (xi.zhu) wrote :

2. when filters is on

Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Mirco Müller (macslow) on 2012-03-15
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-03-17
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.4 KiB)

This bug was fixed in the package unity - 5.8.0-0ubuntu1

---------------
unity (5.8.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - New "push mouse offscreen" feature really difficult to get (LP: #923749)
    - unity-2d-panel crashed with SIGSEGV in
      unity::indicator::DBusIndicators::Impl::RequestSyncAll() (LP: #864737)
    - Pressing "Alt+Enter" causes compiz to crash in CompOption::value() from
      unity::UnityScreen::showLauncherKeyTerminate (LP: #960957)
    - SEGSIGV after unplugging external monitor (LP: #962693)
    - Background colorization should use a different heuristic (LP: #865239)
    - compiz+unity3d generates > 50 wakeups a second on idle system
      (LP: #917210)
    - [FFe, UIFe] HUD - The HUD does not respect launcher autohide or icon
      size settings (LP: #921506)
    - clicking on folders in the file lens does not open nautilus
      (LP: #921665)
    - No text inside multirange filters (LP: #927710)
    - can't alt-tab restore minimized uis which have an instance on another
      workspace (LP: #933397)
    - Ubuntu Software Center Unity launcher integration is not working
      (LP: #932280)
    - The line separator between the launcher and the dash is cleared when
      selecting a category (LP: #941082)
    - unity-panel-service crashed with SIGSEGV in g_hash_table_foreach()
      (LP: #937119)
    - Alt-F10 locks up Unity (LP: #948522)
    - multimonitor, launcher: Provide an option to display either a single
      launcher or a launcher on each display in a multi-monitor environment
      (LP: #950136)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - Unity 5.6: key bindings (such as Super) don't work on empty workspace or
      on slow/loaded systems (LP: #953089)
    - Alt+arrows keyboard shortcuts don't invoke Back and Forward navigation
      (LP: #953783)
    - HUD is sending 2 menu signals instead of 1 (LP: #956878)
    - 6th item of HUD not fully visible (LP: #957229)
    - HUD: seems to trigger operations more than once (LP: #960503)
    - Launcher gets always desaturated when using HUD on secondary monitor
      (LP: #961169)
    - [5.8 pre staging] launcher is displayed on the left screen, not the
      primary one (LP: #961281)
    - launcher icons do not re-saturate after dash is closed (LP: #961844)
    - Launcher shows arrows for applications on all workspaces (LP: #961977)
    - Dash - Implement overlay scrollbars in Dash (LP: #608124)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Dash - "See more..." line should be base-aligned with section header
      (LP: #748101)
    - Dash - Missing category separator line in dash (LP: #850984)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - When multiple results have equal string match relevancy ranking,
      those with equal ranking should be then sorted by frequency of use.
      (LP: #871900)
    - Keyboard shortcut - F10 shortcut is used to show m...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

Where are the overlay scrollbars? I'm running Unity 5.8 and I still get just the thin little lines for scrollbars that are hard to grab; no handles or anything.

This bug is not fixed

cicoandcico (cicoandcico) wrote :

same here. not fixed for me.

affects: unity → null
Changed in null:
milestone: 5.8.0 → none
Changed in unity:
status: New → Confirmed
summary: - Dash - Implement overlay scrollbars in Dash
+ Dash - Implement *overlay scrollbars* in Dash
John Lea (johnlea) on 2012-04-24
Changed in null:
assignee: Mirco Müller (macslow) → nobody
Changed in unity (Ubuntu):
assignee: Mirco Müller (macslow) → nobody
Didier Roche (didrocks) on 2012-04-24
Changed in unity (Ubuntu):
status: Fix Released → Triaged
John Lea (johnlea) on 2012-04-24
Changed in unity:
milestone: none → backlog
Andrea Cimitan (cimi) on 2012-05-02
tags: added: euv

John, shall we open a new bug only for overlay scrollbars?

tags: removed: euv
Andrea Cimitan (cimi) wrote :

Otherwise this bug is fixed

Van Long (pcvl441-a) wrote :

Click and drag inside the dash helped me scroll it pretty easily. However, overlay scrollbar for dash should be good, too. I'm using Unity2D.

Shane Sanders (jssanders75) wrote :

Works great! The visual cue is what is important.

The light-grey blends with theme.

Good job. Bug fixed!

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
John Lea (johnlea) on 2012-09-14
Changed in unity:
status: Confirmed → Triaged
tags: added: dashm
John Lea (johnlea) on 2012-09-14
description: updated
Changed in unity (Ubuntu):
importance: Medium → High
no longer affects: unity-2d (Ubuntu)
Changed in unity:
importance: Undecided → High
milestone: none → backlog
description: updated
Omer Akram (om26er) on 2012-09-14
Changed in unity-2d:
status: Triaged → Won't Fix
Changed in unity-2d (Ubuntu):
status: New → Won't Fix
John Lea (johnlea) on 2012-09-17
no longer affects: unity-2d (Ubuntu)
Omer Akram (om26er) on 2012-09-17
no longer affects: unity-2d
summary: - Dash - Implement *overlay scrollbars* in Dash
+ Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars are
+ too thin to grab on to.
John Lea (johnlea) on 2012-10-10
Changed in unity:
importance: High → Critical
Changed in unity (Ubuntu):
importance: High → Critical
Omer Akram (om26er) on 2012-10-15
Changed in unity:
importance: Critical → High
Changed in unity (Ubuntu):
importance: Critical → High
John Lea (johnlea) wrote :

@om26er; could we move the importance of this bug back up to critical, it is very very difficult for users to scroll the Dash by clicking and dragging the scrollbar, and this presents a critical problem for users without mouse scroll wheels, or without trackpads that support multi-touch gestures.

Omer Akram (om26er) wrote :

ok, sure ;-)

Changed in unity:
importance: High → Critical
Changed in unity (Ubuntu):
importance: High → Critical

Thanks for considering this critical! I couldn't agree more:
https://bugs.launchpad.net/bugs/1061807

How can I delete a comment?

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in unity:
status: Triaged → In Progress

Some general philosophy towards increasing scroll-bar widths in modern applications:
https://bugs.launchpad.net/bugs/1077559

Changed in unity:
importance: Critical → High
Omer Akram (om26er) on 2012-11-22
Changed in unity (Ubuntu):
importance: Critical → High
Changed in nux (Ubuntu):
importance: Undecided → High
Changed in nux:
importance: Undecided → High
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux (Ubuntu):
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux:
status: New → Fix Committed
Changed in nux (Ubuntu):
status: New → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → In Progress
Changed in unity:
milestone: backlog → 7.0.0
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed

When will we likely see this rolled out in an official Ubuntu Recommend Update to 12.04 and 12.10 (at least)?

Omer Akram (om26er) wrote :

the answer to that is probably never, new features are not allowed for SRU and this change is not simple.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily12.12.05-0ubuntu1

---------------
unity (6.12.0daily12.12.05-0ubuntu1) raring; urgency=low

  [ Michael Terry ]
  * debian/control:
    - Update Vcs-Bzr
  * Automatic snapshot from revision 2905 (bootstrap)
    - Hide launcher tooltip once shortcut overlay appears (LP: #1035860)
    - Update shortcut overlay design (LP: #1049601)
    - Don't cut off shadow on launcher icon drag window (LP: #765715)
    - Provide more immediate feedback when clickong on launcher (LP: #893140)
    - Decorate spread windows in switcher (LP: #838222)
    - Make sure to initialize a variable before it can be used (LP: #1073516)
    - Fix FTBFS due to BAMF API change (LP: #1077937)
    - Run gtest during build (LP: #133637)
    - Make shopping lens test more robust (LP: #1077131)
    - Fix some random autopilot test failures (LP: #1078448)
    - Fix autopilot tests for details mode (LP: #1073892)
    - Fix autopilot tests for indicator-session (LP: #1075350)
    - Fix autopilot tests for non-English locales (LP: #1075898)

  [ Didier Roche ]
  * debian/control:
    - adding libgtest-dev and google-mock build-dep now that there are in main
      (LP: #1076763)
    - add libunity-core -> unity-common dep (LP: #1079132)
    - do not have unity-common dep on compiz-gnome: the migration code is only
      ran if compiz-gnome is installed, but compiz-gnome is pulled by compiz
      directly. We don't care if the migration code isn't executed.

  [ bschaefer ]
  * Ported to nux 4.0

  [ Ricardo Salveti de Araujo ]
  * Doesn't need to depend on gcc 4.6 anymore (LP: #1044836)

  [ Nick Dedekind ]
  * Previews loading more than 454 lines of description text crash Unity
    (LP: #1066788)

  [ Brandon Schaefer ]
  * unity::TimeUtil::TimeDelta returns an int value which overflows
    after 24 days of uptime (LP: #806248)
  * Top panel "tooltip" is gone (regression) (LP: #1085045)
  * Dash - Implement *overlay scrollbars* in Dash. Existing scrollbars
    are too thin to grab on to. (LP: #608124)

  [ Andrea Azzarone ]
  * Dash - Regression: Clicking between filter label and 'All' button no
    longer toggles filter label (LP: #1080534)

  [ Didier Roche ]
  * libunity-core fails without the schemas from unity-common (LP:
    #1079132)

  [ Manuel de la Pena ]
  * There is no common ui element that behaves like a url link (LP:
    #1067705)

  [ Automatic PS uploader ]
  * Automatic snapshot from revision 2956
 -- Automatic PS uploader <email address hidden> Wed, 05 Dec 2012 09:27:29 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-12-11
Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux:
milestone: none → 4.0
status: Fix Released → Fix Committed
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma) wrote :

Fix Released in Nux Nux 4.0.0.

Changed in nux:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints