Left-clicking on taskbar icon for transmission brings up the right-click menu

Reported by jerkface on 2010-02-19
106
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Undecided
Unassigned
Transmission
Invalid
Undecided
Unassigned
transmission (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: transmission

1) 10.04 Alpha

2) Transmission 1.90 (10221)

3) Left-clicking the taskbar icon should show the application if it is minimized to the taskbar. If it isn't minimized, left-clicking it should minimize the application to the taskbar when the application window has focus, and should bring the application window to the front and give it focus if it doesn't have focus.

4) The right-click menu is displayed when the icon is left-clicked.

summary: - Left-click on taskbar icon brings up right-click menu
+ Left-clicking on taskbar icon for transmission brings up the right-click
+ menu
Krzysztof Klimonda (kklimonda) wrote :

Thank you for the bug report but the new behaviour of the icon is not a bug.
The new indicator application applet that Transmission and other applications are being ported to doesn't support (by design) right click. You can read more at https://wiki.ubuntu.com/DesktopExperienceTeam/ApplicationIndicators about what has driven developers to this decision.

I'm marking the bug as a Won't Fix, you should voice your concerns to the Canonical DX Team either by using IRC (#<email address hidden>) or by subscribing to the Ayatana Mailing List (though https://edge.launchpad.net/~ayatana).

Changed in transmission (Ubuntu):
status: New → Won't Fix

Wow, that's retarded. I doubt anyone will want to read that much just to find out how to click on an icon properly. I sure didn't read that.

Krzysztof Klimonda (kklimonda) wrote :

I've linked you this specification so you can read it if you are interested why has it been changed. I'd say that as there is only one way to click now people won't get confused.

> people won't get confused.

People already ARE and will be. Terrible decision... This application indicator thing really sucks.

ttp (human-ttp) wrote :

Please, restore the previous behaviour of left click! This is BUG.

Changed in transmission (Ubuntu):
status: Won't Fix → New
ttp (human-ttp) wrote :

This is totally unacceptable behaviour!

Chris Coulson (chrisccoulson) wrote :

This is not a bug and it won't be reverted. I don't see how having a group of icons which all behave in a predictable and consistent manner is more confusing than the previous notification area where every icon had a different response to left/right mouse clicks

Changed in transmission (Ubuntu):
status: New → Won't Fix

Do you use this application every day? So don't tell me what behaviour is
better.

ttp (human-ttp) wrote :

So tell me how can I restore the main window in one click? How it could be done using your new "feature"?

Changed in transmission (Ubuntu):
status: Won't Fix → New
Krzysztof Klimonda (kklimonda) wrote :

Please, bug reports are not really a place to discuss those changes (I'm talking about both bug and bug 525875). This change has been designed by the DX team and they are the right people to discuss it with (by using the Ayatana mailing list). Reopening bugs won't help.

Changed in transmission (Ubuntu):
status: New → Won't Fix
Chris Coulson (chrisccoulson) wrote :

Problem solved

affects: transmission (Ubuntu) → ubuntu
ttp (human-ttp) wrote :

"Resolving" such issues in this way is the best way to make "the best
release" ever.
I already made such bug for them
https://bugs.launchpad.net/indicator-application/+bug/549910

Jean-Paul (jeanpaul145) wrote :

@Chris: 1 consistent way for all icons in the tray I can understand. But what perhaps you don't realize is that the changed behavior isn't Gnome-specific - it propagates through to other DE's, like KDE. There it suddenly becomes the only tray icon behaving that disruptive, since in KDE the normal behavior is: left-click brings up the "main window" and right click gives you a context menu of options (if I remember correctly this is also the old behavior on Gnome).
So like I said in my original (duplicate) report: it's fine with me if they want to fix all of it for Gnome, but they should keep it gnome-specific then to avoid this kind of disruptiveness on other DE's which they don't experiment on.

Jean-Paul (jeanpaul145) wrote :

Btw there's something else (in KDE anyway): after having to right-click and select "show transmission" with the left mouse button, while the window is created, it *isn't* focused on or even brought to the front. Is that also desirable behavior? Because if it isn't, I'd call that a bug.

Kangarooo Jānis (kangarooo) wrote :

Krzysztof Klimonda where in document is written that theres needed for all programms to change theyr right click to left click?
Couse it looks the programms need to change that couse in Xubuntu i can confirm only For Transmission im having right click menu in left click but left click nowhere..

Kangarooo Jānis (kangarooo) wrote :

@Chris Coulson
problem isnt in Ubuntu problem is in programm
Im using Xubuntu - look screenshot
problem exists in program and not in Ubuntu

wcGary83 (gary8316pa) wrote :

I honestly agree that this is a problem, I can't understand for the life of me why the application indicators would be set up this way! I really thought there was a bug when I first came across it... It is absolutely counter-intuitive, I would hope there would at least be an option to configure it the old way for the people like me who it drives nuts!

Charles Kerr (charlesk) wrote :

FWIW I'm getting bug reports on this upstream, too:

 * https://trac.transmissionbt.com/ticket/3537

 * https://trac.transmissionbt.com/ticket/3573

Mike.lifeguard (mikelifeguard) wrote :

Can the application indicator be uninstalled to restore the proper interface?

Kip Warner (kip) wrote :

I've uninstalled it and it still has the same behaviour. It's done at the source level, so the package would have to be reconfigured and rebuilt.

Charles Kerr (charlesk) wrote :

Correct. Ubuntu provided a patch upstream to Transmission to use Application Indicator instead of GtkStatusIcon in Transmission iff the former is present at compile time.

Mike.lifeguard (mikelifeguard) wrote :

Surely then, there can be an option to use GtkStatusIcon even if Application Indicator is present, no?

Charles Kerr (charlesk) wrote :

You're missing my point. Things are behaving exactly as intended by Ubuntu. Asking for upstream for a workaround is addressing a symptom rather than the cause.

Mike.lifeguard (mikelifeguard) wrote :

I'm well aware that the Ayatana team is the cause of the bug (or are they the bug itself?). I just want sensible interface design.

Kip Warner (kip) wrote :

I'm with Mike on this one. I agree that trying to find a sensible way to unify interaction with notification area icons is a great idea, but just not the way it's being done.

Charles Kerr (charlesk) wrote :

Marking as invalid for "Transmission" because this only affects Transmission on Ubuntu, not the upstream behavior. This behavior is broken by design in Ubuntu.

Changed in transmission:
status: New → Invalid
Oli (oli) wrote :

I can't believe some of these comments.

Every other application that has both Notification-Area and Indicator-Applet icons (Banshee, Liferea, Gwibber, Pidgin, etc) still support left/right clicking.

Left click should toggle visibility. Right click should show the menu.

If you want to give it Indicator-Applet behaviour, give it its own Indicator Applet but failover to Notification-Area (like all the other good apps do) so people who don't need or want Indicator-Applet confusing and breaking their tray experience don't have to go without an icon.

Changed in transmission:
status: Invalid → Confirmed

This is confirmed by many users that this is true.
Thats it.
If still thinking otherwise heres Summary of info and more info
SUMMARY- Ayatana team`s idea is no reason for changing programms to
behave different for thouse who doesnt use Ayatanas team`s programm.

"Thats not how menu should pop up. Theres no reason for program to be
different then others in showing menu.
Ayatana teams idea wasnt even known uderstandable by themselfs and
what their idea causes. Their idea is one programm that acts by
collecting all programms in one applet. Then if its needed to make
their idea (just one programm) to work then they need this akward
reprogramming of all programms to show menu different.
I adresed this problem until they understood and they understand that
theres users who wont use their programm.
So they needed to find another way so they started discusing about
making theyr programm to do menu click switching only in their
programm limits.."

ttp (human-ttp) wrote :

This is not problem of transmission, this is problem of ubuntu, because ubuntu uses special patched version of transmission, as it used special patched version of rhythmbox before. Default gnome packages do not have such behavior.

Charles Kerr (charlesk) wrote :

Kangarooo, ttp is exactly correct. Reopening the Transmission component doesn't make sense because the issue is not coming from upstream. If you feel that Ubuntu's decision should be revisited -- which I would sympathize with -- you need to raise this issue with the Ubuntu decisionmakers.

Changed in transmission:
status: Confirmed → Invalid
ttp (human-ttp) wrote :

But could you please make the "correct" version of transmission package for ubuntu and add it to download block on transmission site in any other place? A lot of people will be very grateful.

ttp (human-ttp) wrote :

I have built the .deb package using this instructions http://ubuntuforums.org/showthread.php?t=51003 and this sources http://download.transmissionbt.com/files/transmission-2.10.tar.bz2
This is not so hard as I think before. Now everything works as expected.
The result deb package in attachment.

Kangarooo Jānis (kangarooo) wrote :

Upstream all is ok.. Now i understood how to make for Ubuntu Package

affects: ubuntu → transmission (Ubuntu)
Mike.lifeguard (mikelifeguard) wrote :

Sorry, that package seems to have some errors:

mike@arbour:~/Downloads$ sudo dpkg -i transmission_2.10-0ubuntu1_i386.deb
[sudo] password for mike:
(Reading database ... 265162 files and directories currently installed.)
Unpacking transmission (from transmission_2.10-0ubuntu1_i386.deb) ...
dpkg: error processing transmission_2.10-0ubuntu1_i386.deb (--install):
 trying to overwrite '/usr/share/icons/hicolor/16x16/apps/transmission.png', which is also in package transmission-gtk 2.04-0ubuntu2
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Processing triggers for man-db ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
 transmission_2.10-0ubuntu1_i386.deb

As well, it'd be much nicer to have this in a PPA.

ttp (human-ttp) wrote :

I have removed the original package before installing this package.

Krzysztof Klimonda (kklimonda) wrote :

Please, don't use the bug report for discussion about a third-party packaging. All mails are sent to various people and this particular issue has been discussed to death.

Mike.lifeguard (mikelifeguard) wrote :

Indeed it has - as far as I can tell, consensus is that the bug is with the Ayatana team's design, not Transmission. I've added the team as the affected component.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.