Software-center reports a progamming error in aptdaemon but without any details

Bug #665218 reported by Nolan Cmerek on 2010-10-22
This bug affects 317 people
Affects Status Importance Assigned to Milestone
Aptdaemon
Critical
Fritz Haria
aptdaemon (Ubuntu)
High
Sebastian Heinlein
Maverick
Undecided
Unassigned
Natty
High
Sebastian Heinlein

Bug Description

If software is installed using Ubuntu's Software Center an error dialog occurs with the following wording:

"An unhandlable error occured

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks. Please report this error at http://launchpad.net/aptdaemon/+filebug and retry."

Normally there is a "Details" expander in the dialog, but this isn't the case here. It is missing.

Please don't comment on this bug if you see details in the error dialog.

Nolan Cmerek (ncmerek) on 2010-10-22
description: updated
summary: - Unhandlable error in aptdaemon
+ Software-center reports a progamming error in aptdaemon but without any
+ details
Changed in aptdaemon:
status: New → Confirmed
importance: Undecided → High
importance: High → Critical

how do you fix it

f_padia (f-padia) wrote :

Same problem here

I also have this same issue when trying to install firmware-b43-lpphy-installer.

Jaap Rosema (j-rosema) wrote :

Tried to install Opera 10.6
Bug in Desktop-version 10.10 as well in Netbook-version 10.10

Paolo Zanetti (valconi) wrote :

I've this problem installing Canon MP540 driver (cnijfilter-common_3.00-1_i386.deb)

midday (midday) wrote :

Here https://bugs.launchpad.net/aptdaemon/+bug/688517
error accrures if execute gui app from postinst script in deb (by aptdaemon) but
 with dpkg -i all OK

FredW (fweaver2008) wrote :

Same error but running "Update Manager".
The Details from error are:
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 179, in _process_transaction
    self.commit_packages(*self.trans.packages)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 227, in commit_packages
    self._commit_changes()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 738, in _commit_changes
    self._cache.commit(fetch_progress, inst_progress)
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 427, in commit
    res = self.install_archives(pm, install_progress)
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 394, in install_archives
    install_progress.finish_update()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/progress.py", line 264, in finish_update
    lock.status_lock.acquire()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/lock.py", line 66, in acquire
    raise LockFailedError(self.path, process)
LockFailedError

Zabadda (zabadda) wrote :

I also can't install anything from the software centre as this same error happens

There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 938, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the ttf-mscorefonts-installer package. This might mean you need to manually fix this package.

Zabadda (zabadda) wrote :

I just installed this http://www.getdeb.net/updates/Ubuntu/10.10/?q=Handbrake and it failed but whatever it installed then fixed my software centre problem

what can we do?

Or Ramot (oramot) wrote :

Zabadda. you got it right for me. worked exactly as you wrote.
Thanks

Jonathan Riddell (jr) wrote :

aptdaemon in maverick-proposed Unapproved queue, awaiting ubuntu-sru approval

Martin Pitt (pitti) wrote :

Please fix this in natty first, so that this SRU can progress to -updates at some point.

Changed in software-center (Ubuntu):
assignee: nobody → Sebastian Heinlein (glatzor)
status: New → In Progress
affects: software-center (Ubuntu) → aptdaemon (Ubuntu)
Changed in aptdaemon (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed

Accepted aptdaemon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

brayer benoit (murf-live) wrote :

Same bug :
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 179, in _process_transaction
    self.commit_packages(*self.trans.packages)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 227, in commit_packages
    self._commit_changes()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 738, in _commit_changes
    self._cache.commit(fetch_progress, inst_progress)
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 427, in commit
    res = self.install_archives(pm, install_progress)
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98, in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 394, in install_archives
    install_progress.finish_update()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/progress.py", line 264, in finish_update
    lock.status_lock.acquire()
  File "/usr/lib/python2.6/dist-packages/aptdaemon/lock.py", line 66, in acquire
    raise LockFailedError(self.path, process)
LockFailedError

Changed in aptdaemon:
status: Confirmed → Fix Released
Changed in aptdaemon:
assignee: nobody → Sebastian Heinlein (glatzor)
status: Fix Released → In Progress

I had this problem trying to install usermin, I have webmin installed but need usermin.
There seems to be a programming error in aptdaemon, the software that allows you to install/remove software and to perform other package management related tasks.

Thanks for helping me.... I'll try it.
Roberto

2011/2/12 Michael Smith <email address hidden>

> I had this problem trying to install usermin, I have webmin installed but
> need usermin.
> There seems to be a programming error in aptdaemon, the software that
> allows you to install/remove software and to perform other package
> management related tasks.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (695183).
> https://bugs.launchpad.net/bugs/665218
>
> Title:
> Software-center reports a progamming error in aptdaemon but without
> any details
>
> Status in Aptdaemon:
> In Progress
> Status in “aptdaemon” package in Ubuntu:
> In Progress
> Status in “aptdaemon” source package in Maverick:
> Fix Committed
> Status in “aptdaemon” source package in Natty:
> In Progress
>
> Bug description:
> An unhandlable error occured
>
> There seems to be a programming error in aptdaemon, the software that
> allows you to install/remove software and to perform other package
> management related tasks. Please report this error at
> http://launchpad.net/aptdaemon/+filebug and retry.
>
> I have installed this package on other Ubuntu 10.04 machine and it
> works fine, just not in 10.10.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/665218/+subscribe
>

Changed in aptdaemon:
status: In Progress → New
Marc Deslauriers (mdeslaur) wrote :

An aptdaemon security update was released that does not include the fixes from this package in -proposed. A new package needs to be built for -proposed.

NeonMaximillian (neon-account) wrote :

This happens after I accidentally turn off my pc while the system is installing some new packages...

Accepted aptdaemon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Michael Vogt (mvo) on 2011-03-08
Changed in aptdaemon (Ubuntu Maverick):
status: Fix Committed → Triaged
T@x122 (igualadarafael) wrote :

help i hace ubuntu 10.10

Changed in aptdaemon:
status: New → Incomplete

Hi there! I had the same problem. You might find these helpful:
* This bug is closely related to bug #693138
* I tried to install qmmp from the Ubuntu software center, and the installation died, nothing responded => ACPI reset
* After reset, I couldn't install anything from the software center (I was logged in with the same user account under which the install died)
* As root, the installation worked with no problem
* After installing something with root, the software center worked again under my normal user account

Hope this helps

I got this resolved within a day or two following some tips from the
community support. I ve moved up n this no longer bothers me.

On Sat, Apr 9, 2011 at 4:39 AM, T@x122 <email address hidden> wrote:

> help i hace ubuntu 10.10
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (668362).
> https://bugs.launchpad.net/bugs/665218
>
> Title:
> Software-center reports a progamming error in aptdaemon but without
> any details
>
> Status in Aptdaemon:
> New
> Status in “aptdaemon” package in Ubuntu:
> In Progress
> Status in “aptdaemon” source package in Maverick:
> Triaged
> Status in “aptdaemon” source package in Natty:
> In Progress
>
> Bug description:
> An unhandlable error occured
>
> There seems to be a programming error in aptdaemon, the software that
> allows you to install/remove software and to perform other package
> management related tasks. Please report this error at
> http://launchpad.net/aptdaemon/+filebug and retry.
>
> I have installed this package on other Ubuntu 10.04 machine and it
> works fine, just not in 10.10.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/665218/+subscribe
>

--
Sunil

NeonMaximillian (neon-account) wrote :

Thanks, this was late but it also helps me. :)

On Sun, Apr 17, 2011 at 1:43 AM, Zoltan Makranczi <<email address hidden>
> wrote:

> Hi there! I had the same problem. You might find these helpful:
> * This bug is closely related to bug #693138
> * I tried to install qmmp from the Ubuntu software center, and the
> installation died, nothing responded => ACPI reset
> * After reset, I couldn't install anything from the software center (I was
> logged in with the same user account under which the install died)
> * As root, the installation worked with no problem
> * After installing something with root, the software center worked again
> under my normal user account
>
> Hope this helps
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/665218
>
> Title:
> Software-center reports a progamming error in aptdaemon but without
> any details
>
> Status in Aptdaemon:
> Incomplete
> Status in “aptdaemon” package in Ubuntu:
> In Progress
> Status in “aptdaemon” source package in Maverick:
> Triaged
> Status in “aptdaemon” source package in Natty:
> In Progress
>
> Bug description:
> An unhandlable error occured
>
> There seems to be a programming error in aptdaemon, the software that
> allows you to install/remove software and to perform other package
> management related tasks. Please report this error at
> http://launchpad.net/aptdaemon/+filebug and retry.
>
> I have installed this package on other Ubuntu 10.04 machine and it
> works fine, just not in 10.10.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/aptdaemon/+bug/665218/+subscribe
>

Kate Stewart (kate.stewart) wrote :

Why no prioirity on the bug? Marking the prioritiy as high, based on the number of duplicats reporting this.

Changed in aptdaemon (Ubuntu Natty):
importance: Undecided → High
Robbie Williamson (robbiew) wrote :

Targeting this to Natty-updates, as it won't make the release. Probably a good idea to file it under Oneiric too...I don't have the right authority in the aptdaemon project, to do so.

Changed in aptdaemon (Ubuntu Natty):
milestone: none → natty-updates
Stéphane Graber (stgraber) wrote :

I couldn't reproduce the issue using qmmp on Natty.
During the install I could see some debconf window popping up (usually for < 1s, then disappearing) . Package installed fine and APT seemed in perfect state after install.

I'll try to find another package that'd get APT into an inconsistent state, then see how Software-Center/aptdaemon deals with that.

Stéphane Graber (stgraber) wrote :

I just tried with a package that can't be installed on a regular Ubuntu system (ltsp-client-core). The installation process showed the debconf critical message from ltsp-client-core telling the user it can't be installed on an non-LTSP. The install then fails but APT is still in a consistent state (with ltsp-client-core getting removed) after that.

I'll try something else that fails even more than ltsp-client-core and try the suggested "start GUI from preinst/postinst" to see how aptdaemon deals with that.

Josef (alphonce) wrote :

Installed Maverick (amd64) from scratch and upgraded right away to natty without updating the maverick system first.
Installed dropbox and skype from program-central and got this. Both got installed correctly anyway.

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 212, in _process_transaction
    self.install_file(trans, **trans.kwargs)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/worker.py", line 543, in install_file
    res = deb.install(deb_progress)
  File "/usr/lib/python2.7/dist-packages/apt/debfile.py", line 583, in install
    install_progress.finish_update()
  File "/usr/lib/python2.7/dist-packages/aptdaemon/progress.py", line 266, in finish_update
    lock.wait_for_lock(trans, lock.status_lock)
NameError: global name 'trans' is not defined

Stéphane Graber (stgraber) wrote :

Josef: This issue has been fixed with this morning's upload. Can you make sure you have python-aptdaemon at version 0.41+bzr646-0ubuntu2 ?

Also, please note that we don't really support direct upgrading to Natty from Maverick without first updating Maverick.
Some updates in maverick-updates might be required to have a working upgrade to natty.

midday (midday) wrote :

I told ! If postinst script have a commands with any gui ( ex. xterm, gedit =) ) this bug was appeared. But now gui command just ignoring. Its sad

Sebastian Heinlein (glatzor) wrote :

Could you please explain in more details, midday? What should I do to reproduce the bug?

description: updated
Yhehsyls (yhehsyls) wrote :

Tried to install Skype, and got this message. Posted it on Ubuntu Forums...

dileep (dileepnrm) on 2011-05-22
Changed in aptdaemon:
status: Incomplete → Fix Committed
HX_unbanned (linards-liepins) wrote :

Setting "In Progress" due comment #33.

Changed in aptdaemon:
status: Fix Committed → In Progress
Sarah R. (majo-sarah) wrote :

How do I fix it??? This is getting really annoying, and I need the app ASAP.

Changed in aptdaemon:
status: In Progress → Fix Committed
Sarah R. (majo-sarah) wrote :

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 768, in simulate
    return self._simulate_helper(trans, status_path)
  File "/usr/lib/python2.6/dist-packages/aptdaemon/worker.py", line 938, in _simulate_helper
    return depends, status, self._cache.required_download, \
  File "/usr/lib/python2.6/dist-packages/apt/cache.py", line 218, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate file for the libcddb2 package. This might mean you need to manually fix this package.

I don't get it.....

Tanvir (shourve-gmail) wrote :

Trying to install alsa-driver-linuxant_1.0.23.1_all.deb

Changed in aptdaemon:
status: Fix Committed → Fix Released
Earl Voeller (voellere) wrote :

I have had this happen in 11.10. I have installed 11.10 3 times to test why I think that this is happening. Here is what I found.
Running sudo apt-get update seems to be what is causing this to happen.

Fritz Haria (jdu-19) on 2011-12-16
Changed in aptdaemon:
assignee: Sebastian Heinlein (glatzor) → Fritz Haria (jdu-19)
Sebastian Heinlein (glatzor) wrote :

Since we haven't seen this bug for nearly a year. I close it.

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
Changed in aptdaemon (Ubuntu Natty):
status: In Progress → Won't Fix
Changed in aptdaemon (Ubuntu Maverick):
status: Triaged → Won't Fix
Greg Doyle (tehwabb1t) wrote :

Had this pop up a few times and then suddenly after an update it was sorted. :)

To post a comment you must log in.