can not select SD card to write image to

Bug #1118217 reported by deepak on 2013-02-07
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Image Writer
High
Tobin Davis

Bug Description

i am on Windows XP sp3, tried both 0.6 and 0.7 versions. When i run the program, i can select image file but can not select SD card. In fact in drop down of Device nothing is displayed. When clicked on drop down of Device, when clicked(to select) nothing is displayed and its color changes from white to blue.

deepak (deepak9856) wrote :
raju (rajutech76) wrote :

raju
i am also facing same issue

Tobin Davis (gruemaster) wrote :

Can either of you include info on what system you are running on? Need make/model to get the specs to see if I can determine why this is happening.

I have a feeling it is one of those built-in SD card readers that uses a proprietary interface (most use the USB bus). In the mean time I will look for a simple utility that will scan and list your drive types. This would be very useful to have for debugging.

Changed in win32-image-writer:
status: New → Incomplete
deepak (deepak9856) wrote :

My system is IBM Thinkpad R61, type: 7735-AB5, windows xp professional sp3.
This link may be useful http://support.lenovo.com/en_IN/detail.page?LegacyDocID=migr-67735
Thanks.

Tobin Davis (gruemaster) on 2013-02-15
Changed in win32-image-writer:
status: Incomplete → Triaged
Tobin Davis (gruemaster) wrote :

Does that system even have a built-in SD card reader? None listed in the specs you linked to.

deepak (deepak9856) wrote :

There is a built-in SD Card reader for sure. I was using that when i tried to write a image with image writer.

There is mention of following in services and trouble shooting guide:
Digital media reader
v 4-in-1 digital media reader slot (on some models)

Thanks

Tobin Davis (gruemaster) wrote :

Ugh. Thought so. I found the driver for the SD Card you listed. It appears to be a PCI device.

There is a program at http://smithii.com/dskwipe that you can download that will generate a list of drives. Read the documentation on the site, but I believe you only need to open a cmd window and run "dskwipe -l" to get a listing. If you could attach that here, it would be most helpful.

If I get time, I'll take that program and remove the potentially dangerous stuff, or just add a -d option to our tool to generate a debug log (I personally like this idea best - but it will take more time).

JohnO (johnmo) wrote :

Hi Tobin,

I have the same issue as the original poster.

Dell Latitude E6410
Windows XP SP3

SD Card Reader appears under two different enteries in device manager

Smart card readers
USB\VID_0A5C&PID_5800&MI_01\7&66DE6C9&0&0001

Secure Digital host controllers (SDA Standard Compliant SD Host Controller Vendor)
PCI\VEN_1180&DEV_E822&SUBSYS_040A1028&REV_03\4&DBAB9B0&0&00E2

I downloaded dskwipe and ran the command you suggested.

DskWipe - l output :

\\.\PhysicalDrive0 160 GB Fixed
\\.\PhysicalDrive1 2.0 GB Removable
\Device\Harddisk0\Partition0 160 GB Fixed
\Device\Harddisk0\Partition1 73.2 GB Fixed NTFS
\Device\Harddisk0\Partition2 524 MB Fixed Linux
\Device\Harddisk0\Partition3 64.4 GB Fixed NTFS
\Device\Harddisk0\Partition4 20.9 GB Fixed Linux
\Device\Harddisk0\Partition5 954 MB Fixed Linux Swap
\\.\C: 73.2 GB Fixed NTFS
\\.\D: 2.1 GB Fixed FAT32
\\.\E: 64.4 GB Fixed NTFS
\\.\F: 2.0 GB Removable

I had a micro SD to SD adapter containing a 2GB micro SanDisk SD card in the card reader when I ran the command.

If you would like some additional information please ask.

Thank you.

Regards,

John.

Tobin Davis (gruemaster) wrote :

Thanks for the info. The fact that it lists your SD card as removable, yet Win32ImageWriter won't detect it is very puzzling.

I'll look into writing up a short test program in the next few weeks. We really need to get to the bottom of this.

Changed in win32-image-writer:
importance: Undecided → Medium
Henry Sonntag (hesn) wrote :

I have the same problem with a Dell inspiron E1505 running Win XP SP 3.

hesn

Malcolm (mal4606) wrote :

I had the same problem with my Dell Inspiron 1525 with the SD slot. I tried a USB to Micro SD adapter and the drive populated just fine. Hope this helps those with a mini SD.

Tobin Davis (gruemaster) on 2013-05-09
Changed in win32-image-writer:
assignee: nobody → Tobin Davis (gruemaster)
nemobob (nemo-k) wrote :

I have a Thinkpad R61 with the same issue.

PCI-Bus 21, Device 0, Function 2
PCI\VEN_1180&DEV_0822&SUBSYS_20C817AA&REV_21\4&3B3A03B5&0&02F0

dskwipe -l shows it as
\\.\E: 4.0 GB Removable

Beach Boy (beach.boy) wrote :

Same problem with Dell M90 running XP.

Bill Wallace (unclebillvt) wrote :

I was unable to use through the built-in SD card reader. It worked fine when I used an older plug-in USB based multireader that I had. I'm running Windows Vista Business on a Lenovo T500. Under device manager if found:
IDE ATA/ATAPI Controller
   Ricoh SD/MMC Host Controller

SD Host Adapters
   SDA Standard Compliant SD Host Controller
      PCI BUs 21, Device 0, Function 2

You need a USB connected reader for this to work.

Tobin Davis (gruemaster) wrote :

This may be what I need to make it work. Will look over the code and see. Thanks for this info, it is probably the most helpful to date (any/all information is helpful).

Tobin Davis (gruemaster) wrote :

At long last, I "may" be finally able to reproduce this bug. I am getting a loaner laptop that meets all but the OS specs listed above, so will need to dust off my XP install cd and get my hands dirty this weekend. I will put my best effort into at least getting a better understanding of this bug, but I hope to get it fixed for the release planned for Monday, June 3.

Changed in win32-image-writer:
status: Triaged → In Progress
Tobin Davis (gruemaster) wrote :

I am able to reproduce this on my work system. Not that it is a good thing, but at least I can now debug it. Only took all day just to get to this stage.

This bug only affects XP and (possibly) Vista, as my normal work environment is Windows 7 and it works fine on this laptop. Yet another change in Windows that plagues this project.

I have this problem and I'm runningVista Business edition...

73 de Bill Wallace

On Jun 2, 2013, at 1:50 AM, Tobin Davis <email address hidden> wrote:

> I am able to reproduce this on my work system. Not that it is a good
> thing, but at least I can now debug it. Only took all day just to get
> to this stage.
>
> This bug only affects XP and (possibly) Vista, as my normal work
> environment is Windows 7 and it works fine on this laptop. Yet another
> change in Windows that plagues this project.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1143612).
> https://bugs.launchpad.net/bugs/1118217
>
> Title:
> can not select SD card to write image to
>
> Status in Image Writer for Windows:
> In Progress
>
> Bug description:
> i am on Windows XP sp3, tried both 0.6 and 0.7 versions. When i run
> the program, i can select image file but can not select SD card. In
> fact in drop down of Device nothing is displayed. When clicked on drop
> down of Device, when clicked(to select) nothing is displayed and its
> color changes from white to blue.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/win32-image-writer/+bug/1118217/+subscriptions

Tobin Davis (gruemaster) wrote :

Sorry, I was not able to get this resolved before releasing v0.8. Once I was able to get a system assembled that could reliably reproduce the issue, I discovered that the bug is VERY deep rooted in the Windows API layers (which is why it works for me on Windows 7 but not XP/Vista on the same system).

Due to the nature of this bug, and the number of people affected/potentially affected by the other bugs, I felt that I needed to get v0.8 out without resolving this issue. Now that it is out, I can focus more on this bug exclusively. Bear with me, as I need to swap drives in my work laptop in order to debug this issue. As a workaround, use a USB based SD reader if possible.

This is now becoming a high priority, so it won't be left out. I will first be working on a new tool to help debug this (and future issues). As soon as it is available, I will post a copy here and announce it on this site and Sourceforge, so that people will be able to produce detailed information to add to bug reports.

Please be patient, and thank you for your support.

Changed in win32-image-writer:
importance: Medium → High
Tobin Davis (gruemaster) on 2013-06-04
Changed in win32-image-writer:
milestone: none → 0.9
ugo (bitenet) wrote :

Tobin, if it can help solving, I compiled with VisualStudio 2008, running the pgm i have the empty combo box, debugging the checkDriveType function i docovered that ny external usb card reader (with 8gb sdcard inserted) is reported as DRIVE_NO_ROOT_DIR type, and this does not match any of the subsequent "switch" options.

Jeff B (skydiver38) wrote :

Great info about the device type - thanks for sharing that.

Tobin Davis (gruemaster) wrote :

That is awesome information. I'll need to look at the onlline documentation, but that definitely helps a lot.

ugo (bitenet) wrote :

Found this workaround from Microsoft http://support.microsoft.com/kb/244089/en-us it's working for me, simplpy replace the GetDriveType call in disk.cpp with the new function GetMountPointDriveType

I also forced the writing sectors loop to the maximum sectors number detected from device info, no pretty solution but useful for me, and I was able to finally flash a sdcard, recovering my crashed RaspBerry PI VOIP Pbx!

Tobin Davis (gruemaster) wrote :

Found the problem (at least on my T61 from work, downgraded to XP SP3). It would appear that there was a partial fix already in the code, where it looks for a BusType = 0xC (SD), as this is what mine reports as. But below that, the code looks to see if there is an actual device inserted in the reader. This fails for me.

Will look at a different method for detecting the presence of an SD card. Fix will come very soon.

Tobin Davis (gruemaster) on 2013-06-10
Changed in win32-image-writer:
status: In Progress → Fix Committed
Dermot (dermiem) wrote :

I have the same issue.

I have a micro SD card in an SD adapter, with the SD adapter plugged into the SD slot on a Lenovo T61P laptop running Windows Vista
Windows recognizes the card, and I can read & write it from Windows Explorer.
However, ImageWriter has no entries in the device drop down.
If I plug in a USB stick, it is listed in the IW device drop down, but the SD card is not.
I have tried inserting the card into the slot after starting IW, and also before starting IW. The device drop down is always empty.
I am using IW version 0.8.

Tobin Davis (gruemaster) wrote :

This bug has been fixed in code. I will get a released binary out soon, I just have been overloaded lately. I was hoping to get some more changes in, but this appears to be more pressing. Look for a release in the next couple of days.

Tobin Davis (gruemaster) wrote :

Bug fix released. Please download v0.9 and test it thoroughly. If there are any more issues directly related to this bug, please reopen and I will look into it as soon as I am able to. Any new bugs should be submitted as such.

Thank you all for your patience and support.

Changed in win32-image-writer:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers