Image Writer for Windows

Cannot select Device

Reported by wesc56 on 2012-04-18
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Image Writer
Low
Tobin Davis

Bug Description

I downloaded the win32diskimager-binary and unzipped the file. When I clicked the Win32DiskImager and tried to select the DEVICE it doesn't drop down. I cannot get it to select my mirco SD card in drive "E" . I have a kingston micro sd 8gb card. This is very frustrating as I have done this before on this same card and wiped the card and just formated it again now. Still nothing. Restarted my computer, came back still nothing. Anyone ?

Jeff B (skydiver38) wrote :

Is "E" a multi-card reader? Did you try starting imagewriter with the card already inserted?

The card reader is a built-in one on the Dell. I heard from a
colleague as well that built-in readers aren't supported. I bought a
USB multi-card reader and things work with that.

Brian

On 4/19/12, Jeff B <email address hidden> wrote:
> Is "E" a multi-card reader? Did you try starting imagewriter with the
> card already inserted?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/984510
>
> Title:
> Cannot select Device
>
> Status in Image Writer for Windows:
> New
>
> Bug description:
> I downloaded the win32diskimager-binary and unzipped the file. When I
> clicked the Win32DiskImager and tried to select the DEVICE it doesn't
> drop down. I cannot get it to select my mirco SD card in drive "E" .
> I have a kingston micro sd 8gb card. This is very frustrating as I
> have done this before on this same card and wiped the card and just
> formated it again now. Still nothing. Restarted my computer, came back
> still nothing. Anyone ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/win32-image-writer/+bug/984510/+subscriptions
>

--
Sent from my mobile device

Tobin Davis (gruemaster) wrote :

It is possible that the card reader is not reporting the drive in a normal fashion. Does Windows detect the SD when it is inserted/removed?

Brian Hammill (atmelfaebrian) wrote :

Apparently. The drive is there on the PC. But is not shown in the
drive imager selection.

I got a plug-in USB card reader and that worked fine. It is the
built-in one that doesn't show up.

Brian

On 4/25/12, Tobin Davis <email address hidden> wrote:
> It is possible that the card reader is not reporting the drive in a
> normal fashion. Does Windows detect the SD when it is inserted/removed?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/984510
>
> Title:
> Cannot select Device
>
> Status in Image Writer for Windows:
> New
>
> Bug description:
> I downloaded the win32diskimager-binary and unzipped the file. When I
> clicked the Win32DiskImager and tried to select the DEVICE it doesn't
> drop down. I cannot get it to select my mirco SD card in drive "E" .
> I have a kingston micro sd 8gb card. This is very frustrating as I
> have done this before on this same card and wiped the card and just
> formated it again now. Still nothing. Restarted my computer, came back
> still nothing. Anyone ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/win32-image-writer/+bug/984510/+subscriptions
>

--
Sent from my mobile device

Jess Bermudes (jbermudes) wrote :

The same thing happens to me. No devices show up in the list despite Windows seeing the card under My Computer on my Dell Inspiron 1520 built in SD card Reader running Windows XP.

Oliver Draeger (odraeger) wrote :

I have had the same problem. SD drive worked well in every other way, only Win32 disk imager did not recognize it. Then I installed previous version 0.1 of win32 disk imager (win32diskimager-RELEASE-0.1-r15-win32.zip) and it worked again ! Quite clearly a problem of the software, not the hardware.

Brian Gridley (bgridley) wrote :

I tried running both .5 and .6 binaries. In both cases no drives showed up in the list. I have a vista Toshiba Satellite with a built in sd reader. shows up as a removable E: drive in explorer, but not at all in Image writer.

Tobin Davis (gruemaster) wrote :

It would be nice to see what version of Windows people are using so that I can better troubleshoot this issue.

I believe the problem is with newer systems on Windows Vista or 7, as these systems introduced a new SD interface. This new interface doesn't appear to be on the usb bus, which is what this program looks for. I can try adding the SD detection, but I am not sure it will work on XP (see http://msdn.microsoft.com/en-us/library/windows/desktop/ff800833%28v=vs.85%29.aspx). I also don't know if I can implement it without first patching mingw.

I will try to experiment and see. No guarantees.

Changed in win32-image-writer:
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Tobin Davis (gruemaster)
Tobin Davis (gruemaster) wrote :

Please try this exe. It drops in over 0.6 release (you will need this release).

If it works, it will be in the next official release. If not...

Changed in win32-image-writer:
status: In Progress → Fix Committed
Mardy (mardyf) wrote :

The new exe doesn't work for me. (See my comment on the related issue https://answers.launchpad.net/win32-image-writer/+question/194026.) I still don't see the built-in card reader in the Disk Imager dropdown selector list. By the way, if I plug the same SD card into a USB card reader and plug it in, it works just fine in both versions of Disk Imager. Whether it's in the built-in card reader or the USB card reader, Windows Explorer reports it as type "Removable Disk."

Chris K (ckiowm) wrote :

Same problem for me unfortunately - Toshiba Tecra laptop running XP Pro SP3, has built in SD card reader assigned as E, and Win32DiskImager doesn't see the 4Gb SD card i'm inserting. Windows is seeing it. Tried inserting with WI running, and tried before launching WI. Tried the patch exe that is supplied above - replaced the exe in my WI folder and it still behaves that same.
WI does recognise a USB stick (F:) when plugged in, and it does that with the application is running, but that's not the drive I want to write to!

Chris K (ckiowm) wrote :

Addition to my comment above - I didn;t confirm I was running WI v.0.6 and was getting the fails - however I have downloaded the earlier version 0.4 of WI and that does recognise the internal SD card reader (E:). Rather suggests as Oliver said this is an issue with the latest releases.

Alexnco (alexnco) wrote :

My card reader device (a built-in and normally well-behaved and functioning SD reader built into a stable Dell studio laptop on Windows Vista SP2, 32 bit OS) is an "SDA Standard Compliant SD Host Controller, manuf: SDA Standard Compliant SD Host Controller Vendor" on PCI bus 3, device 1, function 1. Driver by Microsoft, version 6.0.6002.18005.
My problem (also stated elsewhere) is that IW does not recognize the SD Card (or any other functioning "devices") whether the SD Card is inserted and recognized by the OS before or after the IW software has been started. Downloading the new IW exe mentioned in this page over my 0.6 version also made no difference. 0.5 also makes no difference.
**But**, as Chris K has mentioned above, IW version 0.4 works fine and recognizes the SD Drive (and only the Card reader) whether the SD card has been nserted BEFORE or AFTER IW starts!
Thx!

Jon (theotherchap) wrote :

Sorry, the new exe doesn't work for me either (Win Vista).
Just about to download & try V0.4 :)

patyk jaworski (jawor1099) wrote :

I will try to reproduce bug on my Toshiba Satellite L555-12Q with built-in Realtek Card Reader

Erin Flage (eisvik+launchpad) wrote :

Just wanted to report that I tried this fix as well and it didn't work for me either.

Win Vista, 64bit, Dell Latitude XT, built-in SD card.

Brian Hammill (atmelfaebrian) wrote :

I was using Windows XP SP3.
On a Dell E6400 Latitude.
On Oct 18, 2012 12:30 AM, "Tobin Davis" <email address hidden> wrote:

> It would be nice to see what version of Windows people are using so that
> I can better troubleshoot this issue.
>
> I believe the problem is with newer systems on Windows Vista or 7, as
> these systems introduced a new SD interface. This new interface doesn't
> appear to be on the usb bus, which is what this program looks for. I
> can try adding the SD detection, but I am not sure it will work on XP
> (see http://msdn.microsoft.com/en-
> us/library/windows/desktop/ff800833%28v=vs.85%29.aspx). I also don't
> know if I can implement it without first patching mingw.
>
> I will try to experiment and see. No guarantees.
>
> ** Changed in: win32-image-writer
> Status: New => In Progress
>
> ** Changed in: win32-image-writer
> Importance: Undecided => Low
>
> ** Changed in: win32-image-writer
> Assignee: (unassigned) => Tobin Davis (gruemaster)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/984510
>
> Title:
> Cannot select Device
>
> Status in Image Writer for Windows:
> In Progress
>
> Bug description:
> I downloaded the win32diskimager-binary and unzipped the file. When I
> clicked the Win32DiskImager and tried to select the DEVICE it doesn't
> drop down. I cannot get it to select my mirco SD card in drive "E" .
> I have a kingston micro sd 8gb card. This is very frustrating as I
> have done this before on this same card and wiped the card and just
> formated it again now. Still nothing. Restarted my computer, came back
> still nothing. Anyone ?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/win32-image-writer/+bug/984510/+subscriptions
>

cdwells (cwells-7) wrote :

Had same issue as described in initial bug report. Tried IW 0.6 using built in card reader on Dell Vostro 1000, WinXP SP 3, SanDisk 8 GB - Class 4. Did not allow me to select device, although device showed up fine in WinXP. Tried using IW 0.1 as suggested by others, worked fine.

Tobin Davis (gruemaster) on 2013-02-03
Changed in win32-image-writer:
status: Fix Committed → Fix Released
Simon Fish (fishii10) wrote :

0.1 worked for me on a WinXP SP3 Dell Inspiron 640m. Dead helpful since my USB SD reader by Integral died of a faulty disk image write!

Michael Aichlmayr (imikla) wrote :

On my Lenovo T400 running up to date WinXP, could not select the device, but the SDHC card does show up as K: in Windows.

Took the card to my Dell Studio XP machine running Win7 with a cheap add-on card reader plugged into an internal USB port. When I started win32diskimager it automatically selected the device (also K:) and I was able to write the image on that machine.

Tobin Davis (gruemaster) wrote :

There are multiple copies of this bug that keep coming up. I have committed what I believe to be a fix for this, but it is attached to lp:1118217. Please use that bug for future posts. I will try to get an updated release out soon.

Changed in win32-image-writer:
status: Fix Released → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers