[UIFE][FFE] Install Amazon and Ubuntu One Music Store webapp items in the launcher by default

Bug #1046840 reported by Alexandre Abreu on 2012-09-06
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Didier Roche
WebApps: Applications Data
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

There is a need to add "preinstalled" (on installation or package update) webapps launcher icons on a per-webapp basis.

This requires updating the associated "favorites" user specific list of current Launcher desktop files.

This can be done by:

- adding a "session-migration" step added to the debian package with a script that modifies the list of Launcher "favorites" for the current user adding the proper desktop files,

- updating the list of default apps in unity launcher,

** link to translators discussion:

https://lists.ubuntu.com/archives/ubuntu-translators/2012-September/005591.html

Related branches

visibility: private → public
description: updated
Changed in ubuntu:
importance: Undecided → High
milestone: none → ubuntu-12.10-beta-2
summary: - [FFE] add migration step to package to allow preinstallation of webapps
- launcher icons
+ [FFE] Support default preinstallation of webapps launcher icons

Please provide more information on the testing done so far, include code diff, and plans for reverting if there are serious problems. Since we're changing defaults, we need to let the docs team know and go through UIFe.

Setting status to incomplete, please revert to new, when additional information has been provided.

summary: - [FFE] Support default preinstallation of webapps launcher icons
+ [UIFE][FFE] Support default preinstallation of webapps launcher icons

To further comment on it:

- the session-migration script has been developed with the help of Didier Roche, and the associated branch can be seen there: http://bazaar.launchpad.net/~abreu-alexandre/webapps-applications/default-installed-applications/revision/358 , please not that this is not the packaging branch. I will patch the associated packaging branch along with the main trunk. The packaging branch will receive trivial changes to support a session-migration step:

  * update debian/changelog
  * update debian/control to add a dependancy on dh_migration
  * update debian/rules to ask a "migrations" step, i.e. "dh $@ --with autoreconf,migrations"
  * add a debian/unity-webapps.migrations file that points to the script that is to be run during the migration phase, i.e. "scripts/install-default-webapps-in-launcher.py"

- the script responsible for the migration step ("scripts/install-default-webapps-in-launcher.py") has been tested with the packaging branch, after a debbuild, and a manual install of the resulting deb package. After a logout, the state of the launcher has been checked (to account for the new launcher icons),

- In case of issues the migration step in the package will be removed (the debian/rules file modified), the risks are low. In the case of Unity, the launcher desktop files defaults will be updated accordingly also (by removing the new listed files),

Jeremy Bicha (jbicha) wrote :

This UIFe does not have enough information. It sounds like an unspecified number of webapp launcher items will be added to the Unity launcher by default. How many and which ones exactly?

I strongly dislike the idea of adding more stuff to an already over-stuffed launcher. On a 1366x768 screen (the most common screen resolution today according to http://gs.statcounter.com/press/screen-resolution-alert-for-web-developers ), there is only room for a user to start one additional app before launcher icons start rolling off the screen in the accordion effect.

Does this mean the Design Team is proposing we finally get rid of the System Settings & Ubuntu One launchers I've been complaining about for a year? See bug 764744 for some of that conversation.

Adjusting the default launcher items could require redoing up to 10 screenshots, so if this were to happen, it should happen soon.

Please notify the translation teams also. I presume this will require new strings.

2 Launcher items would be added:

- one for amazon,
- one for UbuntuOne Music,

Will try to clarify the rest

Jeremy Bicha (jbicha) wrote :

I can understand the Ubuntu One Music Store link even though I think a link in the Dash & better integration in the default music player would be sufficient.

I do not understand why we need a direct link to amazon.com on the default Ubuntu desktop. I believe adding that link will be rather controversial and I have trouble seeing that it's worth all that bother. Will Canonical be getting referral compensation? If not, I think a fair number of people will assume that there is profit-sharing going on. Maybe there should be. Amazon.com is a very commercial website and I think this decision should be discussed by Ubuntu developers as a whole first.

I updated the description with the link to the translation mail list discussion

description: updated
Jeremy Bicha (jbicha) wrote :

I can understand the Ubuntu One Music Store link even though I think a link in the Dash & better integration in the default music player would be sufficient.

I do not understand why we need a direct link to amazon.com on the default Ubuntu desktop. I believe adding that link will be rather controversial and I have trouble seeing that it's worth all that bother. Will Canonical be getting referral compensation? If not, I think a fair number of people will assume that there is profit-sharing going on. Maybe there should be. Amazon.com is a very commercial website and I think this decision should be discussed by Ubuntu developers as a whole first.

I've not tried the webapps yet, but I think the .desktop's are incomplete. Name should be "Ubuntu One Music Store" not "UbuntuOneMusicStore". And shouldn't that be translatable?

Would "Type=Link" be better suited for weblinks than "Type=Application"? However it looks like Unity doesn't recognize link desktop files. If you're going to use the application type, why not include Categories and Keywords for better discoverability in the Dash and elsewhere?

Ken VanDine (ken-vandine) wrote :

The .desktop files aren't actually links. They are launchers that run unity-webapps-runner with the correct context for that webapp. I do agree that UbuntuOneMusicStore is not an acceptable name.

YannUbuntu (yannubuntu) wrote :

The title of this bug does not reflect the content of post #4.

Iain Lane (laney) on 2012-09-19
summary: - [UIFE][FFE] Support default preinstallation of webapps launcher icons
+ [UIFE][FFE] Install Amazon and Ubuntu One Music Store webapp launchers
+ in the dash by default
summary: - [UIFE][FFE] Install Amazon and Ubuntu One Music Store webapp launchers
- in the dash by default
+ [UIFE][FFE] Install Amazon and Ubuntu One Music Store webapp items in
+ the launcher by default
YannUbuntu (yannubuntu) wrote :

The bug description should explain why these 2 links are needed in the launcher. (see #7 comment)

The name field in the UbuntuOne desktop file has been updated to "UbuntuOne Music Store".

visibility: public → private
Kate Stewart (kate.stewart) wrote :

Timing issue with documentation (screen shots) has been resolved by shifting DocumentationString. Communication of background behind this will go to ubuntu-developer.

Approved, with understanding that if there are significant issues, this may be reverted. Please package with this in mind.

Olli Ries (ories) on 2012-09-20
visibility: private → public
Olli Ries (ories) wrote :

@ comment 3: this is what we will be communicating right after the release to ubuntu-dev

--snip--
Another addition is that we will be including Launcher web apps icons to Amazon and the Ubuntu One Music Store by default. We feel that these icons will provide convenient access to these resources for our users and also benefit the project with the generation of affiliate revenue in those cases that these resources are used. If our users choose to not use these Launcher icons, they can be easily removed by the user by dragging the icon to the trash.
--snap--

Iain Lane (laney) wrote :

I share Jeremy's concern. Could we please have this conversation as a project before going ahead with adding third party commercial content, not just to the desktop, but to the very first screen that new users will see?

Olli Ries (ories) wrote :

Users will be able to remove the icons without much hazzle, sorry for the late inclusion - I agree this should have been communicated well in advance.

Jeremy Bicha (jbicha) wrote :

I am not happy with your plan to communicate this to Ubuntu contributors *after* you land it in Ubuntu. I am also not happy with this bug having been made private. What is so private about this bug?? Open source development happens in the open.

I am also not happy that a major feature like this hasn't landed in Ubuntu by this point if intended for 12.10. I've not even tried it yet because I didn't want to add one more PPA; I prefer to get my Chromium & Firefox from the repositories. PPAs shouldn't substitute for actually testing your work in the archives.

So screenshots are no longer a blocker, but I seriously doubt you'll have any information in ubuntu-docs about this feature.

Jeremy Bicha (jbicha) wrote :

Oh, I forgot to mention that this news story just hit:
http://www.omgubuntu.co.uk/2012/09/amazon-ubuntu-one-web-app-to-be-pre-installed-in-ubuntu-12-10

So I guess we'll get some feedback shortly.

Jono Bacon (jonobacon) wrote :

Jeremy, I think you have every right to be frustrated that this landed after the Feature Freeze. From what I understand the reasons for this were some staffing and technical issues, but the team felt the feature would be valuable and useful for Ubuntu users and also generate revenue to help support investment in the project.

To compensate for it being added late, we are pursuing further testing (Nicholas Skaggs will be coordinating further manual testing) and Olli has assured us that his team will be responsible in fixing and resolving issues.

YannUbuntu (yannubuntu) wrote :

- Do these links lead to localized web pages? (eg, amazon.fr when system locale is French).
If not, please don't add them on non-English systems.

- As the launcher is already cluttered (see comment #3 and Bug #713423 ), why not moving those links into Firefox bookmarks instead ?

Jeremy Bicha (jbicha) wrote :

Does Ubuntu receive a commission from Amazon? Are the new launchers translatable, and if not, why not?

David Planella (dpm) wrote :

Al 19/09/12 04:33, En/na Alexandre abreu ha escrit:
> Hi All,
>
> This is freeze exception request to add two new default Launcher icons for
> WebApps ( http://developer.ubuntu.com/resources/technologies/webapps/).
>
> Those two items (linking to the Amazon and UbuntuOne Music WebApps) would
> be added by default to the Launcher with the appropriate icons
> (distributed as part of each WebApp package)
> in the same fashion as the Launcher icons that can be seens here:
>
> http://developer.ubuntu.com/wp-content/uploads/2012/08/webapps-launcher.jpeg
>
> The link to the FFE bug:
>
> https://bugs.launchpad.net/webapps-applications/+bug/1046840
>
> Thank you,
> Alex
>

I believe this is a significant feature that shouldn't be blocking on
the translations team, as in terms of translations it will introduce
just a handful additional ones. The main discussion is happening on the
ubuntu-devel thread.

For these reasons, and *provided that the two launcher icons are
translatable* as the rest of the launchers in the system, here's a
tentative +1.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Olli Ries (ories) wrote :

@comment 19:

yes, we will redirect you to the according site

we want to increase the explorability of that feature

Stéphane Graber (stgraber) wrote :

How exactly will these icons be added and how can that change be cancelled? Is it a simple matter of removing a package?

I'm asking because why my Edubuntu hat on where we're using Unity but may want to revert that specific change as we don't like the extra entries in the launcher (IIRC our current selection barely fits on a netbook screen).

Release team: If accepting this change, please also grant an exception to any flavour using unity to push the necessary changes to revert that one.

- "Do these links lead to localized web pages? (eg, amazon.fr when system locale is French). If not, please don't add them on non-English systems."

Yes,

- "As the launcher is already cluttered (see comment #3 and Bug #713423 ), why not moving those links into Firefox bookmarks instead ?"

We definitely acknowledge the fact that the Launcher already contains quite a bit, the idea is to bring some visibility to those new icons/functionalities. As Olli Ries pointed out, a given user is, at any point in time, able to remove those icons.

Olli Ries (ories) wrote :

@comment 20:
yes, this will increase the affiliate revenue, similar to how we generate revenue for Ubuntu via the Firefox search bar

Jeremy Bicha (jbicha) wrote :

Olli, thanks for the answers!

I would recommend that the Release Team block this unless Design is willing to drop 2 default launcher items to make room for the 2 new ones being added as I explain in comment #3. That preserves the status quo, for Edubuntu's sake and all of us not using 27" iMacs.

As a Documentation Team member, I don't believe I have the authority to block for non-documentation reasons, like usability.

Jonathan Carter (jonathan) wrote :

Adding to Stéphane's message about Adding to Stéphane's message regarding Edubuntu, it's really about more than just using extra space in the launcher.

We'd like to keep Edubuntu a free system, which includes making it free of any adware as far as possible. We already have text advertising Landscape in the default motd, links to Ubuntu One in the panel, etc. I understand Canonical's intent and right to make some money out of the affiliate codes, but maybe we can think of better ways to do that in Edubuntu than spamming the desktop system with links.

Didier Roche (didrocks) on 2012-09-20
affects: Ubuntu Quantal → unity (Ubuntu Quantal)
Timo Jyrinki (timo-jyrinki) wrote :

@23: I'm uninformed on how they will be added, and may be wrong on this, but one idea would be to ship a gsettings override similar to that in ubuntu-settings and other packages, for example edubuntu-settings, and override the key favorites in com.canonical.Unity:/com/canonical/unity/launcher/. But let's see what are the options.

Stéphane Graber (stgraber) wrote :

Right, for Edubuntu specifically we have indeed two main issues:
 - We like the UI to fit on a netbook.
 - Having those launchers on a student's default desktop doesn't seem appropriate to me.

We'll be happy to have those available in the Dash and/or as bookmarks in firefox (I personally prefer the bookmarks...), but we'll do what's needed to remove them from the default Unity launchers.

Sadly as that's really last minute, it means we may need to start shipping extra gsettings overrides and maybe even a separate edubuntu-settings package overriding ubuntu's... That's something we never quite had to do in the past and I'm certainly not looking forward to having to do that this close to release, not to mention maintain these bits in the future...

Stéphane Graber (stgraber) wrote :

@Timo: Yeah, that's how I assumed they'd be added. We can certainly override those in edubuntu-artwork as we do for the wallpaper, the problem is that as far as I know, we need to override the whole list, so that means we'll have to do manual syncs with Ubuntu from that point on (at least it's not a key that changes too often...).

Olli Ries (ories) wrote :

re comment #28: this is a sabdfl request and this has been discussed with design already

Didier Roche (didrocks) on 2012-09-20
Changed in unity:
status: New → Fix Released
milestone: none → 6.6
assignee: nobody → Didier Roche (didrocks)
Michael Terry (mterry) wrote :

@Stephane, I think the launchers will be added in ubuntu-settings, so that shouldn't be an issue for edubunt, right?

Jeremy Bicha (jbicha) wrote :

Michael, I don't think that's how the code is currently set up. edubuntu-desktop currently depends on ubuntu-desktop so currently it NEEDSWORK if Edubuntu is going to have the ability to disable the new launchers.

Didier Roche (didrocks) wrote :

@Michael: no it's added to unity itself. but the launcher remove everytime you logs in every desktop file it can't find, and so, it will be removed on people's machine not having the webapps icons

it's a gsettings property, so can be overriden as well.

Stéphane Graber (stgraber) wrote :

right, edubuntu is using ubuntu-settings so was going to inherit the new launchers.

I now fixed that with an edubuntu-artwork upload overriding the unity launchers in a gsettings override, so we won't be affected when/if that change lands (and we'll also be safe from any further change to the launchers list).

Jeremy Bicha (jbicha) wrote :

Oops, I forgot that the launcher items are stored in a dconf setting. So Edubuntu will just need to ship a gsettings override for com.canonical.Unity.Launcher favorites.

Guus (guus-verbeek) wrote :

If Amazon gets included by default, wouldn't it make sense to use the local Amazon?

Amazon has websites for Austria, Canada, China, France, Germany, Italy, Japan, Spain, UK and the US.

So if for example a French user opens the Amazon webapp he/she will expect to see the French version.

Just a thought.

Guus (#37):

see comment #22-24,

Kate Stewart (kate.stewart) wrote :

This got included, prior to formal RT signoff, and there have been some concerns raised. Leaving things as is for now. Will revisit tomorrow.

Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 6.6.0-0ubuntu1

---------------
unity (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixes non-escaped character sequences in dash previews (LP: #1039020)
    - Updated background layer for preview cover-art and details panels
      to be 10% low-light
    - Expand a PlacesGroup if it is the only category that contains results
      (LP: #950710)
    - Update unity autopilot tests to match autopilot API
    - Updated the convert files to fix some typos in the key names
    - Add gmodule dependency
    - Activate proper result if the categories aren't displayed in-order
      (LP: #1040101)
    - Refactor device launcher icons (LP: #713423)
    - LauncherController: make the controller enable the launcher struts,
      based on hide-mode option (LP: #1044005)
    - Launcher: make always possible to drag an icon to the bottom or top
      of its sub list (LP: #1043968)
    - Don't desat bfb/hud icon in DNDReset (LP: #1043963)
    - Progressively adjust the speed of the minimize animation. First
      time it is used is slower, then speeds up the more it is used.
      (LP: #1017510)
    - Implement new ordering of categories for home lens. (LP: #1043915)
    - UnityWindow now implements ScaleWindowInterface (LP: #876017)
    - Launcher: restore an icon position after that the dragging has been
      cancelled (LP: #955561)
    - LauncherDragWindow: cancel drag on window mapped/unmapped
      (LP: #1044723)
    - Now there is a check of an override color in RefreshColor (which is
      called when a PropertyNotify event happens). Also added a check in
      FullySaturateColor to a void division by zero. (LP: #975350)
    - Queue redraw after cover-art texture is updated from a url/file source.
      (LP: #1043947)
    - Fixed ability to delete glib::Source wrapper during its callback
      (LP: #1044823)
    - Close preview when dash is hidden. (LP: #1045298)
    - LauncherModel: rewrite the Reordering functions to keep the icon
      priority deltas (LP: #761155)
    - Make sure we can pass extra hints when activating preview actions.
      (LP: #1046352)
    - UnityWindow: scale window code improved (LP: #1033935)
    - The mouse will now cause the HUD buttons to change selection
      (LP: #1042692)
    - "Alt+Space" shortcut to reveal the window menu is not hardcoded, but a
       Compiz key option. " (Hold)" should also be translated. Made all
       Compiz plug-in names and all Compiz plug-in option names in
       unityshell.cpp static constants.
    - remove unity --reset, it's not anymore really needed now that we are
      in stable days of unity and we moved to gsettings
    - Removed the variables 'oldPrev' and 'oldNext' which got assigned the
      value NULL, but then were never used
    - Fixed the size of the previews to 770x380 pixels. (LP: #1045243)
    - UnityWindow: use smart pointers, use static close_icon (with dynamic
      state) and PanelStyle context (LP: #1033935) (LP: #1045127)
      (LP: #1046124) (LP: #1046126)
    - Remove everything in the #ifndef USE_MODERN_COMPIZ_GL ifdefs and remove
      the ifdefs alltogether. unity now requires compiz...

Read more...

Changed in unity (Ubuntu Quantal):
status: New → Fix Released
Michael Terry (mterry) wrote :

Kate asked me to upload this to quantal-proposed for further review, so I did.

webapps-applications 2.4.6-0ubuntu1 is in NEW now.

Jeremy Bicha (jbicha) wrote :

I opened bug 1054167 for the too many launcher items by default bug.

Benjamin Kerensa (bkerensa) wrote :

I share Jeremy Bicha's concerns with this change being pushed in last minute without any decent discussion with the rest of the project.

David King (amigadave) on 2012-10-02
Changed in webapps-applications:
status: New → Fix Released
tags: added: ffe uife
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers