update-manager popup is shown on launcher and alt-tab list but window doesn't show up

Bug #989588 reported by Timo Aaltonen on 2012-04-27
278
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Christopher Townsend
7.2
Fix Committed
High
Christopher Townsend
Xenial Backports
Undecided
Unassigned
unity (Ubuntu)
High
Christopher Townsend
Precise
High
Unassigned
Trusty
High
Unassigned

Bug Description

Yesterday I got a "popup" from update-manager that shows on the launcher how many updated packages there are available, but left-clicking the icon didn't show the window. Alt-tabbing didn't help either, so I closed it from the right-click menu and the next time it showed I did get a proper popup window.

Today this happened again, so filing a bug now.

Steps to reproduce, hastily written:

0. (create another user account)
1. login to my main account
2. lock screen
3. switch user
4. update package lists
5. switch back to main user

Update-manager window is shown in Launcher and Alt-Tab, but does not appear when selected, by either means.

Closing update-manager from the quicklist, and restarting, makes a visible window, as we've said. Also, starting the upgrade from the quicklist worked, and the in-progress dialog appeared normally. BUT, when the upgrade was done, and should return to the main window, that window was still inaccessible.

I don't know if the two-session scenario is the only way this bug shows up, currently. I used to have this problem, under Precise, with only one user session. But I haven't seen that behaviour in a while.

[Test Case]
0. (create another user account)
1. login to my main account
2. lock screen
3. switch user
4. update package lists
5. switch back to main user
6. Update-manger should be shown in the Launcher
7. Make sure that clicking update-manager icon correctly raise and focus the update-manager window.

[Potential Regression]
None.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu5
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,vpswitch,compiztoolbox,imgpng,snap,unitymtgrabhandles,mousepoll,place,resize,regex,wall,move,grid,gnomecompat,session,animation,fade,expo,scale,workarounds,unityshell]
CompositorRunning: compiz
Date: Fri Apr 27 13:22:22 2012
DistUpgraded: 2012-01-14 13:59:33,902 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Intel Corporation Device [8086:2210]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MachineType: Intel Corporation SandyBridge Platform
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=921d8d6a-73e4-4693-8a6a-10cbceb5b51c ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to precise on 2012-01-14 (103 days ago)
dmi.bios.date: 01/13/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: ASNBCPT1.86C.0061.P00.1101131110
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: LosLunas CRB
dmi.board.vendor: Intel Corporation
dmi.board.version: To be filled by O.E.M.
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrASNBCPT1.86C.0061.P00.1101131110:bd01/13/2011:svnIntelCorporation:pnSandyBridgePlatform:pvrTobefilledbyO.E.M.:rvnIntelCorporation:rnLosLunasCRB:rvrTobefilledbyO.E.M.:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: SandyBridge Platform
dmi.product.version: To be filled by O.E.M.
dmi.sys.vendor: Intel Corporation
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Timo Aaltonen (tjaalton) wrote :
Timo Aaltonen (tjaalton) wrote :

note that the session has been running since Apr 18th, so in case there were relevant updates since, I'll start with a fresh session and try to reproduce.

Sebastien Bacher (seb128) wrote :

Thanks, that's not the first time I see such issues (my old laptop on precise do it sometime for im clients as well), it seems like compiz doesn't like things starting minimized

Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz (Ubuntu Precise):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

It would be good to try on an uptodate restarted session, but it's quite an issue if it means users can't access to stable or security updates

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu Precise):
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed

I also faced this issue frequently in Ubuntu 11.10. Interestingly, the bug does not
show up every time the update manager window pops up in launcher. Two out of
three times the update manager window shows up, when I click the icon.

I hoped this would be solved in Ubuntu 12.04 but the problem is still there.
(I'm having it right now.)

Edward Donovan (edward.donovan) wrote :

I don't have careful data. But running Quantal, I don't recall seeing this in a while. Problems with focus when the window.is raised, but not with the update-manager window being lost and inaccessible.

Of course, none of us have found a way to consistently reproduce it, so I can't make strong claims one way or the other. But I'll try to keep an eye on it. Thanks.

Timo Aaltonen (tjaalton) wrote :

I think it's related to me having two sessions on the same computer (mine and my wife's). Not sure but it's possible I see this only when I come back to my session, and update-manager has been run while on the other session.

Ah, that's interesting. It used to happen to me with only one session, and one user account on the machine. Maybe I'll get a chance to test the two-session scenario. Thanks.

Timo, I see what you mean! :) I was able to reproduce what you're talking about.

Steps to reproduce, hastily written:

0. (create another user account)
1. login to my main account
2. lock screen
3. switch user
4. update package lists
5. switch back to main user

Update-manager window is shown in Launcher and Alt-Tab, but does not appear when selected, by either means.

Closing update-manager from the quicklist, and restarting, makes a visible window, as we've said. Also, starting the upgrade from the quicklist worked, and the in-progress dialog appeared normally. BUT, when the upgrade was done, and should return to the main window, that window was still inaccessible.

I guess I'll paste this into the main description.

description: updated
tags: added: quantal
Changed in update-manager (Ubuntu):
status: New → Confirmed
Changed in update-manager (Ubuntu Precise):
status: New → Confirmed
tags: added: raring

I just experienced this in Raring. Only one X session running, so it didn't need that two-user scenario.

In this case, choosing Quit from the quicklist is having no effect. The update-manager process remains, and the Launcher and the alt-tab switcher still act as if there's an open window.

I notice now that window isn't attached to any of the virtual desktops. Maybe that's been true all along, and I've just realized it. I have the standard four virtual desktops, and on all of them, the Launcher shows the hollow or outline pip for "open, but not on this desktop."

Similarly, on all of the desktops, plain alt-tab doesn't show update-manager among the open windows. But Control-alt-tab, showing windows from all desktops, always includes it. Selecting it from this list has no effect, just like selecting it from the Launcher. Hm.

For the heck of it, I increased the number of workspaces to 3x3, in a session where this bug had occured, and Unity believed update-manager was open, but not assigned to any of the workspaces. It was not hiding on any of the extra workspaces.

Karma Dorje (taaroa) wrote :

This affects me too after yesterday's updates.

$ lsb_release -rd
Description: Ubuntu Raring Ringtail (development branch)
Release: 13.04

$ unity --version
unity 6.6.0

BertN45 (lammert-nijhof) wrote :

Same problem almost directly after loading the system 13.04. This time the Software Updater also stalled as shown in the screenshot, maybe because of the "ubuntu-bug" run? See also bug 1090414.

I could start the Software Updater using the Dash and it stalled at the grub-pc. After reboot and dpkg reconfigure everything was OK again.

Josh (majik) wrote :

Confirmed on 12.04.

Switching users is not necessary to replicate.

It seems to happen if the Update Manager starts when the screen is locked.

I filed Bug 1092597 which is a duplicate of this one and was marked as such.

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz (Ubuntu Precise):
status: Confirmed → Triaged
Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
Changed in update-manager (Ubuntu Precise):
status: Confirmed → Triaged
Changed in update-manager (Ubuntu):
importance: Undecided → High
Changed in update-manager (Ubuntu Precise):
importance: Undecided → High

This still happens on Ubuntu 13.10 (64 bit)

Curiously, I don't recall this happening on 13.04 or earlier.

Leo B. (fuzzbuntu) wrote :

I am observing this bug since 13.04. If I start update-manger via a python debugger (pdb), it works and shows its windows properly, although it's slow as hell. If started normally, it doesn't show its window no matter if it has started automatically or manually. A similar bug seems to affect automated starts of deja-dup since 13.10.

Colan Schwartz (colan) on 2015-01-09
tags: added: trusty
Colan Schwartz (colan) wrote :

This looks like a duplicate of bug #1003950, but that one has been "fixed", and this is still an issue so I'm not marking it as such. Let's do any remaining work in here to have this really fixed.

Benjamin Schmid (benbuntu) wrote :

Having this issue frequently also on trusty. I'm a single-session user, but my user session runs for weeks. 2 monitor setup if that matters. I have to close & manually reopen on nearly every instance. Annoying.

Niklas Wenzel (nikwen) wrote :

I can confirm that this happens when the screen is locked.

This is actually a Unity issue in how it handles the unmapped Software Updater window. I'm able to reproduce the issue using the instructions in https://bugs.launchpad.net/compiz/+bug/1003950/comments/87.

I think I have a fix and will propose the solution very soon.

affects: compiz (Ubuntu) → unity (Ubuntu)
no longer affects: update-manager (Ubuntu)
no longer affects: update-manager (Ubuntu Precise)
Changed in unity:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
milestone: none → 7.3.3
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Christopher Townsend (townsend)
tags: added: utopic vivid wily
removed: quantal raring
tags: removed: compiz-0.9
Josh (majik) wrote :

Wow, this semi-critical bug only took two years to be acknowledged by someone who can execute on it!

That's got to be a record for Ubuntu.

Timo Aaltonen (tjaalton) wrote :

critical? hardly..

great to see it fixed!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150819-0ubuntu1

---------------
unity (7.3.2+15.10.20150819-0ubuntu1) wily; urgency=medium

  [ Andrea Azzarone <email address hidden> ]
  * Do not handle events coming from viewports not actually containing
    the window. (LP: #1449654)

  [ Chris Townsend ]
  * Also use the Compiz show() method when forcing an unmapped window to
    be visible when clicking on it's active Launcher icon. (LP: #989588)
  * When using keyboard navigation in the Dash, skip category headers
    that are not expandable. Also, do not highlight the category header
    when the mouse cursor is over it. (LP: #1045933)

  [ Marco Trevisan (Treviño) ]
  * ApplicationManager: rely on windows monitor property changes for
    updating Pips (LP: #1027191)
  * Autopilot: modernize some tests, use stronger methods to ensure
    false positive
  * DecorationsForceQuitDialog: override the background of the window
    with transparent color (LP: #1470292)
  * Launcher: Always unfold an active icon (LP: #1472339)
  * PanelMenuView: ensure that we connect to window signals as soon as
    the AppManager knows it (LP: #1472326)
  * PlacesGroup: connect to view changes using a function instead of a
    lambda (LP: #1470298)
  * SessionButton: set button opacity to 75% when pressed (LP: #1301655)

 -- CI Train Bot <email address hidden> Wed, 19 Aug 2015 14:45:18 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2015-10-23
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello Timo, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → High
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Josh (majik) wrote :

Thank you for fixing.

To post a comment you must log in.