HUD: The selection always returns to the first item whenever menus are updated

Bug #962984 reported by Łukasz Zemczak on 2012-03-23
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Gord Allott
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

After opening the HUD and typing in any search entry, navigating though the results is impossible using the keyboard. Whenever I go down in the displayed entries, wanting to select an entry that's not the first search result, the selection gets automatically changed to the first entry after half-a second. The first entry is getting highlighted always after a short delay, whenever I try selecting something else in the HUD. This happens regardless of whether the search for entries is still done - even when all results are found.

Reproducing:
 - Open up the HUD for any application
 - Type in any string that returns more than one result
 - Try selecting (highlighting) the last search result using the arrow keys

Actual result;
 - The last search result gets highlighted (selected) for a moment and the selection gets back to the first search entry again

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0+bzr2164ubuntu0+670 [origin: LP-PPA-unity-team-staging]
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 1.95-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,gnomecompat,grid,mousepoll,regex,move,resize,wall,place,imgpng,compiztoolbox,snap,vpswitch,animation,workarounds,unitymtgrabhandles,session,fade,scale,expo,ezoom,unityshell]
CrashDB: unity
Date: Fri Mar 23 11:43:25 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=pl:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-01-31 (51 days ago)

Related branches

Łukasz Zemczak (sil2100) wrote :
Omer Akram (om26er) wrote :

can you please make a video of the issue you see and attach it to the bug.

Changed in unity:
status: New → Incomplete
Omer Akram (om26er) wrote :

Uh, oh, that's nasty :/

Changed in unity:
status: Incomplete → New
Omer Akram (om26er) wrote :

I wonder if that have something to do with your locale. tried with english? maybe guest session?

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Oren_B (oren.barnea) wrote :

I have this bug as well when I'm logged in as my normal user, but it does not happen when I'm in a guest session.
My normal user has English interface but Hebrew keyboard layout is also enabled - but the bug happens when the active layout is US.
Here's the output of "export | grep LANG ", for my normal user in case it's relevant:

declare -x LANG="en_US.UTF-8"
declare -x LANGUAGE="en_US:en"

James Dupin (james.dupin) wrote :

same problem but slightly different reaction.

bug appears with the guest session but it does stop and restart meaning:
log in as guest (other account still logged in)
HUD > write > select with arrow down
after a a few tries, the selection is working (not coming back to the first entry) then all of a sudden it defaults to first one again and so on.

french keyboard. I tried with a US layout, same.

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

James Dupin (james.dupin) wrote :

my OS is an upgrade from 10.10 to 12.04.

Just figured out that it may come form the upgrade.

Indeed, I do not have any problem with a brand new user.

Michael (amemain) wrote :

Yes this bug is driving me crazy... also reported here => #966632

Michael (amemain) wrote :

I also do not have this in the Guest Account. Tried different KB languages etc, does not fix the main account.

Changed in unity:
status: Incomplete → Confirmed
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Michael (amemain) wrote :

I have found the issue, give me two seconds.

Michael (amemain) wrote :

The HUD navigation response is directly correlated to what is running in the indicator bar.

I had the following running:

Indicator-Mutliload
Psensor
PS3 Media Server
Indicator Weather

I quit Indicator Multiload and when arrowed down in them menu the selection remained for a few seconds before moving back up. It appears that when the added indicators refresh the force the HUD to refresh back the top position.

I deleted the rest and it fixed itself. I can now move through the menu bar without an issue.

I will re-apply the indicators and see what I can use and what I can't. Google-Music-Manager so far is running and is not causing a issue.

Michael (amemain) wrote :

Psensor and Indicator-Multiload both cause the issue.

PS3 Media Server and Weather-Indicator do NOT effect the HUD.

Jan Nekvasil (jan-nekvasil) wrote :

The selection returns to top whenever any item in whole menu structure is updated. So it depends on refresh interval of indicators like indicator-mutliload.

summary: - HUD keyboard navigation not possible, top entry always gets re-selected
+ HUD: The selection always returns to the first item whenever menus are
+ updated
palimmo (palimmo) wrote :

Same problem.
I have Indicator multiload active.

Jean-Philippe Orsini (jfi) wrote :

For Psensor at least, my guess is that it is due to menu items which are refreshed periodicaly.

Until I found a fix for this issue, you can increase the graph refresh duration (which is used also as indicator refresh period), it will limit the impact.

Łukasz Zemczak (sil2100) wrote :

I can confirm that after disabling indicator-multiload, the problem no longer occurs. So it's related to the refresh duration as everyone else mentions already.

Sebastien Bacher (seb128) wrote :

Unity should probably freeze the model it's using when the ui is open to avoid those issues, raising to high, it's less frequent without indicators like multiload but still nm applet and others do frequent updates and that's a bad user experience

Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Jean-Philippe Orsini (jfi) wrote :

I did not find any way to workaround at application level (for Psensor) this issue.
My idea was to update only once the menu label when the application indicator menu is popup but I did not find any gtk signals for this purpose and the menu widget is alway flagged as visible even when not...

Didier Roche (didrocks) on 2012-04-09
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Changed in unity:
milestone: none → 5.10.0
desrt (desrt) wrote :

two possible fixes, both in unity:

1) keep the cursor in the same physical position when the list updates

2) look at the item key (which is just a 64bit integer these days) of the item that was selected before refreshing the list and search for that item in the new list, causing it to be the new highlighted item

one more possible fix in the backend (but will only help with some cases):

scan the old list and the new list for being equal and don't send updates in that case

Gord Allott (gordallott) on 2012-04-11
Changed in unity:
assignee: nobody → Gord Allott (gordallott)
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
palimmo (palimmo) wrote :

Solved!

palimmo (palimmo) wrote :

HUD works... but there is still an "interference" with Indicator multiload (icon and command).
But it is usable.

Have you noticed that?

Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
palimmo (palimmo) wrote :

HUD works... but there is still an "interference" with Indicator multiload (icon and command).
Here an image.

Sebastien Bacher (seb128) wrote :

@palimmo: could you open a new bug report? is that only happening when using multiload?

palimmo (palimmo) wrote :

No.. it happens also with VLC, weather-indicator, Skype, GoldenDict, gm-notify.. probably every app that shows something in the notification area.
Yes.. I open a new bug.

Didier Roche (didrocks) on 2012-04-24
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers