Topbar - window controls for maximised windows in the top bar should conform to Fitts's law

Reported by John Lea on 2011-09-02
118
This bug affects 52 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
High
Marco Trevisan (Treviño)
unity-2d
Low
Unassigned
unity-2d (Ubuntu)
Low
Unassigned
unity (Ubuntu)
High
Marco Trevisan (Treviño)

Bug Description

Close, maximize/unmaximize and minimize button for maximised windows in the top bar should conform to Fitts law.

Desired solution:
- In addition to clicking directly on the 'close' window decoration, clicking anywhere to the left and above the 'close' window decoration (all the way to the top left pixel) should also trigger the 'close' action. The same goes for the other two (maximize/unmaximize and minimize) buttons. They should be clickable from the top edge of the screen (see bug #874980 for more details).

John Lea (johnlea) on 2011-09-02
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
tags: added: onew udo
Changed in ayatana-design:
importance: Undecided → Low
status: New → Fix Committed
Paul Sladen (sladen) wrote :

Enabling the left edge pixel to activate the maximised close button is probably a bad idea. The close button can result in lose of state (or work) for the user involved.

In a maximised workflow the "Fitts Law" property of the Top-Left pixel is being used to show the Launcher; in the version of Unity shipped with 11.04 hitting this pixel caused for the Launcher to show *instantly*, rather than with the delay from purely hitting the left edge.

IMHO; if this is enabled for the left-edge pixels, it should still remain disabled for the very top-left edge corner pixel. So that a flick of the mouse and accompanied by a click will not cause the present window to vanish. None of the other corners have this unique risk, and I don't believe it's valuable to enable it for the close button.

If it was minimise or maximise it would be fine, as these are reversible actions, but close is not.

John Lea (johnlea) wrote :

Relevant comment by Stefanos A to Ayatana discussion list:

"I would like to bring to your attention a design issue with the new unity buttons for maximized windows. The issue is that the buttons do not touch the edges of the screen, which cause two different problems:

1. They are inconsistent with the indicators on the other side of the top panel, which *do* extend to the edge of the screen.
2. They make closing windows quite difficult. If the X button extended all the way to the cornern, we'd be able to through the mouse to the corner and click. Right now, we have to move the mouse to the corner and move it again to target the button. This is especially difficult on smaller touchpads, like the one on my dm1z, where I consistently have to try two or three times to hit the button.

Since closing windows is one of the most common actions I tend to perform, I'd love to see this fixed."

Omer Akram (om26er) on 2011-09-05
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
The Fiddler (stapostol) wrote :

Paul Sladen (sladen) wrote on 2011-09-03:
> Enabling the left edge pixel to activate the maximised close button is probably a bad idea. The close button can > result in lose of state (or work) for the user involved.

This is definitely not true, since applications are supposed to ask you to save if you have unsaved work. As far as I can tell, this holds true for all applications that ship in the Ubuntu cd.

My suggestion: fix the issue as per the bug's description and file bug reports to misbehaving applications. Workarounds for broken applications shouldn't impact well-behaved ones.

Olli Kankare (o.k) wrote :

Easy fix: move the window control buttons to the right side like they should be.

Omer Akram (om26er) on 2011-09-21
Changed in unity:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
John Lea (johnlea) on 2011-09-28
Changed in ayatana-design:
status: Fix Committed → Fix Released
Dan Quade (danquade) on 2011-10-16
summary: - Topbar - close button for maximised windows in the top bar should
+ Topbar - window controls for maximised windows in the top bar should
conform to Fitts law
description: updated
description: updated
summary: Topbar - window controls for maximised windows in the top bar should
- conform to Fitts law
+ conform to Fitts's law
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: none → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
Denis Washington (dwashington) wrote :

Sorry for my ignorance, but does "Fix Commited" mean that this is fixed in current Ubuntu 11.10? Or will this only go into Precise?

Gerry Boland (gerboland) on 2011-11-14
Changed in unity-2d:
assignee: nobody → Lohith D Shivamurthy (dyams)
status: New → Triaged
importance: Undecided → Low
Gerry Boland (gerboland) on 2011-11-19
Changed in unity-2d:
milestone: none → 5.2
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-11-28
Changed in unity-2d (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in unity-2d:
assignee: Lohith D Shivamurthy (dyams) → nobody
Didier Roche (didrocks) on 2012-01-12
Changed in unity-2d:
milestone: 5.2 → 5.4
Marcus Moeller (marcus.moeller) wrote :

This misbehavior is still not fixed in the Ubuntu 12.04 daily from 20120126.

As mentioned before, it should be possible to push the mouse into the upper left edge and click to close a maximized window. Right now you have to focus the close button exactly.

@Paul Sladen: i guess you got it wrong, it's not that just moving the mouse to the upper left corner should release a window close, but moving it to the upper left corner AND clicking.

Omer Akram (om26er) wrote :

In Windows7 closing a maximized window is sweet, having that in Ubuntu will also be cool.

Changed in unity:
assignee: Neil J. Patel (njpatel) → nobody
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → nobody
John Lea (johnlea) on 2012-02-03
Changed in ayatana-design:
importance: Low → Medium
Changed in unity:
importance: Low → Medium
Changed in unity-2d:
status: Triaged → Fix Released
Changed in unity-2d (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) wrote :
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Low → High
John Lea (johnlea) on 2012-02-21
Changed in ayatana-design:
importance: Medium → Critical
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
milestone: backlog → 5.6.0
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Alexandre Otto Strube (surak) wrote :

I would not classify it as "released" for unity 2d, as I am using the fully updated 12.04 in march 6th, 2012 and still have the issue.

Alexandre Otto Strube (surak) wrote :

Correction: for normal unity. For ubuntu-2d it works as expected.

Omer Akram (om26er) on 2012-03-09
Changed in unity (Ubuntu):
status: Triaged → In Progress
Didier Roche (didrocks) on 2012-03-12
Changed in unity:
milestone: 5.6.0 → 5.8.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-20
tags: added: reviewedbydesignp
Changed in ayatana-design:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-20
tags: removed: udo udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers