Launcher - Open Trash window prevents Nautilus being launched when a user clicks on the Nautilus Launcher icon

Reported by dmandell on 2011-04-07
146
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

Binary package hint: unity

When I click the Trash icon on the launchbar in Unity it opens a trash folder, if I then click the Home icon in the launch bar, nothing happens. I'd expect it to open a window with the contents of the Home folder. I tried right-clicking the Home icon hoping that I might be able to launch it that way (which works in DockBarX), but that doesn't help either. Essentially once the Trash folder is open the Home button is disabled. This is inconsistent with the way the Trash button works (I can launch multiple Trash folders by clicking the Trash icon). This is doubly painful because the new top menu can't seem to find any folder I type in (i.e. /home/username doesn't find the appropriate folder), so there's no easy way to open a folder through the interface now.

Desired resolution:
- If the Trash is open, but no other Nautilus window is open, clicking on the Nautilus launcher icon should open a new Nautilus window.
- If Nautilus window(s) (other than the trash) are open but not focused, clicking on the Nautilus launcher icon should bring the most recently focused Nautilus window back into focus.

Related branches

lp:~3v1n0/unity/application-filemanager-integration
Merged into lp:unity at revision 3263
PS Jenkins bot: Approve (continuous-integration) on 2013-03-29
Brandon Schaefer: Approve on 2013-03-29
Mohsin Falak (fi8er1) on 2011-04-15
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Paul Sladen (sladen) wrote :

Confirmed. Although interestingly, the opposite doesn't happen. If Nautilus is open via the .desktop in the Launcher (Home icon) then the trash can continue to be clicked.

Mohsin Falak (fi8er1) wrote :

This seems to be the actual design of the File Browser. Because Trash is already opened in the File Browser. So, another browser cannot be opened.
The bug over here seems to be that when we press the Home Folder Icon (trash already opened) the File Browser must now show the Home Folder Contents.

Paul Sladen (sladen) wrote :

See also bug #769515 ('"Home Folder" icon does not open home folder if any other Nautilus window is already open').

Sebastien Bacher (seb128) wrote :

Ok, Mark wrote on the duplicate

"The Home Folder icon on the launcher should always open the Home folder
when clicked. If a previous invocation, or Trash, or other windows are
open and pointed elsewhere, then a new window should open with the Home
folder."

Marking design task as fix released (see Mark's comment: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/769515/comments/3)

Changed in ayatana-design:
status: New → Fix Committed
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

it might be a duplicate of bug #766857 or at least similar

John Lea (johnlea) on 2011-04-28
tags: added: udo
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Medium
summary: - Open Trash window prevents launching Home folder from launch bar in
- Unity
+ Clicking on nautilus launcher icon should always open a new window
Jason Smith (jassmith) on 2011-05-05
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)
milestone: none → alpha1
John Lea (johnlea) on 2011-05-06
Changed in ayatana-design:
importance: Medium → High

probably the left click could stay the same, and a reight click context menu
should contain an option to start it again (new window) in the you would
like to

2011/5/6 John Lea <email address hidden>

> ** Changed in: ayatana-design
> Importance: Medium => High
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (758341).
> https://bugs.launchpad.net/bugs/753938
>
> Title:
> Clicking on nautilus launcher icon should always open a new window
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ayatana-design/+bug/753938/+subscribe
>

--
Fábio Leitão
..-. .- -... .. --- .-.. . .. - .- --- ...-.-

how is the fix released? I still exerpeince the issue, 11.04, all packages upgraded to latest...

Andrea Azzarone (andyrock) wrote :

@Akos: it is fixed just for ayatana-design and not for unity.

John Lea (johnlea) on 2011-06-21
summary: - Clicking on nautilus launcher icon should always open a new window
+ When the Trash is open, but no other Nautilus window is open, clicking
+ on the Nautilus launcher icon should open a new Nautilus window
description: updated
summary: - When the Trash is open, but no other Nautilus window is open, clicking
- on the Nautilus launcher icon should open a new Nautilus window
+ Open Trash window prevents launching Home folder from launch barWhen the
+ Trash is open, but no other Nautilus window is open, clicking on the
+ Nautilus launcher icon should open a new Nautilus window
summary: - Open Trash window prevents launching Home folder from launch barWhen the
- Trash is open, but no other Nautilus window is open, clicking on the
- Nautilus launcher icon should open a new Nautilus window
+ Open Trash window prevents Nautilus being launched when a user clicks on
+ the Nautilus Launcher icon
Didier Roche (didrocks) on 2011-06-22
Changed in unity:
milestone: 4.0.1 → 4.2.0
Jorge O. Castro (jorge) on 2011-07-01
tags: added: backlog
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Omer Akram (om26er) on 2011-09-24
Changed in unity (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in unity:
milestone: 4.8.0 → backlog
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) wrote :

not yet, but patches most gratefully accepted ;-)

Tim Penhey (thumper) on 2012-09-14
Changed in unity:
milestone: backlog → none
Tim Penhey (thumper) on 2012-09-14
tags: added: exbacklog
John Lea (johnlea) on 2012-10-08
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Changed in unity (Ubuntu):
assignee: Jason Smith (jassmith) → nobody
status: Confirmed → Triaged
Changed in unity:
status: Confirmed → Triaged
summary: - Open Trash window prevents Nautilus being launched when a user clicks on
- the Nautilus Launcher icon
+ Launcher - Open Trash window prevents Nautilus being launched when a
+ user clicks on the Nautilus Launcher icon
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
importance: High → Medium
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 7.0.0
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity at revision None, scheduled for release in unity, milestone backlog

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 6.12.0daily13.04.01-0ubuntu1

---------------
unity (6.12.0daily13.04.01-0ubuntu1) raring; urgency=low

  [ Marco Trevisan (Treviño) ]
  * Launcher starts with default size then jumps to configured one on
    login (LP: #1099815)
  * Launcher - Open Trash window prevents Nautilus being launched when a
    user clicks on the Nautilus Launcher icon (LP: #753938)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 3263
 -- Ubuntu daily release <email address hidden> Mon, 01 Apr 2013 04:02:55 +0000

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Alfred Neumayer (beidl) wrote :

This change causes some serious inconsistency in the way users interact with the launcher.
I've filed a bug on this here: #1163041

Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
status: Fix Committed → Fix Released

This solution creates a BIG usability issue when working with removable devices. It makes ultra improper navigation between them and the home folder. It is conceptually very complicated to the user to understand what is actually going on and how windows are being open.

Consider reverting this change. Renaming the "home folder" icon in the dash to "files" will be enough to the user to not expect the icon to launch the home folder every time this icon is clicked.

https://bugs.launchpad.net/unity/+bug/1171178

John Lea (johnlea) on 2013-06-20
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints