indicators are mis-aligned

Reported by Omer Akram on 2010-09-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Low
Neil J. Patel
unity (Ubuntu)
Low
Unassigned

Bug Description

when an indicator is clicked. the GtkMenu that pops is not aligned with the indicator menu. the attached image shows it clearly

Omer Akram (om26er) wrote :
David Barth (dbarth) wrote :

Hi, I don't understand the mis-alignment issue you're reporting. Menuitems are indented on the right, by design, to keep space available for checkmarks and other radio items in the menus. Is there a more subtle alignment issue i'm not seeing?

Changed in unity:
status: New → Incomplete
Omer Akram (om26er) wrote :

I have highlighted the mis-aligned part

Yes, there is a two-pixel misalignment when the menu is not pressed up
against the right edge of the screen. Click on your leftmost indicator,
make sure the resulting menu is not up against the right edge of the
screen, and look very closely at the highlight edge around the indicator
icon and the transition from that to the menu edge on the left, below
the panel.

Mark

Omer Akram (om26er) wrote :
Omer Akram (om26er) on 2010-12-01
Changed in unity:
status: Incomplete → Confirmed
Neil J. Patel (njpatel) wrote :

This is caused by not taking the 2x padding into account when emitting the clicked signal (with the x/y of the menuitem), so we send the actual menuitem's x, but not the x of what we draw. This can be fixed in src/PanelIndicatorObjectEntryView.cpp::OnMousePress

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Low
milestone: none → 3.2.6
status: Confirmed → Triaged
tags: added: bitesize
Neil J. Patel (njpatel) on 2010-12-07
Changed in unity:
status: Triaged → Fix Committed
Omer Akram (om26er) on 2010-12-09
affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers