[dash] Keyboard navigation not implemented as specified

Bug #608132 reported by David Siegel on 2010-07-21
138
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
John Lea
Unity
Fix Released
High
Gord Allott
unity-2d
High
Florian Boucault
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Dash keyboard navigation (e.g. tabbing between groups, using arrow keys to select items, pressing enter to activate items) is not implemented. Please see the Dash prototype that Florian has built (it is available as a PPA) for details of the desired functionality.

Related branches

David Barth (dbarth) on 2010-07-27
Changed in unity:
milestone: none → backlog
David Barth (dbarth) on 2010-08-16
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
milestone: backlog → 2010-08-19
Neil J. Patel (njpatel) on 2010-08-18
Changed in unity:
milestone: 2010-08-19 → 2010-08-26
Neil J. Patel (njpatel) on 2010-08-20
Changed in unity:
milestone: 2010-08-26 → 2010-09-02
status: New → Triaged
Neil J. Patel (njpatel) on 2010-09-05
Changed in unity:
milestone: 2010-09-02 → 2010-09-16
Christian Giordano (nuthinking) wrote :

Just tried to tab navigation as soon as it launches (I was expecting to go through the main categories) but after few tabs, it crashes.

Changed in ayatana-design:
importance: Undecided → High
Neil J. Patel (njpatel) on 2010-09-16
Changed in unity:
milestone: 2010-09-16 → 2010-09-22
Neil J. Patel (njpatel) wrote :

This will be valid by A2

Changed in unity:
milestone: 2010-09-22 → 3.2.4
importance: Medium → High
Neil J. Patel (njpatel) on 2010-12-02
Changed in unity:
milestone: 3.2.4 → 3.4
John Lea (johnlea) on 2010-12-15
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
description: updated
tags: added: udn-launcher udt
Changed in ayatana-design:
status: New → Triaged
importance: High → Critical
John Lea (johnlea) on 2010-12-16
tags: added: udn-dash
removed: udn-launcher
John Lea (johnlea) on 2010-12-16
description: updated
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
milestone: 3.4 → 3.6
Changed in unity-2d:
status: New → Triaged
importance: Undecided → High
milestone: none → 3.6
summary: - Keyboard navigation not implemented as specified
+ [dash] Keyboard navigation not implemented as specified
Changed in unity-2d:
milestone: 3.6 → 3.8
Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu):
status: New → Triaged
Neil J. Patel (njpatel) on 2011-02-28
Changed in unity:
assignee: Neil J. Patel (njpatel) → Gord Allott (gordallott)
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.0-0ubuntu1

---------------
unity (3.6.0-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Menu bar becomes blank periodically (LP: #683065)
    - Unity does not update when screen resolution changes (LP: #684539)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Dash - build the Desktop Dash (LP: #683719)
    - Quicklists not working (LP: #719780)
    - Launcher auto hide animation has a life of it's own / Unity launcher
      constantly sliding in and out without user interaction (LP: #717364)
    - compiz crashed with SIGSEGV in PrivateWindow::getModalTransient()
      (LP: #726235)
    - Don't show launcher number overlays on tap of super (LP: #726630)
    - Optimize texture memory usage for unexposed view icons (LP: #609994)
    - Unity should handle video-out keycodes that correspond to Super + P +
      Enter (LP: #632632)
    - dash - wrong count of remaining items to see (LP: #662605)
    - dash - x search box button visibility (LP: #662614)
    - Touch window management gesture previews (LP: #683688)
    - unity not working on rotated displays (LP: #694596)
    - unity main top bar in displays in wrong area (multi-head issue)
      (LP: #707209)
    - unity place group visual improvements (LP: #714528)
    - Implement ref_state_set for toplevel ATK objects in the panel service
      (LP: #715299)
    - Alt + F1 doesn't show the launcher if hidden (LP: #717125)
    - Keyboard navigation: Choosing a window from launcher doesn't change
      input focus. (LP: #721811)
    - Quicklists not closing when losing focus (LP: #724739)
    - wrong animation in the launcher (LP: #724956)
    - Window management - windows go below launcher and panel (LP: #725463)
    - Media and PrintScreen keys don't work (LP: #621887)
    - super-shortcuts should be "serializable" (LP: #638936)
    - Chromium icon in Unity is distorted / some scaled distored in the unity
      place applications (LP: #670169)
    - launcher stays on screen when it shouldn't | false show/hide positives
      on the launcher (LP: #711176)
    - Keyboard navigation: no public API to know the current Laucher Icon
      selected when key nav is activated (LP: #722660)
    - Require to implement AtkSelection on the Launcher (LP: #723804)
    - LauncherIcon accessibility support requires to expose the selection
      state (LP: #723806)
    - Add keyboard shortcuts for launching separate instances of applications
      (LP: #724865)
  * debian/control:
    - dep on latest nux
 -- Didier Roche <email address hidden> Tue, 01 Mar 2011 14:27:16 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
John Lea (johnlea) wrote :

Tested and not working.

- on entering a dash lens (e.g. the file lens) nothing happens in response to pressing the cursor keys
- pressing Tab selects the first item underneath *all* dash headers. The horizontal cursor keys then move the selection, but three items are selected (only one item should be selected at a time)
- Sometimes even pressing Tab does nothing
- inability to launch selected item by pressing return

Alejandro Piñeiro (apinheiro) wrote :

And related to this (please forgive me if this is not the proper place to ask this)

Anyone knows if there is a key combination to open the dash ? (in the same way that pressing Alt+F1 opens the Launcher).

I was not able to find it, and this should be also required in order to have a full dash keyboard navigation

I believe the super key opens the dash, at least thats what I found when playing with unity trunk yesterday.

Alejandro Piñeiro (apinheiro) wrote :

Yes you are right I have just tested the Super key, and it opens the dash.

Thanks

John Lea (johnlea) on 2011-03-11
Changed in unity:
status: Fix Released → Triaged
Changed in unity (Ubuntu):
status: Fix Released → Triaged
tags: added: delta-with-3d
Changed in unity-2d:
milestone: 3.8 → 3.10
Changed in unity-2d:
milestone: 3.10 → none
Gord Allott (gordallott) on 2011-03-23
Changed in unity:
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-24
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: 3.6 → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
John Lea (johnlea) on 2011-04-04
Changed in ayatana-design:
status: Triaged → Fix Released
John Lea (johnlea) on 2011-04-18
tags: added: reviewedbydesign
removed: udt
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Triaged
tags: added: iso-testing
Saxfusion (saxfusion) wrote :

I do still see this bug (no tab or arrow navigation in unity search (Super or Super+A key)) in Ubuntu 11.10 Alpha-2 (unity 4.2.0-0ubuntu1)

tags: added: a11y
Changed in unity-2d:
assignee: nobody → Florian Boucault (fboucault)
milestone: none → 3.8.12
Changed in unity-2d:
status: Triaged → In Progress
Changed in unity-2d (Ubuntu):
status: Triaged → In Progress
Changed in unity-2d:
status: In Progress → Fix Committed
Changed in unity-2d (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-07-28
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.5 KiB)

This bug was fixed in the package unity-2d - 3.8.12-0ubuntu1

---------------
unity-2d (3.8.12-0ubuntu1) oneiric; urgency=low

  [ Florian Boucault ]
  * Upstreamed patch 01_build_with_new_indicator.patch
  * do not run pkgbinarymangler to convert images to 8bit since this breaks
    the launcher icon background handling. (LP: #809205)
    (QT upstream bug: http://bugreports.qt.nokia.com/browse/QTBUG-4459)
  * debian/unity-2d.install:
    - install GSettings schemas into usr/share/glib-2.0/schemas
    - install GConf to GSettings conversion into usr/share/GConf/gsettings
  * debian/gconf/schemas/unity-2d.schemas:
    - remove GConf schema for /desktop/unity-2d/launcher/super_key_enable
    - remove GConf schema for /desktop/unity-2d/launcher/favorites
  * debian/20_unity-2d-gconf-default:
    - remove default value for /desktop/unity-2d/launcher/super_key_enable
    - remove default value for /desktop/unity-2d/launcher/favorites
  * debian/control:
    - add dependency on libdconf-qt-dev
    - add dependency on libnux-1.0-dev

  [ Didier Roche ]
  * New upstream release:
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - [launcher] Tiles background is white/grey instead of the color of the
      icon (oneiric only) (LP: #809205)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - Unity 2D should use dconf instead of gconf (LP: #692965)
    - [launcher] KDE3 Applications do not appear in launcher (LP: #719983)
    - ubuntu-bug showing that I am running unity-2D, when reporting from
      Compiz Unity interface (LP: #712343)
    - Apps pinned in launcher not retained between 2D and 3D Unity versions
      (LP: #746823)
    - [dash] Cannot have KDE4 applications as shortcuts on home screen
      (LP: #750081)
    - [panel] F10 shortcut does not navigate from application menu to
      indicators (LP: #772061)
    - [panel] F10 shortcut does not show application menu (LP: #777993)
    - [dash] Wine applications are not launched (LP: #794471)
    - [spread] GnomeBackground needs to use dconf to retrieve image path
      (LP: #805393)
    - [dash] transparency broken and graphical artifacts when using opengl
      backend (LP: #806019)
    - [dash] Enter no longer launches first item (LP: #811673)
    - [panel] navigation between application menus temporarily gives focus
      back to the application (LP: #717682)
    - [panel] Empathy's emotes not visible in panel menus (LP: #742822)
    - pgadmin3 not handled by unity-2d (LP: #800710)
    - [dash] slow rendering of background with opengl engine (LP: #806122)
    - [spread] Wallpaper is shifted by the width of the launcher (LP: #808712)
    - [launcher] Migrate gconf key /desktop/unity-2d/launcher/super_key_enable
      to dconf (LP: #810509)
    - [panel] application name cut when menu bar visible should use a fade
      (LP: #704615)
    - [panel] Window title could use a little fade (LP: #694924)
    - [launcher] Codeblocks doesn't appear in the list of applications
      (LP: #716524)
  * Fix typo in trigger (debian/unity-2d.triggers): (LP: #807358)
  * Install the apport hook in the right directory so that it's not laun...

Read more...

Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Lain_13 (lain-halfbit) wrote :

Things which doesn't work as I expect (I don't really know how they should):

- To move into list of icons you have to press down twice.
Actually it works fine when dash just opened but try to open "Media Apps" or "Internet Apps" and you will have to press down twice. You have to press it twice if you start typing app name and want to select one of suggested too.

- I have to move cursor down at all when I typing app name and want to select second or third one.
I tried usual Unity and when I started to type program name first program in the list were selected by default. So, I clearly seen which program will be started if I press enter. When I tried to chose another app with left-right keys cursor moved to that apps. I want to have same functionality in unity 2d too. There are almost no use for left-right navigation inside typed string because it's easier to press backspace few times and retype word properly then go to the right place and fix it. I thing navigation between apps is more important then ability to fix 1 wrong letter in the middle of 1-2 short words.

Colin Law (colin-law) wrote :

I am seeing this not quite fully working yet. Another example of this:
Press Super to bring up Dash
Press Down to select Media Apps and hit enter
Press Down, the search bar is deselected, nothing much seems to be selected (this noted by lain_halfbit above)
Press Down again, sometimes the first item in Most Frequently Used is selected (though as I write this I am unable to repeat this correct operation) but often nothing is selected, in which case press Right and the first item is selected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers