[5.8 pre staging] "sticky edge" option does nothing visible

Reported by Sebastien Bacher on 2012-03-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
High
Jason Smith
Unity Distro Priority
High
Unassigned
unity-2d
High
Albert Astals Cid
unity-2d (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Using r2142 turning on "sticky edge" (ie "launcher capture mouse" in cssm) doesn't have any impact on the unity behaviour...

-----
from design:

2012-03-20 13:56:32 JohnLea greyback, didrocks; if sticky edges are turned off, *all* sticky edges should be turned off. This is *different* from the push to reveal, so for example, with sticky
edges is switched 'off' and push to reveal is switched 'on', the pointer will still be held on the launcher edge so that the user can reveal the launcher. "Sticky edges" only refers to all the
sticky edge
behaviour that is *not* related to the launcher. This is all sp
2012-03-20 13:56:32 JohnLea ecified in some detail in the following spec https://docs.google.com/a/canonical.com/document/d/1b3CwE3Wemr347fTxNcu7ixEQBK4YD8JF2pyv5pxiY0U/edit

Additional note on 3d: currently if you set sticky edge to "no" and put your hidden launcher on the right, you can't reveal it. This is what needs to be fixed.

Note that when bug #931384 is fixed, this option will also turn off the top and bottom sticky edges.

Sticky edge need to be separated from launcher reveal resistance

Didier Roche (didrocks) on 2012-03-21
Changed in unity:
milestone: none → 5.8.0
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
milestone: none → 5.8
Changed in unity:
importance: Undecided → High
Changed in unity-2d:
importance: Undecided → High
Changed in unity-2d (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2012-03-21
description: updated
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
description: updated
Didier Roche (didrocks) on 2012-03-21
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks) on 2012-03-23
Changed in unity-2d:
milestone: 5.8 → 5.10.0
Didier Roche (didrocks) on 2012-03-23
summary: - [5.8 pre staging] "sticky edge" option does nothing
+ [5.8 pre staging] "sticky edge" option does nothing visible
John Lea (johnlea) on 2012-04-02
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: New → Fix Committed
tags: added: udp
description: updated
description: updated
Changed in unity-2d:
status: Confirmed → In Progress
Changed in unity-2d:
assignee: nobody → Albert Astals Cid (aacid)
status: In Progress → Fix Committed
Tim Penhey (thumper) on 2012-04-10
Changed in unity:
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-04-12
Changed in unity-2d:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 5.10.0-0ubuntu1

---------------
unity-2d (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - unity-2d-shell crashed with SIGSEGV in
      QCoreApplication::notifyInternal() (LP: #918566)
    - Unity-2d-shell crashes on startup on 64bit machines with 20+ tiles in
      launcher (LP: #967012)
    - Unity 2-d launcher doesn't hide or display properly (LP: #940590)
    - [dash] search terms aren't applied on lens change / dash show
      (LP: #947985)
    - [5.8 pre staging] "sticky edge" option does nothing visible
      (LP: #961285)
    - [dash] Maximise, then restore - much of background not removed from
      screen (LP: #968215)
    - [hud] shows up when using ctrl+alt and pressing alt first (LP: #972318)
    - [UIFe] Dash - No message displayed when no results are returned in the
      Dash (LP: #711199)
    - Missing lens shortcuts (Super-A, Super-F) (LP: #834078)
    - [dash] Unable to scroll Filter Results (LP: #920878)
    - [launcher] stays open if you mouseOut before reveal animation completes
      (LP: #943296)
    - HUD on wrong screen on mutli monitor system (LP: #947145)
    - [a11y] Orca reports "Shell" when opening HUD, Dash or Launcher
      (LP: #948033)
    - multimonitor: Please give me a way to turn off sticky monitor edges
      (LP: #946104)
    - [dash] Esc key behavior inconsistent with Unity (LP: #966121)
    - toggling the spread from the launcher does not work (LP: #968146)
    - unity-2d-shell crashed with SIGSEGV in KeyMonitor::registerEvents()
      (LP: #965464)
    - [Dash] Focus is lost when switching with the mouse (LP: #974235)
    - Multiple items selected in HUD list (LP: #948441)
    - Hud hides launcher even if set to always show (LP: #948960)
    - [launcher] Pointer reveal barrier should be 1 way only (LP: #960175)
    - [hud] connection to HUD being created on startup (LP: #965106)
    - [dash] On 1024x786 screen, dash not fullscreen so border truncated
      (LP: #967305)
  * debian/20_ubuntu-2d-gconf-default:
    - set a default key for HUD showing on Alt, in case unity-3d isn't
      installed or run before unity-2d.
  * debian/control:
    - bump libnux-2.0-dev to latest for ABI break
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 11:02:08 +0200

Changed in unity-2d (Ubuntu):
status: Confirmed → Fix Released
Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Nick Tait (jnick-tait) on 2012-04-26
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: reviewedbydesignp
removed: udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers