Showdesktoped window contents invisible in window spread

Reported by Jay Ó Broin on 2011-10-18
130
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Unity
High
Sam Spilsbury
Unity Distro Priority
High
Unassigned
unity (Ubuntu)
High
Sam Spilsbury

Bug Description

1. have two firefox windows opened
2. alt-tab until getting to "show desktop"
3. click on the firefox icon in the launcher to restore the last focused firefox window
4. click again on the firefox icon in the launcher
  -> the minimized window is scaled, but invisible (empty placeholder)

I'm using the Oneiric proposed channel, so it might have something to do with the latest updates to Unity or Compiz.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Oct 18 19:11:09 2011
DistUpgraded: Log time: 2011-09-13 11:04:09.297261
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 280.13, 3.0.0-12-generic, i686: installed
 nvidia-current-updates, 280.13, 3.0.0-12-generic, i686: installed
GraphicsCard:
 nVidia Corporation GT216 [GeForce GT 220] [10de:0a20] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: BFG Tech Device [19f1:113c]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110909)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
MachineType: Acer Aspire M1201
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=ab49ff83-e28a-460e-84bc-6bcddae18d1e ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-22 (26 days ago)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 08/21/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R03-B1
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: RS740DVF
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR03-B1:bd08/21/2008:svnAcer:pnAspireM1201:pvr:rvnAcer:rnRS740DVF:rvr:cvnAcer:ct3:cvr1.0:
dmi.product.name: Aspire M1201
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

lp:~smspillaz/unity/unity.fix_877778
Merged into lp:unity at revision 2245
Tim Penhey (community): Approve on 2012-04-06
Gord Allott: Pending requested 2012-04-06
Jay Ó Broin (ismise) wrote :
Omer Akram (om26er) wrote :

does that happen with every application all the time or is it specific to a few applications? are there any steps i could take to reproduce the problem here, since i have seen the problem at random and have not been able to find any steps.

Changed in unity:
importance: Undecided → Low
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
Didier Roche (didrocks) on 2012-02-02
summary: - Minimized window contents blank in window spread
+ Minimized window contents blank or invisible in window spread
description: updated
Changed in unity-distro-priority:
status: New → Fix Committed
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
importance: Low → High
Changed in unity (Ubuntu):
importance: Low → High
Changed in unity-distro-priority:
importance: Undecided → High

I believe that's specific to nvidia binary driver so I'll lower the priority for this one.

Changed in unity (Ubuntu):
importance: High → Medium
Changed in unity:
importance: High → Medium
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Petko Ditchev (pditchev) wrote :

I'd add that the expected behaviour is that minimized windows are not shown .

Tim Penhey (thumper) wrote :

In the current precise build (5.6)

CASE 1: invisible window - still occurs
CASE 2: blank window - this is fixed

Alistair Buxton (a-j-buxton) wrote :

I still get blank windows with 5.6.0-0ubuntu4

tags: added: rls-p-tracking
Tim Penhey (thumper) on 2012-03-20
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
tags: removed: rls-p-tracking
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Triaged → In Progress
Didier Roche (didrocks) on 2012-03-30
tags: added: rls-p-tracking
muhalifsirin (alperense) wrote :

This bug is present in a system 12.04 beta 2 using Nvidia proprietary drivers.

I would like to add one more thing. After minimizing all windows, if you click the relevant app's icon on task panel, it will only display one window. Rest of the minimized windows are lost.

palimmo (palimmo) wrote :

Same problem.
Nvidia G105M, Ubuntu 12.04 beta 2 64 bit.

Doug McMahon (mc3man) wrote :

For many nvidia user none of this was in issue in 12.04 until the upgrade to compiz (1:0.9.7.4-0ubuntu1)

Reverting back to compiz (1:0.9.7.2-0ubuntu4) & all windows, (min or shown) are displayed properly in scale (spread
With the current compiz , 9.7.4-0ubuntu1, if window deco is disabled or the /usr/bin/compiz-decorator command is unset then windows again will show correctly in scale/spread

palimmo (palimmo) wrote :

1:0.9.7.4-0ubuntu2 : same problem.
How can I revert to 1:0.9.7.2-0ubuntu4 ? I can't force to this version.

Didier Roche (didrocks) on 2012-04-06
Changed in unity:
status: In Progress → Fix Committed
milestone: none → 5.10.0
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

rev 2246 not fixed;

Changed in unity:
status: Fix Committed → Triaged
Changed in unity (Ubuntu):
status: Fix Committed → Triaged
Changed in unity:
importance: Medium → High
Changed in unity (Ubuntu):
importance: Medium → High
Maximilian Federle (ppd) wrote :

I'm seeing this bug with intel hardware. This is not specific to nvidia hardware.

I'm also seeing this with Intel hardware.

Maximilian Federle (ppd) wrote :

Update: With intel hardware and unity 5.10 from the testing ppa, the problem of the invisible windows is gone. I could not reproduce it so far.

palimmo (palimmo) wrote :

With NVIDIA hardware and unity 5.10 from the testing ppa, the problem of the invisible windows is NOT gone. I could reproduce it (i.e. with Terminal).

Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Sam Spilsbury (smspillaz) wrote :

The nvidia issues are different and have been split into bug 977189

summary: - Minimized window contents blank or invisible in window spread
+ Showdesktoped window contents invisible in window spread
description: updated
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
description: updated
Download full text (4.4 KiB)

I can also confirm the problem being gone on Intel hardware with Unity from
the staging ppa.

2012/4/9 Sam Spilsbury <email address hidden>

> ** Changed in: unity (Ubuntu)
> Assignee: (unassigned) => Sam Spilsbury (smspillaz)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/877778
>
> Title:
> Showdesktoped window contents invisible in window spread
>
> Status in Unity:
> Triaged
> Status in Unity Distro Priority:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> 2 cases:
> CASE 1: invisible window
> 1. have two firefox windows opened
> 2. alt-tab until getting to "show desktop"
> 3. click on the firefox icon in the launcher to restore the last focused
> firefox window
> 4. click again on the firefox icon in the launcher
> -> the minimized window is scaled, but invisible (empty placeholder)
>
> I'm using the Oneiric proposed channel, so it might have something to
> do with the latest updates to Unity or Compiz.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.24.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic i686
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory:
> '/proc/driver/nvidia/gpus/0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43
> PDT 2011
> GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: i386
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Tue Oct 18 19:11:09 2011
> DistUpgraded: Log time: 2011-09-13 11:04:09.297261
> DistroCodename: oneiric
> DistroVariant: ubuntu
> DkmsStatus:
> nvidia-current, 280.13, 3.0.0-12-generic, i686: installed
> nvidia-current-updates, 280.13, 3.0.0-12-generic, i686: installed
> GraphicsCard:
> nVidia Corporation GT216 [GeForce GT 220] [10de:0a20] (rev a2) (prog-if
> 00 [VGA controller])
> Subsystem: BFG Tech Device [19f1:113c]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110909)
> JockeyStatus:
> xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary,
> Disabled, Not in use)
> xorg:nvidia_current_updates - NVIDIA accelerated graphics driver
> (post-release updates) (Proprietary, Enabled, In use)
> MachineType: Acer Aspire M1201
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic
> root=UUID=ab49ff83-e28a-460e-84bc-6bcddae18d1e ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to oneiric on 2011-09-22 (26 days ago)
> XorgConf:
> Section "Device"
> Identifier "Default Device"
> Option "NoLogo" "True"
> EndSection
> dmi.bios.date: 08/21/2008
> dmi.bios.vendor: American Megatrends Inc.
> dmi...

Read more...

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
status: Fix Committed → Fix Released
palimmo (palimmo) wrote :

It seems solved now.
But.. does show desktop (through alt+Tab) work at the first "movement"? I have to repeat it twice to get the desktop....

Download full text (4.6 KiB)

It's because Show Desktop, when invoked for the second time, "unmininize"
all the windows. Because you already have some restored, it will look like
it did nothing. Not that I like this behaviour, though...

2012/4/13 palimmo <email address hidden>

> It seems solved now.
> But.. does show desktop (through alt+Tab) work at the first "movement"? I
> have to repeat it twice to get the desktop....
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/877778
>
> Title:
> Showdesktoped window contents invisible in window spread
>
> Status in Unity:
> Fix Released
> Status in Unity Distro Priority:
> Fix Committed
> Status in “unity” package in Ubuntu:
> Fix Committed
>
> Bug description:
> 1. have two firefox windows opened
> 2. alt-tab until getting to "show desktop"
> 3. click on the firefox icon in the launcher to restore the last focused
> firefox window
> 4. click again on the firefox icon in the launcher
> -> the minimized window is scaled, but invisible (empty placeholder)
>
> I'm using the Oneiric proposed channel, so it might have something to
> do with the latest updates to Unity or Compiz.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.24.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic i686
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory:
> '/proc/driver/nvidia/gpus/0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43
> PDT 2011
> GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: i386
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Tue Oct 18 19:11:09 2011
> DistUpgraded: Log time: 2011-09-13 11:04:09.297261
> DistroCodename: oneiric
> DistroVariant: ubuntu
> DkmsStatus:
> nvidia-current, 280.13, 3.0.0-12-generic, i686: installed
> nvidia-current-updates, 280.13, 3.0.0-12-generic, i686: installed
> GraphicsCard:
> nVidia Corporation GT216 [GeForce GT 220] [10de:0a20] (rev a2) (prog-if
> 00 [VGA controller])
> Subsystem: BFG Tech Device [19f1:113c]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110909)
> JockeyStatus:
> xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary,
> Disabled, Not in use)
> xorg:nvidia_current_updates - NVIDIA accelerated graphics driver
> (post-release updates) (Proprietary, Enabled, In use)
> MachineType: Acer Aspire M1201
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic
> root=UUID=ab49ff83-e28a-460e-84bc-6bcddae18d1e ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to oneiric on 2011-09-22 (26 days ago)
> XorgConf:
> Section "Device"
> Identifier "Default Device"
> Opti...

Read more...

Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 5.10.0-0ubuntu3

---------------
unity (5.10.0-0ubuntu3) precise-proposed; urgency=low

  [ Oliver Grawert ]
  * Enable subarch specific quilt support
  * add linaros disable_standalone-clients.patch to make unity build with GLES

  [ Didier Roche ]
  * remove a symlink and replace with a real file for
    debian/patches/series.<arch> as not supported in non v3 (and we don't
    want v3 format with full source upstream derived branch)

unity (5.10.0-0ubuntu2) precise-proposed; urgency=low

  [ Ricardo Salveti de Araujo ]
  * Enabling build with OpenGL ES2.0 support for ARM and disable maintainer
     mode on that arch to avoid -Werror failure (LP: #980544)

unity (5.10.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream release:
    - bamfdaemon crashed with SIGABRT in g_assertion_message() (LP: #926208)
    - We are using 1 bad hack for compiz hanging on startup (LP: #963264)
    - GConf backend steals glib events from compiz (LP: #965220)
    - when I closed QupZill brawser it crashed and then and then I sow
      worrning that compiz crashed but fire fox and chrome is estle working.
      gtk-window-decorator crashed with SIGSEGV in max_window_name_width()
      (LP: #948580)
    - compiz crashed with SIGSEGV in std::basic_string<...>::basic_string()
      from unity::launcher::HudLauncherIcon::HudLauncherIcon()::{lambda} from
      unity::UBusManager::OnCallback (LP: #964897)
    - unity-panel-service crashed due to heap corruption in g_free() from
      service_proxy_name_changed() [libindicator/indicator-service-
      manager.c:574] (LP: #969360)
    - Opening dash while an application is maximized makes unity completely
      useless, have to relogin (LP: #975103)
    - unity crash on alt-tab (LP: #975168)
    - Top bar - Menus should be condensed to fit panel/overlay of appmenu
      (LP: #655184)
    - Topbar - window controls for maximised windows in the top bar should
      conform to Fitts's law (LP: #839690)
    - [FFe, UIFe] Dash - When the Dash is open and there is a maximised app in
      the background, the top bar background should not disappear
      (LP: #839480)
    - Dash - The inner bottom left, bottom right and top right corners of the
      desktop dash border are rendered incorrectly (LP: #839476)
    - Showdesktoped window contents invisible in window spread (LP: #877778)
    - Maximized windows can be accidentally closed from wrong monitor.
      (LP: #865701)
    - Unity launcher on-screen corruption on resume from suspend with nVidia
      proprietary driver (LP: #915265)
    - Launcher - Inserting items into launcher makes unnecessary animations on
      other monitors (LP: #925021)
    - Far left character in panel (and launcher popups) distorted
      (LP: #927441)
    - Jenkins build failure: SetAcceptKeyNavFocusOnMouseEnter not declared
      (LP: #938037)
    - super+<unbound key> and sometimes super+<number> keys now cause launch
      to wedge with the key hints shown and retains focus instead of selecting
      the requested window (LP: #934084)
    - three-finger move does not move (Precise) (LP: #940612)
    - compiz crashed with SIGSEGV in std::__de...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Piotr Ostrowski (postrowski5) wrote :

About comment #19
I guess there is some "Show Desktop" flag inside. Maybe it should be cleared at some point when restoring windows via Alt+Tab or dash after "Show Desktop".

Didier Roche (didrocks) on 2012-04-17
Changed in unity-distro-priority:
status: Fix Committed → Fix Released

The bug is still reproducable in the up-to-date Ubuntu 12.10 (synaptic tells it is unity version 6.12).

Download full text (4.5 KiB)

It's been fixed for a long time but now it come back for revenge.

2013/3/13 vilbara <email address hidden>

> The bug is still reproducable in the up-to-date Ubuntu 12.10 (synaptic
> tells it is unity version 6.12).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/877778
>
> Title:
> Showdesktoped window contents invisible in window spread
>
> Status in Unity:
> Fix Released
> Status in Unity Distro Priority:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
>
> Bug description:
> 1. have two firefox windows opened
> 2. alt-tab until getting to "show desktop"
> 3. click on the firefox icon in the launcher to restore the last focused
> firefox window
> 4. click again on the firefox icon in the launcher
> -> the minimized window is scaled, but invisible (empty placeholder)
>
> I'm using the Oneiric proposed channel, so it might have something to
> do with the latest updates to Unity or Compiz.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: unity 4.24.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
> Uname: Linux 3.0.0-12-generic i686
> NonfreeKernelModules: nvidia
> .proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory:
> '/proc/driver/nvidia/gpus/0'
> .proc.driver.nvidia.registry: Binary: ""
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27
> 16:55:43 PDT 2011
> GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu3
> Architecture: i386
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> CompositorRunning: compiz
> Date: Tue Oct 18 19:11:09 2011
> DistUpgraded: Log time: 2011-09-13 11:04:09.297261
> DistroCodename: oneiric
> DistroVariant: ubuntu
> DkmsStatus:
> nvidia-current, 280.13, 3.0.0-12-generic, i686: installed
> nvidia-current-updates, 280.13, 3.0.0-12-generic, i686: installed
> GraphicsCard:
> nVidia Corporation GT216 [GeForce GT 220] [10de:0a20] (rev a2) (prog-if
> 00 [VGA controller])
> Subsystem: BFG Tech Device [19f1:113c]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110909)
> JockeyStatus:
> xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary,
> Disabled, Not in use)
> xorg:nvidia_current_updates - NVIDIA accelerated graphics driver
> (post-release updates) (Proprietary, Enabled, In use)
> MachineType: Acer Aspire M1201
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic
> root=UUID=ab49ff83-e28a-460e-84bc-6bcddae18d1e ro quiet splash vt.handoff=7
> SourcePackage: unity
> UpgradeStatus: Upgraded to oneiric on 2011-09-22 (26 days ago)
> XorgConf:
> Section "Device"
> Identifier "Default Device"
> Option "NoLogo" "True"
> EndSection
> dmi.bios.date: 08/21/2008
> dmi.bios.vendor: American Megatrends I...

Read more...

To post a comment you must log in.