[FFE] All launcher icons should be moveable except trash and BFB

Reported by Adam Solino on 2011-04-14
190
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Medium
Marco Trevisan (Treviño)
unity-2d
Wishlist
Unassigned
unity (Ubuntu)
Medium
Unassigned

Bug Description

== CHANGE ==
The Workspace Switcher icon in the Unity bar cannot be moved. Icons below the Workspace icon can be rearranged but not move above the Workspace icon. Additionally, icons above the Workspace icon can be rearranged, but not moved below the Workspace icon. This limits customization of the unity bar.

Desired solution:
- A user should be able to re-order all launcher icons other than the Trash and the BFB to any other location on the Launcher. This includes Workspaces, individual Dash Lenses, and removable storage icons.

- A user should be able to remove both the Workspace icon and the Dash Lens icons from the Launcher. However the Trash and BFB can never be removed from the Launcher.

== TESTING ==
The new functionality is covered by unit tests and manual tests.

== WHY? ==
The design specifications define this behavior since long, but this was never actually introduced in code. It is also a very intuitive behavior. Besides this, the introduced change does not change the existing functionality in any way that could confuse users, since all existing rules applying up until now are still valid. It is just an enhancement.

Original description:

The Workspace Switcher icon in the Unity bar cannot be moved. Icons below the Workspace icon can be rearranged but not move above the Workspace icon. Additionally, icons above the Workspace icon can be rearranged, but not moved below the Workspace icon. This limits customization of the unity bar.

Desired solution:
- A user should be able to re-order all launcher icons other than the Trash and the BFB to any other location on the Launcher. This includes Workspaces, individual Dash Lenses, and removable storage icons.

- A user should be able to remove both the Workspace icon and the Dash Lens icons from the Launcher. However the Trash and BFB can never be removed from the Launcher.

- Both the workspace icon and the Dash Lenses should be accessible via the Dash App Lens. A user must be able to search for say "Workspaces" in the Dash and then drag and drop the Workspaces icon back into the launcher.

Aritchie (aritchie) wrote :

You are talking about Unity and not Unity-2d correct?

Adam Solino (adam-solino) wrote :

Yes, Unity and not Unity-2d. Sorry for the confusion.

Olivier Tilloy (osomon) wrote :

This actually seems to affect both projects, although unity and unity-2d behave slightly differently:

 - in unity, applications and lenses can be re-organized, as long as they remain in their "family" of tiles
 - in unity-2d, only applications can be re-organized, and like in unity, they must remain in their family of tiles

summary: - [Launcher] -Unity Workspace Switcher icon cannot be moved
+ [launcher] Workspace Switcher icon cannot be moved

However I think this restriction is enforced by design. Leaving the bug status "New" until someone from the design team can confirm/invalidate.

I think we'd like to move to having much more flexibility, with the
exception of Trash always being at the bottom. So you should be able to
move or remove Apps, Files and Workspaces.

Mark

John Lea (johnlea) on 2011-04-20
description: updated
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
importance: Undecided → Low
status: New → Fix Committed
tags: added: udo
John Lea (johnlea) on 2011-04-20
description: updated
Omer Akram (om26er) on 2011-04-22
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed

I'd have no problem with the Workspace switcher being locked in position, but I would prefer its location be one of the following:

1. The very top.
2. Just above (or just below) the Trash.

I feel that either of those locations would be better for muscle memory, because its current position in the middle of the bar, varying depending on how many applications are open, can be cumbersome in that regard.

Changed in unity-2d:
importance: Undecided → Low
Péter (fourdots) wrote :

What about adding some right-click functions to it, like locking it in place, as with gnome-panel applets. That should address the requirement that is locking it down now.

Other suggestions (r-click) -- /*sorry if these are in the wrong place, consider them additional motivation for above suggestion*/:
- remove from launcher (i.e. disable 'Keep in Launcher') [!!]
- goto workspace X
- workspace preferences (like defining the number of desktops, similar to compizconfig settings)

Richard Dale (rdale) wrote :

Could this be implemented by extending the /desktop/unity-2d/launcher/favorites gconf value so that it can contain places such as files.place or applications.place, and unity-2d-spread.service, in addition the .desktop file entries that it has now? If that list is used in other places, then extending it might have unforeseen side effects. Can there be more than one workspace (in the comments above 'Workspaces' is used in the plural.

Olivier Tilloy (osomon) wrote :

> Could this be implemented…

It could probably be implemented this way, but in any case, we should first agree on a common implementation, because at the moment unity-2d still stores its favorites in GConf while Unity uses gsettings. We don’t want to loose a functionality the day unity-2d transitions to gsettings…

> Can there be more than one workspace…

The correct term is "Workspace switcher", and it doesn’t really make sense to have more than one instance of it.

Jason Smith (jassmith) on 2011-05-05
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Jason Smith (jassmith)

Just to be clear, in Oneiric it should be possible to add or remove any
Place AND the Workspace switcher to the Launcher. The experience for
each of these should be: you search through the Dash, find them, drag
them to the launcher and can put them wherever you want. The only
fixed-location item in the Launcher will be Trash.

Mark

I hope in addition Dash favorite adds it program and Folder

Changed in unity-2d:
importance: Low → Medium
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Confirmed
Syraxes (syraxes) wrote :

Wow, it's good to see that there is a clear intention to make the icons in Launcher fully user-configurable , including the special ones like Workspaces .

But why is Trash treated as a special case ?

The user should be allowed to (re)move it , too .

John Lea (johnlea) on 2011-06-03
Changed in ayatana-design:
status: Fix Committed → Fix Released
Jorge O. Castro (jorge) on 2011-06-06
Changed in unity:
assignee: Jason Smith (jassmith) → Unity Community Hackers (unity-community-hackers)
milestone: none → backlog
Jorge O. Castro (jorge) on 2011-06-06
tags: added: backlog
John Lea (johnlea) on 2011-08-12
description: updated
John Lea (johnlea) on 2011-08-25
description: updated
Kyubutsu (jf) wrote :

all icons for apps [spawned or 'kept in launcher'] seem to place themselves above workspace switcher icon. trash remains at its usual place [bottom]. looks alright to me. guess this one IS fixed.
however, i do like the idea of having workspace switcher in fixed position above trash icon.
amd64
unity2d
oneiric

Omer Akram (om26er) on 2011-09-24
Changed in unity-2d (Ubuntu):
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Omer Akram (om26er) on 2011-09-25
summary: - [launcher] Workspace Switcher icon cannot be moved
+ [launcher] All launcher icons should be moveable except trash
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
Omer Akram (om26er) on 2011-11-18
summary: - [launcher] All launcher icons should be moveable except trash
+ [launcher] All launcher icons should be moveable except trash and BFB
Omer Akram (om26er) on 2012-03-26
Changed in unity:
assignee: Unity Community Hackers (unity-community-hackers) → nobody
Changed in unity (Ubuntu):
status: Confirmed → Triaged
John Lea (johnlea) on 2012-04-26
description: updated
Changed in ayatana-design:
importance: Low → High
Changed in unity:
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu):
status: Confirmed → Triaged
Andrea Cimitan (cimi) on 2012-05-31
Changed in unity:
assignee: nobody → Andrea Cimitan (cimi)
Stephen M. Webb (bregma) on 2012-06-07
Changed in unity:
assignee: Andrea Cimitan (cimi) → the Bora Bora squad (borabora)

i too would like to see this feature in Unity for Ubuntu 12.04 + ? please. highly un-ergonomic positioned as it is next to trash. looking forward to it guys .... :)

Olivier Tilloy (osomon) on 2012-08-07
Changed in unity:
assignee: Bora Bora (borabora) → Renato Araujo Oliveira Filho (renatofilho)
Changed in unity:
assignee: Renato Araujo Oliveira Filho (renatofilho) → nobody
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity:
status: Triaged → In Progress
Changed in unity:
milestone: backlog → 6.6
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Martin Mrazik (mrazik) on 2012-09-06
Changed in unity (Ubuntu):
status: Fix Committed → In Progress
Didier Roche (didrocks) on 2012-09-06
Changed in unity (Ubuntu):
status: In Progress → Triaged
Changed in unity:
status: Fix Committed → In Progress
Omer Akram (om26er) on 2012-09-06
Changed in unity-2d:
importance: Medium → Wishlist
Changed in unity-2d (Ubuntu):
importance: Medium → Wishlist
status: Triaged → Won't Fix
Changed in unity-2d:
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Triaged → In Progress
summary: - [launcher] All launcher icons should be moveable except trash and BFB
+ [FFE] [launcher] All launcher icons should be moveable except trash and
+ BFB
summary: - [FFE] [launcher] All launcher icons should be moveable except trash and
- BFB
+ [FFE] All launcher icons should be moveable except trash and BFB
description: updated
description: updated
description: updated
Iain Lane (laney) wrote :

This is reasonable, thanks for the clear request. Approved, please go ahead.

Changed in unity (Ubuntu):
status: In Progress → Triaged
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10-beta-2
Changed in unity:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2012-09-20
no longer affects: unity/7.0
Launchpad Janitor (janitor) wrote :
Download full text (9.2 KiB)

This bug was fixed in the package unity - 6.6.0-0ubuntu1

---------------
unity (6.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - Fixes non-escaped character sequences in dash previews (LP: #1039020)
    - Updated background layer for preview cover-art and details panels
      to be 10% low-light
    - Expand a PlacesGroup if it is the only category that contains results
      (LP: #950710)
    - Update unity autopilot tests to match autopilot API
    - Updated the convert files to fix some typos in the key names
    - Add gmodule dependency
    - Activate proper result if the categories aren't displayed in-order
      (LP: #1040101)
    - Refactor device launcher icons (LP: #713423)
    - LauncherController: make the controller enable the launcher struts,
      based on hide-mode option (LP: #1044005)
    - Launcher: make always possible to drag an icon to the bottom or top
      of its sub list (LP: #1043968)
    - Don't desat bfb/hud icon in DNDReset (LP: #1043963)
    - Progressively adjust the speed of the minimize animation. First
      time it is used is slower, then speeds up the more it is used.
      (LP: #1017510)
    - Implement new ordering of categories for home lens. (LP: #1043915)
    - UnityWindow now implements ScaleWindowInterface (LP: #876017)
    - Launcher: restore an icon position after that the dragging has been
      cancelled (LP: #955561)
    - LauncherDragWindow: cancel drag on window mapped/unmapped
      (LP: #1044723)
    - Now there is a check of an override color in RefreshColor (which is
      called when a PropertyNotify event happens). Also added a check in
      FullySaturateColor to a void division by zero. (LP: #975350)
    - Queue redraw after cover-art texture is updated from a url/file source.
      (LP: #1043947)
    - Fixed ability to delete glib::Source wrapper during its callback
      (LP: #1044823)
    - Close preview when dash is hidden. (LP: #1045298)
    - LauncherModel: rewrite the Reordering functions to keep the icon
      priority deltas (LP: #761155)
    - Make sure we can pass extra hints when activating preview actions.
      (LP: #1046352)
    - UnityWindow: scale window code improved (LP: #1033935)
    - The mouse will now cause the HUD buttons to change selection
      (LP: #1042692)
    - "Alt+Space" shortcut to reveal the window menu is not hardcoded, but a
       Compiz key option. " (Hold)" should also be translated. Made all
       Compiz plug-in names and all Compiz plug-in option names in
       unityshell.cpp static constants.
    - remove unity --reset, it's not anymore really needed now that we are
      in stable days of unity and we moved to gsettings
    - Removed the variables 'oldPrev' and 'oldNext' which got assigned the
      value NULL, but then were never used
    - Fixed the size of the previews to 770x380 pixels. (LP: #1045243)
    - UnityWindow: use smart pointers, use static close_icon (with dynamic
      state) and PanelStyle context (LP: #1033935) (LP: #1045127)
      (LP: #1046124) (LP: #1046126)
    - Remove everything in the #ifndef USE_MODERN_COMPIZ_GL ifdefs and remove
      the ifdefs alltogether. unity now requires compiz...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-10-12
Changed in ayatana-design:
status: Fix Committed → Fix Released
no longer affects: unity-2d (Ubuntu)
tags: added: reviewedbydesignq
removed: udo udp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers