USB stick not bootable using unetbootin on Mac

Bug #896686 reported by Steve L
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Fix Released
Geza Kovacs

Bug Description

Hi all. Just putting this in the system in case it happens to correlate with anything else you're looking at.

I downloaded the latest version (version doesn't show up when I run unetbootin, but it's the latest on the website) for my Mac, running OS X Snow Leopard 10.6.8. Used it with the following ISOs and installs:

FreeDos, EasyPeasy 1.6 ISO, and Acer Aspire One 3310 firmware update. Every time I created the USB image, it got "Missing operating system" when I attempted to boot from my USB stick on my Aspire One. I spent hours ... carefully formatting the stick FAT32, d/l'ing the latest unetbootin, etc. Really slaved at it ... tearing out my hair.

Finally I tried doing the download of unetbootin and the EasyPeasy ISO on the Aspire One itself, which at the time was running Kuki Linux, an old version from 2009. And what do you know, it worked.

Perhaps this will help the developers track down this intermittent but not-unheard-of bug.

The USB stick is a SanDisk 16G Cruzer.

Really hope you guys can track this down eventually ... I spent several hours hacking at this last night.

Revision history for this message
laurentd (laurentd) wrote :


Same problem with Mac OS X 10.7.2

trying to "send" VMware_Esxi_5_iso on an USB Stick

     doesn't work (not bootable) using unetbootin on Mac OS X

     usable (bootable) using the same USB Key on a windows 7 VM (with vmware fusion, on the same Mac OS X machine)


Revision history for this message
technoboi (m-launchpad-leafcom-co-uk) wrote :

Ubuntu 11.04. Various OS and several USB sticks.
Always the same. I format etc. with either GParted or GNOME Disk Utility. Then I use Unetbootin. Everything appears to go OK but no matter what computer I try to boot the stick on I always get 'missing operating system'. I've checked the boot flag of course. I have also tried different formats Ext4, Fat 32 etc.
Very frustrating. Unetbootin has been like this for a long time.

Revision history for this message
Birger J. Nordølum (mindtooth) wrote :

I can confirm this with the latest 575 and Ubuntu 12.04. I've downloaded the desktop version, 64-bit. But states when put inside a regular machine that it's missing an operating system. Done via Mac OS X Lion.

Maybe you should provide an "app" that doesn't do what it should do? I've had this problem for a while.

Revision history for this message
Aminda Suomalainen (mikaela) wrote :

This is Mac issue. Mac cannot boot from USB-device, or at least my Macbook doesn't allow that. I don't know about the new Macs, which come without CD-drive.

Revision history for this message
Aminda Suomalainen (mikaela) wrote :

Please ignore my previous comment. I thought that you meant booting on Mac instead of booting on another computer, when device has been created on Mac.

Revision history for this message
bc90021 (f-launchpad-bc90021-net) wrote :

This is very annoying. I'm not trying to boot my Mac, I'm trying to boot another machine with an image created using UNetBootIn on a Mac. It invalidates the use of the tool entirely if it doesn't make the disk bootable.

Revision history for this message
molecule-eye (niburu1) wrote :

I've got exactly the same issue, running OS X 10.8 (Mountain Lion) and trying to boot a Kubuntu 12.04 64-bit Live CD on a flash drive. I get the "Missing operating system" error on my brand new AMD A8-3870K desktop.

Revision history for this message
kronicd (kronicd) wrote :

Mountain Lion rather....

Revision history for this message
kronicd (kronicd) wrote : has an explanation and fix.

The partition isn't marked as bootable and the MBR not written, could this be fixed?

Revision history for this message
RedLegoMan (red-lego-man) wrote :

Just my £0.02, this is still a problem even with the latest version. Is there any movement on getting this fixed for the OS X version?

Revision history for this message
Mephisto (artemjo) wrote :

Same problem here. OS X 10.8.3

Revision history for this message
wutzin (chris-siller) wrote :

Same problem here under OS X 10.7.5
Basically this bug means: unetbootin is COMPLETELY USELESS under OSX. So unless this bug is fixed, the team should pull the OSX download - why offer a program that cannot serve its intended purpose (creating a USB stick that is bootable on a PC)?

All the current osx variant does is to show a UI that pretends to create a bootable USB stick, but doesn't. Please stop offering a mac version as long as this bug is open - you will only frustrate users who will blame the linux distro they are trying to install (since unetbootin claims everything went well)

Revision history for this message
jackwhite21 (davidholland1989) wrote :

More of the same osX 10.8.4 .

Seems to work but will not boot on pc.

Changed in unetbootin:
status: New → Confirmed
status: Confirmed → New
status: New → Confirmed
Revision history for this message
noiseme (noiseme) wrote :

10.8.4. The same problem. USB isn't bootable with different os.

Revision history for this message
Quackers (quackers) wrote :

I found a workaround for this problem (at least it worked for me).
Could be worth a try

Revision history for this message
Matt Ausmus (matt-j) wrote :

Since there is a work around, I don't think that you should pull the Mac version down.

This issue was originally reported in 2011 and I understand how open source projects work. Fixes happen when they happen. In the meantime, it should be in the FAQ or in a very obvious place that unetbootin does not perform it's full function as installed in Mac OS X. A link should be provided to the 3rd part posts or post the link in the FAQ itself.

Unetbootin is a great little tool but the Mac version just doesn't work and acts like it should and having to search the bug reports or the Google to figure this out inadvertently hurts the reputation of the project. It create much frustration and wasted time for all parties.

So, just update the FAQ and the when the fix comes everyone is happy and in the meantime you've provided notification and a work around.

Regards and thanks for a nice tool.

Revision history for this message
mariojuniorjp (mariojuniorjp) wrote :

e Bug has been reported in 2011, and we're in 2014 and developers not corrected. And look who is an open source project. I think if it was closed source, it would have been repaired for a long time!

Revision history for this message
Rune Bohn (zorroen) wrote :

Still not working in 2016, running OS X Mavericks 10.9.5 and trying to make at bootable ubuntu image.
The workaround from terminal does the job, but after more the 4 years this should be fixed.

Revision history for this message
vidak (vidakris) wrote :

Almost 2017, it's the same issue. Guys should just state on the OSX download page that 'DOESN'T WORK, BUT WE DON'T CARE'.

Revision history for this message
bLax (b636915) wrote :

OSX 10.11.6

not working

unbeliveable.... at least delete OSX version from webpage!

Revision history for this message
Geza Kovacs (gezakovacs) wrote :

I've fixed this in release 647 (made the process of marking the partition on the USB as bootable/active on macOS more reliable)

Changed in unetbootin:
assignee: nobody → Geza Kovacs (gezakovacs)
status: Confirmed → Fix Released
Revision history for this message
Nick Gee (ding-dong-ding) wrote :


Just an FYI that unetbootin-mac-647.dmg does not reslove the issue of the drive not being bootable.

#16 solved the issue for me (up to "sudo dd conv=notrunc bs=440 count=1 if=mbr.bin of=/dev/diskX").

Thanks for maintaining UNetbootin and thanks to everyone for the help!

Revision history for this message
Stefan v. Wachter (svwa) wrote :

Sorry, but it seems like the bug is not completely fixed yet.
I created an USB-Stick with Ubuntu ISO file on a Mac with OS X 10.9.5 using UNetbootin 647 from 2017-05-01
I can't boot from it on a PC machine (can select the USB as start device but then it shows only a blinking cursor on a black screen).

A working method is to use dd to copy the .iso file to USB drive.

Revision history for this message
John Walton (jsw73) wrote :

Is this not just because the Mac OSX operating system doesn't recognise the casper-rw partition which is written on a partition formatted to ext4 which isn't apparently recognised on OSX - - - might it be possible to write the casper onto a FAT32 partition?

Revision history for this message
kronicd (kronicd) wrote :

It is amazing that this bug is now ten years old. Just remove the MacOS build...

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.