Ubuntu One storage protocol

If the user has the date/time/timezone wrong, connection fails (Expired timestamp error)

Reported by Roberto Alsina on 2010-12-20
152
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Status tracked in Trunk
Stable-1-4
High
Alejandro J. Cura
Stable-1-6
High
Alejandro J. Cura
Stable-2-0
High
Alejandro J. Cura
Stable-3-0
High
Alejandro J. Cura
Trunk
High
Alejandro J. Cura
Ubuntu One Control Panel
Status tracked in Trunk
Stable-1-0
Undecided
Unassigned
Stable-2-0
Undecided
Unassigned
Stable-3-0
High
Alejandro J. Cura
Trunk
Medium
Alejandro J. Cura
Ubuntu One storage protocol
Status tracked in Trunk
Stable-1-4
High
Alejandro J. Cura
Stable-1-6
High
Alejandro J. Cura
Stable-2-0
High
Alejandro J. Cura
Stable-3-0
High
Alejandro J. Cura
Trunk
Critical
Alejandro J. Cura
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-1-0
High
Alejandro J. Cura
Stable-1-2
High
Alejandro J. Cura
Stable-1-4
High
Alejandro J. Cura
Stable-3-0
High
Alejandro J. Cura
Trunk
Critical
Alejandro J. Cura
ubuntuone-client (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Martin Pitt
Nominated for Natty by Natalia Bidart
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
ubuntuone-control-panel (Ubuntu)
Medium
Alejandro J. Cura
Declined for Maverick by Martin Pitt
Nominated for Natty by Natalia Bidart
Oneiric
Undecided
Unassigned
Precise
Medium
Alejandro J. Cura
ubuntuone-storage-protocol (Ubuntu)
Medium
Rodney Dawes
Declined for Maverick by Martin Pitt
Nominated for Natty by Natalia Bidart
Oneiric
Undecided
Unassigned
Precise
Medium
Rodney Dawes
ubuntu-sso-client (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Martin Pitt
Nominated for Natty by Natalia Bidart
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Oauth API calls fail if the user has the time too wrong, with this error on the backend:

AccountInfoError: args (<ubuntuone.controlpanel.dbus_service.ControlPanelBackend at /preferences at 0x2d7f090>, {'error_type': 'WebClientError', 'error_msg': u"(400L, 'Expired timestamp: given 1292771581 and now 1292857971 has a greater difference than threshold 900')"}), kwargs {}.

The user then gets an empty control panel showing only "Value could not be retrieved" in every field

Related branches

Roberto Alsina (ralsina) on 2010-12-20
Changed in ubuntuone-control-panel:
importance: Undecided → Low
assignee: nobody → Roberto Alsina (ralsina)
Changed in ubuntuone-control-panel:
status: New → Confirmed
Changed in ubuntuone-control-panel:
importance: Low → Medium
tags: added: desktop+ u1-natty
Changed in ubuntuone-control-panel:
assignee: Roberto Alsina (ralsina) → Ubuntu One Desktop+ team (ubuntuone-desktop+)
status: Confirmed → Triaged
Changed in ubuntuone-control-panel (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Ubuntu One Desktop+ team (ubuntuone-desktop+)
Roberto Alsina (ralsina) on 2011-09-19
tags: added: u1-zomg-windows
Changed in ubuntu-sso-client:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Roberto Alsina (ralsina)
Roberto Alsina (ralsina) on 2011-09-21
Changed in ubuntuone-control-panel:
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Alejandro J. Cura (alecu)
Changed in ubuntu-sso-client:
assignee: Roberto Alsina (ralsina) → Alejandro J. Cura (alecu)
Changed in ubuntuone-control-panel (Ubuntu):
assignee: Ubuntu One Desktop+ team (ubuntuone-desktop+) → Alejandro J. Cura (alecu)
Changed in ubuntuone-storage-protocol:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → Critical
status: New → In Progress
tags: added: u1-windows
summary: - If the user has the date wrong, connection fails
+ If the user has the date/time/timezone wrong, connection fails
summary: - If the user has the date/time/timezone wrong, connection fails
+ If the user has the date/time/timezone wrong, connection fails (Expired
+ timestamp error)
Changed in ubuntuone-storage-protocol:
status: In Progress → Fix Committed
Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Changed in ubuntuone-control-panel:
status: Triaged → Fix Committed
tags: added: u1-lucid-sru u1-maverick-sru u1-natty-sru u1-oneiric-sru
removed: u1-natty
Download full text (5.1 KiB)

Hello Alejandro and other users,

After I switched to U1 v2.0 this issue of time zones disabled any possibility of using U1 any more.

Initially I tried to upgrade when on a trip in Bangladesh, 10 hours ahead of Eastern Standard Time (home). I could not install it. When I got home I was able to finish installation. But still, when I travel I can't start U1, and I travel over half my time and far, beyond the 4 hour time difference I read in one of these messages/explanation. 4 hours seems designed for Continental US.

I saw an update to U1 came (v2.01) and I thought that issue was solved. It wasn't.

There has to be a way to make it work independently from time differences. Drop Box works in that sense seamlessly. U1 should not be behind DB.

Just an observation/ suggestion on my behalf.

Regards to the team,
Ernesto
EJM
Sent from my BlackBerry.

-----Original Message-----
From: "Alejandro J. Cura" <email address hidden>
Sender: <email address hidden>
Date: Tue, 22 Nov 2011 14:15:47
To: <email address hidden>
Reply-To: Bug 692597 <email address hidden>
Subject: [Bug 692597] Re: If the user has the date/time/timezone wrong,
 connection fails (Expired timestamp error)

** Changed in: ubuntu-sso-client/stable-1-0
   Importance: Undecided => High

** Changed in: ubuntu-sso-client/stable-1-0
       Status: New => In Progress

** Changed in: ubuntu-sso-client/stable-1-0
     Assignee: (unassigned) => Alejandro J. Cura (alecu)

** Changed in: ubuntu-sso-client/stable-1-2
   Importance: Undecided => High

** Changed in: ubuntu-sso-client/stable-1-2
       Status: New => In Progress

** Changed in: ubuntu-sso-client/stable-1-2
     Assignee: (unassigned) => Alejandro J. Cura (alecu)

** Changed in: ubuntu-sso-client/stable-1-4
   Importance: Undecided => High

** Changed in: ubuntu-sso-client/stable-1-4
       Status: New => In Progress

** Changed in: ubuntu-sso-client/stable-1-4
     Assignee: (unassigned) => Alejandro J. Cura (alecu)

** Changed in: ubuntuone-client/stable-1-4
   Importance: Undecided => High

** Changed in: ubuntuone-client/stable-1-4
       Status: New => In Progress

** Changed in: ubuntuone-client/stable-1-4
     Assignee: (unassigned) => Alejandro J. Cura (alecu)

** Changed in: ubuntuone-client/stable-1-6
     Assignee: (unassigned) => Alejandro J. Cura (alecu)

** Changed in: ubuntuone-client/stable-1-6
   Importance: Undecided => High

** Changed in: ubuntuone-client/stable-1-6
       Status: New => In Progress

** Changed in: ubuntuone-client/stable-2-0
   Importance: Undecided => High

** Changed in: ubuntuone-client/stable-2-0
       Status: New => In Progress

** Changed in: ubuntuone-client/stable-2-0
     Assignee: (unassigned) => Alejandro J. Cura (alecu)

** Changed in: ubuntuone-client/trunk
   Importance: Undecided => High

--
You received this bug notification because you are subscribed to a
duplicate bug report (854447).
https://bugs.launchpad.net/bugs/692597

Title:
  If the user has the date/time/timezone wrong, connection fails
  (Expired timestamp error)

Status in Ubuntu Single Sign On Client:
  Fix Committed
St...

Read more...

Alejandro J. Cura (alecu) wrote :

Hi Ernesto,

I've been working on a workaround for this problem, and it's already included in the UbuntuOne nightlies packages.
Here are the instructions on how to enable the nightlies: https://one.ubuntu.com/help/faq/how-can-i-test-the-latest-ubuntu-one-builds/

Right now I'm working on backporting the fixes to the older released versions of Ubuntu One. They will be showing up on Update Manager as soon as the branches are packaged for all the older versions.

Please let me know if you try the nightlies and encounter any other issue.

Thanks!

Giorgio Wicklein (giowck) wrote :

Good to see some progress on this bug.

This error is shown when dual booting Windows and Ubuntu.
Since Ubuntu and Windows use different methods to manage the local time (and thus interfering), every time windows is booted, after using ubuntu, U1 can't connect because the local time is delayed by an hour.

Hello,
My experience is that U1 v2 doesn't work on my work's Windows XP only PC (I once tried to install Ubuntu on it and it disabled XP to my embarrassment before IT). The problem with U1 seems related to the time zones as soon as I leave home on a travel.
Regards,

________________________________
 From: Giorgio Wicklein <<email address hidden> chpad.net>
To: <email address hidden>
Sent: Thursday, December 1, 2011 5:40 AM
Subject: [Bug 692597] Re: If the user has the date/time/timezone wrong, connection fails (Expired timestamp error)

Good to see some progress on this bug.

This error is shown when dual booting Windows and Ubuntu.
Since Ubuntu and Windows use different methods to manage the local time (and thus interfering), every time windows is booted, after using ubuntu, U1 can't connect because the local time is delayed by an hour.

--
You received this bug notification because you are subscribed to a
duplicate bug report (854447).
https://bugs.launchpad.net/bugs/692597

Title:
  If the user has the date/time/timezone wrong, connection fails
  (Expired timestamp error)

Status in Ubuntu Single Sign On Client:
  Fix Committed
Status in Ubuntu Single Sign On Client stable-1-0 series:
  In Progress
Status in Ubuntu Single Sign On Client stable-1-2 series:
  In Progress
Status in Ubuntu Single Sign On Client stable-1-4 series:
  In Progress
Status in Ubuntu Single Sign On Client trunk series:
  Fix Committed
Status in Ubuntu One Client:
  Fix Committed
Status in Ubuntu One Client stable-1-4 series:
  In Progress
Status in Ubuntu One Client stable-1-6 series:
  In Progress
Status in Ubuntu One Client stable-2-0 series:
  In Progress
Status in Ubuntu One Client trunk series:
  Fix Committed
Status in Ubuntu One Control Panel:
  Fix Committed
Status in Ubuntu One Control Panel stable-1-0 series:
  New
Status in Ubuntu One Control Panel stable-2-0 series:
  New
Status in Ubuntu One Control Panel trunk series:
  Fix Committed
Status in Ubuntu One storage protocol:
  Fix Committed
Status in Ubuntu One storage protocol stable-1-4 series:
  In Progress
Status in Ubuntu One storage protocol stable-1-6 series:
  In Progress
Status in Ubuntu One storage protocol stable-2-0 series:
  In Progress
Status in Ubuntu One storage protocol trunk series:
  Fix Committed
Status in “ubuntu-sso-client” package in Ubuntu:
  New
Status in “ubuntuone-client” package in Ubuntu:
  New
Status in “ubuntuone-control-panel” package in Ubuntu:
  Triaged
Status in “ubuntuone-storage-protocol” package in Ubuntu:
  New

Bug description:
  Oauth API calls fail if the user has the time too wrong, with this
  error on the backend:

  AccountInfoError: args
  (<ubuntuone.controlpanel.dbus_service.ControlPanelBackend at
  /preferences at 0x2d7f090>, {'error_type': 'WebClientError',
  'error_msg': u"(400L, 'Expired timestamp: given 1292771581 and now
  1292857971 has a greater difference than threshold 900')"}), kwargs
  {}.

  The user then gets an empty control panel showing only "Value could
  not be retrieved" in every field

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-sso-client/+bug/692597/+subscriptions

Rodney Dawes (dobey) on 2011-12-21
Changed in ubuntuone-storage-protocol (Ubuntu Precise):
assignee: nobody → Rodney Dawes (dobey)
importance: Undecided → Medium
milestone: none → precise-alpha-2
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-storage-protocol - 2.99.0-0ubuntu1

---------------
ubuntuone-storage-protocol (2.99.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Verify timestamp to avoid invalid auth failures (LP: #692597)
    - Use /api/time to sync the timestamp (LP: #891644)
  * Convert to pure dh
 -- Rodney Dawes <email address hidden> Wed, 21 Dec 2011 13:46:52 -0500

Changed in ubuntuone-storage-protocol (Ubuntu Precise):
status: In Progress → Fix Released
Changed in ubuntuone-control-panel:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.99.0-0ubuntu1

---------------
ubuntuone-client (2.99.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Verify timestamp to avoid invalid auth failures (LP: #692597)
    - Files in new UDFs not uploaded due to filtering (LP: #869920)
  * debian/patches:
    - Remove upstreamed patches
 -- Rodney Dawes <email address hidden> Wed, 21 Dec 2011 15:46:25 -0500

Changed in ubuntuone-client (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
Rodney Dawes (dobey) on 2012-04-12
Changed in ubuntuone-control-panel (Ubuntu Precise):
status: Triaged → Fix Released
Changed in ubuntu-sso-client (Ubuntu Precise):
status: Confirmed → Fix Released
Clint Byrum (clint-fewbar) wrote :

Hi! Thanks for the fix in the queue for oneiric-proposed. Its a large patch, but very easy to read, and I think its great for an SRU, given the regression potential and impact are well documented.

Can you please add an SRU justification header to the description of this bug (and bug #890277). See this link for instructions on what to include:

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Thanks!

tags: added: u1-sru
Alejandro J. Cura (alecu) wrote :

Still missing are fixes for ubuntuone-control-panel stable-2-0 and stable-1-0.
It looks like the fix for stable-3-0 will work mostly unchanged in stable-2-0, but the changes for stable-1-0 are much bigger so they'll take some time.

Hello Roberto, or anyone else affected,

Accepted ubuntuone-storage-protocol into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-storage-protocol (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Changed in ubuntu-sso-client (Ubuntu Oneiric):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello Roberto, or anyone else affected,

Accepted ubuntu-sso-client into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntuone-client (Ubuntu Oneiric):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello Roberto, or anyone else affected,

Accepted ubuntuone-client into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Roman Yepishev (rye) wrote :

Tested on packages in oneiric-proposed:
* ubuntuone-client: works (tested by publishing a file - that's rest api within syncdaemon)
* ubuntuone-storage-protocol: works - connection and file transfer
* ubuntuone-control-panel: Does not work, this is not in current SRU so will need to be fixed later
* ubuntu-sso-client: Works - sso ping uses oauth

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 1.4.1-0ubuntu1

---------------
ubuntu-sso-client (1.4.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Avoid connection failure when timestamp invalid. (LP: #692597)
    - Fix test inheritance with twisted TestCase. (LP: #890277)
  * debian/watch:
    - Update to use the stable-1-4 series for upstream source.
 -- Rodney Dawes <email address hidden> Wed, 18 Apr 2012 13:33:55 -0400

Changed in ubuntu-sso-client (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 2.0.1-0ubuntu1

---------------
ubuntuone-client (2.0.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Avoid connection failure when timestamp invalid. (LP: #692597)
    - Files in new folders not uploaded due to filtering. (LP: #869920)
    - Sync daemon not running (mmap ValueError). (LP: #825366)
    - Typo in man page for "paths." (LP: #682954)
    - Apport recipe attaches old and useless logs. (LP: #956407)
  * debian/control:
    - Require the new ubuntuone-storage-protocol for #692597.
  * debian/patches:
    - Remove patches which have been included in upstream.
  * debian/watch:
    - Update to use the stable branch.
 -- Rodney Dawes <email address hidden> Wed, 18 Apr 2012 16:37:15 -0400

Changed in ubuntuone-client (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-storage-protocol - 2.0.1-0ubuntu1

---------------
ubuntuone-storage-protocol (2.0.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - Avoid connection failure when timestamp invalid. (LP: #692597)
    - Fix test inheritance with twisted TestCase. (LP: #890277)
 -- Rodney Dawes <email address hidden> Tue, 17 Apr 2012 15:39:00 -0400

Changed in ubuntuone-storage-protocol (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers