Ubuntu

Jockey fails to install binary ati driver (post release) version

Reported by Dave Morley on 2011-10-12
This bug affects 282 people
Affects Status Importance Assigned to Milestone
fglrx
Confirmed
Undecided
Unassigned
jockey (Ubuntu)
High
Alberto Milone
Oneiric
High
Alberto Milone
Precise
High
Alberto Milone
nvidia-common (Ubuntu)
High
Alberto Milone
Oneiric
High
Alberto Milone
Precise
High
Alberto Milone

Bug Description

I do a fresh 64bit install and then try and add the binary drivers from jockey.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: jockey-gtk 0.9.4-0ubuntu10
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Wed Oct 12 21:04:58 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 002: ID 0557:8021 ATEN International Co., Ltd
 Bus 002 Device 003: ID 04f3:0103 Elan Microelectronics Corp.
 Bus 002 Device 004: ID 04f2:0718 Chicony Electronics Co., Ltd
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=491d192c-c7fe-48f5-acb4-10f6cfb63d9e ro quiet splash vt.handoff=7
SourcePackage: jockey
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/23/2006
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS K8N4-E SE ACPI BIOS Revision 0106
dmi.board.name: K8N4-E SE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSK8N4-ESEACPIBIOSRevision0106:bd01/23/2006:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnK8N4-ESE:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Dave Morley (davmor2) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jockey (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

The installation of fglrx-updates went alright according to the log:

Setting up fglrx-updates (2:8.881-0ubuntu6) ...
[...]
Building only for 3.0.0-12-generic
Building for architecture x86_64
Building initial module for 3.0.0-12-generic
Done.
[...]
DKMS: install Completed.

However, it seems it didn't install the alternatives correctly, or nvidia-common detects them wrongly:

2011-10-12 21:03:14,639 ERROR: xorg:fglrx_updates: get_alternative_by_name(fglrx-updates) returned nothing
2011-10-12 21:03:14,936 DEBUG: fglrx.enabled(fglrx_updates): target_alt None current_alt /usr/lib/fglrx/ld.so.conf other target alt None other current alt /usr/lib/fglrx/alt_ld.so.conf
2011-10-12 21:03:14,937 DEBUG: fglrx_updates is not the alternative in use

Both reporters seem to confirm that the non-updates version (fglrx) worked fine, right?

affects: jockey (Ubuntu) → nvidia-common (Ubuntu)
Changed in nvidia-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
Dave Morley (davmor2) wrote :

Yeap normal version installs flawlessly

i am also affected by this bug.

Martin Pitt (pitti) on 2011-10-30
Changed in nvidia-common (Ubuntu Precise):
importance: Medium → High
Changed in nvidia-common (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
cmavr8 (cmavr8) wrote :

Retried on a fully updated clean install of 11.10 x64: Same thing happens!

Arup (arup-chowdhury) wrote :

Same here on ASUS 1015B with ATI Radeon 6250.

Kyle Bentley (kwbent) wrote :

I'm also affected, jockey logs look similar so I will not attach.

System:
Ubuntu 11.10 x64
AMD Phenom II x6 1090t
Gigabyte 790FXT-UD5P
16 GB GSkill Ripjaw 1600 MHz
2 x ATI 4870's
Everything running in ACHI and SATA mode

Cas (calumlind) wrote :

I had problems installing the drivers with jockey but installing fglrx-updates and fglrx-amdcccle-updates with apt-get was not a problem.

Changed in nvidia-common (Ubuntu Oneiric):
assignee: nobody → Alberto Milone (albertomilone)

I have the same problem with 32-bit. Moreover, the flgrx that finally come installed is not working with gnome shell (garbled top bar), and I have instabilities in Unity too.

Hmmm --- I have installed manually it:

fglrx-amdcccle-updates 2:8.881-0ubuntu6.1
fglrx-updates 2:8.881-0ubuntu6.1

(and still additional drivers says that it's not activated). Maybe it's expecting a module called fglrx-updates when the module is called simply fglrx? (wild guess). The first relevant WARNING in jockey.log file is:

: modinfo for module fglrx_updates failed: ERROR: modinfo: could not find module fglrx_updates

hmmm? The module I have installed says it's a 11.9 (is this correct?)

BTW now it is working OK with Unity, not working with Gnome shell

Sorry --- amdcccle says driver is 11.8, not 11.9.

Werner (werner-0) wrote :

Also affects me.
Attaching my jockey.log

Changed in nvidia-common (Ubuntu Precise):
status: Confirmed → In Progress
Changed in nvidia-common (Ubuntu Oneiric):
status: Confirmed → In Progress
Martin Pitt (pitti) on 2011-11-16
Changed in jockey (Ubuntu Precise):
status: New → Triaged
Changed in jockey (Ubuntu Oneiric):
status: New → Triaged
Changed in jockey (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu Oneiric):
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu Precise):
importance: Undecided → High
Changed in jockey (Ubuntu Oneiric):
importance: Undecided → High
Michael Brady (psychx) wrote :

I am on a fresh install of Lubuntu 11.10 (this also happened with Ubuntu 11.10 fresh install), and have only done the updates. I am having this bug. Here is my jockey.log: http://pastebin.com/Au0X5mr2

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-common - 1:0.2.36

---------------
nvidia-common (1:0.2.36) precise; urgency=low

  * NvidiaDetector/alternatives.py:
    - Add optional ignore_pattern argument to get_alternative_by_name.
      This argument allows ignoring a substring in the name. This is
      required in the case of fglrx and fglrx-updates which share the
      same master link name (LP: #873058).
 -- Alberto Milone <email address hidden> Wed, 16 Nov 2011 17:04:21 +0100

Changed in nvidia-common (Ubuntu Precise):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.5-0ubuntu4

---------------
jockey (0.9.5-0ubuntu4) precise; urgency=low

  * debian/control: bump dependency on nvidia-common (>= 1:0.2.36).
    data/handlers/fglrx.py: pass ignore_pattern='-updates' to
    get_alternative_by_name so that the library returns the correct
    alternative name (LP: #873058).
 -- Alberto Milone <email address hidden> Wed, 16 Nov 2011 17:21:40 +0100

Changed in jockey (Ubuntu Precise):
status: Triaged → Fix Released
Alberto Milone (albertomilone) wrote :

SRU request:

I've backported the fixes for this bug in nvidia-common and jockey to Oneiric. They are already in oneiric-proposed, waiting for approval.

Martin Pitt (pitti) wrote :

There is still a jockey waiting for testing in oneiric-proposed, so this is stalled a bit.

Alberto: The nvidia-common API change looks unnecessary to me. The new second argument just modifies the first one. Wouldn't it be easier to just change the handler to do

  fglrx_alternative = self._alternatives.get_alternative_by_name(self.package.replace('-updates', ''))

?

Leon Maurer (leon-n-maurer) wrote :
Download full text (13.0 KiB)

I installed the updates with apt-get as others suggested, but I got a bunch of warnings, copied below. Is this a problem?

leon@leon-desktop:~$ sudo apt-get install fglrx-updates fglrx-amdcccle-updates
[sudo] password for leon:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  libnotify-bin
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  fglrx fglrx-amdcccle
The following NEW packages will be installed:
  fglrx-amdcccle-updates fglrx-updates
0 upgraded, 2 newly installed, 2 to remove and 0 not upgraded.
Need to get 0 B/43.4 MB of archives.
After this operation, 5,161 kB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 434205 files and directories currently installed.)
Removing fglrx-amdcccle ...
Removing fglrx ...
Removing all DKMS Modules
Done.
update-alternatives: removing manually selected alternative - switching x86_64-linux-gnu_gl_conf to auto mode
update-alternatives: using /usr/lib/pxpress/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-alternatives: warning: skip creation of /usr/bin/amdcccle because associated file /usr/lib/fglrx/bin/amdcccle (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/share/applications/ubuntu-amdcccle.desktop because associated file /usr/share/fglrx/amdcccle.desktop (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/share/applications/ubuntu-amdccclesu.desktop because associated file /usr/share/fglrx/amdccclesu.desktop (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/bin/amdupdaterandrconfig because associated file /usr/lib/fglrx/bin/amdupdaterandrconfig (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: skip creation of /usr/bin/amdxdg-su because associated file /usr/lib/fglrx/bin/amdxdg-su (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: warning: not replacing /usr/lib/x86_64-linux-gnu/xorg/extra-modules with a link.
update-alternatives: removing manually selected alternative - switching i386-linux-gnu_gl_conf to auto mode
update-alternatives: using /usr/lib/pxpress/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.
update-alternatives: using /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode. ...

Alberto Milone (albertomilone) wrote :

@Martin: yes, that would definitely be easier and probably best for the SRU but, with the current implementation, I think (at least for Precise), we have a standard way to deal with this problem in the API. Should the way we handle suffixes change (for whatever reason), we would only have to change how that specific function works (without an API break) without having to change all of our handlers.

EternalFury (lrtherond-9) wrote :

Fixing this is not going to enable support for switchable graphics in AMD/ATI GPUs, is it?

Sorry, accidentaly I changed the status to Fix Released. Admin, please rollback.

Changed in nvidia-common (Ubuntu Oneiric):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2011-12-15
Changed in nvidia-common (Ubuntu Oneiric):
status: Fix Released → Fix Committed

Hello Dave, or anyone else affected,

Accepted nvidia-common into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

For me, the new version doesn't work either. Actually, the graphics are best with all additional drivers deactivated. I will attach my jockey.log.

@ Martin Pitt #23

Is your proposed fix to nvidia-common supposed to fix jockey's handling of installing proprietary AMD drivers (fglrx)? That seems rather counter-intuitive.

I have a fresh AMD64 installation of Oneiric, plus all updates (but no -proposed). Jockey fails with the message "sorry installation of this driver failed" "please have a look at the log file for details: /var/log/jockey.log". I have no nVidia hardware.

The jockey log is somewhat opaque. It does include a python traceback in nVidia code:
2011-12-28 16:29:59,976 DEBUG: NVIDIA accelerated graphics driver (post-release updates) availability undetermined, adding to pool
2011-12-28 16:29:59,977 DEBUG: Could not instantiate Handler subclass __builtin__.NvidiaDriverBase from name NvidiaDriverBase
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/jockey/detection.py", line 962, in get_handlers
    inst = obj(backend)
TypeError: __init__() takes exactly 3 arguments (2 given)
2011-12-28 16:29:59,987 WARNING: modinfo for module nvidia_current_updates failed: ERROR: modinfo: could not find module nvidia_current_updates

Zentai Andras (andras-zentai) wrote :

I have the same situation as D. Hugh Redelmeier (except my Oneiric is updated from Natty)
and I agree with Him in the followings :>

Is your proposed fix to nvidia-common supposed to fix jockey's handling of installing proprietary AMD drivers (fglrx)? That seems rather counter-intuitive.

I have a fresh AMD64 installation of Oneiric, plus all updates (but no -proposed). Jockey fails with the message "sorry installation of this driver failed" "please have a look at the log file for details: /var/log/jockey.log". I have no nVidia hardware.

I attached my /var/log/jockey.log (the updated driver install failure part is from beginning UNTIL 2012-01-03 13:59:54,525)

The most interesting part is probably the following:>
2012-01-03 13:54:36,907 WARNING: /sys/module/fglrx_updates/drivers does not exist, cannot rebind fglrx_updates driver
2012-01-03 13:54:37,041 ERROR: xorg:fglrx_updates: get_alternative_by_name(fglrx-updates) returned nothing

Changed in jockey (Ubuntu Oneiric):
status: Triaged → Opinion
Changed in jockey (Ubuntu Oneiric):
status: Opinion → Triaged
Matt B (matty-brennan) wrote :

I did
sudo apt-get install jockey-common/oneiric-proposed jockey-gtk/oneiric-proposed

Jockey failed to install update drivers

.var.log.jockey.log:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
MachineType: Gigabyte Technology Co., Ltd. GA-78LMT-S2P
Package: nvidia-common 1:0.2.35
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-14-generic root=UUID=b6e40959-7b62-4e69-b5a5-568f2f977c18 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Tags: oneiric running-unity oneiric running-unity
Uname: Linux 3.0.0-14-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/08/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: GA-78LMT-S2P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd04/08/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-78LMT-S2P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

The proposed fixes do not work for me either.
The original Jockey made an effort on installation and failed after ~ a minute and returned with these errors:

2012-02-16 10:37:29,631 WARNING: /sys/module/fglrx_updates/drivers does not exist, cannot rebind fglrx_updates driver
2012-02-16 10:37:29,907 ERROR: xorg:fglrx_updates: get_alternative_by_name(fglrx-updates) returned nothing

The proposed one fails after a second. I've attached the log.

Jack Foy (jfoy) wrote :

I don't believe the fglrx installer failure is a bug in nvidia-common, but rather in the interface between jockey-common and fglrx-updates.

It looks like /usr/share/jockey/handlers/fglrx.py in package jockey-common expects the package fgrlx-updates to create a module named 'fglrx-updates', but the module generated by building that package is actually named 'fglrx'. See https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/825339

Can someone who knows this code comment on this issue? How can we get the jockey-common and fglrx-updates maintainers to agree on an interface?

Hello Dave, or anyone else affected,

Accepted jockey into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in jockey (Ubuntu Oneiric):
status: Triaged → Fix Committed

Doesn't work for me. I don't get an error message when updating the driver, instead after a short "driver is updating" message nothing happens anymore.

screenshot for the comment above...

Иван (netone94) wrote :

#44 - same

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
DistroRelease: Ubuntu 11.10
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
MachineType: Gigabyte Technology Co., Ltd. GA-78LMT-S2P
NonfreeKernelModules: fglrx
Package: nvidia-common 1:0.2.35
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=b6e40959-7b62-4e69-b5a5-568f2f977c18 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-16.29-generic 3.0.20
Tags: oneiric running-unity oneiric running-unity
Uname: Linux 3.0.0-16-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 04/08/2011
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F2
dmi.board.name: GA-78LMT-S2P
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF2:bd04/08/2011:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2P:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2P:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-78LMT-S2P
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I don't know what this fix is supposed to be, but like in comment 40, this ATI/AMD FGLRX post-release updates still doesn't work using Ubuntu 12.04 beta 2 fully updated as of today and rebooted before running jockey.

Attached is the jockey.log from the failed installation.

The NON-post-release updates installs fine, as usual.

Tyler Hallada (thallada) wrote :

I have a AMD Radeon 6900 Series and I was getting this error with the identical log. I upgraded to the -proposed version of the package but I am now getting this error when I run jockey from the console:

$ sudo jockey-gtk
Traceback (most recent call last):
  File "/usr/bin/jockey-gtk", line 382, in on_button_toggle_clicked
    'toggle', False):
  File "/usr/lib/python2.7/dist-packages/jockey/ui.py", line 667, in set_handler_enable
    handler_id, enable)
  File "/usr/lib/python2.7/dist-packages/jockey/backend.py", line 98, in convert_dbus_exceptions
    return fn(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/jockey/backend.py", line 90, in dbus_sync_call_signal_wrapper
    raise _h_exception_exc
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.TypeError: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.7/dist-packages/jockey/backend.py", line 337, in _f_result_wrapper
    self._f_result = f()
  File "/usr/share/jockey/handlers/fglrx.py", line 95, in enable
    self._other_alternatives.set_alternative(other_fglrx_alternative)
  File "/usr/lib/python2.7/dist-packages/NvidiaDetector/alternatives.py", line 130, in set_alternative
    self._master_link, path])
  File "/usr/lib/python2.7/subprocess.py", line 506, in check_call
    retcode = call(*popenargs, **kwargs)
  File "/usr/lib/python2.7/subprocess.py", line 493, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/subprocess.py", line 679, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/subprocess.py", line 1239, in _execute_child
    raise child_exception
TypeError: execv() arg 2 must contain only strings

The visual behavior of jockey is identical to the reports of the other two people.

tags: added: verification-failed
removed: verification-needed
Martin Pitt (pitti) wrote :

Tyler, you are experiencing bug 804662. This is not a regression introduced by this SRU, though.

tags: added: verification-needed
removed: verification-failed
Natim (site-remy) on 2012-04-27
no longer affects: nvidia-common
Benedikt Bär (beniwtv) wrote :

I still get this on a fully updated precise install...

Stephen Zimmerman (szimmer3) wrote :

I'll chime in to say that I'm getting this error (or at least one indistiguishable from it from the symptoms and /var/log/jockey.log) on a clean 12.04 install. kernel is 32-bit PAE.

Installing the "updates" packages with apt worked, though jockey is none the wiser that any driver is in use.

Adam Niedling (krychek) wrote :

I made a clean Precise x64 installation today and this is still a bug. Please reopen.

Adam Niedling (krychek) on 2012-05-10
summary: - Jockey fail to install binary ati driver (post release) version
+ Jockey fails to install binary ati driver (post release) version

Same as Adam Niedling, the bug still exists

Alexandrosg (alexandrosg) wrote :

Bug still exists on fresh install of precise

Sebastien Bacher (seb128) wrote :

Could you confirm that the fix works for you so the update can be moved out of staging?

Sini (jozsef-sin) wrote :

Also affects me.
Jockey fail to install binary ati driver (post release) version

Ubuntu 12.04

lspci | grep VGA
Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4500/5100 Series]
Toshiba Satellite l500

The bug is still there. Kubuntu 12.04, ati drivers.

pheanex (pheanex) wrote :

Any updates on this bug or workarounds?

lspci | grep VGA
02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cayman XT [Radeon HD 6970]

Paul Cullum (paul-cullum) wrote :

This issue still exists in 12.04.

Andreas Wesik (ezel) wrote :

Still no patch.
We are stuck on old crappy video-drivers when there are smooth and shiny new ones out there. How sad.
It can be worked around by manually installing the Catalyst-drivers I guess, but that is a real hassle for a newbie!

Here are my jockey logs.

Andreas Wesik (ezel) wrote :

And another log.

Andreas Wesik (ezel) wrote :

BTW, isn't this bug in the wrong place now?
Nvidia problems are fixed, aren't they? Only AMD/ATI remains?

Redsandro (redsandro) wrote :

@Andreas Yes, and is has been that way for two years now. (10.04)

But iirc, there was a fix for nvidia updates that caused ati/amd updates to break. Maybe there are not many devs using amd hardware, so interest in fixing this is low.

Andreas Wesik (ezel) wrote :

Lots of confirmation in the comments from AMD/ATI-users.
If anybody think this is still unconfirmed, please change accordingly.

Changed in fglrx:
status: New → Confirmed
Rained23 (rained23) wrote :

I had this bug also...

Hope dev can help fixing this bug ...

Morten (morten-hattesen) wrote :

I also experience this problem after upgrading from 10.04 to 12.04.

/var/log/jockey.log contains...

2012-08-31 12:48:52,914 WARNING: /sys/module/fglrx_updates/drivers does not exist, cannot rebind fglrx_updates driver
2012-08-31 12:49:16,549 DEBUG: fglrx.enabled(fglrx_updates): target_alt None current_alt /usr/lib/fglrx/ld.so.conf other target

Brian Murray (brian-murray) wrote :

The fix for this bug is in the oneiric-proposed repository and requires testing before we can release to the oneiric-updates repository. You can read about how to enable this repository and test the package at the following url:

https://wiki.ubuntu.com/QATeam/PerformingSRUVerification

So we have worked on the fix we just need you to test it.

Redsandro (redsandro) wrote :

The link is not very straightforward. How do we test this without getting every proposed update?

1) enable proposed in synaptic
2) update jockey
3) restricted drivers -> install post-release updates one
4) disable proposed in synaptic

Is this correct?

Redsandro (redsandro) wrote :

After choosing the proposed repo in synaptic and refreshing, there was no update for jockey (or nvidia-common, if that's still relevant for amd). Unable to verify.

Redsandro (redsandro) wrote :

@Brian My mistake, you are talking about oneiric-proposed and I am running precise lts.
I conveniently assumed you were talking about precise.

Anyway, doesn't it make more sense to have a fix in precise-proposed since everyone is and will be running lts while 11.10 is kinda old news?

Precise error jockey.jog

Redsandro (redsandro) wrote :

FYI, although status 'Fix Released', the bug remains.

Redsandro (redsandro) wrote :

Note on comment #84 attachment:

Please ignore until
DEBUG: dpkg: error: dpkg status database is locked by another process

I closed synaptic and ran the update again. Refer to 2nd part of the log.

Timothy Arceri (t-fridey) wrote :

I'm also still getting an error I have:
jockey 0.9.7-0ubuntu7.1
nvidia-common 1:0.2.44

Timothy Arceri (t-fridey) wrote :

Sorry still getting the error in 12.04 (precise)

Jochen Fahrner (jofa) wrote :

I confirm that this bug is still not fixed in 12.04.

Adam Niedling (krychek) wrote :

Jockey is not part of Ubuntu 12.10, it has been discontinued. I guess this but report is not relevant anymore.

@Adam: isn't 12.04 a LTR? --- BTW, I ended up switching to radeon open source drivers. Forget 3D game playing, but for the normal desktop it's running ok.

Romano: +1

12.04 is LTS: supported of some more years.

Furthermore, Mythbuntu only supports LTS, and the proprietary driver is necessary for home theatre applications.

So: this needs to be fixed for 12.04

Travis Larson (tlarson) wrote :

I can confirm that the released fix does not fix this bug on 12.04. Jockey version 0.9.7-0ubuntu76 in 12.04 proposed is completly un-usable. Please see the attached file for the console output errors.

It has been 8 months since 12.04, a long term release, has been in use. This highly visible bug has been an eyesore for the entire time. Is this being looked at?

I can confirm this bug. Recently setup up dual-boot with Ubuntu 12.04 precise using Wubi after a reformat.

Bryce Harrington (bryce) wrote :

Reopening the Precise tasks for this bug due to several people claiming it is still unfixed.

(For oneiric it sounds like no one cares; those tasks would be ok to wontfix, and back out the oneiric-proposed package.)

Changed in nvidia-common (Ubuntu Precise):
status: Fix Released → New
Changed in jockey (Ubuntu Precise):
status: Fix Released → New
Adam Conrad (adconrad) wrote :

Per the above comment, these packages have been removed from oneiric-proposed:

Removing packages from oneiric-proposed:
 jockey 0.9.4-0ubuntu10.2 in oneiric
  dh-modaliases 0.9.4-0ubuntu10.2 in oneiric amd64
  dh-modaliases 0.9.4-0ubuntu10.2 in oneiric armel
  dh-modaliases 0.9.4-0ubuntu10.2 in oneiric i386
  dh-modaliases 0.9.4-0ubuntu10.2 in oneiric powerpc
  jockey-common 0.9.4-0ubuntu10.2 in oneiric amd64
  jockey-common 0.9.4-0ubuntu10.2 in oneiric armel
  jockey-common 0.9.4-0ubuntu10.2 in oneiric i386
  jockey-common 0.9.4-0ubuntu10.2 in oneiric powerpc
  jockey-gtk 0.9.4-0ubuntu10.2 in oneiric amd64
  jockey-gtk 0.9.4-0ubuntu10.2 in oneiric armel
  jockey-gtk 0.9.4-0ubuntu10.2 in oneiric i386
  jockey-gtk 0.9.4-0ubuntu10.2 in oneiric powerpc
  jockey-kde 0.9.4-0ubuntu10.2 in oneiric amd64
  jockey-kde 0.9.4-0ubuntu10.2 in oneiric armel
  jockey-kde 0.9.4-0ubuntu10.2 in oneiric i386
  jockey-kde 0.9.4-0ubuntu10.2 in oneiric powerpc
 nvidia-common 1:0.2.35.1 in oneiric
  nvidia-common 1:0.2.35.1 in oneiric amd64
  nvidia-common 1:0.2.35.1 in oneiric i386
Comment: Failed SRU verification
Remove [y|N]? y
2 packages successfully removed.

Changed in jockey (Ubuntu Oneiric):
status: Fix Committed → Won't Fix
Changed in nvidia-common (Ubuntu Oneiric):
status: Fix Committed → Won't Fix
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in jockey (Ubuntu Precise):
status: New → Confirmed
Changed in nvidia-common (Ubuntu Precise):
status: New → Confirmed
Tim Abell (tim-abell) wrote :

Hi, I'm on LTS and this is causing me problems as the new Steam linux client keeps complaining my driver is out of date, but the additional drivers dialog fails as described. Today I just want to play my game :-( When will this be fixed?

tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions