Xorg freezes on start. Black screen with waiting cursor. Unichrome video, worked on hardy.

Bug #274340 reported by Anko on 2008-09-25
204
This bug affects 15 people
Affects Status Importance Assigned to Milestone
openchrome
Fix Released
Unknown
Fedora
Fix Released
High
openSUSE
Fix Released
Unknown
xserver-xorg-video-openchrome (Ubuntu)
High
Raphael Geissert
Nominated for Intrepid by Bartosz Kosiorek

Bug Description

------------------------------------------------------
This bug was solved upstream, and a new package was made for Ubuntu 9.04.
However, the fix was not released for Ubuntu 8.10.
We are requesting a Stable Release Update for Ubuntu 8.10, in order to facilitate upgrading from Ubuntu 8.04, which didn't have the bug in the first place.

Ubuntu 8.10 package has version 1:0.2.903-0ubuntu3
Ubuntu 9.04 package has version 1:0.2.903+svn713-1ubuntu1

The Stable Release Update should be at least version 1:0.2.903+svn696

The patch is here http://www.openchrome.org/trac/changeset/696

------------------------------------------------------
Binary package hint: xorg

On a asus pundit barebones pc with unichrome video.

Ubuntu logo shows fine, system boots to X, shows cursor. Cursor changes to waiting cursor and system locks up. CTRL-ALT-F1 etc. do nothing.

Same on live cd.

Ubuntu intrepid ibex alpha 6. Works on Hardy.

tried logging this bug 6 times but can't navigate around w3m!

will attach log.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: xserver-xorg 1:7.4~2ubuntu4
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/sbin:/sbin:/bin
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.27-4-generic (buildd@palmer) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu7) ) #1 SMP Mon Sep 22 04:40:44 UTC 2008

SourcePackage: xorg
Uname: Linux 2.6.27-4-generic i686
Xrandr:

setxkbmap:

xdpyinfo:

xkbcomp:
[lspci]
00:00.0 Host bridge [0600]: VIA Technologies, Inc. K8M800 Host Bridge [1106:0204]
     Subsystem: ASUSTeK Computer Inc. Device [1043:8129]
01:00.0 VGA compatible controller [0300]: VIA Technologies, Inc. K8M800/K8N800/K8N800A [S3 UniChrome Pro] [1106:3108] (rev 01)
     Subsystem: ASUSTeK Computer Inc. Device [1043:8129]

Description of problem:
X hangs after startup when driver in xorg.conf set to "openchrome". Same with
Anaconda installer, system stops respoding just after showing title screen.
When starting just xinit, systems stops responding just after moving mouse
cursor. If replace "openchrome" with "vesa", everything works fine.

Version-Release number of selected component (if applicable):

Steps to Reproduce:
1. set driver to openchrome, or just start graphical intaller
2. wait until X starts
3.X fails

Created attachment 305398
Xorg Log

Created attachment 305399
xorg log with openchrome

I had same problem. My smolt profile is here:
http://www.smolts.org/client/show/pub_920668d9-1de6-4d85-92d6-e84d3dd246a1
This is i386 arch only.
Fedora 9 x86_64 arch works fine on the same PC.

(In reply to comment #0)
ok, I'll try to port a fix from another branch of openchrome in the next days in
order to get rid off of the VBE calls, it might fix the pb. This is rather
heavy, so please give me a little time.

(In reply to comment #3)
> I had same problem. My smolt profile is here:
> http://www.smolts.org/client/show/pub_920668d9-1de6-4d85-92d6-e84d3dd246a1
> This is i386 arch only.
> Fedora 9 x86_64 arch works fine on the same PC.

Not sure this is the same problem, could you please post your xorg log and conf ?

Dear,

I let the story that I am having the same problem that the friend Peter Veres
posted.
To start the installation in the anaconda recognizes the drive to start ox lock
the PC.
After installing text mode and modify the drive to vesa ok, no problem.
We already have some track or forecast?

Regards,

José Ivan Paes

Scholar of Librarianship - UFSC
Technician in Telecommunications

E-mail/MSN: paes.jose @ gmail.com
Skype: ivanpaesjose
Palhoça - Santa Catarina - Brazil

"... Criticism is easier to praise ..."

"A bit of science in turn from God. Very, brings us closer."
                                   Louis Pasteur.

NOTE: Sorry English is that was translated from Portuguese into English.

(In reply to comment #6)
> After installing text mode and modify the drive to vesa ok, no problem.

What happens if you set the driver to openchrome ? Can you please post the xorg
log with openchrome ?

(In reply to comment #7)
> (In reply to comment #6)
> > After installing text mode and modify the drive to vesa ok, no problem.
>
> What happens if you set the driver to openchrome ? Can you please post the
xorg
> log with openchrome ?

The openchrome driver is the problem... If i set X to use the openchrome, X
hangs just after start. I mean, it shows the background and then stop
responding. In anaconda it shows Installer's title screen with Fedora title
screwed up at the top of screen, that's all. Using vesa i was able at least use
system "normally" - slow as hell but it did work, openchrome doesn't work at
all.

And sorry, no, i can't post the xorg log because I had to reinstall back to
Fedora 8 as Fedora 9 wasn't useable to me. Not only X with openchrome, but
neither video playing(slow and noting did help), touchpad not working(click by
tap - no chance to enable it, tried to set manually in xorg.conf, tried updated
driver, nothing worked). And that new final released KDE4 isn't final for me,
rather alpha or something a bit more.

I can't imagine new release of Fedora when xorg.conf will be disabled at all
and only autodetection will work - as it seems it won't work.

Created attachment 306618
Log do X com drives open e vesa

When you select the drive openchrome is exactly what the friend Peter Veres
commented on post 8. Then the log of X, where X Xorg.0.log_vesa and with the
vesa driver and Xorg.0.log_open with the drive openchrome. I hope I have
helped.

Instaldos versions of software:

Kernel: 2.6.25.3-18.fc9.i686
xorg-x11-drv-openchrome-0.2.902-3.fc9.i386

Regards,

Ivan Paes

Created attachment 306710
Xorg.log XAA lockup

Here is hard lockup from 0.2.902-3.fc9.
No lockups when EXA acceleration is activated or NoAccel "true".

xorg-x11-drv-openchrome-0.2.902-5.fc9 might work better for you. Available from
Koji before it hits updates-testing.
http://koji.fedoraproject.org/koji/taskinfo?taskID=629814

I just installed xorg-x11-drv-openchrome-0.2.902-5.fc9.i386 and rebooted, and my
X server locks up when it starts. When I kill the X server, my whole system
hangs (hard lock-up, magic SysRq key doesn't work).

I was also seeing hangs with the old openchrome driver, but not when the server
started up -- it hung when I tried to use rdesktop.

It does not appear that 0.2.902-5.fc9 fixes the problem.

Hello!

Once the tests installing the packages:

[root @ netuno paes] # rpm -aq | grep openchrome
xorg-x11-drv-openchrome-0.2.902-5.fc9.i386
xorg-x11-drv-openchrome-devel-0.2.902-5.fc9.i386
[root @ netuno paes] #

In my case to install this package holding went further, or to the setar drive
openchrome and make the restart of X is shown in animation cusor mouse and
tinker with it for a moment (+ - 2 seconds), the screen fund default and when
appear to the login screen with the users of the system is that all white screen
and lock the PC.
In the previous package could not move the mouse at any time and did not appear
any image sharp.

Regards,

Ivan Paes

Does adding the following line to the Device section of the xorg.conf fix the
issue for everyone ?

Option "AccelMethod" "EXA"

If not, does Option "NoAccel" fix the issue ?

(In reply to comment #14)
> Does adding the following line to the Device section of the xorg.conf fix the
> issue for everyone ?
>
> Option "AccelMethod" "EXA"
>
> If not, does Option "NoAccel" fix the issue ?

Hello,

Xavier I did not understand exactly where they need to put that line. You can
put xorg.conf an example of where that line would be bold?

Thank you!

Ivan Paes

(In reply to comment #15)
The Device section of your xorg.conf should look to something like that :
Section "Device"
        Identifier "Videocard0"
        Driver "openchrome"
        Option "AccelMethod" "EXA"
EndSection

if it still doesn't work, try with :
Section "Device"
        Identifier "Videocard0"
        Driver "openchrome"
        Option "NoAccel"
EndSection

(In reply to comment #16)
> (In reply to comment #15)
> The Device section of your xorg.conf should look to something like that :
> Section "Device"
> Identifier "Videocard0"
> Driver "openchrome"
> Option "AccelMethod" "EXA"
> EndSection
>
> if it still doesn't work, try with :
> Section "Device"
> Identifier "Videocard0"
> Driver "openchrome"
> Option "NoAccel"
> EndSection

Ok,

When I am at work. Once we arrive at home I will make the tests and post the
results.

Thank you!

(In reply to comment #14)
> Does adding the following line to the Device section of the xorg.conf fix the
> issue for everyone ?
>
> Option "AccelMethod" "EXA"

This works for me.

Hello,

After putting the line Option "AccelMethod" "EXA" and restarted the X interface
was ok, but the xorg is occupying much processing reaches peak of 90% leaving
the PC very slow.

  PID USER PR NI VIRT RES SHR S% CPU% MEM TIME + COMMAND
  2141 root 20 0 98516 21m 8168 S 48.6 4.9 0:53.09 Xorg

Correcting this problem of occupation of CPU is ok.

Thank you!

Ivan Paes

I'm using:

Option "NoAccel" "True"

So, X starts to work with openchrome driver, but it still a bit slow, mainly
when you moving a window or scroll down/up a web page on firefox.

The option "AccelMethod" "EXA" doesn't change anything.

If I comment the "NoAccel" option I get the X instance very very slow and the
Xorg.0.log shows:

"[mi] EQ overflowing. The server is probably stuck in an infinite loop.
 [mi] mieqEnequeue: out-of-order valuator event; dropping."

Extremely erratic behavior. Sometimes the driver works with no options;
sometimes it hangs. Sometimes it works with EXA; sometimes it hangs.
Sometimes it works with NoAccel; sometimes it hangs. Sometimes when I kill the
X server, my machine recovers; sometimes my machine locks up. After the most
recent lock-up and reboot, I was able to run the driver with no options, with
EXA, and with NoAccel repeatedly with no hangs, despite the fact that it had
just been hanging a few moments before.

I don't know what's up with all this, but clearly stability has not yet been
achieved.

Any news?

(In reply to comment #19)
> After putting the line Option "AccelMethod" "EXA" and restarted the X interface
> was ok, but the xorg is occupying much processing reaches peak of 90% leaving
> the PC very slow.
>
Ivan, try to add :
Option "MigrationHeuristic" "greedy"

(In reply to comment #21)
> Extremely erratic behavior. Sometimes the driver works with no options;
> sometimes it hangs. Sometimes it works with EXA; sometimes it hangs.
> Sometimes it works with NoAccel; sometimes it hangs. Sometimes when I kill the
> X server, my machine recovers; sometimes my machine locks up. After the most
> recent lock-up and reboot, I was able to run the driver with no options, with
> EXA, and with NoAccel repeatedly with no hangs, despite the fact that it had
> just been hanging a few moments before.
>
Jonathan, I'm not convinced all your troubles are related to openchrome. Is your
machine perfectly stable when using the vesa driver ?

(In reply to comment #22)
> Any news?

Diego, I believe there are multiple problems mixed here. One problem is XAA
acceleration is broken for some people and switching to EXA mitigate the issue.
In your case, you have to completely disable the acceleration to get the driver
running. Unfortunately, you didn't provide neither your xorg conf nor your xorg
log, so I'm afraid there's not much I can do to diagnose or even categorise the
problem.

All, I'm still awaiting for upstream to provide a patch that will remove the
need of the VGA bios to do the modesetting, as I failed to produce it by myself.
This should greatly reduce the pain some laptop users are suffering with openchrome.

"Is your machine perfectly stable when using the vesa driver ?"

Yes.

Download full text (4.1 KiB)

(In reply to comment #23)
> (In reply to comment #19)
> > After putting the line Option "AccelMethod" "EXA" and restarted the X interface
> > was ok, but the xorg is occupying much processing reaches peak of 90% leaving
> > the PC very slow.
> >
> Ivan, try to add :
> Option "MigrationHeuristic" "greedy"
>
> (In reply to comment #21)
> > Extremely erratic behavior. Sometimes the driver works with no options;
> > sometimes it hangs. Sometimes it works with EXA; sometimes it hangs.
> > Sometimes it works with NoAccel; sometimes it hangs. Sometimes when I kill the
> > X server, my machine recovers; sometimes my machine locks up. After the most
> > recent lock-up and reboot, I was able to run the driver with no options, with
> > EXA, and with NoAccel repeatedly with no hangs, despite the fact that it had
> > just been hanging a few moments before.
> >
> Jonathan, I'm not convinced all your troubles are related to openchrome. Is your
> machine perfectly stable when using the vesa driver ?
>
> (In reply to comment #22)
> > Any news?
>
> Diego, I believe there are multiple problems mixed here. One problem is XAA
> acceleration is broken for some people and switching to EXA mitigate the issue.
> In your case, you have to completely disable the acceleration to get the driver
> running. Unfortunately, you didn't provide neither your xorg conf nor your xorg
> log, so I'm afraid there's not much I can do to diagnose or even categorise the
> problem.
>
>
> All, I'm still awaiting for upstream to provide a patch that will remove the
> need of the VGA bios to do the modesetting, as I failed to produce it by myself.
> This should greatly reduce the pain some laptop users are suffering with
openchrome.

Hello,

Once the test by placing putting Option "MigrationHeuristic" "greedy" getting sa
follows:

1 st test:

Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "NoAccel"
         Option "MigrationHeuristic" "greedy"
EndSection

NOTE: The X rises but remains very slow. The simple task of maximizing and
discard maximize the xorg occupies 94% of the CPU.

2 nd test

Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "AccelMethod" "EXA"
         Option "MigrationHeuristic" "greedy"
EndSection

NOTE: Not rises X on television reports that connection with X server fi and
lost in the last lines of / var/log/Xorg.0.log.old shows the following:

Backtrace:
0: X (xf86SigHandler +0 x79) [0x80d60c9]
1: [0x12e400]
2: / lib/libc.so.6 (memcpy +0 x46) [0x471f46]
3: [0xb425d000]
4: / usr / lib / xorg / modules / / libexa.so [0x7a5334]
5: / usr / lib / xorg / modules / / libexa.so (exaComposite +0 xc0f) [0x7a602f]
6: X [0x8175f76]
7: X (CompositePicture +0 x1c6) [0x815fc86]
8: X [0x810d7ff]
9: X [0x811f1e5]
10: X (miPointerUpdateSprite +0 x229) [0x8118aa9]
11: X [0x8118ba5]
12: X [0x8147e7d]
13: X [0x81691b1]
14: X [0x808cfb3]
15: X (ChangeWindowAttributes +0 xcc0) [0x8073730]
16: X (ProcChangeWindowAttributes +0 xc0) [0x8085550]
17: X (Dispatch +0 x34f) [0x8085a3f]
18: X (main +0 x47d) [0x806b3bd]
19: / lib/libc.so.6 (__libc_start_main +0 xe6) [0x4115d6]
20: X (Fon...

Read more...

The MigratioHeuristic option only matters if you are using EXA. man openchrome
for details.
About the crash, try to add :
Option "ExaNoComposite"
in the Device section of xorg.conf.

Ivan's symptoms look familiar to me. Opencrome has worked here fine since I
switched to EXA with some extra parameters. No more crashes or cpu hogs.

Option "AccelMethod" "EXA"
Option "ExaNoComposite" "True"
Option "MigrationHeuristic" "greedy"
Option "ExaScratchSize" "8192"
Option "MaxDRIMem" "16384"

I believe some non-EXA problems are avoided with;
Option "SWCursor" "true"
Option "NoXVDMA" "true"

From some tests I also have still active this;
Section "Extensions"
        Option "Composite" "enable"
EndSection

(In reply to comment #27)
> Ivan's symptoms look familiar to me. Opencrome has worked here fine since I
> switched to EXA with some extra parameters. No more crashes or cpu hogs.
>
> Option "AccelMethod" "EXA"
> Option "ExaNoComposite" "True"
> Option "MigrationHeuristic" "greedy"
> Option "ExaScratchSize" "8192"
> Option "MaxDRIMem" "16384"
>
> I believe some non-EXA problems are avoided with;
> Option "SWCursor" "true"
> Option "NoXVDMA" "true"
>
> From some tests I also have still active this;
> Section "Extensions"
> Option "Composite" "enable"
> EndSection
>

Hello,

With settings that Vesa Ruokonen returned and set the drive and restart the
openchrome X, xorg was ok, not giving the problem of high consumption of CPU. I
believe my problem was resolved.
So my xorg.conf was as follows:

Section "Device"
         Identifier "Videocard0"
         Driver "openchrome"
         Option "AccelMethod" "EXA"
         Option "ExaNoComposite" "True"
         Option "MigrationHeuristic" "greedy"
         Option "ExaScratchSize" "8192"
         Option "MaxDRIMem" "16384"
EndSection

Thanks to friends for help.

Regards,

Ivan Paes

Hello,

Only to appear, indicating that more staff utlizar managed to drive the openchrome.

Again Thank you!

Ivan Paes

"Thank you for the tip Paes, note 10!
until they finally managed to install the fedora on my note.
How can tell has not run desktop 3D, I am using KDE 4 and I'm amazed by it. "

The solution from comment #28 works for me. Without this, I've got serious
hangs. I have ASUS K8V-VM with onboard VGA:

01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890 [Chrome9]
Integrated Video (rev 11)

Numeric output: 01:00.0 0300: 1106:3230 (rev 11)

xorg-x11-drv-openchrome-0.2.902-7.fc9.i386

I also tried comment #28. It stop hanging but system is very slow. So I returned
to VESA. Is there a more permanent solution.

I added XaaNoImageWriteRect option to xorg.conf. now it is fine.

My xorg.conf is as follows:

Section "Device"
 Identifier "Videocard0"
 Driver "openchrome"
 Option "XaaNoImageWriteRect" "True"
EndSection

Anko (anko-com+ubuntu) wrote :
Timo Aaltonen (tjaalton) wrote :

Please try with 'Option "DRI" "false"' in the Device section.

Changed in xorg:
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

also, try a daily livecd which has a newer driver version.

Anko (anko-com+ubuntu) wrote :

Option "DRI" "false" did not work, trying to get a daily live cd but there only appears to be alternate cds available from http://cdimage.ubuntu.com/daily/current/

Anko (anko-com+ubuntu) wrote :

I did an apt-get distupgrade to get the latest drivers.

It did not fix the problem.

So I tried "
Subsection Module
Disable "dri"
EndSubsection
"

which didn't work either.

Option "NoAccel" works, but the X background (before you load a window manager) is extremely flickery, and without acceleration gnome really sucks.

This is a definate regression!

any ideas on other stuff I can test?

Georg Duffner (mcduff) wrote :

Thank you, Anko! Option "NoAccel" works for me too and gnome is really a pain without acceleration. even with the vesa driver it seems better to me.

goto (gotolaunchpad) wrote :

Thanks! Only the cursor on KDE is still unusable. It's just a big weird box...

Anko (anko-com+ubuntu) on 2008-10-02
Changed in xserver-xorg-video-openchrome:
status: Incomplete → Confirmed
Georg Duffner (mcduff) wrote :

is this upstream or an ubuntu bug? should we report this bug to openchrome.org?

Anko (anko-com+ubuntu) wrote :

What's the best way to tell? I don't know enough about video drivers in X to tell.

Forest Bond (forest-bond) wrote :

I added the upstream and Fedora bug reports.

Try:

Option "AccelMethod" "EXA"

This was suggested in the upstream bug report.

Changed in openchrome:
status: Unknown → New
Georg Duffner (mcduff) wrote :

on k8m800 option "AccelMethod" "EXA" doesn't work (see duplicate Bug #267115). Option "XaaNoImageWriteRect", the second workaround proposed in the upstream bug report does work.

Kai Springer (kai-nuknetz) wrote :

recent update (18th oktober) didn't change anything. xserver-xorg-video-openchrome still makes my system freeze completely. I got a K8M800, the old via driver worked with the same issues like the openchrome driver in hardy (no 3D applications like google earth). please supply the via driver again.

Kai Springer (kai-nuknetz) wrote :

Option "AccelMethod" "EXA" doesn't work with Via Unichrome Pro (Rev. 01)
Option "NoAccel" works but is bloody slow. Maybe the old via driver could be supplied for this adapter.

Georg Duffner (mcduff) wrote :

kai, have you tried Option "XaaNoImageWriteRect"? i too have a k8m800 and this solves it.

Kai Springer (kai-nuknetz) wrote :

Hey Georg,

it kind of solves it, but is still slower than with the via driver. I think I can live with this solution for the moment.

Forest Bond (forest-bond) wrote :

XaaNoImageWriteRect fixes things for me.

Anko (anko-com+ubuntu) wrote :

XaaNoImageWriteRect works for me too, but is still a bit slow, and should be fixed on the livecd!

Kai Springer (kai-nuknetz) wrote :

I now did a new install of 8.04 as I couldn't use my webcam properly anymore (blurry picture in skype, cheese crashing...) and gnome was really slow with the openchrome driver in 8.10. Does anybody know whether there is any progress regarding this problem? What about re-releasing the via driver again? Is it worth it downloading the 8.10 live-cd now or does it still hang on boot?

Sorry for asking these inconvenient questions, but owning a laptop with a K8M800 via graphics adapter isn't really fun in ubuntu.

Cheers
Kai

Hi Kai,

On Fri, Oct 31, 2008 at 08:18:13AM -0000, Kai Springer wrote:
> I now did a new install of 8.04 as I couldn't use my webcam properly
> anymore (blurry picture in skype, cheese crashing...) and gnome was
> really slow with the openchrome driver in 8.10. Does anybody know
> whether there is any progress regarding this problem? What about re-
> releasing the via driver again? Is it worth it downloading the 8.10
> live-cd now or does it still hang on boot?

Have you tried this in your xorg.conf?

  Option "XaaNoImageWriteRect" "True"

Thanks,
Forest
--
Forest Bond
http://www.alittletooquiet.net
http://www.pytagsfs.org

Kai Springer (kai-nuknetz) wrote :

Hey Forest,

sure I tried that option. It works but it not very fast compared to the proprietary via driver.

Cheers
Kai

Bryce Harrington (bryce) on 2008-11-08
Changed in xserver-xorg-video-openchrome:
importance: Undecided → High
status: Confirmed → Triaged
Paul Sinnett (paul-sinnett) wrote :

I tried the patch suggested in the openSUSE bug report (adding the SYNC_CHECK to the XAA_PIXMAP_OP_PROLOGUE macro) but without much luck on my Acer 1392LC laptop using the openchrome driver.

My process for testing this was to get all the build dependencies for xserver-xorg-core, insert the lines suggested, build with dpkg-buildpackage, install with dpkg -i.

(I actually got it to behave once by running startx remotely with ssh, however this wasn't repeatable - which makes me think there might be other missing SYNC_CHECK instances?)

2008/11/9 Paul Sinnett <email address hidden>:
> I tried the patch suggested in the openSUSE bug report [...] but without much luck on
> my Acer 1392LC laptop using the openchrome driver.

Thanks for testing the patch.
I've forwarded your comments to upstream and am now waiting for a reply.

Graham (ubuntu-grahams) wrote :

I'm having the same problem: X server locking up.

I have a VIA EPIA 10000 mobo.
It's a home brew with a LCD 1280x1024 connected to VGA.

Booted via PXE using the Xubuntu Intrepid Live image downloaded about a week ago.

Can boot to console, but when I bring up the X server it locks and Ctrl-Alt-F1 etc it needed.

It also causes kernel panic if I just let it try to boot GUI normally.

This worked on Hardy, but it gets the res wrong (1280x960 instead of the native 1280x1024).

A couple of lines in the xorg.conf cures the resolution issue, but it still hangs the X server.

I'll post some logs in a bit.

Graham (ubuntu-grahams) wrote :
Kai Springer (kai-nuknetz) wrote :

Is anyone at least caring about this problem? Can we maybe have the old via driver back? I'd really like to see Intrepid Ibex on my laptop. In dozens of forum on the internet I can see questions popping up regarding this topic, but nobody answers them anymore. Really Sad.

Bartosz Kosiorek (gang65) wrote :

This bug is well known in Openchrome project.
Also exist in Fedora distribution.

Here is the link to this bug:

http://www.openchrome.org/trac/ticket/263

"Some people are reporting crashes either at the login screen (gdm) or later using some applications. xorg-server is 1.5, openchrome is 0.2.903 or 0.2.903 plus panel/hw cursor patch. These crashes are workaround'ed by using the XaaNoImageWriteRect? option. Affected hardware includes at least P4M900, K8M890 and VM800... "

Bartosz Kosiorek (gang65) wrote :

In the Hardy Heron the xserver-xorg-video-openchrome (1:0.2.901-0ubuntu4) works perfectly.
I didn't see any freezes or bugs.

Only when I upgrade from Hardy to Intrepid my VIA K8M890 graphic card stop working.

What do You think about idea to backport xserver-xorg-video-openchrome (1:0.2.903-0ubuntu3)
from Intrepid to Hardy, to ensure that problem exist/not exist in openchrome drivers.

If Ubuntu Hardy freeze or crash after upgrade xserver-xorg-video-openchrome, that mean the bug exist directly in xserver-xorg-video-openchrome.

If Ubuntu Hardy work properly after upgrade, that mean the bug not exist in xserver-xorg-video-openchrome but somewhere else (for example in X server)

What do you think about this Idea?

Raphael Geissert (atomo64) wrote :

Done, revision 685 for hardy is being built as I type. Package can be
found at https://launchpad.net/~atomo64/+archive

Bartosz Kosiorek (gang65) wrote :

On my K8M890 chipset, with standard settings the Intrepid freezes (I can't do anything, even swith off X, enter to terminal).
Add XaaNoImageWriteRect option to xorg.conf file, resolve this problem.

I run Hardy Heron (LiveCD) and install above openchrome 0.2.903 driver, by using command:
sudo dpkg -i --auto-deconfigure xserver-xorg-video-openchrome_0.2.903+svn685-1+hardy1_i386.deb

Next I restarted X by using the CTRL+ALT+BACKSPACE shortcut.
The new drivers works fine (the X not freeze).
Only one bug exists: the mouse cursor is not displayed. I think enable Software Cursor in xorg.conf should help.

I add in attachment file X logs from Hardy (openchrome 0.2.901 and 0.2.903) and Intrepid (on openchrome 0.2.903 when fail, and when its ok - XaaNoImageWriteRect enabled).
I add also working xorg.conf file.

Please investigate this files.

Is it possible to add XaaNoImageWriteRect option to xorg.conf file as default for Openchrome drivers?

Raphael Geissert (atomo64) wrote :

2008/12/16 Bartosz <email address hidden>:
> I run Hardy Heron (LiveCD) and install above openchrome 0.2.903 [...] 0.2.903+svn685-1+hardy1_i386.deb
>
> Next I restarted X by using the CTRL+ALT+BACKSPACE shortcut.
> The new drivers works fine (the X not freeze).

As I expected :)

> Only one bug exists: the mouse cursor is not displayed. I think enable Software Cursor in xorg.conf should help.
>

Yeah, that's a known issue and the openchrome folks were going to
investigate with VIA.

[...]
>
> Is it possible to add XaaNoImageWriteRect option to xorg.conf file as
> default for Openchrome drivers?

The other day I talked to Timo Aaltonen, and switching to EXA by
default looked like the best solution. To enable it take a look at
openchrome's man page.

Steve Beattie (sbeattie) wrote :

This bug was reported in the Intrepid development cycle; removing regression-potential and marking as regression-release.

This bug continuous in fedora 10 also is there any progress in fixing this bug.

unfortunately, no real progress in fixing the bug. We tried to reproduce it on several hardware setup, but none of us succeed. I currently have both a KM400 and a VX800 running F10, but they are not impacted. I'll soon have a CLE266 under F10 too, but I don't expect it to be impacted either. What would help a lot would be to retrieve both the xorg log and the backtrace of a crash. If anyone CC'ed to this bug can get us that, it would be good.

Bartosz Kosiorek (gang65) wrote :

This bug should now be fixed as of svn Rev 696 :
http://www.openchrome.org/trac/ticket/263

I will try to build this under Ubuntu Intrepid, and inform about results.

The build instructions is available at:
https://help.ubuntu.com/community/OpenChrome

*** Bug 473117 has been marked as a duplicate of this bug. ***

*** Bug 472420 has been marked as a duplicate of this bug. ***

*** Bug 465199 has been marked as a duplicate of this bug. ***

*** Bug 450321 has been marked as a duplicate of this bug. ***

Bartosz Kosiorek (gang65) wrote :

After build/install/run openchrome driver rev696, the problem was solved.

Unfortunately the problem with mouse pointer still exists (the mouse cursor is not displayed).

Openchrome works fine, after add to xorg.conf file option:
    Option "SWcursor"

May I please someone to create xserver-xorg-video-openchrome_0.2.903+svn696 package?

*** Bug 469346 has been marked as a duplicate of this bug. ***

xorg-x11-drv-openchrome-0.2.903-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-2.fc9

xorg-x11-drv-openchrome-0.2.903-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-2.fc10

Changed in openchrome:
status: New → Confirmed
David Kaiser (dkaiser) wrote :

Success report - running a HP 2133 (Mini Note). (Model KX869AT)

From lspci: 01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)

I upgraded from Ubuntu 8.04 to Ubuntu 8.10 and noticed that these functions:
"Suspend"
"Hibernate"
"Lock Screen"
"Log Out"
changing from X display to a VTY with CTRL-ALT-F1
or allowing the screensaver to kick-in
Would cause the Xserver to segfault and log the following message:"
[ 5032.490431] Xorg[5194]: segfault at 0 ip 00000000 sp bffc5c2c error 4 in Xorg[8048000+18f000]

I thought it might be related to this bug so I followed the instructions posted above ( https://help.ubuntu.com/community/OpenChrome ) and pulled version 697 from openchrome SVN.

I'm very glad to report that it all works now. Screensaver and logging out and suspending - no segfaults on the Xserver now. While I didn't have the same issues with gdm or the mouse cursor, whatever changed solved my issues too. Hope this is helpful.

I will test .deb files as they become available.

David

Bartosz Kosiorek (gang65) wrote :

The X freeze and cursor problem was fixed in openchrome Revision 707.
On Ubuntu Intrepid and chipset VIA K8M890 its works perfeclty !

Build instruction I described at:
https://help.ubuntu.com/community/OpenChrome

xorg-x11-drv-openchrome-0.2.903-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/xorg-x11-drv-openchrome-0.2.903-3.fc10

Changed in openchrome:
status: Confirmed → Unknown

Created attachment 328249
Xorg.0.log showing crash inside Xorg with openchrome which hoses machine

xorg-x11-drv-openchrome-0.2.903-4.fc11.i386 continues to hang for me immediately and hose my system (stops pinging, although I am able to reboot with the Magic SysRq key) on a system updated today from rawhide. I've got no xorg.conf, so I'm using whatever the auto-generated settings are. I've tested it with three different kernels with the same results:

kernel-2.6.28-2.fc11.i686
kernel-2.6.29-0.7.rc0.git3.fc11.i686
kernel-2.6.29-0.9.rc0.git4.fc11.i686

I've attached my /var/log/Xorg.0.log, which shows a crash inside Xorg, from the hang.

Changed in openchrome:
status: Unknown → Fix Released

(In reply to comment #43)
> Created an attachment (id=328249) [details]
> Xorg.0.log showing crash inside Xorg with openchrome which hoses machine
>
This is a different bug that only happens with xserver 1.6. It's already been reported to xorg (https://bugs.freedesktop.org/show_bug.cgi?id=19337) and a patch against the deprecated via driver submitted (http://lists.freedesktop.org/archives/xorg/2008-December/041972.html).
Jon will have a patch for openchrome soon. Meanwhile can you please open a new bug ?

xorg-x11-drv-openchrome-0.2.903-3.fc10 has been pushed to the Fedora 10 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0210

xorg-x11-drv-openchrome-0.2.903-2.fc9 has been pushed to the Fedora 9 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing-newkey update xorg-x11-drv-openchrome'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-0214

xorg-x11-drv-openchrome-0.2.903-2.fc10 has been pushed to the Fedora 10 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0227

Changed in xserver-xorg-video-openchrome:
assignee: nobody → atomo64
status: Triaged → In Progress
Bryce Harrington (bryce) on 2009-01-17
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xserver-xorg-video-openchrome - 1:0.2.903+svn713-1

---------------
xserver-xorg-video-openchrome (1:0.2.903+svn713-1) experimental; urgency=low

  * New upstream snapshot
    + 682-685: Initial VX800 chipsets support
      + 708: Initial XVideo support
    + 682: via_cursor.c: register corrections
    + 686: Mitac 8624, but with a P4M890
    + 687: VIA Epia M700
    + 688: Hide overlay when video is invisible
    + 690: Axper XP-M8VM800
    + 693: Added more needed panel modes
    + 694: XvMC Unichrome Pro allocation fixes (LP: #304119)
    + 696: Fixed Crash worked around by XaaNoImageWriteRect (LP: #274340)
    + 713: Twinhead M6
  * vt_fix.patch: removed, different solution by upstream in r695
  * disable_ARGB_cursor_VM800.patch: removed, no longer needed

 -- Timo Aaltonen <email address hidden> Fri, 23 Jan 2009 14:31:23 +0000

Changed in xserver-xorg-video-openchrome:
status: In Progress → Fix Released

This is the original bug report.

pshahmumbai (pshahmumbai) wrote :

I have a ASUS K8V-VM motherboard with onchip display card

01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890CE/K8N890CE [Chrome 9] (rev 11)

The jaunty alpha 4 and alpha 3 Live CD (amd64) freezes with the same issues on start up. I havent tried the (x86) Live CD yet.

Bartosz Kosiorek (gang65) wrote :

I think its because the jaunty alpha 4 do not have newest xorg-video-openchrome (1:0.2.903+svn713-1).
Please upgrade xorg-video-openchrome to the newest one, and try again.

xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-openchrome'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-2009

xorg-x11-drv-openchrome-0.2.903-5.fc10 has been pushed to the Fedora 10 stable repository. If problems still persist, please make note of it in this bug report.

Bartosz Kosiorek (gang65) wrote :

Please resolve this bug in the Ubuntu 8.10 Intrepid.
When this bug exist, there is no possible to upgrade from Hardy to Jaunty.

Here is the solution of this bug:
http://www.openchrome.org/trac/changeset/696

vocx (eliudcabrera) on 2009-05-11
description: updated
tags: added: verification-needed
Martin Pitt (pitti) on 2009-05-14
tags: removed: verification-needed
Paul Sinnett (paul-sinnett) wrote :

This issue is now fixed for me with the Jaunty release.

Changed in fedora:
importance: Unknown → High
To post a comment you must log in.