Ubuntu

Distorted screen on MacBook Air 3,2 (GT216 10de:08a3)

Reported by Peter Hedlund on 2011-12-01
56
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Linux
Confirmed
Medium
Nouveau Xorg driver
Fix Released
Medium
Fedora
Unknown
Unknown
xserver-xorg-video-nouveau (Ubuntu)
High
Maarten Lankhorst

Bug Description

The internal display is distorted with vertical bands of different colors separated by black and white noise.

The the good news is that an external monitor now works perfectly through the mini displayport.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1
ProcVersionSignature: Ubuntu 3.2.0-2.5-generic 3.2.0-rc3
Uname: Linux 3.2.0-2-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.90-0ubuntu1
Architecture: amd64
CasperVersion: 1.292
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgpng,mousepoll,move,place,regex,resize,session,snap,unitymtgrabhandles,vpswitch,wall,animation,expo,ezoom,fade,scale,unityshell,workarounds]
CompositorRunning: compiz
Date: Thu Dec 1 19:21:56 2011
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 nVidia Corporation Device [10de:08a3] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00d3]
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
MachineType: Apple Inc. MacBookAir3,2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper quiet splash --
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/18/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA31.88Z.0061.B01.1011181342
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-942C5DF58193131B
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir3,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-942C5DF58193131B
dmi.modalias: dmi:bvnAppleInc.:bvrMBA31.88Z.0061.B01.1011181342:bd11/18/10:svnAppleInc.:pnMacBookAir3,2:pvr1.0:rvnAppleInc.:rnMac-942C5DF58193131B:rvrMacBookAir3,2:cvnAppleInc.:ct10:cvrMac-942C5DF58193131B:
dmi.product.name: MacBookAir3,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Bryce Harrington (bryce) wrote :

Please attach a photo of the screen showing the corruption.

Also, does the corruption occur all the time, or only when an external monitor is attached?

Did you notice this immediately on installing Precise or has it regressed only recently?

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete

Screenshot looks normal.

A photo of the screen shows the distortion. It does not matter if an external monitor is attached or not. The internal monitor works fine in Oneiric. A live CD with Fedora 16 shows the same regression.

Bryce Harrington (bryce) on 2011-12-06
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium

Still present in daily build for 20120111.

Forwarding this bug from Ubuntu reporter Peter Hedlund:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/898784

[Problem]
The internal display is distorted with vertical bands of different colors separated by black and white noise. This worked in Ubuntu 11.10 (kernel 3.0).

The the good news is that an external monitor now works perfectly through the mini displayport, which did not work in Ubuntu 11.10.

DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1
Uname: Linux 3.2.0-2-generic x86_64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,gnomecompat,grid,imgpng,mousepoll,move,place,regex,resize,session,snap,unitymtgrabhandles,vpswitch,wall,animation,expo,ezoom,fade,scale,unityshell,workarounds]
CompositorRunning: compiz
Date: Thu Dec 1 19:21:56 2011
GraphicsCard:
 nVidia Corporation Device [10de:08a3] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00d3]
LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20111129.1)
MachineType: Apple Inc. MacBookAir3,2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/hostname.seed boot=casper quiet splash --
SourcePackage: xserver-xorg-video-nouveau
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/18/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA31.88Z.0061.B01.1011181342
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-942C5DF58193131B
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir3,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-942C5DF58193131B
dmi.modalias: dmi:bvnAppleInc.:bvrMBA31.88Z.0061.B01.1011181342:bd11/18/10:svnAppleInc.:pnMacBookAir3,2:pvr1.0:rvnAppleInc.:rnMac-942C5DF58193131B:rvrMacBookAir3,2:cvnAppleInc.:ct10:cvrMac-942C5DF58193131B:
dmi.product.name: MacBookAir3,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu7
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.27-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.10.4-1ubuntu5
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Created attachment 55885
DSC03982.JPG

Photo of screen showing corruption.

The background is supposed to be a purple gradient (ala https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/898784/+attachment/2616711/+files/Screenshot%20at%202011-12-02%2017%3A17%3A49.png)

Created attachment 55886
BootDmesg.txt

Created attachment 55887
XorgLog.txt

Bryce Harrington (bryce) on 2012-01-21
summary: - Distorted screen on MacBook Air 3,2
+ Distorted screen on MacBook Air 3,2 (GT216 10de:08a4)
summary: - Distorted screen on MacBook Air 3,2 (GT216 10de:08a4)
+ Distorted screen on MacBook Air 3,2 (GT216 10de:08a3)
Bryce Harrington (bryce) wrote :

You have a nVidia Corporation Device [10de:08a3], which is a GT216 (GeForce 320M), however the nvidia 290.10 driver's README only lists that it supports the 10de:08a5 version of the GT216, so I wonder if that could be part of the problem. However that doesn't explain why it would work on oneiric and then fail on precise.

I see they have a beta 290.53 driver but it's windows only, and I don't see mention of any fixes for GeForce 3xxM series hardware.

Bryce Harrington (bryce) wrote :

Of course my last comment might make sense if you were running -nvidia, which you aren't!
So, nevermind that.

I'll forward this to the nouveau guys.

Changed in xserver-xorg-video-nouveau (Ubuntu):
importance: Medium → High
Bryce Harrington (bryce) wrote :

Peter Hedlund - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=45017 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Bryce Harrington (bryce) wrote :

You may also want to doublecheck that the new development kernel still shows the bug. If not, there might be a patch to be backported:

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc1-precise/

Changed in nouveau:
importance: Unknown → Medium
status: Unknown → Confirmed

Since this is a regression I am interested in trying to walk backwards to try to identify the problem. Is it likely that the problem is in xf86-video-nouveau or someplace else? Is cgit.freedesktop.org down or where do I browse the code? I would appreciate any hints on how to go about this.

zEn (der-eremit) wrote :

http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.3-rc1-precise/

problem is fixed when running this kernel

I can also confirm that the issue is fixed in kernel 3.3. I am running rc7 from mainline. There appears to be confirmation from Fedora also https://bugzilla.redhat.com/show_bug.cgi?id=650949.

Any chance we can see relevant parts backported to precise?

Fixed for me in linux kernel 3.3.

zEn (der-eremit) wrote :

sorry if i ask this in this bug-report, but Peter, do you have working wifi with the mainline kernel,
at the moment i can choose between graphics corruption or no wireless...

Yes, wireless works fine. For an earlier kernel (3.0 I believe) I had blacklisted the bcma module. For 3.3 I removed the blacklisting and wireless started working.

I'm guessing running 3.3 kernel isn't going to be very stable for a while... no chance of the driver changes included in 3.3 to make it into a 3.2 kernel that will be supported by 12.04 LTS 8( I'm having a fair bit of kernel panics, and inability to mount btrfs from 3.3, which I can from the 3.2 included with 12.04.

The good times did not last, the bug is back in kernel.ubuntu.com/~kernel-ppa/mainline/v3.4-rc3-precise/.

Changed in linux:
importance: Unknown → Medium
status: Unknown → Confirmed
Soulnafein (soulnafein) wrote :

I've just downloaded Ubuntu 12.04 64bit. I've booted my Macbook Air 3,2 from external drive and I've noticed the same graphic corruption. It starts from the ubuntu progress bar.
Is there a workaround for this problem? Do I need to cope with it only during the installation?

Soulnafein (soulnafein) wrote :

This page https://help.ubuntu.com/community/MacBookAir3-2/Pangolin says I can cope with it during installation and fix it afterward upgrading kernel.

Still present in 3.4-rc5.

Maarten Lankhorst (mlankhorst) wrote :

If it's back in v3.4-rc3-precise, did it work with v3.4-rc2-precise?

No, I have now tested rc1 and rc2. None of them work.

Still present in 3.4-rc6.

Soulnafein (soulnafein) wrote :

Do you reckon this bug will be fixed in time for the release of 12.04.1 ?

Well, 12.04 runs fine with a 3.3 kernel. The real problem is that the bug is back in the 3.4 kernel including the final release and there has been no fix during the entire rc-cycle. Also, so far no comment from an involved developer.

Maarten Lankhorst (mlankhorst) wrote :

This looks suspicious:

[ 4.607278] fb: conflicting fb hw usage nouveaufb vs EFI VGA - removing generic driver
[ 4.607298] Console: switching to colour dummy device 80x25
It

The dummy device is not connected to anything, it should say say 'frame buffer device' or something.
Can you post a dmesg of the working kernel?

Judging from xrandr it can detect all outputs fine, so it seems to be a bug in handoff.

Also can you try to boot linux with 'noefi' on v3.4 to see if that works around the bug? I would like dmesg from that as well. :)

I think 3.4 is a lost cause. The problem is fixed in 3.5-rc1 although I have had some instability issues that I hope will improve. The drm pull request for 3.5 (http://lists.freedesktop.org/archives/dri-devel/2012-May/023395.html) contains this comment which I think is the relevant part:

drm/nouveau/disp: fix dithering not being enabled on some eDP macbooks

Maarten Lankhorst (mlankhorst) wrote :

Well if reverting that patch breaks things again I would assume you could build the 3.4 kernel with it and have it working. :)

Yes, assuming that is the relevant patch. I have not done any compilation, but the code is in a file called nouveau_connector.c and 3.4 and 3.5 are similar enough to do a backport. In the Precise kernel 3.2 the code is very different.

However, right now I don't really see the point. Precise works fine with a 3.3 kernel and I assume Quantal will use 3.5 or 3.6. We just have to make sure there are no further regressions.

Maarten Lankhorst (mlankhorst) wrote :

I'll try to get all the patches in through the upstream stable kernel.

Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
tags: added: qa-kernel-lts-testing
Maarten Lankhorst (mlankhorst) wrote :
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Triaged → Fix Committed

Fix is backported from 3.5rc to 3.4.3 and 3.2.21

Changed in nouveau:
status: Confirmed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/898784

tags: added: package-qa-testing

I can confirm that the latest Ubuntu kernel 3.2.0-27 works on my MacBook Air 3,2. Thank you!

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.