[sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003 using Oracle SQL Developer

Bug #974830 reported by Andy Choens on 2012-04-06
110
This bug affects 23 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
linux (Ubuntu)
High
Unassigned
Precise
High
Timo Aaltonen
xserver-xorg-video-intel (Ubuntu)
High
Timo Aaltonen
Precise
Critical
Unassigned

Bug Description

SRU justification:

Impact: fixes hangs with sandybridge hw
Fix: framebuffer compression for sandybridge got disabled upstream in v3.3, and is queued for 3.2 stable
Testcase: many Java apps (like Oracle sqldeveloper) can trigger a hang, but there are a number of freeze bugs filed, no idea how many of those get fixed by disabling FBC

--

When I try to use a Java app (example - Oracle sqldeveloper) or attach an external monitor, my GPU hangs and crashes.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Chipset: sandybridge-m-gt2+
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri Apr 6 00:14:15 2012
DistUpgraded: 2012-03-25 01:29:05,765 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Several times a day
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 4286CTO
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=16349118-6988-480b-a70b-4bb30b3a2d91 ro quiet splash pcie_aspm=force i915.i915_enable_rc6=1 vt.handoff=7
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003
UpgradeStatus: Upgraded to precise on 2012-03-25 (11 days ago)
UserGroups:

dmi.bios.date: 05/13/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET45WW (1.15 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4286CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET45WW(1.15):bd05/13/2011:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4286CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.4-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Andy Choens (andy-choens) wrote :
tags: removed: need-duplicate-check
Andy Choens (andy-choens) wrote :

The error reported here happened when running sqldeveloper. I can reproduce this bug under Unity, Gnome-Shell and Gnome Classic (Fallback) mode. I can't get a solid dump from the hang when I plug in an external monitor because the system completely locks up. I can't even ssh in.

Thus far, I have found the performance of the intel driver to be problematic under Precise. For my purposes, this is the biggest bug affecting my use of Precise but is, at the moment, making it difficult for me to switch to precise full-time so I can test it further.

Andy Choens (andy-choens) wrote :

It seems that this bug is getting worse. I can not use Gnome-Commander or many other apps because they cause a hang in the GPU. This isn't killing the computer completely. I don't have to reset the system but it does cause a momentary system freeze and sometimes compixz/Unity are unable to recover and I'm left without a window manager. My Lenovo X220 with i5 / Intel graphics is having real prolems with Precise.

Bryce Harrington (bryce) on 2012-04-10
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High

Forwarding this bug from Ubuntu reporter Andy Choens:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/974830

[Problem]
GPU lockup using Java apps or hotplugging a monitor

[Original Description]
When I try to use a Java app (example - Oracle sqldeveloper) or attach an external monitor, my GPU hangs and crashes.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Chipset: sandybridge-m-gt2+
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri Apr 6 00:14:15 2012
DistUpgraded: 2012-03-25 01:29:05,765 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DuplicateSignature: [sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Several times a day
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
MachineType: LENOVO 4286CTO
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-22-generic root=UUID=16349118-6988-480b-a70b-4bb30b3a2d91 ro quiet splash pcie_aspm=force i915.i915_enable_rc6=1 vt.handoff=7
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003
UpgradeStatus: Upgraded to precise on 2012-03-25 (11 days ago)
UserGroups:

dmi.bios.date: 05/13/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 8DET45WW (1.15 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4286CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8DET45WW(1.15):bd05/13/2011:svnLENOVO:pn4286CTO:pvrThinkPadX220:rvnLENOVO:rn4286CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4286CTO
dmi.product.version: ThinkPad X220
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.4-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Created attachment 59771
BootDmesg.txt

Created attachment 59772
CurrentDmesg.txt

Created attachment 59773
i915_error_state.txt

Created attachment 59774
XorgLog.txt

Bryce Harrington (bryce) wrote :

Andy Choens - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=48525 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Triaged

Further comments from reporter:

"""
The error reported here happened when running sqldeveloper. I can reproduce this bug under Unity, Gnome-Shell and Gnome Classic (Fallback) mode. I can't get a solid dump from the hang when I plug in an external monitor because the system completely locks up. I can't even ssh in.

Thus far, I have found the performance of the intel driver to be problematic under Precise. For my purposes, this is the biggest bug affecting my use of Precise but is, at the moment, making it difficult for me to switch to precise full-time so I can test it further.

It seems that this bug is getting worse. I can not use Gnome-Commander or many other apps because they cause a hang in the GPU. This isn't killing the computer completely. I don't have to reset the system but it does cause a momentary system freeze and sometimes compixz/Unity are unable to recover and I'm left without a window manager. My Lenovo X220 with i5 / Intel graphics is having real prolems with Precise.
"""

Bryce Harrington (bryce) wrote :

Also I suspect the lockup with external monitor plugging may be a separate issue than the gpu lockup. You might try using netconsole to see if you can get the dmesg output for that, and then file a new bug report.

Bryce Harrington (bryce) wrote :

For the external monitor lockup, you might try this ppa:
   https://launchpad.net/~sarvatt/+archive/sru6

This contains the following upstream patch, which fixes a common failure on ext. monitor hotplug.
   http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=1c2932e9cb283942567c3dd2695d03b8045da27f

Bryce Harrington (bryce) on 2012-04-10
tags: added: kernel-handoff-graphics
Bryce Harrington (bryce) wrote :

@kernel team - upstream says framebuffer compression should be disabled for sandybridge as an interim fix to this and other similar issues. This was disabled in 3.3-rc4 due to BLT ring problems and performance issues. I do not know if they have plans to backport the disablement to 3.2.

Bryce Harrington (bryce) wrote :

@kernel team - Upstream suggests as an alternative to test the following patch:

http://cgit.freedesktop.org/~danvet/drm/commit/?h=for-chainsaw&id=b9cc0560cc47eb52d2e4f9d820f3ebdcb8d0a83e

Brad Figg (brad-figg) on 2012-04-10
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Fix Released
Bryce Harrington (bryce) on 2012-04-10
summary: - [sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003
+ [sandybridge-m-gt2+] GPU lockup render.IPEHR: 0x78170003 using Oracle
+ SQL Developer
Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Choens (andy-choens) wrote :

Thanks for the netconsole tip. When I see the xorg packages pushed out, I'll upgrade and see if I can still crash the desktop.

Andy Choens (andy-choens) wrote :

I am still experiencing this problem. In fact, the GPU now hangs repeatedly for the first few seconds after opening a new Unity Desktop session. I am fully updated.

Andy Whitcroft (apw) wrote :

I have pulled the "Color BLT w/a" patch from comment #15 back to precise (for another bug) and built some test kernels. If those of you who can reproduce this issue can test the kernels at the URL below and confirm whether this fixes things:

    http://people.canonical.com/~apw/lp981261-precise/

Please report any testing back here.

Andy Whitcroft (apw) on 2012-04-17
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Andy Choens (andy-choens) wrote :

I just spent the last 30 minutes or so using sqldeverloper and razorsql, another java based application that was causing me problems. So far, I have not had any problems. I am using the amd64 version of the kernel you created. I no longer own anything that runs 32-bit so I'm afraid someone else will have to test that but so far I like it and I don't see any obvious regressions.

Later today I'll unplug the laptop and check to see that my power usage looks OK.

Andy Choens (andy-choens) wrote :

I have now used your kernel for several hours at work using a variety of apps and have experienced no regressions. Again, this is relevant to the amd64 image only.

Andy Choens (andy-choens) wrote :

After unplugging the laptop and looking at powertop, I don't see anything unusual or problematic.

Bryce Harrington (bryce) wrote :

[For tracking purposes setting the X task to fix committed to indicate the kernel patch is verified.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Committed
Andy Choens (andy-choens) wrote :

Any word on when the patch will be released in a kernel update? Until a patch is released, I'd rather continue to use the kernel you created allowing me to use Java apps without crashing the computer.

Andy Choens (andy-choens) wrote :

Unfortunately, this patch was never loaded into the mainline kernel. I removed the patched kernel yesterday and upgraded to Pangolin yesterday and can no longer use sqldeveloper or other applications that trigger this bug.

William Lachance (wrlach) wrote :

Hopefully not adding to the noise, just wanted to pipe in and say that using Andy Whitcroft's kernel images fixed this issue for me on my Thinkpad W520.

Before I was getting all sorts of random crashes and freezes in Gnome Shell under normal operation (xchat, Firefox Aurora, etc.). My system was basically unusable.

Andy Whitcroft's kernel images fixed this issue for me on my Thinkpad T420s.

Before I was getting all sorts of random X crashes mostly when working with sqldeveloper. My system was basically unusable.

How can we get this patch into the mainline kernel?

Andy Choens (andy-choens) wrote :

I agree that I want to see it in a released kernel. In the meantime, I've discovered that the Squirrel SQL tool does not trigger the bug and I've been using it instead of SQL Developer for that reason. It isn't as nice of a system but it gets the job done. Might be a useful work around for someone.

Aede (vdweij) wrote :

This problems occurs when I'm using SoapUi, another Java Swing based application. It started after upgrading from 11.10 to 12.04 last month.

Really like to see it in the main kernel release. Is there anything that can be done to speed this up?

Dan Jared (danjaredg) wrote :

When the fix is ready for update?

Timo Aaltonen (tjaalton) wrote :

The proposed commit is confirmed to fix the issue, so please consider adding it to precise.

Changed in linux (Ubuntu):
status: Incomplete → Triaged
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Committed → Triaged
Timo Aaltonen (tjaalton) wrote :

hmm, marking the -intel task as fix committed made it not appear on the precise bug list, so changing back to triaged so we can better see the progress.

Changed in linux (Ubuntu):
importance: Medium → High
Andy Choens (andy-choens) wrote :

This really needs to get resolved sooner rather than later. I am seriously considering downgrading to 11.10 because it is so much more stable for me. I use Ubuntu because I want a stable development platform and right now, 12.04 just ain't ready for my needs.

Timo Aaltonen (tjaalton) wrote :

there is a kernel update coming next week, though it won't have this commit in it.

Timo Aaltonen (tjaalton) wrote :

Andy: could you test something simple.. to disable FBC you can give an option to the kernel 'i915.i915_enable_fbc=0' by editing the kernel options from the boot menu. So if could test with that when booting the -25 kernel it would be great.

There is a commit in upstream v3.2 stable queue disabling that, and it's a oneliner change that _should_ be possible to get in the next kernel upload.. here's hoping.

Lucazade (lucazade) wrote :

@Timo Aaltonen (tjaalton)

added 'i915.i915_enable_fbc=0' to kernel params and it fixed the issue totally!
thanks for the workaroud.. awaiting for the final fix :)

Timo Aaltonen (tjaalton) wrote :

phew, thanks for testing Lucazade! I'll try to squeeze the upstream commit in the next upload.. it changes just one integer after all :)

Timo Aaltonen (tjaalton) on 2012-06-07
description: updated
description: updated
Timo Aaltonen (tjaalton) on 2012-06-07
Changed in xserver-xorg-video-intel (Ubuntu):
assignee: nobody → Timo Aaltonen (tjaalton)
Andy Choens (andy-choens) wrote :

I agree. This appears to fix the problem without causing any other regressions. (thus far). I'm running two Java applications that were nearly impossible to use before and right now they are both running flawlessly. Sorry my reply took so long. Meetings. Not the most productive way to start the day.

Brad Figg (brad-figg) on 2012-06-07
Changed in linux (Ubuntu Precise):
status: New → Fix Committed
Timo Aaltonen (tjaalton) wrote :

let's just close this for quantal, since it's been verified that 3.3/3.4 both work fine

Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Fix Released
Changed in xserver-xorg-video-intel (Ubuntu Precise):
importance: Undecided → High
status: New → Fix Committed
Luis Henriques (henrix) wrote :

This bug is awaiting verification that the kernel for Precise in -proposed solves the problem (3.2.0-26.41). Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-precise' to 'verification-done-precise'.

If verification is not done by one week from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-precise
Aede (vdweij) wrote :

I have been using the 3.2.0-26.41 kernel for over a day now and do not experience momentary system freezes anymore. Previously they were happening pretty often and sometimes compixz/Unity could not recover. The new kernel appaers to fix this issue.

tags: added: verification-done-precise
removed: verification-needed-precise
Changed in linux (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Timo Aaltonen (tjaalton)
Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package linux - 3.2.0-26.41

---------------
linux (3.2.0-26.41) precise-proposed; urgency=low

  [Luis Henriques]

  * Release Tracking Bug
    - LP: #1012057

  [ Andy Whitcroft ]

  * [Config] fix up postinst to ensure we know which error is which
    - LP: #1002388
  * [Config] highbank -- commonise filesystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise subsystems
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise network protocols
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise input drivers
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRYPTO options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise HID options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise sensors options
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise EXPORTFS/FHANDLE
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_CRYPTO_LZO
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise ENCRYPTED_KEYS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CONFIG_ATALK
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise INET/INET6
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise NLS
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BLK/CHR
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise PHY settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise CRC settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise BINFMT settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise DM settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise RTC_DRV settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise KEYBOARD/MOUSE settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise USB settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise GPIO settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise I2C settings
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise numerous subsystem selectors
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise A-C modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise D-F modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise G-I modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise J-L modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise M modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise N-P modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise Q-R modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise S modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise T modules missmatches
    - LP: #1000831, #1010463
  * [Config] highbank -- commonise U-Z modules missmatches
    - LP: #1000831, #1010463

  [ Herton Ronaldo Krzesinski ]

  * SAUCE: fix get_gate_vma call in i386 NX emulation code
    - LP: #1009200

  [ Ike Panhc ]

  * [Config] add...

Changed in linux (Ubuntu Precise):
status: Fix Committed → Fix Released
Timo Aaltonen (tjaalton) on 2012-08-03
Changed in xserver-xorg-video-intel (Ubuntu Precise):
importance: High → Critical
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.