[sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003

Bug #981261 reported by fgr1986 on 2012-04-13
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
linux (Ubuntu)
Medium
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

Error on login.
The error "[sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003" shows on login half the times.
The other half the X server gets frozen and I have to restart the X's or the system

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Chipset: sandybridge-m-gt2
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri Apr 13 15:18:46 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.4.1, 3.2.0-23-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-23-generic, x86_64: installed
DuplicateSignature: [sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GpuHangFrequency: Several times a day
GpuHangReproducibility: Occurs more often under certain circumstances
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:fc31]
 NVIDIA Corporation GF108 [GeForce GT 540M] [10de:0df4] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
MachineType: TOSHIBA SATELLITE P750
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=47966917-c048-45a8-a852-b1850c6e207d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+12ubuntu1
 libdrm2 2.4.32-1ubuntu1
 xserver-xorg-video-intel 2:2.17.0-1ubuntu4
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 07/13/2011
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 2.10
dmi.board.asset.tag: NULL
dmi.board.name: PEQAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvr2.10:bd07/13/2011:svnTOSHIBA:pnSATELLITEP750:pvrPSAY3E-03S018CE:rvnTOSHIBA:rnPEQAA:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: SATELLITE P750
dmi.product.version: PSAY3E-03S018CE
dmi.sys.vendor: TOSHIBA
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

fgr1986 (fernando-garca) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Download full text (3.5 KiB)

Forwarding this bug from Ubuntu reporter fgr1986:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/981261

[Problem]
One of several 0x7... bugs happening on Ubuntu. This one occurs on login

[Original Description]
Error on login.
The error "[sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003" shows on login half the times.
The other half the X server gets frozen and I have to restart the X's or the system

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Chipset: sandybridge-m-gt2
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Fri Apr 13 15:18:46 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.4.1, 3.2.0-23-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-23-generic, x86_64: installed
DuplicateSignature: [sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003 Ubuntu 12.04
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GpuHangFrequency: Several times a day
GpuHangReproducibility: Occurs more often under certain circumstances
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:fc31]
 NVIDIA Corporation GF108 [GeForce GT 540M] [10de:0df4] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InterpreterPath: /usr/bin/python2.7
MachineType: TOSHIBA SATELLITE P750
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=47966917-c048-45a8-a852-b1850c6e207d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+12ubuntu1
 libdrm2 2.4.32-1ubuntu1
 xserver-xorg-video-intel 2:2.17.0-1ubuntu4
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-m-gt2] GPU lockup render.IPEHR: 0x78170003
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 07/13/2011
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 2.10
dmi.board.asset.tag: NULL
dmi.board.name: PEQAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvr2.10:bd07/13/2011:svnTOSHIBA:pnSATELLITEP750:pvrPSAY3E-03S018CE:rvnTOSHIBA:rnPEQAA:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: SATELLITE P750
dmi.product.version: PSAY3E-03S018CE
dmi.sys.vendor: TOSHIBA
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubunt...

Read more...

Created attachment 60111
BootDmesg.txt

Created attachment 60112
CurrentDmesg.txt

Created attachment 60113
i915_error_state.txt

Created attachment 60114
XorgLog.txt

Bryce Harrington (bryce) wrote :

fgr1986 - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=48790 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Triaged
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → Confirmed

1. Disable FBC.
2.

commit 80e829fade4eea5f07c410df6a551c42e2d0ca9c
Author: Daniel Vetter <email address hidden>
Date: Sat Mar 31 11:21:57 2012 +0200

    drm/i915: implement ColorBlt w/a

    According to an internal workaround master list, we need to set bit 5
    of register 9400 to avoid issues with color blits.

    Testing shows that this seems to fix the blitter hangs when fbc is
    enabled on snb, thanks to Chris Wilson for figuring this out.

    Tested-by: Chris Wilson <email address hidden>
    Tested-by: Michael "brot" Groh <email address hidden>
    Acked-by: Ben Widawsky <email address hidden>
    Signed-Off-by: Daniel Vetter <email address hidden>

Bryce Harrington (bryce) on 2012-04-17
tags: added: kernel-handoff-graphics
Brad Figg (brad-figg) on 2012-04-17
Changed in linux (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

Upstream indicates they believe it to be fixed by disabling framebuffer compression and adding this kernel patch (present in linux master):

commit 80e829fade4eea5f07c410df6a551c42e2d0ca9c
Author: Daniel Vetter <email address hidden>
Date: Sat Mar 31 11:21:57 2012 +0200

    drm/i915: implement ColorBlt w/a

    According to an internal workaround master list, we need to set bit 5
    of register 9400 to avoid issues with color blits.

    Testing shows that this seems to fix the blitter hangs when fbc is
    enabled on snb, thanks to Chris Wilson for figuring this out.

    Tested-by: Chris Wilson <email address hidden>
    Tested-by: Michael "brot" Groh <email address hidden>
    Acked-by: Ben Widawsky <email address hidden>
    Signed-Off-by: Daniel Vetter <email address hidden>

Changed in linux (Ubuntu):
status: Confirmed → New
Brad Figg (brad-figg) on 2012-04-17
Changed in linux (Ubuntu):
status: New → Confirmed
Andy Whitcroft (apw) wrote :

I have pulled the patch from comment #9 back to precise and built some test kernels. If those of you who can reproduce this issue can test the kernels at the URL below and confirm whether this fixes things:

    http://people.canonical.com/~apw/lp981261-precise/

Please report any testing back here.

Changed in linux (Ubuntu):
importance: Undecided → Medium
Andy Whitcroft (apw) on 2012-04-17
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Bryce Harrington (bryce) on 2012-04-19
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
Bryce Harrington (bryce) on 2012-04-20
Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → In Progress
Timo Aaltonen (tjaalton) wrote :

sugree, fgr1986, Steph Vast; we need your feedback! Test the kernel found here

http://people.canonical.com/~apw/lp981261-precise/

and report back if it fixes the issue.

sugree (sugree) wrote :

This kernel has been tested in other bug which should be identical with this issue for a while.

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/974830

And it fixes GPU lockup in several java applications. Probably this is the same issue but at least they seem to relate. I will be glad if you apply this patch to the main kernel release.

Timo Aaltonen (tjaalton) wrote :

Oh cool, perhaps I should mark this one as a dupe of the other bug then. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.