sandybridge-gt1 GPU lockup

Bug #980198 reported by jascha on 2012-04-12
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
High
xserver-xorg-video-intel (Ubuntu)
High
Unassigned

Bug Description

hangs up after scrolling down a web page with some images but without flash

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Chipset: sandybridge-gt1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Thu Apr 12 21:24:49 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-22-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-23-generic, x86_64: installed
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Continuously
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation Device [1849:0102]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
InterpreterPath: /usr/bin/python2.7
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=f9070d7d-a7b6-47b3-bfed-f3d37adb15b1 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+12ubuntu1
 libdrm2 2.4.32-1ubuntu1
 xserver-xorg-video-intel 2:2.17.0-1ubuntu4
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-gt1] GPU lockup
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 07/08/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.60
dmi.board.name: H67M
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.60:bd07/08/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH67M:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.7.4-0ubuntu3
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

jascha (jaschak) wrote :
Bryce Harrington (bryce) wrote :

Hi, unfortunately apport did not capture a valid error state from this lockup. Are you able to reproduce the hang scrolling on the web page? If so, can you give a link to one of the pages where scrolling makes it lock up?

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
jascha (jaschak) wrote :

i did capture an error state myself, see attachment. The webpage was http://forum.xda-developers.com/ and i was just scrolling down to search for my mobile.

Bryce Harrington (bryce) on 2012-04-17
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Download full text (3.6 KiB)

Forwarding this bug from Ubuntu reporter jascha:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/980198

[Problem]
Yet another intermittent snb lockup. The user is able to easily reproduce this by browsing web pages with pictures.

[Original Description]
hangs up after scrolling down a web page with some images but without flash

i did capture an error state myself, see attachment. The webpage was http://forum.xda-developers.com/ and i was just scrolling down to search for my mobile.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Chipset: sandybridge-gt1
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
Date: Thu Apr 12 21:24:49 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-22-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-23-generic, x86_64: installed
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GpuHangFrequency: Continuously
GpuHangReproducibility: Yes, I can easily reproduce it
GpuHangStarted: Immediately after installing this version of Ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASRock Incorporation Device [1849:0102]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120201.1)
InterpreterPath: /usr/bin/python2.7
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=f9070d7d-a7b6-47b3-bfed-f3d37adb15b1 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6+12ubuntu1
 libdrm2 2.4.32-1ubuntu1
 xserver-xorg-video-intel 2:2.17.0-1ubuntu4
SourcePackage: xserver-xorg-video-intel
Title: [sandybridge-gt1] GPU lockup
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 07/08/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.60
dmi.board.name: H67M
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.60:bd07/08/2011:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH67M:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
version.compiz: compiz 1:0.9.7.4-0ubuntu3
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libg...

Read more...

Created attachment 60356
BootDmesg.txt

Created attachment 60357
CurrentDmesg.txt

Created attachment 60358
XorgLog.txt

Created attachment 60359
i915_error_state.txt

Created attachment 60360
i915_error_state_webpage

I had the user gather a second error state file since the first one didn't look like it had any valid data. Yet this one looked much the same. So these may not be at all useful for diagnostics.

However, forwarding the bug since the steps to reproduce are so specific and the user's able to reproduce it very reliably.

Bryce Harrington (bryce) wrote :

jascha - I've forwarded this bug upstream to https://bugs.freedesktop.org/show_bug.cgi?id=48940 - please subscribe yourself to this bug, in case they need further information or wish you to test something. Thanks ahead of time!

Changed in xserver-xorg-video-intel:
importance: Unknown → High
status: Unknown → Confirmed

Turn off FBC and
commit 80e829fade4eea5f07c410df6a551c42e2d0ca9c
Author: Daniel Vetter <email address hidden>
Date: Sat Mar 31 11:21:57 2012 +0200

    drm/i915: implement ColorBlt w/a

    According to an internal workaround master list, we need to set bit 5
    of register 9400 to avoid issues with color blits.

    Testing shows that this seems to fix the blitter hangs when fbc is
    enabled on snb, thanks to Chris Wilson for figuring this out.

    Tested-by: Chris Wilson <email address hidden>
    Tested-by: Michael "brot" Groh <email address hidden>
    Acked-by: Ben Widawsky <email address hidden>
    Signed-Off-by: Daniel Vetter <email address hidden>

Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.