Ubuntu

[i915gm] GPU lockup 1df215e0 (PGTBL_ER: 0x00000010)

Reported by Kim Tyler on 2010-02-21
150
This bug affects 32 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
linux (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Everything seems to work OK, but I have the crash indicator in the panel, so I'm reporting it if it of some use to you

ProblemType: Crash
Architecture: i386
Date: Mon Feb 22 00:48:45 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100113)
InterpreterPath: /usr/bin/python2.6
MachineType: ASUSTeK Computer INC. 1000HD
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu5
ProcAttrCurrent: unconfined (enforce)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=db8f94ce-391e-4fbe-a39a-72c8dd774668 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu6
 libgl1-mesa-glx 7.7-3ubuntu1
 libdrm2 2.4.18-1ubuntu2
 xserver-xorg-video-intel 2:2.9.1-1ubuntu5
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.32-12-generic i686
UserGroups:

dmi.bios.date: 07/11/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0601
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1000HD
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0601:bd07/11/2008:svnASUSTeKComputerINC.:pn1000HD:pvrx.x:rvnASUSTeKComputerINC.:rn1000HD:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1000HD
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.32-12-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04)
     Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]

Kim Tyler (ktyler) wrote :
Bryce Harrington (bryce) on 2010-02-24
tags: added: crash
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-03-04
summary: - crash detected after login
+ X freeze on netbook
Bryce Harrington (bryce) on 2010-03-04
tags: added: freeze

[This is an automatic notification.]

Thanks for reporting this bug to help making the Intel graphics driver
better. We hear from upstream that a number of bugs (possibly including
this one) have been fixed in the newer DRM code from the 2.6.33 kernel.
I don't know if your bug is one of the ones fixed in this release,
though, but we've prepared a PPA with this DRM update. Would you mind
installing this, rebooting, and testing if the original issue can be
reproduced with it or not?

The DRM PPA is here:

    https://edge.launchpad.net/~apw/+archive/red

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug linux' (for kernel or DRM or KMS bugs) or
'ubuntu-bug xorg' if you suspect them to be X.org issues.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete

I have install new kernel from PPA (described below) and the problem
still exists. (along with some kerneloops - not sent to bugs).

I have filed a new bug which is probably a duplicate of this ( bug #532381)

Good luck

Bryce Harrington wrote:
> [This is an automatic notification.]
>
> Thanks for reporting this bug to help making the Intel graphics driver
> better. We hear from upstream that a number of bugs (possibly including
> this one) have been fixed in the newer DRM code from the 2.6.33 kernel.
> I don't know if your bug is one of the ones fixed in this release,
> though, but we've prepared a PPA with this DRM update. Would you mind
> installing this, rebooting, and testing if the original issue can be
> reproduced with it or not?
>
> The DRM PPA is here:
>
> https://edge.launchpad.net/~apw/+archive/red
>
> Note there could be new bugs... please file these as new reports using
> the command 'ubuntu-bug linux' (for kernel or DRM or KMS bugs) or
> 'ubuntu-bug xorg' if you suspect them to be X.org issues.
>
>
> ** Changed in: xserver-xorg-video-intel (Ubuntu)
> Status: Confirmed => Incomplete
>
>

Kim Tyler (ktyler) wrote :
Kim Tyler (ktyler) wrote :
Kim Tyler (ktyler) wrote :

Please note that the PC display is not hanging. It continues on and displays a screen either as tty7 or tty8. If the display is tty7, there are framebuffer error messages above the tty login prompt on tty1 ; if the display is on tty8, there are framebuffer error messages on the tty7, with tty7 not showing any other text/graphics.

We have several automatically reported GPU errors on 915GM on Ubuntu 10.04 with PGTBL_ER: 0x00000010 and a ringbuffer which is all zero.
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/525517
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/532225
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/532381
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/533364
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/533876
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/535613

Kim Tyler from the first report says that he doesn't notice anything wrong except for the error messages in dmesg and the automatic bug report. Kim has also tested with drm-intel-next kernel and i915_error_state form that will be attached.

Architecture: i386
DistroRelease: Ubuntu 10.04
Frequency: Once a day.
HibernationDevice: RESUME=UUID=feb1300b-9c1a-42f4-a3f1-ea81c5d2b518
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100304)
MachineType: ASUSTeK Computer INC. 900
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu13
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=4a909b82-8b3d-48b0-ad9a-806db385f535 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Uname: Linux 2.6.32-16-generic i686
dmi.bios.date: 07/07/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0802
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 900
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0802:bd07/07/2008:svnASUSTeKComputerINC.:pn900:pvr0704:rvnASUSTeKComputerINC.:rn900:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 900
dmi.product.version: 0704
dmi.sys.vendor: ASUSTeK Computer INC.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

Created an attachment (id=34034)
i915_error_state from intel-drm-next kernel

Created an attachment (id=34035)
intel_error_decode output on the previously attache i915_error_state

Created an attachment (id=34036)
dmesg output

Created an attachment (id=34037)
Xorg.0.log

One thing I noticed was that while in the automatically reported outputs of intel_gpu_dump the ringbuffer start at 0x00000000, in the intel_error_decode output it starts at 0x007bf000, but in both cases the head is at ACTHD: 0x00000000, which doesn't make much sense in the latter case.

I should have been more specific in Kim's description of the symptoms. This is what he writes:

Please note that the PC display is not hanging. It continues on and displays a screen either as tty7 or tty8. If the display is tty7, there are framebuffer error messages above the tty login prompt on tty1 ; if the display is on tty8, there are framebuffer error messages on the tty7, with tty7 not showing any other text/graphics.

I have marked two more downstream bug reports as duplicates of this one:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/533139
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/535454

In these bugs there were some slight differences:
- In the first one the CPU has started writing to the ringbuffer, but the GPU hasn't started writing yet (ACTHD: 0x00000000).
- In the second bug report the GPU has also started reading, and it has PGTBL_ER: 0x00000001 instead of PGTBL_ER: 0x00000001.

Geir Ove Myhr (gomyhr) on 2010-03-14
summary: - X freeze on netbook
+ [i915gm] X freeze on netbook
Geir Ove Myhr (gomyhr) on 2010-03-14
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Triaged

Thank you Kim, this is exactly what we needed. I have forwarded the bug to the intel developers upstream at https://bugs.freedesktop.org/show_bug.cgi?id=27070 . Please subscribe to the upstream bug report (i.e. register to get a user and add yourself to the CC field) so that you may get any updates and answer any questions that the developers might have. Also, if you think there is some information that I failed to mention, you can add a comment there.

I'm attaching the output of intel_error_decode, which decodes the i915_error_state file to a more human readable format. The output is comparable to the intel_gpu_dump output.

summary: - [i915gm] X freeze on netbook
+ [i915gm] GPU error 1df215e0 (PGTBL_ER: 0x00000010)
Changed in xserver-xorg-video-intel:
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2010-03-17
description: updated

Architecture: i386
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100304)
MachineType: ASUSTeK Computer INC. 900
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu16
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-16-generic root=UUID=4a909b82-8b3d-48b0-ad9a-806db385f535 ro quiet splash
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
Tags: lucid lucid
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin netdev plugdev sambashare
dmi.bios.date: 07/07/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0802
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 900
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0802:bd07/07/2008:svnASUSTeKComputerINC.:pn900:pvr0704:rvnASUSTeKComputerINC.:rn900:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 900
dmi.product.version: 0704
dmi.sys.vendor: ASUSTeK Computer INC.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.32-16-generic

tags: added: apport-collected

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Geir Ove Myhr (gomyhr) on 2010-03-20
summary: - [i915gm] GPU error 1df215e0 (PGTBL_ER: 0x00000010)
+ [i915gm] GPU lockup 1df215e0 (PGTBL_ER: 0x00000010)
Geir Ove Myhr (gomyhr) wrote :

mikeh789, thank you for providing the apport-collect information in order to help with this issue. apport-collect is a powerful command in that it attaches a lot of potentially useful information to a bug report. Because of this, it also takes a lot of space in a bug report, so we would prefer that it is not used unsolicited. In this case we did not need this information so it would have been better if you had not run apport-collect 525517. Thank you anyway for your good intentions!

PS: Only very rarely would we want anyone but the original reporter of a bug to run apport-collect on that bug report, since gets easy to mix up which information comes from who. Just like I asked Kim at your bug 532225 to attach his information on this (i.e. his) bug report, we would have wanted your files on bug 532225 if we needed them.

holstein (mikeholstein) wrote :

will do.. i just assumed that was the next step... /me is learning... thanks for your time

TAKE ME OFF OF YOUR LIST!
<email address hidden>

--- On Sat, 3/20/10, mikeh789 <email address hidden> wrote:

From: mikeh789 <email address hidden>
Subject: [Bug 525517] GdmLog.txt
To: <email address hidden>
Date: Saturday, March 20, 2010, 2:28 PM

apport information

** Attachment added: "GdmLog.txt"
   http://launchpadlibrarian.net/41418453/GdmLog.txt

--
[i915gm] GPU error 1df215e0 (PGTBL_ER: 0x00000010)
https://bugs.launchpad.net/bugs/525517
You received this bug notification because you are subscribed to Ubuntu.

Status in X.org xf86-video-intel: Confirmed
Status in “xserver-xorg-video-intel” package in Ubuntu: Triaged

Bug description:
Binary package hint: xserver-xorg-video-intel

Everything seems to work OK, but I have the crash indicator in the panel, so I'm reporting it if it of some use to you

ProblemType: Crash
Architecture: i386
Date: Mon Feb 22 00:48:45 2010
DistroRelease: Ubuntu 10.04
DkmsStatus: Error: [Errno 2] No such file or directory
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100113)
InterpreterPath: /usr/bin/python2.6
MachineType: ASUSTeK Computer INC. 1000HD
Package: xserver-xorg-video-intel 2:2.9.1-1ubuntu5
ProcAttrCurrent: unconfined (enforce)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=db8f94ce-391e-4fbe-a39a-72c8dd774668 ro quiet splash
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
RelatedPackageVersions:
 xserver-xorg 1:7.5+1ubuntu6
 libgl1-mesa-glx 7.7-3ubuntu1
 libdrm2 2.4.18-1ubuntu2
 xserver-xorg-video-intel 2:2.9.1-1ubuntu5
SourcePackage: xserver-xorg-video-intel
Uname: Linux 2.6.32-12-generic i686
UserGroups:

dmi.bios.date: 07/11/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0601
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1000HD
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0601:bd07/11/2008:svnASUSTeKComputerINC.:pn1000HD:pvrx.x:rvnASUSTeKComputerINC.:rn1000HD:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1000HD
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro:             Ubuntu
 architecture:       i686kernel:             2.6.32-12-generic

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04)
        Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]

Kim Tyler (ktyler) wrote :
Download full text (5.4 KiB)

I have been installing all updates when they become available, and have noticed that there is no crash report for the video anymore.

However, I am still seeing errors on tty1 when rebooting, and error messages in /var/log/kern.log and /var/log/syslog - see below :-

=============syslog================
<snip>
Mar 30 11:05:52 eeepc kernel: [ 16.018721] fb0: inteldrmfb frame buffer device
Mar 30 11:05:52 eeepc kernel: [ 16.018728] registered panic notifier
Mar 30 11:05:52 eeepc kernel: [ 16.018745] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
Mar 30 11:05:52 eeepc kernel: [ 16.018824] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Mar 30 11:05:52 eeepc kernel: [ 16.018883] HDA Intel 0000:00:1b.0: setting latency timer to 64
Mar 30 11:05:52 eeepc kernel: [ 16.035003] vga16fb: initializing
Mar 30 11:05:52 eeepc kernel: [ 16.035013] vga16fb: mapped to 0xc00a0000
Mar 30 11:05:52 eeepc kernel: [ 16.035022] vga16fb: not registering due to another framebuffer present
Mar 30 11:05:52 eeepc kernel: [ 16.245228] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input9
Mar 30 11:05:52 eeepc kernel: [ 16.268051] Console: switching to colour frame buffer device 128x37
Mar 30 11:05:52 eeepc gdm-binary[863]: WARNING: Unable to find users: no seat-id found
Mar 30 11:05:52 eeepc kernel: [ 16.732140] composite sync not supported
Mar 30 11:05:53 eeepc kernel: [ 17.384072] render error detected, EIR: 0x00000010
Mar 30 11:05:53 eeepc kernel: [ 17.384171] page table error
Mar 30 11:05:53 eeepc kernel: [ 17.384221] PGTBL_ER: 0x00000010
Mar 30 11:05:53 eeepc kernel: [ 17.384282] [drm:i915_handle_error] *ERROR* EIR stuck: 0x00000010, masking
Mar 30 11:05:53 eeepc kernel: [ 17.384407] render error detected, EIR: 0x00000010
Mar 30 11:05:53 eeepc kernel: [ 17.384489] page table error
Mar 30 11:05:53 eeepc kernel: [ 17.384539] PGTBL_ER: 0x00000010

<snip>

Mar 30 11:05:54 eeepc kernel: [ 18.112589] composite sync not supported
Mar 30 11:05:54 eeepc kernel: [ 18.804073] composite sync not supported
Mar 30 11:05:56 eeepc kernel: [ 20.331397] composite sync not supported
Mar 30 11:05:57 eeepc kernel: [ 21.028102] composite sync not supported
Mar 30 11:05:57 eeepc kernel: [ 21.723366] composite sync not supported

<snip>

Mar 30 11:06:11 eeepc kernel: [ 35.676021] wlan0: no IPv6 routers present
Mar 30 11:06:12 eeepc kernel: [ 36.576108] composite sync not supported
Mar 30 11:06:13 eeepc kernel: [ 37.292165] composite sync not supported
Mar 30 11:06:14 eeepc kernel: [ 38.016584] composite sync not supported

<snip>

==============END of syslog===============

=============kern.log===================
<snip>

Mar 30 11:05:51 eeepc kernel: [ 15.860045] ppdev: user-space parallel port driver
Mar 30 11:05:52 eeepc kernel: [ 16.018721] fb0: inteldrmfb frame buffer device
Mar 30 11:05:52 eeepc kernel: [ 16.018728] registered panic notifier
Mar 30 11:05:52 eeepc kernel: [ 16.018745] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
Mar 30 11:05:52 eeepc kernel: [ 16.018824] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
Mar 3...

Read more...

Kim Tyler (ktyler) wrote :

Updated system this morning 31st Mar 8:00 am (UTC+10) and all of above behavior is now fixed. No app crash, no PGTBL error etc.

Only problem is switching from X to TTY and back again garbles the X screen on tty8 - but recovers after some seconds and rewrites of screen by moving windows/highlighting etc.

Should this bug be closed? Should I report another bug (unrelated to this one)?

Well done.

Kim Tyler (ktyler) wrote :

Please disregard previous entry - did another upgrade and problem is still as was previously stated, and switching X is now OK again. I must have got only a partial upgrade. Sorry for inconvenience.

Geir Ove Myhr (gomyhr) wrote :

There is a kernel patch on the intel-gfx mailing list that is supposed to fix this problem. http://lists.freedesktop.org/archives/intel-gfx/2010-May/006982.html

The pair of patches to ensure that the framebuffers are correctly aligned are now upstream, as of 2.6.35-rc2:

commit fd2e8ea597222b8f38ae8948776a61ea7958232e
Author: Chris Wilson <email address hidden>
Date: Tue Feb 9 14:14:36 2010 +0000

    drm/i915: Increase fb alignment to 64k

    An untiled framebuffer must be aligned to 64k. This is normally handled
    by intel_pin_and_fence_fb_obj(), but the intelfb_create() likes to be
    different and do the pinning itself. However, it aligns the buffer
    object incorrectly for pre-i965 chipsets causing a PGTBL_ERR when it is
    installed onto the output.

    Fixes:
      KMS error message while initializing modesetting -
      render error detected: EIR: 0x10 [i915]
      http://bugs.freedesktop.org/show_bug.cgi?id=22936

    Signed-off-by: Chris Wilson <email address hidden>
    Cc: <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

commit ac0c6b5ad3b3b513e1057806d4b7627fcc0ecc27
Author: Chris Wilson <email address hidden>
Date: Thu May 27 13:18:18 2010 +0100

    drm/i915: Rebind bo if currently bound with incorrect alignment.

    Whilst pinning the buffer, check that that its current alignment
    matches the requested alignment. If it does not, rebind.

    This should clear up any final render errors whilst resuming,
    for reference:

      Bug 27070 - [i915] Page table errors with empty ringbuffer
      https://bugs.freedesktop.org/show_bug.cgi?id=27070

      Bug 15502 - render error detected, EIR: 0x00000010
      https://bugzilla.kernel.org/show_bug.cgi?id=15502

      Bug 13844 - i915 error: "render error detected"
      https://bugzilla.kernel.org/show_bug.cgi?id=13844

    Signed-off-by: Chris Wilson <email address hidden>
    Cc: <email address hidden>
    Signed-off-by: Eric Anholt <email address hidden>

stlubuntu (jlrbennett) wrote :

I looked at the link to the patch, but need a step by step on how to apply it for testing.

Thanks.

Christopher (soft-kristal) wrote :

It occurred when resuming from suspend, with most of the devices unplugged. Yesterday it wouldn't unsuspend at all when the devices that had been in use were not used.

I suspect the Logitech AudioHub, as it has been plagued with issues for a couple of years now.

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

I notice the upstream bug has been marked fixed; is anyone still seeing this particular gpu lockup bug?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete
Kim Tyler (ktyler) wrote :

Not seeing this bug, am on maverick now

tags: added: kj-triage
Changed in xserver-xorg-video-intel:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
Bryce Harrington (bryce) wrote :

Thanks, closing as per last comment.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Fix Released
Brad Figg (brad-figg) on 2011-05-04
Changed in linux (Ubuntu):
status: New → Confirmed

Kim Tyler, this bug report is being closed due to your last comment https://bugs.launchpad.net/ubuntu/+source/linux/+bug/525517/comments/50 regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in linux (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.