Ubuntu

[i945gme] Mouse cursor disappears after restarting screen (xrandr / resume)

Reported by boert89 on 2009-12-05
460
This bug affects 109 people
Affects Status Importance Assigned to Milestone
xf86-video-ati
Confirmed
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

I use xrandr to activate my external monitor or set the screen size of my Asus Eee 900A PC. However, since the upgrade to Ubuntu Karmic, the mouse cursor disappears after using xrandr. I'm using xorg version 1:7.4+3ubuntu10 and Ubuntu 9.10.

The commands I use are:
xrandr --output LVDS --mode 800x600
xrandr --output LVDS --off --output VGA --mode 1280x1024

After using these commands, the mouse cursor disappears, but I can still focus and click. Moving the (suspected, but invisible) mouse cursor over a desktop item, highlits it and I can activate it by clicking.

One temporarily solution I've found is to switch to the console (CTRL + ALT + F1) and back (CTRL + ALT + F7). This makes the mouse cursor reappear. Using xrandr to reset to the original settings doesn't bring the cursor back.

ProblemType: Bug
Architecture: i386
Date: Sat Dec 5 10:45:14 2009
DistroRelease: Ubuntu 9.10
Lsusb: Error: command ['lsusb'] failed with exit code 1:
MachineType: ASUSTeK Computer INC. 900A
Package: xorg 1:7.4+3ubuntu10
ProcCmdLine: root=UUID=f2d72569-836f-4878-832e-3b9ad0270b07 ro quiet splash
ProcEnviron:
 LANG=de_AT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.28-12.43-hostname-eeepc
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu10
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xorg
Tags: ubuntu-unr
Uname: Linux 2.6.28-12-netbook-eeepc i686
XsessionErrors:
 (gnome-settings-daemon:2545): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2545): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (nautilus:2568): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (polkit-gnome-authentication-agent-1:2578): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 10/27/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0703
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 900A
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0703:bd10/27/2008:svnASUSTeKComputerINC.:pn900A:pvrx.x:rvnASUSTeKComputerINC.:rn900A:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 900A
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.28-12-netbook-eeepc

[lspci]
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03)
     Subsystem: ASUSTeK Computer Inc. Device [1043:8340]

boert89 (boert89) wrote :
Bryce Harrington (bryce) on 2009-12-05
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Bryce Harrington (bryce) on 2009-12-06
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Confirmed
Cactus (uzi18) wrote :

This bug also affect: PLD Linux with xserver-xorg-driver-ati

Changed in xf86-video-ati:
status: New → Confirmed
Bryce Harrington (bryce) on 2010-02-09
description: updated
Bryce Harrington (bryce) on 2010-02-15
summary: - Mouse cursor disappears after using xrandr
+ [i945gme] Mouse cursor disappears after using xrandr
Bryce Harrington (bryce) on 2010-02-25
tags: added: karmic
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945gme] Mouse cursor disappears after using xrandr
+ [i945] [i945gme] Mouse cursor disappears after using xrandr
Bryce Harrington (bryce) on 2010-03-02
summary: - [i945] [i945gme] Mouse cursor disappears after using xrandr
+ [i945gme] Mouse cursor disappears after using xrandr

same problem, another trick is writing something on gedit, so mouse shape change an it reappear

Nate Wiebe (natew) wrote :

I get the same issue on fully updated Lucid (Release Candidate). I use xrandr -x, cursor disappears. I lock screen and cursor reappears. Very annoying bug. Did not have this issue on Karmic.

Shaved Wookie (shavedwookie) wrote :

I get this when I suspend to ram and then resume. As in the above report ctrl+f1, ctrl+f7 fixes the problem as does typing in a text document.

I'm using Kubuntu Lucid Final 32bit on an AMD64 processor with an ATI HD4850 running the FOSS ati driver. I didn't have this on karmic, either.

tags: added: lucid
summary: - [i945gme] Mouse cursor disappears after using xrandr
+ Mouse cursor disappears after restarting screen (xrandr / resume)
Bryce Harrington (bryce) on 2010-05-16
tags: added: resume
Bryce Harrington (bryce) on 2010-05-21
tags: added: jaunty
Anthony David (adavid-adavid) wrote :

Had this problem with Mobility Radeon HD 3650

[See http://ubuntuforums.org/showthread.php?t=1470815&highlight=radeonhd ]

Latest kernel upgrade eliminates the invisible cursor issue for me.

  2.6.32-22-generic #35-Ubuntu SMP Tue Jun 1 14:18:25 UTC 2010 x86_64 GNU/Linux

Anthony David (adavid-adavid) wrote :

#7 was a hasty diagnosis. Problem HAS NOT been resolved with package upgrade.

seakayone (seakayone) wrote :

I am also bugged with this issue when I suspend to ram and then resume. As in the above reports ctrl+f1, ctrl+f7 fixes the problem as does typing in a text document as well as changing the workspace with ctrl+alt+cursor.

Running latest lucid Linux with FOSS ati drivers and newest kernel:
2.6.32-22-generic #36-Ubuntu SMP Thu Jun 3 22:02:19 UTC 2010 i686 GNU/Linux

I am using a Thinkpad T43p with ATI Mobility FireGL V3200 graphic card.

The above mentioned workaround does the job for me, thanks.

Please let me know if there is more useful information that I may be able provide.

Alejandro J. Cura (alecu) wrote :

I've just tested on Maverick Alpha 1, and this problem is still happening.

My original report was #552246, and was marked as a duplicate of this bug.

cwawak (chris-wawak) wrote :

Having the same problem on a T60 with 945 video. Can post dmesg and lspci -vvv and Xorg.0.log if needed.

Otto Kekäläinen (otto) wrote :

This bug has lots of duplicates and I've seen it on several computers lately.

tags: added: iso-testing
Otto Kekäläinen (otto) wrote :

There is also a question about this at https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+question/108987

Common to all bug reports I read is that:
- The symptom is that the mouse pointer is invisible, but the mouse still works: you can hover on stuff and click.
- The problem appears after the X mode changes (eg. while returning from blank screen, returning from suspend, changing resolutions, other fiddling with xrandr, sometimes even directly from boot).
- In some reports there are step-by-step how to reproduce while in some the cursor disappears randomly. At least is is sure that for average bug reporters it is hard to spot the pattern why/when the mouse pointer disappears.
- There are several workarounds that makes the X mode reload and thus brings the mouse back:
-- switching back and fourth to a console (Ctrl+Alt+F1, Ctrl+Alt+F7)
-- opening Gnome terminal and writing something (some other apps too, but writing in any app won't work)
- It seems that this bug is expressed on both Intel, ATI and Nvidia cards.
- The desktop environment seems always to be Gnome. Bug #457046 might be related - there the cursor disappears because of a race condition in Gnome which makes the cursor drawn under the window.
- Different Ubuntu releases and kernel versions are affected, however in some bug reports upgrading to a new release/kernel made the problem go away. The patch in bug #614176 comment #22 seems interesting.
- Bug #595282 hints it might be a problem in how X detects the display or some interaction between xorg-server and kernel that messes the mouse pointer.
- According to bug #475917 removing the file ~/.config/monitors.xml prevents expression of the bug.

Disclaimer: kernel drivers, Xorg, xrandr, Gnome display management etc is not my expertise, so I don't know where the problem actually is. I however hope this investigation helps somebody and decreases the number of new bugs of the same issue.

If it turns out that this is now fixed in newer kernels, please backport the fix to 10.04 LTS to increase it's stability.

Matt Smith (smith.matthew.s) wrote :

In case it helps narrow things...

I just did a fresh install of Kubuntu 10.10 and I'm seeing this issue now. This did not occur, for me, on Kubuntu 10.04, using drivers downloaded from nVidia.

I'm running a dual-display setup. The problem only occurs on my left screen (screen 1). The right display is fine. That is, the mouse will show on the right screen, but disappears when I move across to the left.

Opening a terminal and performing the steps previously mentioned does not fix the problem. I haven't tried console switching, yet.

Some info:
Linux hostname 2.6.35-22-generic #34-Ubuntu SMP Sun Oct 10 09:26:05 UTC 2010 x86_64 GNU/Linux
02:00.0 VGA compatible controller: nVidia Corporation G96 [GeForce 9500 GT] (rev a1)

A number of xorg packages were installed, by default. I can post them (or other logs) if anyone thinks it's of interest -- otherwise, it's purely a stock Kubuntu 10.10 install.

Shaved Wookie (shavedwookie) wrote :

Otto - I was getting this problem on KDE and don't have Gnome installed at all, so I don't think it's gnome specific. Admittedly I didn't get it for months and then just got it once a few weeks back. If it's not the desktop environment, and it's not the video driver / hardware, then that suggests to me that it's probably something X / Kernel related.

drink (martin-espinoza) wrote :

I just found this bug by searching because I am having the problem ATM with Maverick and Ubuntu on fresh install with nVidia drivers via repo. Am not running unclutter (seeing some related bugs?) and more interestingly was not having this problem on migrated install upgraded through each step approximately since edgy or maybe feisty.

drink (martin-espinoza) wrote :

(probably should also mention I am using compiz and emerald sorry for repeated entries)

I found a (rather old and slow) computer at a customer where the mouse
is invisible directly after boot. The machine is running the newest
kernel for Lucid at the moment (Linux ubuntu 2.6.32-27-generic
#49-Ubuntu SMP Wed Dec 1 23:52:12 UTC 2010 i686 GNU/Linux), so I guess
this bug is still unsolved.

Switching to console and back makes the cursor visible again, as in
the other cases too.

As a workaround I noticed that switching the cursor in System >
Settings > Appearance to something else than the default fixes it and
the mouse cursor is always visible.

tags: added: maverick natty

[Dropping natty tag, since none of the comments or attached files indicate natty has been tested for this bug. If it has, please elaborate test findings and attach Xorg.0.log and any other relevant evidence.]

tags: removed: natty
Otto Kekäläinen (otto) wrote :

Correction to #20: switching the cursor in System > Settings > Appearance didn't help after all. The cursor was just sometimes visible by random.

gene (eugenios) wrote :

Same issue on a freshly installed and now fully updated Xubuntu 10.10 with the nouveau driver. Any fixes yet?

Stephen Birch (sgbirch) wrote :

This bug is driving me crazy because the IBM ThinkPad it affects is used by my kids, they can't understand why closing and opening the lid makes the cursor permanently disappear. The workarounds are amateurish to them. I get to listen to "Windows didn't do this" every time it happens.

Daniel Knittl-Frank (knittl) wrote :

this has been happening to me for about a week now running fully upgraded natty with nouveau driver. graphic card is 01:00.0 VGA compatible controller [0300]: nVidia Corporation G86M [Quadro FX 360M] [10de:042d] (rev a1)

after some time the mouse cursor will randomly disappear on my external monitor, with no errors in Xorg.0.log (but errors in kern.log)

other times the cursor is still visible, but if the cursor changes shape (textcursor, loading, links) it will be verry sluggy for a moment (pulseaudio also hangs while this) and trash kern.log with "no space while unhiding cursor" messages. when the symptom is a disappearing cursor only the "EvoCh" line is written to the log file, i.e.

    Feb 7 10:28:05 kbook kernel: [49943.295050] [drm] nouveau 0000:01:00.0: EvoCh 0 Mthd 0x0000 Data 0x00000400 (0x0002 0x01)
    Feb 7 10:33:01 kbook kernel: [50239.740629] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
    Feb 7 10:33:01 kbook kernel: [50239.871880] [drm] nouveau 0000:01:00.0: no space while unhiding cursor
    ...

starting the monitor resolution tool will completely freeze X, logging out will not restart X, killing X with ctrl-alt-backspace will hang the screen. the only thing to bring the mouse cursor back to a usable state is to restart the machine (either using shut down from the gnome panel, or after X has hung up using sysrq-reisub)

i'll be glad to provide further log files or system information. this bug is really annoying.

DBooth (david-dbooth) wrote :

This bug also affects me, on Dell Studio 15, Ubuntu 10.04. For a while, the workaround at
https://bugs.launchpad.net/ubuntu/+bug/554438/comments/21
was effective, but recently ctrl-alt-f7 started completely freezing my display, forcing me to power-off reboot. ( I have not yet found a workaround for that problem, but for the moment I am assuming that that is a separate issue.)

The workaround of changing virtual desktops (via ctrl-alt-leftArrrow and ctrl-alt-rightArrow) does NOT work for me.

The partial workaround of making the pointer visible when ctrl is pressed is helpful, but not a full workaround:
https://bugs.launchpad.net/ubuntu/+source/acpi/+bug/64333/comments/2

The gedit workaround described at
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/492782/comments/3
*does* work for me, though it is inconvenient to be blindly trying to start up an instance of gedit after every suspend/resume cycle. To make it slightly more convenient, I modified the code at
https://bugs.launchpad.net/ubuntu/+bug/554438/comments/21
to run gedit automatically upon resuming. I did this by placing the following shell script (and remember to chmod +x 99_mousecursor) in /etc/pm/sleep.d/99_mousecursor

#!/bin/sh
case "${1}" in
  hibernate)
    #nothing
    ;;
  resume|thaw)
    # dbooth 2/21/11: this is a workaround for the mouse pointer being
    # invisible after suspend/resume, given that ctrl-alt-f7 now
    # freezes my display, so i can no longer use the workaround
    # described at
    # https://bugs.launchpad.net/ubuntu/+bug/554438/comments/21
    # The gedit workaround requires both a key press in gedit
    # and the pointer must be within the gedit window.
    /usr/bin/xrefresh -display ":0.0"
    /usr/bin/gedit --display :0.0
    ;;
  suspend)
    ;;
esac

SteveLoughran (steve-loughran) wrote :

This went away for me, and came back -the change was I'd disabled screen locking on resume from suspend/hibernate. Locking the screen must trigger a desktop switch which is enough to trigger the cursor coming up.

DBooth (david-dbooth) wrote :

I can confirm that this problem goes away when I enable screen locking on resume from suspend/hibernate (via System->Preferences->ScreenSaver->Lock_screen_when_screen_saver_is_active .

Anakin Starkiller (sunrider) wrote :

DBooth > well, does your workaround work if I suspend from GDM without any user logged in ?

With Ubuntu/kernel upgrades, this problem has long since disappeared.
Only one of use the laptop at a time.

Marvin

On Sun, Mar 27, 2011 at 7:09 AM, Anakin Starkiller
<email address hidden> wrote:
> DBooth > well, does your workaround work if I suspend from GDM without
> any user logged in ?
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (131877).
> https://bugs.launchpad.net/bugs/492782
>
> Title:
>  Mouse cursor disappears after restarting screen (xrandr / resume)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/xf86-video-ati/+bug/492782/+subscribe
>

Anakin Starkiller, the mouse pointer *is* visible after the following sequence:

1. Logout, causing GDM login screen to appear
2. Suspend
3. Resume
4. Login

The mouse pointer is visible after step 4 (Login). I did not notice whether it is also visible before step 4 (Login). Let me know if you want me to check something else.

bugbot (bugbot) on 2011-04-28
summary: - Mouse cursor disappears after restarting screen (xrandr / resume)
+ [i945gme] Mouse cursor disappears after restarting screen (xrandr /
+ resume)
Helge (helgesdk) wrote :

I am experiencing this problem for the first time, and have recently upgraded to Ubuntu 11.04 64-bit - possible regression?
When I connect an external monitor to my Lenovo ThinkPad X200, Intel 4500MHD graphics, the mouse is invisible on the second display (extended desktop mode).
Also, I get some weird black flickering on the second display when Compiz dialogs are shown. E.g. pressing Alt+Tab I get some brief flickering just as the dialog appears and disappears. If I hold Ctrl+Shift and press an arrow key to switch workspace, keeping Ctrl+Shift pressed to leave the dialog open (on the first display), there will be constant flickering on the second display. Activating the Benchmark plugin also causes constant flicker.

linux-image-2.6.38-8-generic 2.6.38-8.42
xserver-xorg-video-intel 2.14.0-4ubuntu7.1
compiz 0.9.4+bzr20110415-0ubuntu2

Chris Wilson (ickle) on 2013-02-15
Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
dino99 (9d9) on 2013-05-04
tags: removed: jaunty karmic maverick
Oliver (t.raum) wrote :

The bug affects also Thinkpad R500 with ati card and Ubuntu 13.04 amd64 + awesome wm.
You can reproduce it by hibernating and resuming.

switching to console (ctrl-alt-1) and back (ctrl-alt-7) fixes the problem.

With ubuntu 12.04 I used the proprietary graphics driver and never had this problem.

Barius (barius-cn) wrote :

This bug is seen on Ubuntu 13.10 64-bit, as guest system, on a VMware Workstation 9.0.1 virtual machine with dual screen. The host system is Windows 7 64-bit on Lenovo Ideapad Y480N laptop, which uses Intel HD Graphis 4000, and a secondary Nvidia GT650m card. I have installed VMware tools in the guest system.
To reproduce the bug, switch the virtual machine to full-screen mode, then press the "Cycle multiple monitors" button on the toolbar to expand the guest to the 2nd screen. The mouse cursor then disappears when moved to the 2nd screen, while in 1st screen it remains fine. However if you move quickly enough, you can see it remain visible for a very short moment on the 2nd screen before it vanishes.
I tested using my built-in monitor as main display, the external Dell monitor as 2nd display, and vice versa. In both situations the bug exists.
Workaround includes bringing out tty via Ctrl Alt F1 then back with Ctrl Alt F7, as well as simply opening up a file explorer window, which will cause the shape of the cursor to change to "wait". This fix is persistent until the vm is powered down. Locking the screen, logging out or suspending (via VMware or inside Ubuntu) will not bring back the bug.

Guus Geluk (onsitecd) wrote :

I had this bug a few years back after pauzing.
But for me this bug has long been solved.
So I wonder if this is still the same bug.

To post a comment you must log in.