Flickering with version 2.4.0

Bug #256142 reported by Emil Soleyman on 2008-08-08
130
This bug affects 6 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
xf86-video-intel
Fix Released
High
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Bryce Harrington

Bug Description

Binary package hint: xserver-xorg-video-intel

This particular problem has been fixed in the git trunk:

http://gitweb.freedesktop.org/?p=xorg/driver/xf86-video-intel.git;a=commitdiff;h=2049ba211e7cdc383976c09f52c2b43acdd59481

Interestingly, the bug does not effect other pipes. I have had a CRT plugged into the VGA output and it has continued working fine while my laptop's LCD has gone blank.

Please attach xorg.conf and full Xorg.0.log.

Just to note, my machine is actually a Dell D820 although this problem was originally reported by a mac owner. Sorry, should have mentioned that earlier.

Created an attachment (id=12690)
My xorg.conf

Created an attachment (id=12691)
A log from a jittering (not yet blanked) X session

Created an attachment (id=12704)
Log file from crashed X

Just now the machine froze again, this time with a blank orange screen. I was able to switch to a VT, but the machine apparently locked when I attempted to switch back to X. This might be another issue but then again it might be related. Attached is the log file from the crashed X session

Any input on this bug? Even advice as how to approach debugging the bug myself would be welcome. I'm fairly competent at debugging driver issues but without an error I don't even know where to start.

Maybe a git bisect? The problem is that only a human can the problem, so no automatic bisect is possible.

Does this still happen if you disable framebuffer compression? Does it still happen with more recent pulls from git?

It happens without EXA, and EXA is required for framebuffer compression AFAIK.

Yes, but the driver defaults to EXA now, and your log indicates that it's in use.

To quote my original mail on the xorg mailing list regarding this issue:

----------------------------------------------------------------------
I tried the git version ab2055ebb20aa6de121fa377e488ce91913035ae of
intel_drv.so with an Xorg server version 1.4. The computer is a Mac
mini Core Duo with i945 graphics. A 1680x1050 TFT is connected via
DVI-D.

Every few seconds, the whole screen jittered for some tenth of a
second. After a few minutes of normal work, the whole picture suddenly
became black. Restarting the Xorg server or rebooting via kexec didn't
help. I had to do a hard reboot to get a working Xserver again.

Both of the above bugs already happened with a git version from a few
months ago. I can't tell what exact version that was, but the date
could be the 12th of September.
----------------------------------------------------------------------

This was with EXA disabled.

Ah ok, thanks for the clarification. I was suspicious of FBC since it rescans the framebuffer every 15 seconds or so, but if you had EXA off, it should have been disabled (you would see messages in your log about it if it was still on for some reason).

Can you build the intel_reg_dumper tool (src/reg_dumper in the git tree) and try to get register dumps from while things are working and then after the screen blanks? If we're lucky, something will have changed and that might give us a clue. Otherwise it might just be a bad mode that the LCD rejects after awhile?

Adding Hong to the cc list since he's been looking at LCD mode programming lately.

Hong, any ideas?

I use a modeline in my xorg.conf to get a usable mode at all with version 2.1 (fixed meanwhile in version 2.2, which I would use this this bug would't be present). So I guess that 2.1 and 2.2 use the same mode.

Another detail: a reboot via kexec won't bring back a usable output, the screen stays black. I have do trigger a real reboot without kexec to get back working graphics.

(In reply to comment #14)
> I use a modeline in my xorg.conf to get a usable mode at all with version 2.1
> (fixed meanwhile in version 2.2, which I would use this this bug would't be
> present). So I guess that 2.1 and 2.2 use the same mode.
>

So which modeline is working with your card?
And would you please attach your xorg log with "modedebug" turned on?

(In reply to comment #7)
> Any input on this bug? Even advice as how to approach debugging the bug myself
> would be welcome. I'm fairly competent at debugging driver issues but without
> an error I don't even know where to start.
>
Hi, Ben
Would you please turn on the "modedebug" option and attach your xorg.log?
I am not sure whether your 1920x1200 (requires 162M pixel clock) is OK for our LVDS mode programming?

Thanks,
Hong

Does it help to unload the drm module from git and reload the one from kernel tree? At least that avoids the bug for me even without a reboot (see #13446).

I don't use drm from git. I always use the one from the kernel tree.

Created an attachment (id=12833)
Log of server with ModeDebug enabled

I just attached a log from Xorg starting with the ModeDebug option enabled. Note that I too run the kernel in-tree DRM modules (presently from 2.6.23). Additionally, it appears that framebuffer compression is enabled in my case.

Created an attachment (id=12921)
blacklight fixes

Hi, I send this weekend this patch to Jesse Barnes and Lukas Hejtmanek. They are the authors , I just compile what I think is the best .
The patch solve (almost) all my problem, could you give a try , and feed back please

(In reply to comment #21)
> Created an attachment (id=12921) [details]
> blacklight fixes
>
> Hi, I send this weekend this patch to Jesse Barnes and Lukas Hejtmanek. They
> are the authors , I just compile what I think is the best .
> The patch solve (almost) all my problem, could you give a try , and feed back
> please
>

I have yet to try the patch you provided but unfortunately I doubt this will fix my problem. I'm fairly certain that the backlight on my machine (a Dell Latitude D820) is not controlled by the graphics controller. I'll give it a try anyways though.

I tested that patch and at least for me it changes nothing. Maybe because I also have a Dell Latitude D820. :)

I have this problem with an external Eizo TFT, so it shouldn't have to do anything with ACPI backlight stuff.

Yeah, sounds like the backlight code isn't the problem. Unfortunately, I've been having difficulty reproducing the problem lately. I don't believe it has happened in the last few days. Has anyone else found that the incidents have stopped wit recent git revisions or have I just had a lucky streak? I never was able to figure out a way to reliably produce the blanking, so maybe it's just been luck that it has stopped. Has anyone found a way to force the problem to occur?

Created an attachment (id=12933)
The output of intel_reg_dumper while the screen is working

I should point out that while the blanking may have apparently stopped, the jittering continues.

I just got the blanking error again. one additional remark: suspending to ram and resuming again restores the screen (VBE_POST??).
Also after that compiz had been killed.

Created an attachment (id=12983)
Register dump during blank screen

I finally managed to get the bug to recur. This time the screen turned straight white. This time I managed to SSH in to the machine and grab a register dump as well. Moreover, I can confirm that suspending and resuming the machine fixes the issue. Additionally I know for a fact that backlight control is not the issue:
  1) When I allowed the machine to sit idle, I could see gnome-power-manager eventually dim the display
  2) My machine does not rely on the GPU for backlight control.

I hope this helps. If there's anything else necessary for debugging, just ask.

- Ben

I just tried the latest git (d9df93578b74785c08ba860b4c9aa23b0c89c91c). The jittering is still there. However, no black screen so far.

(In reply to comment #29)
> I just tried the latest git (d9df93578b74785c08ba860b4c9aa23b0c89c91c). The
> jittering is still there. However, no black screen so far.
>

Would you please try to add some new modes toggling the polarity of HSYNC VSYNC to see if there is a mode working?

Thanks,
Hong

(In reply to comment #30)
> (In reply to comment #29)
> > I just tried the latest git (d9df93578b74785c08ba860b4c9aa23b0c89c91c). The
> > jittering is still there. However, no black screen so far.
> >
>
> Would you please try to add some new modes toggling the polarity of HSYNC VSYNC
> to see if there is a mode working?
>
> Thanks,
> Hong
>

Have there been any changesets that might fix the issue? I didn't see anything too promising in gitweb. Unfortunately, I won't be able to do any testing for a few weeks. Yesterday I dropped my laptop, triggering all manner of hardware failures. I'll definitely report back when I have my machine back, though.

P.S. Be careful about marking this as fixed. My screen behaved fine for nearly 72 hours once before blacking out four times in a matter of 10 minutes. It's a tricky one...

I already use a modeline (because I won't get a correct output without a modeline before 2.2.0).

Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync

This modeline works fine with 2.1.1, so I think that it should be no problem with 2.2.0, too.

(In reply to comment #32)
> I already use a modeline (because I won't get a correct output without a
> modeline before 2.2.0).
>
> Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089
> -hsync +vsync
>
> This modeline works fine with 2.1.1, so I think that it should be no problem
> with 2.2.0, too.
>
Hi, Tino
Since you can workaround your problem with your specific modeline, maybe there are something wrong with your monitor's EDID data. Would you please attach your xorg.log with modedebug turned on?

For Ben's problem, I don't have any clue now :(

Thanks,
Hong

(In reply to comment #33)
Well, I should have a new computer by Friday (albeit with an i965) so hopefully I'll be able to reproduce it at that point.

- Ben

> (In reply to comment #32)
> > I already use a modeline (because I won't get a correct output without a
> > modeline before 2.2.0).
> >
> > Modeline "1680x1050_60.00" 146.25 1680 1784 1960 2240 1050 1053 1059 1089
> > -hsync +vsync
> >
> > This modeline works fine with 2.1.1, so I think that it should be no problem
> > with 2.2.0, too.
> >
> Hi, Tino
> Since you can workaround your problem with your specific modeline, maybe there
> are something wrong with your monitor's EDID data. Would you please attach your
> xorg.log with modedebug turned on?
>
> For Ben's problem, I don't have any clue now :(
>
> Thanks,
> Hong
>

See Bug #10784. I attached logfiles with modedebug enabled to this bug.

Hi, I've also been experiencing this problem (jittery external DVI display, occasional external display blanking). Note that the laptop (Dell D620) doesn't hang, and the Laptop display (which was still enabled through xrandr) is still working. DVI is the only pipe that causes the problem btw (DVI is exposed through a port replicator too- that could be important).

I would love to get this issue fixed. The 2.1 driver didn't suffer from this problem in my experience. 2.2 definitely does. I run the debian packaged from sid.

Christian

(In reply to comment #36)
> Hi, I've also been experiencing this problem (jittery external DVI display,
> occasional external display blanking). Note that the laptop (Dell D620) doesn't
> hang, and the Laptop display (which was still enabled through xrandr) is still
> working. DVI is the only pipe that causes the problem btw (DVI is exposed
> through a port replicator too- that could be important).
>
Hi, Christian

Your problem is not the same as Ben's. Would you please open a new bug and attach the Xorg.log with modedebug turned on?

Thanks,
Hong

*** Bug 13446 has been marked as a duplicate of this bug. ***

Created an attachment (id=13717)
enable ssc for lvds dual channel

Hi, Ben

Would you please try this patch? And please attach the xorg log with modedebug turned on (with this patched applied) if problem is still there.

Thanks,
Hong

I used a slightly adapted version for the current git (origin/xvmc branch), that did not solve the problem, although the log says:
(WW) intel(0): enable SSC clock for LVDS
(WW) intel(0): enabling SSC clock for LVDS, setting dpll_b

Bryce Harrington (bryce) on 2008-08-08
Changed in xserver-xorg-video-intel:
assignee: nobody → bryceharrington
status: New → Triaged
Timo Aaltonen (tjaalton) on 2008-08-08
Changed in xserver-xorg-video-intel:
assignee: bryceharrington → nobody
status: Triaged → Fix Released
Timo Aaltonen (tjaalton) on 2008-08-08
Changed in xserver-xorg-video-intel:
status: Fix Released → Triaged
Changed in xorg-server:
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
status: Unknown → Fix Released
Changed in xserver-xorg-video-intel:
status: Triaged → Fix Released
106 comments hidden view all 186 comments

I believe that i just found a temporary workaround.

Since the flickering seems to be caused by the automatic mode detection on my non-connected VGA output, I used xrandr to force a mode on that output.

I used the following commands

xrandr --newmode dummy 75.00 1280 1301 1333 1408 800 804 808 816 -hsync -vsync
xrandr --addmode VGA dummy
xrandr --output VGA --mode dummy

Those commands cause a lot of flickering but after them, flickering is gone.

The result can be verified with

 $ xrandr --prop | cat -n
     1 Screen 0: minimum 320 x 200, current 1280 x 800, maximum 1280 x 1280
     2 VGA disconnected 1280x800+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
     3 dummy 65.3*
     4 LVDS connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
     5 EDID_DATA:
     6 00ffffffffffff0006af142100000000
     7 010f0103801a10780a30259855548827
     8 24505400000001010101010101010101
     9 0101010101014c1d0080502010301520
    10 440005a3100000190000000000000000
    11 00000000000000000001000000fe0057
    12 35333832004231323145570a000000fe
    13 00fffdf3e9bb8d6f0001010a2020005f
    14 PANEL_FITTING: full
    15 supported: center full_aspect full
    16 BACKLIGHT_CONTROL: native
    17 supported: native legacy combination kernel
    18 BACKLIGHT: 0 (0x00000000) range: (0,0)
    19 1280x800 65.3*+
    20 1024x768 60.0
    21 800x600 60.3
    22 640x480 59.9
    23 TV disconnected (normal left inverted right x axis y axis)
    24 BOTTOM: 37 (0x00000025) range: (0,100)
    25 RIGHT: 46 (0x0000002e) range: (0,100)
    26 TOP: 36 (0x00000024) range: (0,100)
    27 LEFT: 54 (0x00000036) range: (0,100)
    28 TV_FORMAT: NTSC-M
    29 supported: NTSC-M NTSC-443 NTSC-J PAL-M
    30 PAL-N PAL

The interesting line is 3 which indicates that my "dummy" mode is activated for the VGA output.

PS: I used a 1280x800 mode because this is the resolution of my laptop panel and, somehow, using a smaller resolution caused my gnome panels to be resized.

WARNING! The xrandr commands from my previous post must be adapted to set a mode on a NON CONNECTED output. Specifying some incorrect modelines on a connected output could damage your monitor.

Timo Aaltonen (tjaalton) wrote :

Ok, reopening.. Server logfiles are usually useful.

Changed in xserver-xorg-video-intel:
status: Fix Released → Confirmed

See also the following upstream bug

   http://bugs.freedesktop.org/show_bug.cgi?id=17405

And here is my log

Flickering has stopped for me with latest package, but what I'm seeing in Xorg log (same as comment #18 except for the (EE) line) is probably due to bug #245383.

snifer@snifer-laptop:~$ dpkg -l | grep xserver-xorg-video-intel
ii xserver-xorg-video-intel 2:2.4.1-1ubuntu2 X.Org X server -- Intel i8xx, i9xx display d

Franck (alci) wrote :

For me, 1ubuntu2 partly fixes the problem.

In fact, I had two distinct symptoms, that is :

1) screen was flickering or "blittering", whole parts of the background had erratic moves
2) mouse pointer was "flipping", that is the pointer was switching from one point to another one about 20 pixels on the lower right

1) is fixed by 1ubuntu2. It was associated with the "underrun on pipe B" message in the log, and this error has disappeared as well.

2) remains. It is associated with another message in the log, that is not an error message (EE) but an information (II):

(II) intel(0): I2C device "LVDSDDC_C:ddc2" registered at address 0xA0.
(II) intel(0): I2C device "LVDSDDC_C:ddc2" removed.

I opened a new bug specific to the second problem (#264228). Should I mark it as a duplicate of this one, or should this one remain closed and work go on #264228 ?

BC7333 (brian-abtrafco) wrote :

This just started today for me after updating to newest alpha

(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x1024 - internal error
(EE) intel(0): underrun on pipe B!
(EE) intel(0): underrun on pipe B!
(II) intel(0): I2C device "LVDSDDC_C:ddc2" registered at address 0xA0.
(II) intel(0): I2C device "LVDSDDC_C:ddc2" removed.
(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x1024 - internal error
(II) intel(0): I2C device "LVDSDDC_C:ddc2" registered at address 0xA0.
(II) intel(0): I2C device "LVDSDDC_C:ddc2" removed.
(EE) intel(0): Mode 1280x1024 does not fit virtual size 1024x1024 - internal error
(EE) intel(0): underrun on pipe B!
(EE) intel(0): underrun on pipe B!
(EE) intel(0): underrun on pipe B!

Franck (alci) wrote :

I have tested 1ubuntu2 with a video-projector connected on VGA output.

In these conditions, each time I launch an application, the screen becomes black on both output (VGA+LCD) and then comes back...

Download full text (6.1 KiB)

I have the same issue here on a HP/Compaq D510 SFF computer (business model).
Things worked fine in Ubuntu Hardy but after an upgrade to Intrepid in August, X broke, and is still broken.
I'm running 2.6.27-3 with and xserver-xorg-video-intel 2:2.4.1-1ubuntu4

My display manager is KDM.
Whenever I try to login to KDE4 the screen goes black after the first KDE icon (during startup) appears during KDE initialization.

If I enable desktop effects in Gnome, X also dies.

Restarting X or KDM doesn't help either, I need to reboot the computer.
My Xorg0.log is full of:
  (EE) intel(0): underrun on pipe A!

The last entries in Xorg.0.log before things go crazy are these:
(II) Initializing built-in extension XEVIE
(II) AIGLX: Screen 0 is not DRI2 capable
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 11, (OK)
drmOpenByBusid: drmOpenMinor returns 11
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
(II) AIGLX: enabled GLX_texture_from_pixmap with driver support
(II) AIGLX: Loaded and initialized /usr/lib/dri/i915_dri.so
(II) GLX: Initialized DRI GL provider for screen 0
(II) intel(0): Setting screen physical size to 338 x 270
(EE) intel(0): underrun on pipe A!
(II) config/hal: Adding input device Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)
(II) LoadModule: "evdev"

(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
        compiled for 1.5.0, module version = 2.0.99
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.1
(**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): always reports core events
(**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Device: "/dev/input/event3"
(II) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Found x and y relative axes
(II) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Found 5 mouse buttons
(II) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Configuring as mouse
(II) XINPUT: Adding extended input device "Microsoft Microsoft 5-Button Mouse with IntelliEye(TM)" (type: MOUSE)
(**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): YAxisMapping: buttons 4 and 5
(**) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) config/hal: Adding input device Apple, Inc Apple Keyboard
(**) Apple, Inc Apple Keyboard: always reports core events
(**) Apple, Inc Apple Keyboard: Device: "/dev/input/event2"
(II) Apple, Inc Apple Keyboard: Found keys
(II) Apple, Inc Apple Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "Apple, Inc Apple Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Apple, Inc Apple Keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) Apple, Inc Apple Keyboard: xkb_model: "pc105"
(**) Option "xkb_layout" "se"
(**) Apple, Inc Apple Keyboard: xkb_layout: "se"
(**) Opti...

Read more...

Paul Gevers (paul-climbing) wrote :

I have the same problem as the last remark, I can use GNOME, but not KDE. I'll attach the log files and config file. The .old is from the failed KDE session, the .log is from the successful GNOME session.

Paul Gevers (paul-climbing) wrote :
Paul Gevers (paul-climbing) wrote :
Yves Glodt (yglodt) wrote :

How about getting the version 2.5 of the driver into intrepid?

It will be released tomorrow, and yesterday the final rc was released:
http://lists.freedesktop.org/archives/xorg/2008-October/039496.html

Yves, it's *far* too late for that. Drivers can often have regressions.

FWIW, I don't experience this anymore, and haven't in a long time, so I suspect it's a different bug to the original.

The latest xorg driver in the latest intrepid update has resolved this
issue.

Sarah Hobbs wrote:
> Yves, it's *far* too late for that. Drivers can often have regressions.
>
> FWIW, I don't experience this anymore, and haven't in a long time, so I
> suspect it's a different bug to the original.
>

Bryce Harrington (bryce) on 2008-10-27
Changed in xserver-xorg-video-intel:
status: Confirmed → Fix Released
jbrsks (jkras) wrote :

>The latest xorg driver in the latest intrepid update has resolved this
>issue.
If "this issue" relates to the original bug (flickering: for me only after resuming from a suspend), it still occurs (though improved) on most recent available updates (2:2.4.1-1ubuntu10). Xorg.0.log looks similar to those previously posted (lots of "underrun pipe A")
I lost the thread a little: I thought the patch in 2.5 from upstream has already been applied in Ubuntu. If the patch has been applied, the bug should remain open.

Matt Foster (matt-foster42) wrote :

I have this problem as well on a Dell Latitude D620. Lot's of buffer underuns, and dual display with an external VGA is unusable - the external VGA keeps on flicking on and off.

root@psll09551:/var/log# dpkg -l | grep -i intel
rc 915resolution 0.5.3-1ubuntu1 resolution modification tool for Intel graphic chipset
ii wvdial 1.60.1+nmu2 PPP dialer with built-in intelligence
ii xserver-xorg-video-i810 2:2.4.1-1ubuntu10 X.Org X server -- Intel i8xx, i9xx display driver
ii xserver-xorg-video-intel 2:2.4.1-1ubuntu10 X.Org X server -- Intel i8xx, i9xx display driver

lspci -vnn:
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
        Subsystem: Dell Device [1028:01c2]
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at eff00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at eff8 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at efec0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
        Capabilities: [d0] Power Management version 2
        Kernel modules: intelfb

root@psll09551:/var/log# uname -a
Linux psll09551 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

Xorg.conf:
Section "Device"
        Identifier "Configured Video Device"
EndSection

Section "Monitor"
        Identifier "Configured Monitor"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Monitor "Configured Monitor"
        Device "Configured Video Device"
Subsection "Display"
          Depth 24
          Virtual 1440 1924
        EndSubSection

EndSection

When running just on the panel display, it works OK ish, although some of the desktop effects are very sluggish, I'm running KDE.

Wesley Schwengle (wesleys) wrote :

Reopening bug, if this unwanted please inform me so I can create a new bug report which addresses this issue.

Changed in xserver-xorg-video-intel:
status: Fix Released → New
Paul Gevers (paul-climbing) wrote :

Comment 39 was mine[1].

In my case KDE does not crash, but it does not give me a desktop. I have had different appearances in the recent past: black screen, white screen and now my GNOME background (it is different from the background I had in KDE). I can start all the programs that I like using <ALT-F2>. Gnome works like a charm. Usually I do get a Aport message if I tried KDE and are back to Gnome (related to skim or scim and xrandr). I do think those are reported elsewhere, but until now I have not found out the proper bug number.

[1] https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/256142/comments/39

TStahl (mail-myname-tstahl) wrote :

The problem persist for me (with an i915 card) both with the latest driver in intrepid and with the 2.5.0 from PPA. Only a downgrade to 2.3.2 is able to solve the buffer underruns.

Paul Gevers (paul-climbing) wrote :

I am testing KDE (and using) again and I get a crash from plasma. This time I was offered a backtrace which I am attaching. Still, I can only start programs with <ALT-F2>

I will also attach a screenshot of my empty desktop. I sometimes get the feeling that I am on a secondary screen with the controls invisible on the first screen. This is especially the case when KDE is reporting a crash or possible updates, because usually you get a message window attached to the task-bar, but in my case it is attached to the left-top corner of my screen, as if the task-bar is really over there.

Paul Gevers (paul-climbing) wrote :
jbrsks (jkras) wrote :

Has this bug report wandered off the original bug?

> Has this bug report wandered off the original bug?

I was thinking the same thing this morning. Do you reckon I should start
a new bug? Against plasma?

Omegamormegil (omegamormegil) wrote :

I still experience flickering on the bottom 1/4th of the screen while loading some applications, and I'm using Gnome. I have an intel 915 graphics card. It has gotten better since Alpha 4, but it's still an issue. So, it's not just a KDE issue, if anyone was wondering.

Arnaud Quette (aquette) wrote :

with a Dell Latitude D630, I got lot's of buffer underuns as soon as I enable the external display.
In that case, the dual display (with an external LCD display) doesn't work and I got an empty desktop.

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Using an up to date Intrepid with xserver-xorg-video-intel = 2:2.4.1-1ubuntu10

Wesley Schwengle (wesleys) wrote :

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/256142/comments/47

I do not have the issue anymore as I downgraded KDE to version 3, see Xorg.0.log relevant entries:

(II) intel(0): Fixed memory allocation layout:
(II) intel(0): 0x00000000-0x0001ffff: ring buffer (128 kB)
(II) intel(0): 0x00020000-0x00024fff: HW cursors (20 kB)
(II) intel(0): 0x00025000-0x0002cfff: logical 3D context (32 kB)
(II) intel(0): 0x007df000: end of stolen memory
(II) intel(0): 0x007df000-0x007dffff: overlay registers (4 kB, 0x00000000271fa000 physical
)
(II) intel(0): 0x007e0000-0x011a3fff: front buffer (10000 kB)
(II) intel(0): 0x011a4000-0x02eeffff: exa offscreen (30000 kB)
(II) intel(0): 0x02ef0000-0x038b3fff: back buffer (10000 kB)
(II) intel(0): 0x038b4000-0x04277fff: depth buffer (10000 kB)
(II) intel(0): 0x04278000-0x06277fff: classic textures (32768 kB)
(II) intel(0): 0x08000000: end of aperture
(II) intel(0): Output configuration:
(II) intel(0): Pipe A is on
(II) intel(0): Display plane A is now enabled and connected to pipe A.
(II) intel(0): Output VGA is connected to pipe A
(II) intel(0): [drm] mapped front buffer at 0xe07e0000, handle = 0x2c0fc000
(II) intel(0): [drm] dma control initialized, using IRQ 16

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/256142/comments/55
> So, it's not just a KDE issue, if anyone was wondering.

I'm using XFCE. While I don't get any crashes, I can certainly confirm the annoying flickering.

Arnaud Quette (aquette) wrote :

uh, strange. while I failed all the morning in my attempt to switch to dual screen (see my above report), it's now working!
And I've obviously not changed anything, nor rebooted nor done anything (except coding and mailing ;-)

here is the output from Xorg.0.log, just after the successful switch to dual screen:
(II) intel(0): EDID vendor "SAM", prod id 170
(II) intel(0): EDID vendor "LPL", prod id 3073
(II) intel(0): DDCModeFromDetailedTiming: 1280x800 Warning: We only handle seperate sync.
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1280x800"x0.0 72.17 1280 1320 1352 1432 800 808 816 840 -hsync -vsync (50.4 kHz)
(II) intel(0): Modeline "1280x800"x0.0 72.17 1280 1320 1352 1432 800 808 816 840 -hsync -vsync (50.4 kHz)
(II) intel(0): EDID vendor "LPL", prod id 3073
(II) intel(0): DDCModeFromDetailedTiming: 1280x800 Warning: We only handle seperate sync.

still Intrepid/Gnome on a Dell Latitude D630...

derPeter (derpeter) wrote :

same problem on an intel macbook with 945GM/GMS.

(II) intel(0): I2C device "SDVOB DDC Bus:ddc2" registered at address 0xA0.
(II) intel(0): I2C device "SDVOB DDC Bus:ddc2" removed.
(II) intel(0): xf86BindGARTMemory: bind key 2 at 0x087a8000 (pgoffset 34728)
(II) intel(0): xf86UnbindGARTMemory: unbind key 2
(EE) intel(0): underrun on pipe B!

Errors occurs using xrandr with 2 screens. The flickering only occurs on the laptop screen.

If I open a video application the hole screen turn shortly black with the first 2 lines of the log.

the last line comes during the flickering of the laptop screen. It happens sometime without a reason but mostly if the screen changes its brightness.

(intreped actual patch level, gnome desktop)

Same problem on Dell Inspiron 1300 after upgrading to 8.10:
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1280x800"x0.0 72.25 1280 1328 1360 1440 800 802 808 823 -hsync -vsync (50.2 kHz)
(II) intel(0): Modeline "1280x800"x0.0 72.25 1280 1328 1360 1440 800 802 808 823 -hsync -vsync (50.2 kHz)
(II) intel(0): EDID vendor "LPL", prod id 43264
(II) intel(0): DDCModeFromDetailedTiming: 1280x800 Warning: We only handle seperate sync.
(EE) intel(0): underrun on pipe B!

VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

xserver-xorg-video-intel 2:2.4.1-1ubuntu10

Bryce Harrington (bryce) wrote :

> > Has this bug report wandered off the original bug?
>
> I was thinking the same thing this morning. Do you reckon I should start
> a new bug? Against plasma?

Yes, flickering is such a generic symptom that can be caused by so many different things, that it's very likely that folks commenting and confirming since this was reopened are actually seeing some different problem. For the sake of the mailboxes of the original reporters (for whom it sounds like their flickering issue was solved), please open a NEW bug if you're seeing flickering behavior still.

Changed in xserver-xorg-video-intel:
status: New → Fix Released
Michael Zehrer (zehrer) wrote :

I can confirm this bug on my Fujitsu Siemens Amilo Si 15120 running the latest intrepid, please see the attached xorg log.

Danniello (danniello) wrote :

Ubuntu 8.10
xserver-xorg-video-intel 2.4.1-1ubuntu10

Asus EeePC 901
Intel Mobile 945GME and/or Intel Mobile 945GM/GMS/GME, 943/940GML

sudo lshw -c display

  *-display:0 UNCLAIMED

       description: VGA compatible controller

       product: Mobile 945GME Express Integrated Graphics Controller

       vendor: Intel Corporation

  *-display:1 UNCLAIMED

       description: Display controller

       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller

       vendor: Intel Corporation

When I am working only on integrated LCD (1024x600x60) - everything is OK.
When I connect d-sub to my old CRT monitor (Philips Brilliance 109P, 1280x960x85, internal laptop LCD off) for some time is almost OK (sometimes screen flickers - in Xorg.0.log driver again recognise monitor ModeLines).
After some time, especially when I start movie in Totem or SMPlayer, screen disappears (sound works, everything works, but no display on CRT - all screen filled with one colour) - driver is starting filling Xorg.0.log with many "(EE) intel(0): underrun on pipe A!
".

I could switch to terminal (Ctrl+Alt+F1) - display works again on LCD and CRT. If I back to X (Ctrl+Alt+F7) - still no display. I could restart laptop or start another X session (xinit -- :1) - works again OK...

I changed d-sub cable, problem still remains, but I have little impression that is happening less often... Maybe driver is sending/receiving too weak signal to/from monitor?

Jens Gustedt (jens-gustedt) wrote :

Hi, just adding to this bug, please direct me to an appropriate one if you think there is a better one.

I observed the same `underrun' error on for my Intel card after seeking for the reasons of
occasional crashes of X that I observed on my machine. First I though that this would be
hibernation related, since it was then when this happened. But now I see that it occurs when
switching the console.

So happening under hibernation is probably just a side effect when switching console, there.

I am running

xserver-xorg-video-intel 2:2.4.1-1ubuntu10.1

Has anybody an idea if dowgrading to 2:2.4.1-1ubuntu10 (without the .1) could help?

Thanks

Jens

Paul van Genderen (paulvg) wrote :

Sorry for posting to this bug, but bug #256142 was marked as a duplicate of this bug. However I think these bugs are unrelated because if this was fixed, how come I still get:

(EE) intel(0): underrun on pipe B!

in Xorg.0.log? I don't know what's best, filing a new report, reopening this one, or something else.

(Attached is yet another log, just in case.)

Brian Harkness (maestro-bwh) wrote :

See:

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/221119

I am frustrated because using the vesa driver, apparently there is a dpms bug which keeps the display from shutting off. So no driver really works for me.

Ari (ari-nevala) on 2009-11-07
Changed in xserver-xorg-video-intel (Ubuntu):
status: Fix Released → Confirmed
Chris Coulson (chrisccoulson) wrote :

Ari - please don't just reopen a bug without leaving any explanation

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in xserver-xorg-video-intel:
importance: High → Unknown
Changed in xserver-xorg-video-intel:
importance: Unknown → High
Changed in xorg-server:
importance: Unknown → Medium
Displaying first 40 and last 40 comments. View all 186 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.