8086:2a42 [Toshiba Portégé R600-10Q] VGA output doesn't work with Intel GM45 chipset

Bug #1364292 reported by Oliver Woodford on 2014-09-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Medium
Unassigned

Bug Description

I have just installed Ubuntu 14.04 64-bit on my Toshiba Portege R600-10Q laptop (a model from 2009). I am now trying to display the desktop on a BenQ Senseye3 22" monitor, via the vga output, but it's not working - the monitor says "No Signal Detected!".

What I've done:
I have gone into "Screen Display", where I can see the monitor is detected by the laptop.
The monitor has a 1920 x 1080 native resolution, which I have tried to use, but I have also set it to lower resolutions, e.g. 1024 x 576.
I have tried to use the monitor in dual screen, mirrored and single screen mode - none work.
I have tried pressing Fn + F5 to get single screen output - the laptop screen goes blank, but still no output on the monitor.
I have tried several monitors (of the same type, and also of a different make), so I don't think it's that.

If I plug the vga cable in after boot up, then the monitor receives no signal.

WORKAROUND: If, and only if, the monitor was plugged in to the PC's VGA output during boot up, then the display outputs to the monitor correctly.

The laptop has the Intel® GS45 Express chipset for graphics acceleration. I installed mesa-utils and ran glxinfo in a terminal. Amongst the output was:
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset

Also, in the "About This Computer" window I see:
Graphics: Mobile Intel® GM45 Express Chipset

I wonder if the problem is that my chipset is GS45 not GM45.

The output of "sudo lshw -C video" is:
*-display:0
description: VGA compatible controller
product: Mobile 4 Series Chipset Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 07
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:44 memory:ff400000-ff7fffff memory:e0000000-efffffff ioport:cff8(size=8)
*-display:1 UNCLAIMED
description: Display controller
product: Mobile 4 Series Chipset Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 07
width: 64 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:ffc00000-ffcfffff

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: xorg 1:7.7+1ubuntu8
ProcVersionSignature: Ubuntu 3.13.0-35.62-generic 3.13.11.6
Uname: Linux 3.13.0-35-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Tue Sep 2 10:00:57 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
EcryptfsInUse: Yes
ExtraDebuggingInterest: Yes, if not too technical
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:000c]
   Subsystem: Toshiba America Info Systems Device [1179:000c]
InstallationDate: Installed on 2014-08-28 (4 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
MachineType: TOSHIBA PORTEGE R600
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-35-generic root=UUID=fe977943-4013-472e-b627-f7184c9e190f ro quiet splash vt.handoff=7
SourcePackage: xorg
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/27/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 1.60
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion1.60:bd11/27/2008:svnTOSHIBA:pnPORTEGER600:pvrPPR61E-00Q00CEN:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: PORTEGE R600
dmi.product.version: PPR61E-00Q00CEN
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.52-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.1.3-0ubuntu0.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.1.3-0ubuntu0.1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3.1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.910-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sun Aug 31 11:29:04 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.15.1-0ubuntu2

tags: added: bios-outdated-3.20
Changed in xorg (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
summary: - VGA output doesn't work with Intel GM45 chipset
+ [Toshiba Portégé R600-10Q] VGA output doesn't work with Intel GM45
+ chipset

It took me several hours, but I eventually found a way to flash the BIOS. (None of the suggestions online worked.) It's now v3.20

Changed in xorg (Ubuntu):
status: Incomplete → Confirmed

Oh, and the problem still exists...

Sorry, forgot this. The output of sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date is:
Version 3.20
09/21/2010

tags: added: latest-bios-3.20
removed: bios-outdated-3.20
Changed in xorg (Ubuntu):
importance: Low → Medium
status: Confirmed → Incomplete
description: updated
Launchpad Janitor (janitor) wrote :

[Expired for xorg (Ubuntu) because there has been no activity for 60 days.]

Changed in xorg (Ubuntu):
status: Incomplete → Expired

Why has this expired? It's still a bug, and it's still outstanding.

Changed in xorg (Ubuntu):
status: Expired → Opinion

Oliver Woodford, anything change with the latest release via http://cdimage.ubuntu.com/daily-live/current/ ?

Changed in xorg (Ubuntu):
status: Opinion → Incomplete

No, nothing changed. The bug still exists.

Was there any reason to believe that it wouldn't?

Closing bugs on which there has been no comment for 60 days is absurd. It's the equivalent of brushing dirt under the rug. But I don't want to check the latest image every 60 days on the off chance something has changed, when nobody is trying to fix this - that's a complete waste of my time. So there's a problem with the bug tracking system here.

tags: added: vivid

I did not test it on a release prior to 14.04. However, the following resources suggest this bug has existed since at least release 10.04:
http://askubuntu.com/questions/121228/laptop-with-intel-graphics-external-vga-monitor-only-gets-signal-on-boot-no-h
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1218224

Oliver Woodford, for regression testing purposes, could you (not someone else on a forum or with other hardware) please test 12.04.0 (kernel series 3.2.x not another variant) via http://old-releases.ubuntu.com/releases/12.04.0/ and advise to the results?

I tried the release you asked me to (12.04.0) and it exhibits the same problem. The VGA output works fine when the monitor is plugged in at boot up, but not if plugged in after booting.

By the way, I didn't state this before, but the VGA output worked fine under Windows, even when plugged in after booting.

tags: added: precise

Oliver Woodford, could you please test the latest upstream kernel available from the very top line at the top of the page (the release names are irrelevant for testing, and please do not test the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue.

If the test did not allow you to test to the issue (ex. you couldn't boot into the OS) please make a comment in your report about this, and continue to test the next most recent kernel version until you can test to the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested exactly shown as:
kernel-fixed-upstream-3.18-rc7

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description.

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

I tested with kernel 3.19 rc2 and the bug still exists.

Changed in xorg (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream kernel-bug-exists-upstream-3.19-rc2

Before I remove the mainline kernel, the output of "uname -a" in a terminal is:
3.19.0-031900rc2-generic #201412290135 SMP Mon Dec 29 01:36:54 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
I confirmed that the vga output doesn't work when the cable is hot plugged, but does when the cable is inserted prior to booting. I.e. the behaviour is identical to previous kernels.

Oliver Woodford, the issue you are reporting is an upstream one. Could you please report this problem via https://bugs.freedesktop.org/enter_bug.cgi?product=xorg ?
Component: Driver/intel
Version: 7.7
Severity: Normal
Hardware: x86-64
OS: Linux
Priority: Medium

Please provide a direct URL to your bug report once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in xorg (Ubuntu):
status: Confirmed → Triaged
summary: - [Toshiba Portégé R600-10Q] VGA output doesn't work with Intel GM45
- chipset
+ 8086:2a42 [Toshiba Portégé R600-10Q] VGA output doesn't work with Intel
+ GM45 chipset
Timo Aaltonen (tjaalton) on 2015-01-29
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)

Oliver Woodford, as requested by upstream, could you please test the latest mainline kernel (4.5-rc6) and advise to the results?

Changed in xserver-xorg-video-intel (Ubuntu):
status: Triaged → Incomplete

I'm not in a position to test this now, as I don't have access to an external monitor with VGA.

Andrew Drummond (4ndy) wrote :

I had this problem on a Toshiba Tecra A10-104 using Linux mint 17.3 XFCE (based on U14.04) with Intel GM45 onboard graphics.
Updating from a 3.x kernel to the latest 4.4 one fixed the problem for me, with no regressions found so far. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.