[gm45] VGA Output not activated

Bug #1218224 reported by Cefn on 2013-08-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-intel (Ubuntu)
Low
Unassigned

Bug Description

If I carry my suspended laptop into work and then connect it to the external Dell U2410f the monitor seems to be identified (visible in Grandr) but activating it doesn't cause any image to appear (it seems the signal is not sent).

In order to succeed at seeing anything, I have to reboot the machine entirely, with the monitor attached, at which point it not only sees the monitor, but also sends it a signal.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: xserver-xorg-video-intel 2:2.21.14-4ubuntu2
Uname: Linux 3.11.0-031100rc6-generic i686
ApportVersion: 2.12.1-0ubuntu2
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Thu Aug 29 08:44:35 2013
DistUpgraded: Fresh install
DistroCodename: saucy
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.2.16, 3.11.0-031100rc6-generic, i686: installed
 virtualbox, 4.2.16, 3.11.0-2-generic, i686: installed
 virtualbox, 4.2.16, 3.11.0-3-generic, i686: installed
 virtualbox, 4.2.16, 3.11.0-4-generic, i686: installed
ExtraDebuggingInterest: Yes, including running git bisection searches
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:000c]
   Subsystem: Toshiba America Info Systems Device [1179:000c]
InstallationDate: Installed on 2013-08-15 (13 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha i386 (20130626)
MachineType: TOSHIBA PORTEGE R600
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.11.0-031100rc6-generic root=/dev/mapper/ubuntu--gnome--vg-root ro quiet splash vt.handoff=7
SourcePackage: xserver-xorg-video-intel
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/23/2008
dmi.bios.vendor: TOSHIBA
dmi.bios.version: Version 1.50
dmi.board.asset.tag: 0000000000
dmi.board.name: Portable PC
dmi.board.vendor: TOSHIBA
dmi.board.version: Version A0
dmi.chassis.asset.tag: 0000000000
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: Version 1.0
dmi.modalias: dmi:bvnTOSHIBA:bvrVersion1.50:bd10/23/2008:svnTOSHIBA:pnPORTEGER600:pvrPPR61E-00Q00CEN:rvnTOSHIBA:rnPortablePC:rvrVersionA0:cvnTOSHIBA:ct10:cvrVersion1.0:
dmi.product.name: PORTEGE R600
dmi.product.version: PPR61E-00Q00CEN
dmi.sys.vendor: TOSHIBA
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.46-1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.6-2ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.6-2ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.14.2.901-2ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.2.0-0ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.14-4ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.8-0ubuntu3
xserver.bootTime: Wed Aug 28 20:50:58 2013
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.14.2.901-2ubuntu3

Cefn (6-launchpad-net-cefn-com) wrote :
Chris Wilson (ickle) wrote :

The output of xrandr before suspending, after wakeup (with monitor plugged in) and finally after activating the monitor would be useful. As would the Xorg.0.log from that session, and dmesg. If you 'echo 6 | sudo tee /sys/modules/drm/paramters/debug' before suspending, then dmesg > dmesg.txt after resume attached to the monitor (and activation) would hopefully have all the information we need.

Cefn (6-launchpad-net-cefn-com) wrote :

Thanks for your reply, Chris.

I think you meant...

echo 6 | sudo tee /sys/module/drm/parameters/debug

...and I will attach the sequential xrandr outputs, X l.ogs and Dmesg for all three cases.

Cefn (6-launchpad-net-cefn-com) wrote :

OK, so attached is the result of a two-reboot cycle.

Initially (first reboot) I didn't have the monitor attached at all.

Then I ran your diagnostic scripts (output in post-reboot-unattached).

Then I attached the monitor.

Then I ran your diagnostic scripts (output in post-reboot-attached-after).

Throughout this process, no signal was received by the monitor, even though the Gnome randr GUI detects the correct manufacturer, shows that the monitor is on, and indicates that it is using the correct resolution.

I finally rebooted the laptop WITH THE MONITOR ATTACHED DURING the reboot and that was the only way it successfully started sending a signal.

I then ran the diagnostic scripts for a third time (output in post-reboot-attached-during).

I have not bothered to work with a suspend/resume condition, as it happens whenever the monitor is not attached on boot anyway, whether or not I suspend/resume.

Cefn (6-launchpad-net-cefn-com) wrote :

I'm currently testing with a mainline kernel and the same issues exist...

$ uname -a
Linux cefn-saucy-portege 3.11.0-031100-generic #201309021735 SMP Mon Sep 2 21:44:40 UTC 2013 i686 i686 i686 GNU/Linux

Chris Wilson (ickle) on 2013-09-23
summary: - VGA Output not activated
+ [gm45] VGA Output not activated
Cefn (6-launchpad-net-cefn-com) wrote :

I can confirm that this applies also to a Samsung monitor as well as the Dell monitor, with two different, high-quality VGA cables, suggesting that it's a driver issue. A reboot of the machine with the monitor attached is a workaround for the issue with the Samsung as well.

Cefn, this bug was reported a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue? If so, could you please test for this with the latest development release of Ubuntu? ISO images are available from http://cdimage.ubuntu.com/daily-live/current/ .

If it remains an issue, could you please run the following command in the development release from a Terminal (Applications->Accessories->Terminal), as it will automatically gather and attach updated debug information to this report:

apport-collect -p xserver-xorg-video-intel REPLACE-WITH-BUG-NUMBER

Please note, given that the information from the prior release is already available, doing this on a release prior to the development one would not be helpful.

Thank you for your understanding.

Helpful bug reporting tips:
https://wiki.ubuntu.com/ReportingBugs

Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
Changed in xserver-xorg-video-intel (Ubuntu):
status: Expired → Confirmed

This is an issue for me too. More info here: http://askubuntu.com/questions/517481

Oliver Woodford, thank you for your comment. So your hardware and problem may be tracked, could you please file a new report by executing the following in a terminal:
ubuntu-bug xorg

Please ensure you have xdiagnose installed, and that you click the Yes button for attaching additional debugging information.

For more on this, please see the official Ubuntu documentation:
Ubuntu X.Org Team, Ubuntu Bug Control, and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report will delay your problem being addressed as quickly as possible.

Thank you for your understanding.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-intel (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers