Ubuntu

X Error of failed request: BadAlloc (insufficient resources for operation)

Reported by Ray T on 2012-10-25
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
xf86-video-intel
Fix Released
Medium
Arch Linux
New
Undecided
Unassigned
xserver-xorg-video-intel (Ubuntu)
Undecided
Unassigned

Bug Description

After a recient update of the following files:
libdrm-intel1 2.4.32-1ubuntu1 2.4.39~precise~ppa2.2
libdrm-nouveau1a 2.4.32-1ubuntu1 2.4.39~precise~ppa2.2
libdrm-radeon1 2.4.32-1ubuntu1 2.4.39~precise~ppa2.2
libgl1-mesa-dri 8.0.4-0ubuntu0.1 9.0.0.99~glasen~ppa1.1
libgl1-mesa-glx 8.0.4-0ubuntu0.1 9.0.0.99~glasen~ppa1.1
libglapi-mesa 8.0.4-0ubuntu0.1 9.0.0.99~glasen~ppa1.1
libxatracker1 8.0.4-0ubuntu0.1 9.0.0.99~glasen~ppa1.1
xserver-xorg-video-radeon 1:6.14.99~git20111219.aacbd629-0ubuntu2 1:6.14.99~really6.14.6~glasen~ppa3
xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2 1:6.14.99~really6.14.6~glasen~ppa3
xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2 1:1.1.0~glasen~ppa4.1

my opengl has stopped working.

glxinfo
name of display: :0.0
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 22
  Current serial number in output stream: 25

running armagetron from a terminal gives:
armagetronad -w
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 25
  Current serial number in output stream: 26

This error also occurs when i run warzone2100 XScreensaver glMatrix for example, all three were fine before.

Thanks and if i have missed anything please ask. (not sure what info ubuntu-bugs attached)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+12ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic 3.2.30
Uname: Linux 3.2.0-32-generic i686
ApportVersion: 2.0.1-0ubuntu14
Architecture: i386
Date: Thu Oct 25 23:19:47 2012
InstallationMedia: Xubuntu 12.04.1 LTS "Precise Pangolin" - Release i386 (20120817.3)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)

Created attachment 68637
dmesg

When I run glxinfo, or any 3D application, the app doesn't start, and I only get this error. With Mesa 8.0.4 there was no problem.

$ glxinfo
name of display: :0
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 22
  Current serial number in output stream: 25

-----------

Linux 3.6.2
X Server 1.13.0
libdrm 2.4.39
xf86-video-intel 2.20.10

00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
        Subsystem: ASRock Incorporation Device 2572
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx+
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at ff280000 (32-bit, non-prefetchable) [size=512K]
        Region 2: I/O ports at ec00 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power Management version 1
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Kernel driver in use: i915

I don't know what information should I provide.

Created attachment 68638
Xorg.0.log

Ray T (raymond-thomson76) wrote :
Daniel Letzeisen (dtl131) wrote :

Please attach /var/log/Xorg.0.log to make sure all is okay there.

Changed in xorg (Ubuntu):
status: New → Incomplete
Ray T (raymond-thomson76) wrote :

Just to add...
Was a fresh install 2 days ago.

I have added the following info:
lspci
sudo lshw -C display
xdpyinfo
to here >> http://pastebin.com/3XLcrR4p

Ray T (raymond-thomson76) wrote :

here you go.

helloworld (halloaron) on 2012-10-28
affects: xorg (Arch Linux) → xorg-server
helloworld (halloaron) wrote :

I have exactly the same problem.

My Graphic Card is: Intel Corporation 82865G/PE/P

Linux 3.6.3-1-ARCH #2 SMP PREEMPT Mon Oct 22 12:55:44 CEST 2012 i686 GNU/Linux

After Update to newer version of the packages like RayT, openglapplication crashes.

$ glxinfo
name of display: :0.0
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 22
  Current serial number in output stream: 25

$ glxgears
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 28
  Current serial number in output stream: 30

$ blender
AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 143
  Current serial number in output stream: 144

Before Update to newer verison of xorg etc., everything was fine.

DMESG:

https://gist.github.com/3968631

Xorg log

https://gist.github.com/3968634

Please fix this, i tryed so long, nothing can fix this, i think its a real bug.

no longer affects: xorg-server
helloworld (halloaron) on 2012-10-28
information type: Public → Public Security
information type: Public Security → Public
henczati (henczati) wrote :

hi, same problem here
both in Lubuntu 12.04 (after some recent update) and 12.10 (installed just about now) on a Dell Inspiron 1150 (integrated intel GMA 82852/855GM )

everything GL-related just stopped working and started to output the same error message

Daniel Letzeisen (dtl131) wrote :

I see the OP is using glasen PPA and another poster is using ArchLinux.
So this only happens when you upgrade to mesa 9.0?

Changed in xorg (Ubuntu):
status: Incomplete → Confirmed
helloworld (halloaron) wrote :

Yes after Update to Mesa 9.0 and other Packages like xorg-server 1.30 and xf86-video-intel, GL related application doesnt work anymore. (on Archlinux). I also tried git packages of mesa, no affect. I forced to use Windows XP Currently. I'll waiting for a bug fix and try archlinux later. And using Windows for me, is unusable for me. Please notice this to the mesa developers. Thx.

helloworld (halloaron) on 2012-10-29
no longer affects: mesa (Ubuntu)
Ray T (raymond-thomson76) wrote :

Hi Dave, thanks for looking into this.
Am i correct in thinking this is a debian/linux bug more that an "just" ubuntu disto's (from the arch-linux post)?
Also as a possible quick fix
1) Is there any way of reverting the system back to the earlier versions of the updated files?
2) or/and Blacklisting the files, so as they can not be installed.
I only ask as this machine is a fresh install with nothing on it, and i could always reinstall.
Cheers Ray

helloworld (halloaron) wrote :

Once day:

I do Update with "pacman -Syu" and mesa libs was included. After that GL Application didnt stop and my KDE Effects stoped working.

So i decide to reinstall older version of all the updated packages. After that everything works again.

I decide to wait another Update. After doing the new Update again with mesa and etc. It breaks everything again...

So I thought something is broken generelly on my system, i formated and reinstalled archlinux.
Sad. Doesnt work. GL Application Crash. Tested with different Window Manager.

How long would it take to fix this issue?

Ray T (raymond-thomson76) wrote :

Hi Helloworld,

QUOTE "So i decide to reinstall older version of all the updated packages. After that everything works again."

May i ask how you did this ?

helloworld (halloaron) wrote :

( https://wiki.archlinux.org/index.php/Downgrading_Packages )

As example:
pacman -U /var/cache/pacman/pkg/pkgname-olderpkgver.pkg.tar.gz

If you have not run pacman -Scc recently, it should be there.

Ray T (raymond-thomson76) wrote :

cheers for that,
Xubuntu uses synaptic package manager, but they do the same thing i guess.

by "forcing the version" i was able to downgrade the two following files from the update.
and this seems to have re-enabled openGL.

Start-Date: 2012-10-31 01:22:05
Commandline: /usr/sbin/synaptic
Downgrade: libdrm-intel1:i386 (2.4.39~precise~ppa3, 2.4.32-1ubuntu1),
libgl1-mesa-dri:i386 (9.0.0.99~glasen~ppa2, 8.0.4-0ubuntu0.1)
End-Date: 2012-10-31 01:22:15

Steps for someone new like me:
Open synaptic package manager, type "libdrm-intel1" into the search box.
select it with a left click. goto the top of the window and select "Package" > "Force Version" and select a 8.0.4. version.
do the same with "libgl1-mesa-dri" to 2.4.32

Good luck,

a workaround for me for now.

helloworld (halloaron) wrote :

Someone must assigne this.
This is a big bug. And in future, I will continue to use my Computer with this graphics chip.

Please Report this, to the developer of mesa and intel drm.

bugbot (bugbot) on 2012-11-01
tags: added: xubuntu
bugbot (bugbot) on 2012-11-01
affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Ray T (raymond-thomson76) wrote :

Hi,

Just like to say after todays update of the files below the problem seems to be fixed!
And this has included undoing my temp fix.

Start-Date: 2012-11-02 14:57:31
Commandline: aptdaemon role='role-commit-packages' sender=':1.43'
Upgrade:
base-files:i386 (6.5ubuntu6.2, 6.5ubuntu6.4),
xserver-xorg-video-ati:i386 (6.14.99~really6.14.6~glasen~ppa3, 6.14.99~really6.14.6~glasen~ppa4),
libdrm-intel1:i386 (2.4.32-1ubuntu1, 2.4.39~precise~ppa3),
gir1.2-gudev-1.0:i386 (175-0ubuntu9.1, 175-0ubuntu9.2),
udev:i386 (175-0ubuntu9.1, 175-0ubuntu9.2),
libgudev-1.0-0:i386 (175-0ubuntu9.1, 175-0ubuntu9.2),
libudev0:i386 (175-0ubuntu9.1, 175-0ubuntu9.2),
libgl1-mesa-dri:i386 (8.0.4-0ubuntu0.1, 9.0.0.99~glasen~ppa2),
xserver-xorg-video-radeon:i386 (6.14.99~really6.14.6~glasen~ppa3,6.14.99~really6.14.6~glasen~ppa4),
xserver-xorg-video-intel:i386 (2.20.9~really~2.20.12~precise~ppa4, 2.20.9~really~2.20.12~precise~ppa5)
End-Date: 2012-11-02 14:59:09

I would just like to say thank you very much to the people involved.
This again allows me to enjoy such a wonderful system !!

Ray T (raymond-thomson76) wrote :

Seems i may have jumped the gun,
just started the little bugger up again and shes back to her old tricks....

Sorry

I got the same problem with mesa 9.0.1

Ray T (raymond-thomson76) wrote :

Just to add... the fix of downgrading my packages has also activated the following bug:

8086:2562 [drm:intel_prepare_page_flip] *ERROR* Prepared flip multiple times every frame with intel graphics
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/765813

This i originally got around by using the following commands:
sudo add-apt-repository ppa:glasen/intel-driver
sudo apt-get update
sudo apt-get install xserver-xorg-video-intel
but this does not work anymore?

so i am officially at a loss with what to do.

Götz Christ (g-christ) wrote :

Same problem using Mesa 9.0 with:
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

I have reported the bug upstream:
https://bugs.freedesktop.org/show_bug.cgi?id=56042

henczati (henczati) on 2012-11-06
tags: added: lubuntu

I have the same problem here with the new mesa 9.0

Additional Info:

(tested with extra/xf86-video-intel 2.20.12 under mesa 9.0)
Dell Dimension 4600i or similar.
Intel Corporation 82865G Integrated Graphics Controller (rev 02)
archlinux

I downgraded my mesa to 8.0.4. and libgl too.

Waiting for a bug fix. Thank you.

Stefan Glasenhardt (glasen) wrote :

Hi guys,

The bug is basically a "won't fix"-bug because Mesa 9.x does not support the old DRI1-based graphics-cards any longer. This means all pre-i915-chipsets have no hardware-accelerated OpenGL with Mesa 9.x and you have to use the Software-based rasterizer "LLVMpipe":

http://www.phoronix.com/scan.php?page=news_item&px=OTgzMg

To force enable "LLVMpipe" you have to add the following line to the file ".bashrc" in your users directory:

export LIBGL_ALWAYS_SOFTWARE=1

Maybe there is a way to add the old DRI1-based drivers to Mesa 9.0 but currently

Stefan Glasenhardt (glasen) wrote :

Sorry forgot to write the rest of the comment:

Maybe there is a way to add the old DRI1-based drivers to Mesa 9.0 but currently i don't know how to do this.

Götz Christ (g-christ) wrote :

glasen, are you sure about that? Last year you said:
"All chips since the i830 (e.g. 855GM, 865G, etc.) do not use the i810-driver in Mesa. They use the newer i915-driver and get still supported by this driver." http://phoronix.com/forums/showthread.php?59632-Legacy-Mesa-Drivers-Receive-Their-Death-Sentence&p=224719#post224719

And there is no mention about droping support in the Mesa 9.0 release notes: http://mesa3d.sourceforge.net/relnotes-9.0.html

So if they use the same DRI2 driver, i915, why should those chipsets be afected by a DRI1 removal?

Stefan Glasenhardt (glasen) wrote :

You are right. I made a mistake in my statement. Normally the pre-i915-chipsets should work with Mesa 9.0 but their seems to be a bug which breaks OpenGL on these chipsets.

Maybe you can provide me some more informations. Can you please run the following command and post the output:

env LIBGL_DEBUG=verbose glxgears

The package "mesa-utils" is needed for "glxgears".

ciaopaste (jungeriano) wrote :

Please fix this bug...there's a lot of people out there who use older intel chipset like i830m... Why I can see movies without lag and play a lot of games using win2k_xp147.exe driver on windows? I hope there's a way to add dri1 to mesa. Thank you very much for your work

Götz Christ (g-christ) wrote :

$ env LIBGL_DEBUG=verbose glxgears
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/i915_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/i915_dri.so
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /home/ice/.drirc: No such file or directory.
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 28
  Current serial number in output stream: 30

Stefan Glasenhardt (glasen) wrote :

@ciaopaste:

I'm not a developer. I'm just making some packages out of some freely available source-code. But i'll try my best to narrow down the cause of the bug and try to help the developers to fix it.

@G. Christ:
Okay, this means the DRI-driver is still used but there seems to be some problems with the memory allocation (As far as i know). It must be a Mesa-bug because when using version 8.0.4, the newest graphics-driver and a newer kernel-version as 3.2.0 OpenGL still works. Only when using Mesa 9.0 the bug occurs.

Also the bug occurs in other distributions which use Mesa 9.0 e.g. RedHat, Arch and so on. As i wrote i'm trying to narrow down the bug and i think i found the cause but need a bit more time for testing (At the moment i have no more 855GM-based notebook and i have to ask my uncle to borrow me his ;-) )

Same error on ArchLinux

$ lspci -v
00:02.0 VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
 Subsystem: Biostar Microtech Int'l Corp Device 3101
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f0000000 (32-bit, prefetchable) [size=128M]
 Memory at f8500000 (32-bit, non-prefetchable) [size=512K]
 I/O ports at da00 [size=8]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915
$ env LIBGL_DEBUG=verbose glxgears
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/i915_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/i915_dri.so
libGL: Can't open configuration file /home/n4zm/.drirc: No such file or directory.
X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 28
  Current serial number in output stream: 30

Using mesa 9.0-1

no longer affects: archlinux

Just another "me too"; mesa-9.0 breaks any all DRI on 865G, with only the here mentioned error message as a result from running any 3D application.

I also downgraded to 8.0.4, which works very well on this hardware -- which actually surprised me a bit when testing, since the xorg intel driver was problematic on older hardware for a long time. I therefore quite hope that this is just a bug and not an abandonment?

(still current for mesa-9.0.1)

Is there any chance that you're all using Arch? We've recently seen some other similar weirdness that we could only reproduce on Arch.

As many users have reported, this problem also happens in the Ubuntu packages: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1071530
I see this problem in my machine using Arch and Ubuntu.

@ Ian:

Sorry, I didn't get email when you replied so missed it (have now added myself to the CC list). I am in fact on Arch, but, yes, the problem is shared with Ubuntu at least.

It's interesting though. The Arch bug report is here (it's just me up to now):

https://bugs.archlinux.org/task/32666

If you know of something that Arch could do different in order to avoid this or that other earlier problem that you speak of, I'm very sure the Arch X maintainers would be interested in hearing about it.

(posting to that bug report will get it noticed; I could also relay it, if need be).

This is marked as "NEEDINFO". Is there anything I can provide?

As example:

$ etracer #extreem tuxracer (an opengl programm)

X Error of failed request: BadAlloc (insufficient resources for operation)
  Major opcode of failed request: 153 (GLX)
  Minor opcode of failed request: 3 (X_GLXCreateContext)
  Serial number of failed request: 25
  Current serial number in output stream: 26

This happens to all opengl application.

Installed on my Archlinux:

extra/intel-dri 9.0.1-1
extra/xf86-video-intel 2.20.14-1
extra/xorg-server 1.13.0-4
extra/libgl 9.0.1-1

Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Its nearly 2 Months, no one will fix it. Its took too much time.
Please give more Support for the old cards like this, they're many out there using them.

Thanks.

Same here on my 845G system with mesa 9.0 on Arch Linux:
Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 01)

Downgrading to mesa 8.0.4 solves the problem.

PUSH
Please Fix. Another month ago...

If you can't fix it, so clear the supported Status:

http://dri.freedesktop.org/wiki/Intel

henczati (henczati) wrote :

hi guys, has anyone heard about any news/progress concerning this bug?

Changed in xserver-xorg-video-intel:
importance: Unknown → Medium
status: Unknown → In Progress

Same problem on opensuse 12.3 (Beta 1) with Mesa-9.0.1-31.1.i586

Intel 845G Chipset

On an updated ArchLinux:

intel-dri-9.0.2
libegl-9.0.2
libdrm-2.4.42
(mesa-9.0.2)

glxinfo(and other 3D application) crashes:

BadAlloc (insufficient resources for operation)

Chris Wilson (ickle) wrote :

This was an Xorg bug when idr broke everything trying to add support for GL3.

Changed in xserver-xorg-video-intel (Ubuntu):
status: Confirmed → Fix Released
Ray T (raymond-thomson76) wrote :

Hi Chris,

you have stated that there is a fix released,
Does this mean i can update my video drivers now and i will get a fixed version?

Thanks

On Wed, Feb 20, 2013 at 01:13:23AM -0000, Ray T wrote:
> Hi Chris,
>
> you have stated that there is a fix released,
> Does this mean i can update my video drivers now and i will get a fixed version?

Yes, if I have recognised the bug correctly, then it should be fixed
with an update to xserver-xorg-core. (Hopefully there is a backport and
you will not have to jump forward to the next release of Ubuntu.)
-Chris

--
Chris Wilson, Intel Open Source Technology Centre

Götz Christ (g-christ) wrote :

In which version of xserver is the fix, the upcomming 1.14?

Then, is the freedesktop bug #56042 not related, or is a Mesa updated also needed?

Ray T (raymond-thomson76) wrote :

Hi again Chris

Thank you "very" much, i will try later and see!!

Quote "(Hopefully there is a backport and
you will not have to jump forward to the next release of Ubuntu.)"

I hope so too, as my system is non-pae!!
So if its an upgrade, i could be looking for a new OS. ?!?

Sad but true and i am loving Xubuntu!!

Ray T (raymond-thomson76) wrote :

Erm Hi again,

Just wondering ...
I forced the version of the libgl library to 8.0.4 using syaptic package manager to get over this problem.

Er how do you unforce the versions so they will update as normal?
have i missed something stupid?

Cheers

This specific issue has been fixed (for me, Intel 865G on arch linux) in mesa-9.1-2 which is at the time of writing in the testing repository.

9.1 does regress with respect to 8.0 (ie, "Speed Dreams" just crashed on me, which it didn't use to) but that sort of thing is just business as usual for older intel. In two releases time, nothing will work anymore again, so let's count our blessings for now.

Or rather, I guess from the reply one above, let's count the number of opensuse users -- and prey to god it stays above 1000 so that the pack of drug-crazed baboons that have been fucking up 3D on older intel on basically each and every release for multiple years now keeps getting told so by en entity with a cool corporate presence.

Or something. Go Wayland go.

Ouch, that's painful. I just found out that Wayland also uses mesa...

As René said, although many programs break with Mesa 9.1, this specific issue has been fixed (865G).

Changed in xserver-xorg-video-intel:
status: In Progress → Fix Released
Vladimir Berkut (vbr) wrote :
Vladimir Berkut (vbr) wrote :
Vladimir Berkut (vbr) wrote :

This bug is not ressolved!
I can only classify its current status as "Gentlemen, the ice has shifted (a bit)". The Unity desktop still shows wallpaper only, and decorations are absent.

Have exactly same situation as OP.
Environiment:
Ubuntu 13.04, 32bit, stock install. lshw of machine attached.

Installed on other machine with radeon opensource driver, then transfered to Intel machine -- situation.

After reading, I updated via Xorg-Edgers PPA. They have MESA 9.2 right now. The results are almost same.

Improvements:
Right now, glxinfo runs fine, glxgears shows gears. Thats all.

Breakages:
Situation in Unity is NOT improved. Same old wallpaper-only desktop, decorations are absent, window manager (compiz) dead.

When I try to run ccsm, "OpenGL", "Composite" and "Unity" extensions are not enabled.
I can successfully tick "Composite", but anything else unticks after few seconds.

I attached the results of "compiz --replace"

When I try to run "unity-support-test", I get segfault. I have attached the gdb log.

I was able to install xfce and run it, however I experience corruption of window borders, when composite mode is enabled.

I have found similar bugs, that link to this case:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1136541
:: This one happens precisely, after adding lastest mesa 9.2 by means of xorg-edgers or manual compilation

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/1130175
:: This seems to be duplicate of this bug.

I have not tried to downgrade to Mesa 8.xx yet, but I choose 13.04 exactly because I wanted newer fixes of i915. In old Mesa 8 and kernel 3.2 with xcompmgr enabled (LXDE), my machine was simply deepfreezing, tty switch didn't work at all.

PLEASE REOPEN BUG!

Vladimir Berkut (vbr) wrote :

I wanted just to add, that I have very recently built a machine using Intel G2020 (Ivy) it it worked flawless out of the box on 13.04 64bit, even after dist-upgrade.

This bug affects only i8xx/i9xx chipsets!

David A Check Jr. (dcheck246) wrote :

Ran from system testing on ubuntu 12.04

I do not like seeing this but do not know if it relates to how sometimes my refresh rate will revert to 60 from 80 and the hangs i have been getting on some online mmorts' using flash and java

graphics/compiz_check

FAILED

X Error of failed request: BadAlloc (insufficient resources for operation) Major opcode of failed request: 153 (GLX) Minor opcode of failed request: 3 (X_GLXCreateContext) Serial number of failed request: 32 Current serial number in output stream: 33

David A Check Jr. (dcheck246) wrote :

This is the Webpage view of the report, did not realize it would absent in my previous upload. Apologies.

Is it possible to backport this fixes to Ubuntu version available in raring ?

Javier Barroso (javibarroso) wrote :

Is it possible to backport the fix to ubuntu package ?

Thank you

Created attachment 87794
The patch to fix this issue

Attached here is a patch (tested) to fix this issue for Mesa 9.0.

You are also welcome to pull the commit from my github: https://github.com/matwey/mesa branch fix_i830_context

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.