Ubuntu

MASTER: xserver crash, performs poorly, or other severe problem when loading the radeon driver if -fglrx has not been properly removed first

Reported by Ikipou on 2008-10-18
118
This bug affects 11 people
Affects Status Importance Assigned to Milestone
xserver-xorg-video-ati (Ubuntu)
Wishlist
Unassigned
Declined for Intrepid by Bryce Harrington

Bug Description

[Problem]
Running X with the -ati driver shows various problems if -fglrx is not fully installed first, including crashing, performing poorly, failing during gl operations, etc.

A typical use case is upgrading from Ubuntu when you were using to fglrx, to a development version of Ubuntu where -fglrx is not available, and -ati is used instead.

-ati and -fglrx share some overlapping files like libgl, which -fglrx replaces when it's installed and that results in -ati breakage. -fglrx also installs kernel components which can cause problems if they're still present when running -ati.

For more info, see https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver

[Workaround]
Make sure -fglrx is fully purged from your system

1. sudo apt-get remove --purge fglrx*
2. sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
3. sudo apt-get install xserver-xorg-video-ati
4. Restart X

[Original report]
After the update to Intrepid, the X server no longer starts.

When launching the X server by hand I have this message:
(==) Using config file: "/etc/X11/xorg.conf"

Backtrace:
0: X(xf86SigHandler+0x79) [0x80c2fe9]
1: [0xb809f400]
2: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb7b05b07]
3: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb7ad355a]
4: /usr/lib/xorg/modules/drivers//radeon_drv.so [0xb7ad64fc]
5: X(InitOutput+0x96f) [0x80aac7f]
6: X(main+0x279) [0x8071b19]
7: /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe5) [0xb7ca1685]
8: X [0x8071101]
Saw signal 11. Server aborting.

The message is the same if I choose the driver "radeon" or "ati". The graphic card is a ATI RV100:
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

The ubuntu version is:
Description: Ubuntu intrepid (development branch)
Release: 8.10

The driver version is:
xserver-xorg-video-radeon:
  Installed : 1:6.9.0+git20081003.f9826a56-0ubuntu2

Ikipou (ikipou) wrote :
Torsten Spindler (tspindler) wrote :

This problem might be a duplicate of bug 274234. See this comment for a possible work around:
https://bugs.edge.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/274234/comments/13

Ikipou (ikipou) wrote :

Unfortunately it don't work. I had already checked with the bug 274234 and tried the fix but the error remains.

Ikipou (ikipou) wrote :
Bryce Harrington (bryce) on 2008-11-04
Changed in xserver-xorg-video-ati:
status: New → Confirmed
Bryce Harrington (bryce) on 2008-11-26
description: updated
description: updated
Bryce Harrington (bryce) on 2008-11-26
Changed in xserver-xorg-video-ati:
importance: Undecided → High
status: Confirmed → Triaged
Bryce Harrington (bryce) wrote :

From bug #315889, which had a similar root problem - fglrx bits left over from a prior install, here are some comments/notes:

With the linux-source-fglrx package installed, dkms kicks in and loads the kernel module even when -ati is used.

There should be some sort of dependency between the linux-source-fglrx and fglrx-installer package so that uninstalling fglrx will take out linux-source-fglrx as well.

description: updated
Rune K. Svendsen (runeks) wrote :

I just experienced this bug as well when upgrading from Intrepid to Jaunty. Except I was using the "ati" video driver with Intrepid, and for some reason the upgrade process installed the "fglrx" video driver and this broke X. The gdm-log had the following to say:

/usr/bin/X: symbol lookup error: /usr/lib/xorg/modules/extensions/libdri.so: undefined symbol: atiddxAbiDixLookupPrivate
5109 5077
giving up.

I solved the problem by purging everything fglrx-related and reinstalling "libgl1-mesa-glx" and "libgl1-mesa-dri":

  sudo apt-get remove --purge xorg-driver-fglrx
  sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri
  dpkg-reconfigure xserver-xorg

taken from this guide: https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver (linked in Bug #345669).

It seems to me that this is a bug in the upgrade process of Ubuntu. If it hadn't installed the fglrx-driver, I assume everything would have worked fine. At least it did after removing the fglrx-driver.

Adam Niedling (krychek) wrote :

3D games freeze for me after upgrading to Jaunty. I have ATI Mobility FireGL V5200. I looked for fglrx in synaptic and found these two packages: linux-restricted-packages-2.6.22-14-generic; linux-restricted-packages-2.6.24-21-generic. They both include the fglrx module. I removed them and Urban terror did not freeze during 40 minutes of playing.

Adam Niedling (krychek) wrote :

I'm still getting freezes after all. However it's possible to press ctrl+alt+f2 and kill the process manually and then switch back to X. I followed all procedures at https://wiki.ubuntu.com/X/Troubleshooting/FglrxInteferesWithRadeonDriver .

emarkay (mrk) wrote :

Folks, this bug is logged in for 8.10 Intrepid.
There's (apparently) a new set of issues that MAY be related, but IMHO need another bug report for 9.04 Jaunty.
See details here:
http://ubuntuforums.org/showthread.php?t=1133931
Can anyone confirm that this is a separate issue?

Adam Niedling (krychek) wrote :

emarkay: I think this bug is about the possible problems when people with Ati video cards are upgrading from Intrepid to Jaunty. But maybe it should be repoorted as a separate bug that the new ati driver is freezing when using 3d apps.

Adam Niedling wrote:
> emarkay: I think this bug is about the possible problems when people
> with Ati video cards are upgrading from Intrepid to Jaunty. But maybe it
> should be repoorted as a separate bug that the new ati driver is
> freezing when using 3d apps.
>

Yea - I did the removal instructions there before installing the ATI
driver. I am still researching - also that listed bug is for Jaunty...

http://ubuntuforums.org/showthread.php?t=1133931

The above URL is the focus for me.

emarkay (mrk) wrote :

sorry - I replied to an email forgetting it posts, too - ignore this dupe post - the new bug report is:
https://bugs.launchpad.net/ubuntu/+bug/369621

Bryce Harrington (bryce) on 2009-05-15
tags: added: crash
Adam Niedling (krychek) wrote :

I think I've found out what was causing my freezes. During a boot I noticed that something called DKMS loaded fglrx even tho I uninstalled everything fglrx related. Turned out that this DKMS was still loading fglrx so this might have had something to do with my freezes. I had no freezes ever since.

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid
Bryce Harrington (bryce) wrote :

[This is an automatic notification.]

A new version of the -ati driver is now available in Karmic.

This is a significant update to -ati which brings in kernel mode-setting
(currently disabled) and scores of fixes for DRI2, EXA, etc.

I've posted the new version of this driver to the following PPA,
would you mind testing it and seeing if it resolves the bug you
reported?

  https://edge.launchpad.net/~bryceharrington/+archive/ppa/+sourcepub/709908/+listing-archive-extra

If you're not running this release of Ubuntu, you can try booting the Karmic
LiveCD and loading the PPA onto it, and then log out/in to restart X.
ISOs are available at http://cdimages.ubuntu.com/releases/

After testing Karmic, report back here whether it's still an issue or not,
and if it is please post a fresh Xorg.0.log and 'dmesg' output.

Note there could be new bugs... please file these as new reports using
the command 'ubuntu-bug xorg'.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Incomplete
status: Incomplete → Triaged
importance: High → Wishlist
forscher (forscher) wrote :

sorry, the bug is still there.
regards

Bryce Harrington (bryce) wrote :

From dupe:

"Fglrx installer overwrites mesa and xserer files causing prombles with open source drivers even after removal. Solution would be install fglrx and open drivers to own subdirectories. Loading would either happen using symbolic links or /etc/ld.so.conf.d/ configuration. Also kernel modules should be blacklisted in /etc/modprobe.d/ when switching between drivers."

Shahar Or (mightyiam) wrote :

Doe the fglrx package still behave this way?

Adam Niedling (krychek) wrote :

I haven't had this problem for ages, even forgot about this bug. Of course I don't use Jaunty anymore. I think this bug can be closed.

shankao (shankao) on 2014-01-15
tags: added: jaunty karmic
shankao (shankao) wrote :

More information here: https://wiki.ubuntu.com/X/Troubleshooting/VideoDriverDetection#Problem:_Need_to_purge_-fglrx

Is this still a problem? If it's so, shouldn't this bug be fixed via a "conflicts" in the packages of both the open source and the proprietary driver?
Otherwise, jockey could deal with the driver situation in a more automatic way.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for xserver-xorg-video-ati (Ubuntu) because there has been no activity for 60 days.]

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers